1. Mitglieder surfen ohne Werbung auf Android-Hilfe.de! ✔ Jetzt kostenlos Mitglied in unserer Community werden.
  1. TimeTurn, 13.11.2013 #1
    TimeTurn

    TimeTurn Threadstarter Foren-Inventar

    Windows in der x64-Variante erlaubt seit Windows Vista keine unsignierten Treiber mehr. Leider sind die Treiber weder von Sony noch vom Flashtool für Windows gültig signiert, sodass die Installation immer fehlschlägt. Jedoch gibt es eine Möglichkeit, die erzwungene Signatur auszuschalten - darum geht es hier.


    Wozu Fastboot? Was ist das?
    :

    Der Fastboot Mode ist ein spezieller Modus des Bootloaders, in dem das Gerät u.a. das Flashen von Kerneln oder des ganzen Systems erlaubt. Der Fastboot-Mode wird bei Sony aber auch verwendet, um den Bootloader zu entsperren. Danach wird der Mode hauptsächlich zum Flashen von Boot-Images mit dem Kernel verwendet.

    Solange der Bootloader gesperrt ist, kann man Fastboot zwar auch zum flashen benutzen, der Bootloader akzeptiert dann aber ausschließlich durch den Hersteller digital signierte Images. Deshalb kann man mit geschlossenem Bootloader normalerweise nur Custom ROMs benutzen, die auf den Kernel des stock ROMs des Geräts aufsetzen und auch nur, wenn man es ohne öffnen des Bootloaders rooten kann.


    MÖGLICHKEIT 1: Testmodus aktivieren und Treiber installieren


    Der bei weitem einfachste Weg, die Treibersignatur zu umgehen ist, Windows im Testmode zu starten - dann blockiert Windows die Installation unsignierter Treiber nicht sofort, sondern fragt, ob man die trotzdem installieren möchte.

    Öffnet dazu eine Kommandozeile mit Administratorrechten, in dem ihr (bei Windows 8 und 10) einen Rechtsclick auf Start macht und "Eingabeaufforderung (Administrator)" auswählt. Bei Windows 7 geht ihr in das Suchfeld "cmd.exe" ein, macht einen Rechtsclick auf das Suchergebnis und wählt "Als Administrator ausführen". Ob das Kommando auch bei Windows 7 funktioniert, hab ich nicht getestet, da ich seit Jahren kein Windows 7 mehr fahre.

    2015-08-09 21_00_16-Administrator_ Eingabe (Admin).png

    Gebt dort dann folgendes ein:

    bcdedit -set testsigning on

    2015-08-09 20_58_10-Administrator_ Eingabe (Admin).png

    Dann habt ihr nach einem Neustart in der rechten unteren Ecke das hier stehen:

    2015-08-09 14_01_56-Greenshot.png

    2015-08-09 14_01_01-Info-Center.png

    Installiert nun Flashtool, falls ihr das noch nicht getan habt und geht in dessen "drivers"-Ordner: Wählt nun euer Handymodell aus. In meinem Fall ist ex das Xperia Z Ultra, sowie die Fastboot- und Flashmode-Treiber und clickt "Install".

    2015-08-09 20_41_26-FlashTool Xperia Driver Pack v1.8 (20141101) Setup.png 2015-08-09 20_43_20-FlashTool Xperia Driver Pack v1.8 (20141101) Setup.png

    Es kommt eine schöne dick rote Sicherheitswarnung, das ihr die Treibersignatur nicht ignorieren sollt. Clickt auf "Trotzdem installieren". Das Ganze kommt dreimal hoch, für Fastboot, Flashmode und Handytreiber.

    2015-08-09 14_00_27-Windows-Sicherheit.png

    Danach sollten schöne grüne Haken vor den Treibern sein. Habt ihr keine grünen Haken, konnten die Treiber nicht installiert werden. In dem Fall habt ihr das System nicht wie beschrieben im Modus gestartet, in dem man die Treibersignatur ignorieren kann, oder ihr habt "Nicht installieren" geclickt in der roten Sicherheitswarnung von Windows.

    Nachdem ihr die Treiber installiert habt, könnt ihr entsprechend wieder eine EIngabeaufforderung mit Adminrechten starten und den Textmode mit folgendem Kommando beenden:

    bcdedit -set testsigning off

    2015-08-09 20_58_28-Administrator_ Eingabe (Admin).png

    Den Testmode wieder verlassen und damit das Wasserzeichen vom Desktop wieder loswerden (auch hier ist ein Neustart nötig).


    MÖGLICHKEIT 2: Wenn der Testmode nicht will, etwa wegen aktiviertem Secure Boot


    Alternativ zum Testmode gibt es noch den erweiterten Start. Dort kann man die Treibersignatur ebenfalls deaktivieren.

    Clickt im Startmenü (bei Windows 8 im CHARMS-Menü auf der Rechten Seite auf "PC-Einstellungen" gehen) auf "Einstellungen". Hier seht ihr Start10, also nicht das Original-Startmenü von Windows 10 - da ist der Punkt aber natürlich ebenso zu finden:

    01.jpg

    Geht auf den Punkt "Updates und Sicherheit". Bei Windows 8 heißt der so ähnlich glaub ich.

    02.jpg

    Geht auf "Wiederherstellung" und clickt bei "Erweiterter Start" auf "Jetzt neustarten".

    03.jpg

    Clickt auf "Problembehandlung"

    04.jpg

    Clickt auf "Erweiterte Optionen"

    05.jpg

    Clickt auf "Starteinstellungen"

    06.jpg

    Clickt auf "Neu starten"

    07.jpg

    Hier drückt ihr nun einfach die Zifferntaste 7 für "Erzwingen der Treibersignatur deaktivieren". Euer Rechner startet neu und das war's dann auch schon.

    08.jpg

    Fahrt mit der Installation der Treiber wie in MÖGLICHKEIT 1 beschrieben fort.
     
    Zuletzt bearbeitet: 21.08.2015
    Rhonin, Rob J. Cole, Lorki und 13 anderen gefällt das.
  2. TimeTurn, 31.12.2013 #2
    TimeTurn

    TimeTurn Threadstarter Foren-Inventar

    UPDATE vom 31.12.2013:

    Ich hab mein System wegen einem Problem mit "Bioshock Infinite" (über Steam) nochmal neu aufsetzen müssen (erst Windows 7 zum testen, nun wieder Windows 8.1), dabei ist mir aufgefallen, das der alte hier beschriebene Weg mit der INF-Datei nicht funktioniert. Daher hab ich das Ganze nochmal mit dem Treiber versucht, der beim Flashtool dabei ist - und siehe da, der funktioniert. Flashtool bekommt ihr hier kostenlos: Download | Flashtool
     
    WolfgangN-63 gefällt das.
  3. TimeTurn, 06.02.2014 #3
    TimeTurn

    TimeTurn Threadstarter Foren-Inventar

    Gerry72 gefällt das.
  4. TimeTurn, 23.02.2014 #4
    TimeTurn

    TimeTurn Threadstarter Foren-Inventar

    UPDATE

    Inzwischen ist das Flashtool 0.9.14 raus, da sollten die aktualisierten Treiber mit drin sein.
     
  5. gogosch, 10.03.2014 #5
    gogosch

    gogosch Erfahrener Benutzer

    Verwende selbiges, aber die Installation der Treiber schmiert trotzdem ab mit einer Fehlermeldung! (Treiber konnten nicht installiert werden. )
     
    TimeTurn gefällt das.
  6. TimeTurn, 12.03.2014 #6
    TimeTurn

    TimeTurn Threadstarter Foren-Inventar

    Yepp, hab ich inzwischen auch nochmal gemacht - man muss auch mit den neuen Treibern die Treibersignatur deaktivieren wie beschrieben, damit ds funktioniert.

    Ich pass das mal im Eingangsposting an.

    Der ursprüngliche Beitrag von 09:57 Uhr wurde um 11:25 Uhr ergänzt:

    Update: Habe noch Vista und 7 mit aufgnommen und die Variante über die Gruppenrichtlinien eingefügt.
     
  7. ymicky, 15.03.2014 #7
    ymicky

    ymicky Erfahrener Benutzer

    Hat eig alles funktioniert, nur wenn ich auf alle Geräte beim installieren des Fastboot Treibers gehe steht dort kein "Sony sa0109 ADB Interface Driver", nur Sony ADB Interface und Sony Fastboot Interface. Habe bis jetzt bei beiden auf weiter gedrückt und ne halbe sekunde danach wurde sofort angezeigt das die Treiber erfolgreich aktualisiert worden sind. Trotzdem sehen ich mein Gerät nicht im Geräte-Manager und es bleibt auch nicht im Fastbootmode sondern startet sofort. Jemand eine Idee?
    [​IMG]
     
  8. TimeTurn, 15.03.2014 #8
    TimeTurn

    TimeTurn Threadstarter Foren-Inventar

    Du musst den Treiber manuell installieren wie in der Mitte von Punkt 7 beschrieben. ALso nach der Installation der Treiber vom Flashtool manuell die korrekten Treiber installieren.
     
  9. ymicky, 15.03.2014 #9
    ymicky

    ymicky Erfahrener Benutzer

    K
    Hab alle Treiber davon erfolgreich installiert

    Der ursprüngliche Beitrag von 17:00 Uhr wurde um 17:03 Uhr ergänzt:

    Edit:Sry dachte du meinst die vom Flashtool. Die jm Geräte-Manager hab ich ja wie ich im vorherigen Post geschrieben habe
     
  10. TimeTurn, 15.03.2014 #10
    TimeTurn

    TimeTurn Threadstarter Foren-Inventar

    Hmmm bei mir zeigt er dann dort den korrekten Treiber an. Warst Du auch im fastboot dabei? Er sollte mindestens eine halbe Minute im fastboot bleiben, eher er neu startet - dann muss ich auch passen fürchte ich.
     
  11. ymicky, 15.03.2014 #11
    ymicky

    ymicky Erfahrener Benutzer

    Mein Handy startet nach 3-5 sek. sofort.

    Der ursprüngliche Beitrag von 17:07 Uhr wurde um 18:06 Uhr ergänzt:

    Okay hab den Fehler entdeckt, alles funktioniert, wenn ich den USB 3.0 Port benutze^^
     
  12. Monkee, 14.12.2014 #12
    Monkee

    Monkee Android-Hilfe.de Mitglied

  13. Aaskereija, 15.12.2014 #13
    Aaskereija

    Aaskereija Foren-Inventar

    Die Treiber alleine bringen dir nix, oder glaubst du die adb befehle etc gehen einfach so?

    Aber zumindest ist das gut zu wissen, falls es neue Treiber gibt fuer Leute mit aelteren Flashtool
     
  14. TimeTurn, 15.12.2014 #14
    TimeTurn

    TimeTurn Threadstarter Foren-Inventar

    Doch bringen schon was, wenn man nur Fastboot braucht, etwa um ein Boot.img zu flashen. ADB-Kommandos hat doch meist eh jeder liegen.
     
  15. Mompelgard, 03.01.2015 #15
    Mompelgard

    Mompelgard Neuer Benutzer

    Hallo,

    ich wollte mein Xperia Go von Android 4.1 auf 2.3 mit der Anleitung von Aaskereija downgraden. Ich habe aber das Problem, dass die Installation der Treiber fehlschlägt.
    Dann habe ich die Anleitung von TimeTurn gefunden. Leider habe ich als Betriebssystem Windows 7 Home. Ich habe mir den Driver Signature Enforcement Overrider 1.3 heruntergeladen und den Test Mode aktiviert. Auf der Seite steht ich muss noch eine Systemdatei signieren. Welche muss ich auswählen? Die Flashtool-drivers.exe?

    Wie gehe ich dann bei Punkt 4 dieser Anleitung vor, wenn ich Windows 7 besitze? Dort finde ich die Eintragung erweiterter Start und so nicht. Muss ich da in den abgesicherten Modus?

    Und benötige ich irgendwelche Backups meines Smarthphones? Ich habe irgendwas von TA-Backups gelesen, brauche ich die auch?

    Tut mir leid, wenn ich so doofe Fragen stelle, aber ich kann mit manchen Begriffen nix anfangen.


    Danke im vorraus.

    Mfg

    Mompelgard
     
  16. Aaskereija, 03.01.2015 #16
    Aaskereija

    Aaskereija Foren-Inventar

    Die Anleitung hilft dir unter win7 nix. Und wenn du keine TA hast, brauchst du diese auch nicht (die braeuchte man nur wenn man noch Garantie hat und man den bootloader schliessen will)

    Welcher Fehler wird ueberhaupt angezeigt? Hast du Win7 32bit oder 64bit?
     
  17. Mompelgard, 03.01.2015 #17
    Mompelgard

    Mompelgard Neuer Benutzer

    Schöner Mist.

    Ich hab mir das Handy nochmal gekauft, bei dem ich es erstmal ausprobieren wollte, bevor ich mein "gutes" in einen Brick verwandel.
    Quasi, müsste ich das dann bei meinem anderen Beachten, weil da noch Garantie drauf ist.

    Es steht nur da, dass die Installation fehlgeschlagen ist. (Siehe Anhang)

    Ich hab Windows 7 64 Bit.
     

    Anhänge:

    • Flash.JPG
      Flash.JPG
      Dateigröße:
      1,8 KB
      Aufrufe:
      885
  18. Aaskereija, 03.01.2015 #18
    Aaskereija

    Aaskereija Foren-Inventar

    Ist dein Windows auch aktuell? Also Service pack 1 etc mit allen Updates? Manchmal liegts daran.

    Ansonsten wuesste ich nicht was da schlief laeuft. Vielleicht mal Flashtool deinstallieren und neu aufsetzen nach nem pc neu start eventuell passte da was nicht oder schalte etwaige Firewalls und Virenscanner aus, die funken gerne dazwischen.
     
  19. Mompelgard, 03.01.2015 #19
    Mompelgard

    Mompelgard Neuer Benutzer

    Ich hab die Version 6.1.7601 Service Pack 1.

    Seit neustem lassen sich 2 Updates nicht installieren, sind aber für Word, dürfte nicht schlimm sein.

    Neu installiert hatte ich es auch schon. Ging auch nicht.
    Ich versuch nochmal die Virenscanner auszuschalten und geb dann nochmal Bescheid.
     
  20. TimeTurn, 05.01.2015 #20
    TimeTurn

    TimeTurn Threadstarter Foren-Inventar

    Driver Signature Enforcement Overrider wird nicht mehr benötigt - das erledigt ein einzelner Kommandozeilenaufruf als Administrator eleganter:
    bcdedit.exe -set TESTSIGNING ON
    Nach getaner Arbeit dann wieder deaktivieren, um das hässliche Wasserzeichen auf dem Desktop wieder loszuwerden:
    bcdedit.exe -set TESTSIGNING OFF
    @mompelgard: Das sieht bei Dir aber sehr nach aktivem Signaturzwang aus. Versuch mal die o.g. Zeile.

    Der ursprüngliche Beitrag von 20:03 Uhr wurde um 20:07 Uhr ergänzt:

    PS: Mach auch mal folgends in der Admin-Kommandozeile:
    sfc /scannow
    Das scannt nach fehlenden Dateien und stellt auch Startmenüeinträge wieder her. Erfahrungsgemäß fallen Updates oft auf die Schnauze, wenn Startmenü-Einträge fehlen, etwa "Accessories" oder ähnliches (die der Explorer dann als "Zubehör" anzeigt). Besonders ironisch ist das Ganze unter Windows 8, das ja kein Startmenü mehr hat. Da auf sowas zu kommen, das hat bei mir ne ganze Weile gedauert :D
     

Benutzer fanden diese Seite durch die Suche nach:

  1. fast boot

    ,
  2. fastboot

    ,
  3. fastboot treiber installieren

    ,
  4. fastboot treiber,
  5. was ist fastboot,
  6. flash tool win8 driver,
  7. fastboot treiber windows 10,
  8. sony fastboot,
  9. s1 fastboot treiber windows 8,
  10. was ist fastboot windows,
  11. fastboot driver installation fehlgeschlagen,
  12. fastboot treiber für sony tablet z,
  13. windows 7 fastboot,
  14. s1 boot fastboot treiber,
  15. s1 boot fastboot treiber windows 10
Du betrachtest das Thema "[HOWTO] Was ist Fastboot? // Fastboot-Treiber unter Windows x64 installieren" im Forum "Anleitungen für Sony-Geräte",