Falsche Akku Prozentzahl

  • 35 Antworten
  • Neuester Beitrag
Diskutiere Falsche Akku Prozentzahl im Asus Padfone Infinity A86 Forum im Bereich Weitere Asus Geräte.
O

Osram12

Neues Mitglied
Seit eines morgens zeigt die prozentuale Akku Anzeige keine vernünftigen Werte mehr an, sondern meistens nur 1% oder gar 0%. Ich habe ein paar mal die Werte meines Akkus aufgeschrieben:

1% = 4.304 V (nachdem ich die ganze Nacht mit einem 2A netzteil geladen habe!)
9% = 4.303 V
10% = 3.865 V
23% = 3.860 V
40% = 4.302 V

Offensichtlich berechnet Android aus der Spannung und anderen Dingen die Prozentzahl.

Dies fing übrigens noch vor Kitkat an und auch das Update auf KitKat hat das Problem nicht behoben. Ich habe auch gerootet und mehrere Kalibrator-Apps die die batterystats.bin säubern ohne Erfolg ausprobiert.
Nicht so überraschend, eine Google Ingenieurin sagte, die batterystats.bin würde NICHT für die akku-Prozent_Berechnung da sein. Auch ein "Cache Wipe" hat nichts gebracht.

Was kann man da machen?
Weiss jemand wie die Berechnung der Prozentzahl funktioniert?

Übrigens haben auch andere das problem , z.B. in diesem Forum matze282 oder mehrere im Padfoneclub:
Forums / New Padfone Infinity Help / Padfone battery shows 1% despite being charged - Padfone Club

Dort meint ja einer dass es kein SW sondern ein HW Problem ist. ich hoffe mal dass er unrecht hat.
 
sinus23

sinus23

Fortgeschrittenes Mitglied
Es gibt apps, die z.B. lediglich alle Akku Temps etc löscht.

die "Volt" Zahl sagt nicht über die Leistung des Akkus aus, i.d.R. werde Akkusstandsanzeigen an der machbaren ah festgestellt.
Lädts du mit Tablet oder das Telefon solo? Schon mal den akku ganz und gar entleert, so das es nimmer anging? Sozusagen tief entladen und wieder aufgeladen?

Akku Lebenszyklus beachtet, d.h. als es neu war 5 mal komplett aufladen und leeren um maximale akku-lebendsdauer zu gewährleisten?

Wie Alt ist denn der Akku? Wie häufig geladen?

80% Aller akku Probleme sind auf falsche Handhabung zurückzuführen, zum glück sieht das recht vor, das eingebaute Akkus die Garantie des Gerätes tragen. Somit statt 6 Monate volle Garantie zeit von i.d.R. 2 Jahren
 
O

Osram12

Neues Mitglied
Danke für die Antwort.

sinus23 schrieb:
die "Volt" Zahl sagt nicht über die Leistung des Akkus aus, i.d.R. werde Akkusstandsanzeigen an der machbaren ah festgestellt.
Das ist wohl richtig; Ich habe von Leuten mit einem anderen Android Gerät gehört die sich einen stärkeren Akku gekauft haben und die Prozentuale Anzeige ging so schnell runter wie bei einem normalen Akku. Allerdings konnten sie dann bei 0 das Smartphone neu starten und da hat dann der Algorythmus gemerkt dass der Akku ja wieder seines Erwartens doch nicht leer ist.

Übrigens, gibt wenigstens Teile der Quellen die ASUS für die Padfone Firmware nutzt? Ich habe eine Datei mit Akkuberechnungen von Android gefunden aber
a) Nicht viel verstanden weil jede Menge Abkürzungen (wenn ich mich recht erinnere fcc, ovc..) benutzt werden und nicht erklärt werden
b) Ich mir gut vorstellen kann dass zB je nach verbauter Hardware diese Teile der Quellen unterschiedlich sind.

Lädts du mit Tablet oder das Telefon solo?
Normalerweise solo.

Schon mal den akku ganz und gar entleert, so das es nimmer anging? Sozusagen tief entladen und wieder aufgeladen?
Ja, das soll man nach Nutzung der Kalibrier-Apps machen und das habe ich auch gemacht.

Akku Lebenszyklus beachtet, d.h. als es neu war 5 mal komplett aufladen und leeren um maximale akku-lebendsdauer zu gewährleisten?
Nein. Ich dachte man kann nur NiCd "trainieren" und das A86 hat Li-Ionen?

Wie Alt ist denn der Akku? Wie häufig geladen?
6 Monate, mindestens 1 mal am Tag.
 
G

gainerking

Neues Mitglied
Ich habe das selbe Problem, zwar ist es nicht essentiell zu wissen wie voll der Akku ist, es nervt aber schon ziemlich. Ich würde mich also auch über eine Lösung freuen .

An einem Bug in der Systemsoftware kann es auch nicht liegen. Ich hoffe, das ich es nicht einschicken muss -.-
Danke im voraus.
 
sinus23

sinus23

Fortgeschrittenes Mitglied
Ein Fall für die Werkstatt, vermutlich gibt die Logik des Akkus falsche Interpreter werte wieder.
Sollte es der Interpreter im OS selbst sein, wäre das Problem mit einem Update behoben
 
Q

qbcgraphics

Neues Mitglied
Hi @ll

ich hatte das selbe Problem. Habe es dann zur Reparatur gegeben. Es kam mit einem neuen Akku zurück jedoch war das Problem immer noch da. Ich habe dann ein wenig Druck gemacht und ein neues Gerät bekommen. Die Wartezeit betrug auch geschlagene 6 Wochen. Jetzt ist aber alles wieder OK. Habe im Internet diverse Beiträge zu Akkuproblemen gelesen und da gibt es wohl nichts anderes als einmal austauschen. Das wird wohl ein Hardwaredefekt sein aber wo genau keine Ahnung. Jedenfalls mit dem Akkutausch hat es sich nicht gelöst mein Problem.

Grüsse qbcgraphics
 
Doktor Schuh

Doktor Schuh

Ambitioniertes Mitglied
Hallo an alle,

ich habe nun das gleiche Problem. Akku lädt und sackt plötzlich auf 1% ab. Auch nach dem Laden und einem Neustart, derselbe Quatsch.
Habe testweise den Akku meines anderen A86 genommen und bekomme die gleiche Anzeige. Egal welchen Akku ich verwende, ich erhalte immer 1%. Lege ich die Akkus in das andere A86 ist alles ok.
Beide haben Lollipop drauf, das mit der falsche Akkuanzeige ist gerootet. Ich tippe hier auf einen Hardwarefehler. Zum letzen Beweis werde ich demnächst das Telefon noch einmal zurücksetzen. Aber eigentlich wollte ich nicht schon wieder das gesamte System neuaufsetzen. Das hatte ich ja erst nach dem Wechsel auf Lollipop durchgemacht.

Leider muss ich noch das andere Telefon wegen defektem GPS reparieren lassen. Der erste Reparatur-Versuch von ASUS ist schonmal gescheitert. :(
Ich teste jetzt mal wie lange er trotz der 1%-Anzeige durchhält. Den Energiesparmodus habe ich jetzt abgeschaltet, da mir die Meldung auf den Senkel geht.

Langsam geht mir das Padfone auf die Nerven. Display kaputt (super empfindlich beim Sturz), dann Display Padfone Station, dann GPS defekt und nun Akku. Und ich habe beide noch keine 2 Jahre.
 
Ozryel

Ozryel

Fortgeschrittenes Mitglied
Und ich dachte mein Akku wär einfach hinüber.
Ich habe genau das gleiche Problem wie du:
Handy liegt am Ladegerät und lädt meist auf 99%, manchmal sogar noch auf 100%. Mache das Handy ab und nichtmal 60 Minuten später hab ich angeblich nur noch ein Prozent. Halten tut es aber trotzdem noch die normalen 6 bis 7 Stunden bei meienr Nutzung.
Wenn das Handy denkt es wär voll geladen und ich starte es neu, hab ich zack wieder nur 1%.
Irgendwelche "Energiesparoptionen" hab ich sowieso deaktiviert.

So langsam neigt sich meine Padfone-Zeit wohl auch dem Ende...
 
Doktor Schuh

Doktor Schuh

Ambitioniertes Mitglied
Laut Asus Zenforum ist das Probem auch bei anderen Asus-Produkten, wie etwa dem Zenfone bekannt. Abhilfe kam damals durch ein Update der FW. Da es sich hierbei anscheinend um ein Problem von mehreren FW-Versionen handelt, sehe ich keine schnelle Lösung. Eine angebliche "Notlösung" soll wohl die Deaktivierung des Akku-Widgets mit den Lollipop-Update gewesen sein.
Ursache soll wohl auch ein SW-Problem sein, wo falsche Werte in Dateien und Tabellen zum Akkuverbrauch und den Kennzahlen des Akkus stehen. So versteht das System wohl nicht, dass z. B. 2500 mAh = voll ist und interpretiert die Werte anders.
Aber so richtig verstanden hat das wohl noch keiner. ;-)
Schade.
 
Ozryel

Ozryel

Fortgeschrittenes Mitglied
Hast du einen Link zu dem Thread?
Ich würds mit gern mal komplett durchlesen
 
Ozryel

Ozryel

Fortgeschrittenes Mitglied
Könntest du mal den Inhalt von folgender Datei posten? Gern auch per Screenshot
/sys/class/power_supply/battery/uevent

Für das Zenfone hat Asus das anscheinend in den Griff bekommen. Wir sollten uns eventuell mal beim Support melden und auf den Fehler beim Zenfone hinweisen
 
Doktor Schuh

Doktor Schuh

Ambitioniertes Mitglied
ok, hab ich. was liest du daraus? Wie sieht das bei dir aus?
 

Anhänge

Ozryel

Ozryel

Fortgeschrittenes Mitglied
Sieht bei mir genau so aus, abgesehen davon, dass mein Akku voller ist...

Es ging mir um die Zeile: POWER_SUPPLY_CHARGE_FULL_DESIGN=2500

So wie ich das in dem Thread zum Zenfone verstanden hab, drehte es sich darum, dass die Kapazität des Akkus, sowie die höchste und niedrigste Spannung irgendwie verkehrt ist.

Aber wir beide haben 2500 eingetragen, was ja auch der Kapazität in mAh entspricht.
Voltage max und min sind auch gleich.
Ist schon komisch. Ich werd morgen mal den Support deswegen anschreiben.
 
Doktor Schuh

Doktor Schuh

Ambitioniertes Mitglied
Cool, melde Dich wenn Du dort Unterstützung brauchst.

Grüße.
 
Ozryel

Ozryel

Fortgeschrittenes Mitglied
So, ich hab Asus geschrieben. Mal sehn was dabei rum kommt...
 
Ozryel

Ozryel

Fortgeschrittenes Mitglied
Root ist kein Problem

Viele dieser "kalibrier" Apps löschen nur die Batterystats, was nicht viel bringt.
Ich schaus mir aber trotzdem mal an

Edit: Wie vermutet löscht die App nur die batterystats.bin... In dieser Datei steht leider nichts drin, was mit dem Akku zu tun hat, sondern nur die Werte welche App wie viel verbraucht hat die man in den Einstellungen sieht.
Die App hat also keinen wirklichen Effekt
 
V

Vual

Neues Mitglied
...hilft alles nichts, hatte mit dem selben Problem zu kämpfen. Meine Tochter hat das Telefon öffters fallen gelassen und damit begann eine Reparatur-Reise des A86. Erst Akku 1%-Fehler, dann WLAN/Bluetooth Empfang weg... aber nun zurück zum Thema: Es ist der klumpige Akku-Stecker/Buchse schuld. einfach bisschen zusammengefaltetes Papierstück über dem Stecker hinlegen/ankleben und probieren ob es funktioniert hat. Damit drückt der hintere Deckel auf den Stecker und die Kommunikations-Leitung bekommt Kontakt. Falls es nicht geholfen hat -> mehr Papier zusammenfalten... usw
 
Ozryel

Ozryel

Fortgeschrittenes Mitglied
Ich hatte den Akku bereits komplett ausgebaut und auch richtig fest wieder rein, aber cih werds trotzdem mal Probieren, danke
-- Dieser Beitrag wurde automatisch mit dem folgenden Beitrag zusammengeführt --
10 Punke für @Vual
Es scheint jetzt wirklich wieder zu funktionieren...