Autoradio automatisch über Bluetooth verbinden

  • 14 Antworten
  • Neuester Beitrag
Diskutiere Autoradio automatisch über Bluetooth verbinden im Automatisierung - Tasker im Bereich Tools.
M

Mike-El

Erfahrenes Mitglied
Hallo,

Ich versuche jetzt schon seit einiger Zeit meine freisprecheinrichtung vom Autoradio zu nutzen.

Dafür hab ich mir ein Tasker Profil gebaut. Aber es funktioniert nicht richtig.

Ich gehe so vor. Wenn ich ein WLAN erlassen soll er nach einer gewissen Zeit BT einschalten und wenn das Autoradio in der nähe ist, sich mit ihm verbinden. Dies soll so lange anhalten bis ich das Auto verlasse. Dann soll evtl noch eine gewisse Zeit gewartet werden. Falls man mal tankt und dann soll BT abgeschaltet werden.

Mein Problem ist jetzt folgendes.

Ich verlasse mein WLAN und Tasker prüft ob das Radio da ist. Koppelt sich mit ihm aber bricht die Verbindung wieder ab. Dies passiert mit der ei gestellten zeit die Tasker warten soll in dem Fall das kein Autoradio zur Verfügung steht.

Ich vermute es stimmt was nicht mit meiner variablen Einstellung.

Ich konnte das Projekt nur als XML exportieren. Vielleicht kann mir ja jemand helfen. Ist bestimmt nix großes.

http://db.tt/tIEUXLJ8

Lg
 
coolfranz

coolfranz

Lexikon
Nur als Anregung: wieso soll sich Tasker mit dem Autoradio verbinden?

Bei meinem Sony Radio ist es so, das es sich von alleine mit dem Smartphone verbindet, wenn es verfügbar ist.
 
M

Mike-El

Erfahrenes Mitglied
Ist richtig. Ich will aber nicht rund um die Uhr BT anhaben. Und auch nicht immer manuell BT einschalten und ausschalten.

Deswegen hab ich an so ein Profil gedacht.

Lg
 
coolfranz

coolfranz

Lexikon
Wie wärs mit Profilen und Exit Tasks?

Zuhause im Wlan: Profil Wlan zu Hause getriggert durch deine SSID zu Hause.
Dann als Exit Task Bluetooth an.

Das selbe dann bei der Verbindung zum Autoradio.
 
M

Mike-El

Erfahrenes Mitglied
Genauso hatte ich es ja probiert. Aber an irgendeiner stelle hab ich einen Fehler drinne.

Lg
 
S

Scorba

Fortgeschrittenes Mitglied
Wie wäre es mit:
Profil1:
Bluetooth verbunden:
Eingangstask: Variable BluCon=1
Ausgangstask: Variable BluCon=0
Profil2:
-Wenn nicht WLAN verbunden:
Eingangstask: -Bluetooth an
- Wait (Zeit deiner Wahl)
-If BluCon=0
Bluetooth aus
Ausgangstask:-Bluetooth aus
 
M

Mike-El

Erfahrenes Mitglied
Ich werde das mal probieren und berichten.

Lg
 
M

Mike-El

Erfahrenes Mitglied
So, ich hab das jetzt mal probiert. Das positive ist. Das Bluetooth bleibt stabil an. Problem ist. Wenn ich das Haus verlasse und nicht ins Auto steige geht Bluetooth nicht aus. Genauso geht Bluetooth nicht aus wenn ich nach dem fahren aus dem Auto aussteige und die Verbindung zum Radio weg ist.

Hier mal als Bilder mein programm













Lg

Edit


Ich glaube so funktioniert es...




So schaltet er auf jeden Fall ab wenn er nicht mit BT verbunden wird.

Danke an alle die geholfen haben und vielleicht helfen die Bilder ja noch wem anders
 
Zuletzt bearbeitet:
DeAndi

DeAndi

Experte
Hallo habe zwei Lösungsansätze für dich.

1. Llama ;)

2. Hast du den Bluetooth Namen deines Autoradio in Tasks eingetragen ?
 
M

Mike-El

Erfahrenes Mitglied
Hi,

Ja danke es funktioniert wie es soll.

Lg
 
D@ve

D@ve

Erfahrenes Mitglied
ich habs bei mir so gelöst:
Wenn das Handy lädt => BT an (da ist Akku verbrauch eh egal)
Wenn nicht läft: BT aus

Im Auto hab ich das Handy eh immer in der Ladestation. Und wenn das Handy mit dem Radio verbunden ist, wird automatisch der Auto-Modus gestartet.

Problem ist, dass er sich nur kurz mit dem Autoradio verbindet und dann nach ein paar Sekunden wieder entkoppelt. Erst wenn ich nochmal manuell unter BT auf das Autoradio (JVC R741 BT) gehe und dann Medienwiedergabe deaktiviere funktioniert's.

Gruß, Dave
 
Zuletzt bearbeitet:
D@ve

D@ve

Erfahrenes Mitglied
Hab immer noch das Problem... Hab ewig rum probiert.

ich hab ein Eingangstask, das ausgeführt werden soll, wenn ich mich mit dem Auto-Radio per BT verbinde und einen entsprechenden Ausgangstask.

Aber ich kann machen was ich will. Er führt den Eingangstask aus und danach direkt den Ausgangstask.
Das Profil bleibt aktiviert (eigentlich logisch, er ist ja noch verbunden). Ich hab auch am Ende mal eine Wartezeit von einer Minute eingefügt (dachte, dass beim connecten die Verbindung vielleicht kurz unterbrochen wird) aber das hat auch nichts geholfen.


Code:
20130924 17.55.50 P Active   ID45     Auto
20130924 17.55.50 T Running  ID2      Location: Auto-Modus: Ein
20130924 17.55.50 P Inactive ID45     Auto
20130924 17.55.51 A OK       ID2.1    Location: Auto-Modus: Ein.Secure Settings
20130924 17.55.51 T Running  ID22:2   Location: Auto-Modus: Aus
20130924 17.55.51 A OK       ID2.2    Location: Auto-Modus: Ein.Task Ausführen
20130924 17.55.51 T Running  ID21:3   Mobile Daten: Ein
20130924 17.55.51 A OK       ID21:3.1 Mobile Daten: Ein.Mobile Daten
20130924 17.55.51 T ExitOK   ID21:3   Mobile Daten: Ein
20130924 17.55.51 A OK       ID2.3    Location: Auto-Modus: Ein.Task Ausführen
20130924 17.55.51 T Running  ID18:4   WiFi: Aus
20130924 17.55.58 P Active   ID45     Auto
20130924 17.55.59 T RejCopy  ID2      Location: Auto-Modus: Ein
20130924 17.56.06 A OK       ID18:4.1 WiFi: Aus.Warte
20130924 17.56.06 A OK       ID18:4.2 WiFi: Aus.Wi-Fi
20130924 17.56.06 T ExitOK   ID18:4   WiFi: Aus
20130924 17.56.06 A OK       ID2.4    Location: Auto-Modus: Ein.Task Ausführen
20130924 17.56.07 T Running  ID6:5    Sound: Laut
20130924 17.56.07 A OK       ID6:5.1  Sound: Laut.Lautlos
20130924 17.56.07 A OK       ID6:5.2  Sound: Laut.Alarmlautstärke
20130924 17.56.07 A OK       ID6:5.3  Sound: Laut.Klingelton Lautstärke
20130924 17.56.07 A OK       ID6:5.4  Sound: Laut.Benachrichtigungs Lautstärke
20130924 17.56.07 A OK       ID6:5.5  Sound: Laut.Systemlautstärke
20130924 17.56.07 A OK       ID6:5.6  Sound: Laut.Vibriere beim Klingeln
20130924 17.56.07 T ExitOK   ID6:5    Sound: Laut
20130924 17.56.07 A OK       ID2.5    Location: Auto-Modus: Ein.Task Ausführen
20130924 17.56.07 T Running  ID4:6    Helligkeit: 100%
20130924 17.56.07 A Disabled ID4:6.1  Helligkeit: 100%.Beende Applikation
20130924 17.56.07 A OK       ID4:6.2  Helligkeit: 100%.Auto-Helligkeit
20130924 17.56.07 A OK       ID4:6.3  Helligkeit: 100%.Display Helligkeit
20130924 17.56.07 A Disabled ID4:6.4  Helligkeit: 100%.Lade Applikation
20130924 17.56.07 A Disabled ID4:6.5  Helligkeit: 100%.Taste
20130924 17.56.07 T ExitOK   ID4:6    Helligkeit: 100%
20130924 17.56.08 A OK       ID2.6    Location: Auto-Modus: Ein.Display Timeout
20130924 17.56.08 A OK       ID2.7    Location: Auto-Modus: Ein.Lade Applikation
20130924 17.56.08 A OK       ID2.8    Location: Auto-Modus: Ein.Lade Applikation
20130924 17.56.08 A OK       ID2.9    Location: Auto-Modus: Ein.Profil Status
20130924 17.56.08 A OK       ID2.10   Location: Auto-Modus: Ein.Profil Status
20130924 17.56.08 A OK       ID2.11   Location: Auto-Modus: Ein.Tasker Icon setzen
20130924 17.56.08 A OK       ID2.12   Location: Auto-Modus: Ein.Variable Setzen
20130924 17.56.09 A OK       ID2.13   Location: Auto-Modus: Ein.Secure Settings
20130924 17.56.09 A OK       ID2.14   Location: Auto-Modus: Ein.Secure Settings
20130924 17.56.09 A OK       ID2.15   Location: Auto-Modus: Ein.Beende Applikation
20130924 17.56.09 A OK       ID2.16   Location: Auto-Modus: Ein.Secure Settings
20130924 17.56.09 A OK       ID2.17   Location: Auto-Modus: Ein.Home-Screen anzeigen
20130924 17.56.10 A OK       ID2.18   Location: Auto-Modus: Ein.Home-Screen anzeigen
20130924 17.57.09 A OK       ID2.19   Location: Auto-Modus: Ein.Warte
20130924 17.57.09 A OK       ID2.20   Location: Auto-Modus: Ein.Klingelton Abspielen
20130924 17.57.09 T ExitOK   ID2      Location: Auto-Modus: Ein
20130924 17.57.09 A OK       ID22:2.1 Location: Auto-Modus: Aus.Shell Ausführen
20130924 17.57.10 A OK       ID22:2.2 Location: Auto-Modus: Aus.Automodus
20130924 17.57.10 A OK       ID22:2.3 Location: Auto-Modus: Aus.Beende Applikation
20130924 17.57.10 A OK       ID22:2.4 Location: Auto-Modus: Aus.Beende Applikation
20130924 17.57.10 A OK       ID22:2.5 Location: Auto-Modus: Aus.Task Ausführen
20130924 17.57.10 T Running  ID6:7    Sound: Laut
20130924 17.57.10 A OK       ID6:7.1  Sound: Laut.Lautlos
20130924 17.57.10 A OK       ID6:7.2  Sound: Laut.Alarmlautstärke
20130924 17.57.11 A OK       ID6:7.3  Sound: Laut.Klingelton Lautstärke
20130924 17.57.11 A OK       ID6:7.4  Sound: Laut.Benachrichtigungs Lautstärke
20130924 17.57.11 A OK       ID6:7.5  Sound: Laut.Systemlautstärke
20130924 17.57.11 A OK       ID6:7.6  Sound: Laut.Vibriere beim Klingeln
20130924 17.57.11 T ExitOK   ID6:7    Sound: Laut
20130924 17.57.11 A OK       ID22:2.6 Location: Auto-Modus: Aus.Beende Applikation
20130924 17.57.11 A OK       ID22:2.7 Location: Auto-Modus: Aus.Beende Applikation
20130924 17.57.11 A OK       ID22:2.8 Location: Auto-Modus: Aus.Secure Settings
20130924 17.57.11 A OK       ID22:2.9 Location: Auto-Modus: Aus.Display Timeout
20130924 17.57.11 A OK       ID22:2.10 Location: Auto-Modus: Aus.Tasker Icon setzen
20130924 17.57.11 A OK       ID22:2.11 Location: Auto-Modus: Aus.Profil Status
20130924 17.57.11 A OK       ID22:2.12 Location: Auto-Modus: Aus.Profil Status
20130924 17.57.11 A OK       ID22:2.13 Location: Auto-Modus: Aus.Profil Status
20130924 17.57.11 A OK       ID22:2.14 Location: Auto-Modus: Aus.Secure Settings
20130924 17.57.11 A OK       ID22:2.15 Location: Auto-Modus: Aus.Secure Settings
20130924 17.57.12 A OK       ID22:2.16 Location: Auto-Modus: Aus.Beende Applikation
20130924 17.57.13 A OK       ID22:2.17 Location: Auto-Modus: Aus.Beende Applikation
20130924 17.57.13 A OK       ID22:2.18 Location: Auto-Modus: Aus.Secure Settings
20130924 17.57.14 A OK       ID22:2.19 Location: Auto-Modus: Aus.Home-Screen anzeigen
20130924 17.57.14 A OK       ID22:2.20 Location: Auto-Modus: Aus.Home-Screen anzeigen
20130924 17.57.14 T ExitOK   ID22:2   Location: Auto-Modus: Aus
Gruß, Dave
 
thloe

thloe

Stammgast
Hallo, habe eine andere dazu: Nachdem sich BT verbunden hat, soll jedoch Media Audio (unter den BT Einstellungen) deaktiviert werden. Weiss jemand wie das geht?
Vielen Dank im Voraus!!!
 
schmetty2

schmetty2

Stammgast
Hallo,

das brauchste eigentlich hur einmal händisch machen, denn merkt Android sich das.

mfg
 
thloe

thloe

Stammgast
Ok, meinte ich anders, mein Fehler. Sobald ich TomTom aktiviere soll sich Media Audio deaktivieren. Danke nochmals im Voraus