Regelmässige Task ausführen obwohl Deep Sleep?

  • 18 Antworten
  • Neuester Beitrag
Diskutiere Regelmässige Task ausführen obwohl Deep Sleep? im Automatisierung - Tasker im Bereich Tools.
M

mbefore305

Erfahrenes Mitglied
Habe ohne Erfolg gesucht (hier und Netz), verzeiht, wenn ich die Lösung übersehen habe.

Ich möchte mit Tasker eine Task regelmäßig ausführen (z.B. all 30 Minuten).
Das funktioniert, aber nur solange das Handy nicht im Tiefschlaf ist. Soweit kann ich das verstehen,
nur weiß ich nicht, wie ich das Telefon für diesen Zweck automatisch aufwecken kann.

Nehme an, es ist unabhängig vom Handy, aber falls nicht: Samsung Galaxy S7, Android 7 (Nougat).

Freu' mich über Tipps und hoffe, ich habe mein Problem verständlich erklärt).
 
M

mickk

Stammgast
In Tasker kann man unter Einstellungen / Anzeige / "Use reliable alarms" eine besonders aggressive Methode einschalten, bei der erfahrungsgemäß tatsächlich alle auch zeitgesteuerten Aktionen pünktlich ausgeführt werden. Nachteil ist der erhöhte Akkuverbrauch.

Ich verwende diese Option nicht, fahre aber mit automatisch gesetzten Kalendereinträgen und ihrer Auswertung ziemlich zuverlässig und dennoch stromsparend (vgl. Tasker: Power). Ich habe nach meiner Erinnerung noch nie einen zeitgesteuerten Termin verpasst.

Gruß
Mick
 
Rak

Rak

Gesperrt
Alternativ geht auch recht zuverlässig als Profil einen Zeitraum von 5 min festzulegen und die gewünschten Aktionen im Ausgangstask festzulegen.
 
M

mbefore305

Erfahrenes Mitglied
@mickk: Meine Task möchte ich alle 30 Minuten ausführen. Weisst Du, wie stark sich die Option "Use reliable alarms" dann auf den Akku auswirkt?
Geht das Handy dann gar nicht mehr in Deep Sleep? Ein paar Prozent am Tag wären egal. Ich teste es auf jeden Fall mal.
Mit Kalender würde bedeuten, dass ich 48 Einträge pro Tag mache . . .

@Rak: Genau das hatte ich versucht, hat aber nicht mehr funktioniert, sobald das Handy in Tiefschlaf geht.
 
Rak

Rak

Gesperrt
Tasker ist vom Doze Mode ausgeschlossen?
 
M

mbefore305

Erfahrenes Mitglied
Denke schon. Tasker ist als nicht überwachte app definiert,
Bei den ganzen Settings im Samsung bin ich aber nicht 100% sicher.
Habe Momentan auch Probleme mit Push mail, die nicht kommt (keine Benachrichtigung, keine LED, und nicht auf meiner Smartwatch).
Aber Whatsapp klappt. Anderes Thema, ich teste noch, bevor ich ein anderem Unterforum einen Thread aufmache.
 
M

mbefore305

Erfahrenes Mitglied
Einstellungen -> Gerätewartung -> Akku
Ganz nach unten Scrollen, da gibt es dann 'Nicht überwachte Apps' und da ist Tasker gelistet.
 
Rak

Rak

Gesperrt
Da ich noch kein Nougat habe: Den Punkt Akkuoptimierung gibt es da im Menü nicht mehr?
 
M

mbefore305

Erfahrenes Mitglied
Gibt es, hatte ich aber bisher noch nicht bemerkt, habe Nougat auch erst seit 1 Woche.
Zumindest Tasker ist dort nicht aktiviert (wird also nicht Akku Optimiert).
 
schmetty2

schmetty2

Stammgast
mbefore305 schrieb:
Einstellungen -> Gerätewartung -> Akku
Ganz nach unten Scrollen, da gibt es dann 'Nicht überwachte Apps' und da ist Tasker gelistet.
Guten Morgen

Das ist nur der Energiemonitor. Du musst Tasker bei "Aukkuverbrauch optimieren" auf nicht optimiert setzen.
Taskers Akkuverbrauch ist absolut vernachlässigbar mit und ohne "Use reliable alarms". Aktuell habe ich 31 mAh bei einer Laufzeit von 28 Stunden.
Und ich habe nicht wenige Profile am Laufen.

mfg
 
M

mbefore305

Erfahrenes Mitglied
Feedback:
Mit Anpassen der Einstellungen wie oben vorgeschlagen (Reliable Alarms, Keine Akkuoptimierung, usw.) scheint so weit alles wie gewünscht zu funktionieren.

Ich seh' hier niergendwo einen Haken, so dass ich diesen Thread als 'solved' markieren kann?
 
M

mickk

Stammgast
Danke fürs Feedback :)

"Solved" gibts hier nicht. Macht m.E. aber auch nix, denn wenn man die Suche bemüht, sollte man die Fundstücke ja ohnehin genauer unter die Lupe nehmen.
 
M

mbefore305

Erfahrenes Mitglied
Noch ein Update:
Reliable Alarms hat einen kleinen Nebeneffekt: Ich benutze KWGT Widgets und in einem Widget wird die Zeit des nächsten Alarms angezeigt.
Da steht nun aber immer eine falsche Zeit (immer 30 Minuten im voraus, 14:30, 15:00, 15:30, usw), die wird wohl von Tasker gesetzt um das Handy aufzuwecken.
Habe in Tasker auf die schnelle keine Variable gefunden, die die korrekte Alarmzeit hat. Dann könnte ich die an KWGT weiterleiten und
diese dort anzeigen, statt den falschen Systemwert.
 
schmetty2

schmetty2

Stammgast
Jo,
ähnliches Problem hatte ich mit Zooper. Bin vom integrierten Wecker zu AlarmPad gewechselt. Den kann man auch über Tasker wunderbar steueren.

mfg
 
M

mbefore305

Erfahrenes Mitglied
Klingt gut, leider wird AlarmPad nicht im Play Store gellistet (nicht im meinem Land verfügbar).
 
M

mickk

Stammgast
Ah, jetzt weiß auch wieder, warum ich die "reliable alarms" nicht mehr verwende :(.
 
C

cramu

Dauergast
mbefore305 schrieb:
Klingt gut, leider wird AlarmPad nicht im Play Store gellistet (nicht im meinem Land verfügbar).
Die App wird nicht mehr weiterentwickelt.
 
schmetty2

schmetty2

Stammgast
Funktioniert aber unter Android 7 trotzdem noch.