Smart Home Aktion Schalten

  • 39 Antworten
  • Neuester Beitrag
Diskutiere Smart Home Aktion Schalten im Automatisierung - Tasker im Bereich Tools.
B

Bahni

Fortgeschrittenes Mitglied
Hallo,
ich möchte das beim eintreten in mein heimisches WLAN die an der FritzBox angeschlossene "SmartHome" Dect Steckdose eingeschalten wird.
Habe es nun soweit hinbekommen das wenn ich mein WLAN betrete die App "MyFritz2" gestartet wird.
Nun muss aber in der App noch das "Smart Home" Menü geöffnet werden und der Button "AN" gedrückt werden.
Wie mache ich das mit Tasker?
 
B

Bahni

Fortgeschrittenes Mitglied
Habe mich gerade mal etwas belesen zu deinem Vorschlag.
Man braucht eine gültige SID der FritzBox.
Du hast da die "0" stehen damit gehts nicht.
Wie komme ich an die SID meiner Box?
 
schmetty2

schmetty2

Stammgast
Hallo

geht mit 0. Schalte schon ewig mit Tasker meine Dect200.

mfg
 
B

Bahni

Fortgeschrittenes Mitglied
schmetty2 schrieb:
Hallo

geht mit 0. Schalte schon ewig mit Tasker meine Dect200.

mfg
Bei mir leider nicht.
Hast du auch die 7490 mit neuster Firmware?
Wenn ich die Zeile mit meiner AIN in den Browser eingebe/kopiere kommt die Meldung:
Der Zugriff auf fritz.box wurde verweigert
Sie sind nicht zum Aufrufen dieser Seite autorisiert.
HTTP ERROR 403

https://avm.de/fileadmin/user_uploa...ttstellen/AVM_Technical_Note_-_Session_ID.pdf
https://avm.de/fileadmin/user_upload/Global/Service/Schnittstellen/AHA-HTTP-Interface.pdf
 
schmetty2

schmetty2

Stammgast
Hallo

nicht im Browser!!!
HTTP get Funktion von Tasker hab ich geschrieben.

mfg
 
B

Bahni

Fortgeschrittenes Mitglied
OK, dachte es geht auch im Browser.
Habe nun im Tasker "HTTP Get" geöffnet, wo genau muss ich deine Zeile (natürlich mit meiner AIN) reinkopieren?
Muss sonst noch etwas eingestellt werden?
 
schmetty2

schmetty2

Stammgast
Hallo

in die erste Zeile bei Server : Port und das wars.

mfg
 
B

Bahni

Fortgeschrittenes Mitglied
Funktioniert bei mir nicht. Die Fritz!Dect 200 rührt sich nicht.
 
O

oggy

Experte
eventuell muss die SmartHomeFunktion fürs Netzwerk freigegeben werden.
 
B

Bahni

Fortgeschrittenes Mitglied
oggy schrieb:
eventuell muss die SmartHomeFunktion fürs Netzwerk freigegeben werden.
Habe die AVM App MyFritz! auf dem Smartphone und damit kann ich die Steckdose schalten, dann sollte es doch nicht daran liegen.

Zum testen müsste die Zeile doch auch im Browser funktionieren, weil schmetty2 oben schreibt es funktioniere nur mit Tasker?

AVM schreibt hier:
https://avm.de/fileadmin/user_upload/Global/Service/Schnittstellen/AHA-HTTP-Interface.pdf
"Ab Firmware 6.50 sid-Parameter(SessionID) immer benötigt, Session-ID Referenz korrigiert"
 
Zuletzt bearbeitet:
schmetty2

schmetty2

Stammgast
Hallo

kopier den Befehl mal aus der pdf. Vllt. habe ich mich verschrieben.

mfg
 
O

oggy

Experte
Bahni schrieb:
Habe die AVM App MyFritz! auf dem Smartphone und damit kann ich die Steckdose schalten, dann sollte es doch nicht daran liegen.
Ist der Haken für "Smarthome-Freigabe im Heimnetz" gesetzt? (Heimnetz>Heimnetzübersicht>Netzwerkeinstellung) ...

die im PDF aufgeführte Methode hatte ich auch schon unter Linux am laufen (erst SessionID erfragen und dann damit die Steckdose schalten), aber seit dem ich FHEM laufen habe, schalte ich über FHEM. Bei FHEM hab ich kein Passwort setzen müssen, soweit ich mich erinnere.
 
Rak

Rak

Gesperrt
Hi, ich mache das über Tasker mit der sowieso für Fritzboxen empfehlenswerten App "Box to go" :
BoxToGo Pro – Android-Apps auf Google Play

Eh besser nutzbar als die Apps von AVM, finde ich und daher zu Recht hoch bewertet im Play Store.

Das Schalten eines Smart Home Gerätes (bei mir Steckdosen) geht über eine Verknüpfung. Verknüpfungsn kann man auch in Tasker einbauen (über die Secure Settings).
 
schmetty2

schmetty2

Stammgast
@oggy
Ich habe diesen Haken in den Netzwerkeinstellungen nicht gesetzt und es funzt. Die sid brauch nicht abgefragt werden. 0 ist immer gültig.

mfg
 
schmetty2

schmetty2

Stammgast
Hallo,

ich hab' Dir mal meinen Task angehängt. Ändere die Aktornummer und probier mal.
Den Haken bei "Manuelles Schalten zulassen" hast Du gesetzt? Müsste eigentlich sonst würde es mit der App nicht gehen. Aber guck nochmal nach.

mfg
 

Anhänge

  • DectAN.tsk.zip
    468 Bytes Aufrufe: 170
B

Bahni

Fortgeschrittenes Mitglied
Danke schmetty2, leider geht es auch mit deiner Kopie bei mir nicht.
Wenn du den Task manuell (mit den Play Pfeil links unten) ausführst wird dann bei dir etwas angezeigt?
Was hast du für fritzbox mit welcher Firmware?
 
Zuletzt bearbeitet:
schmetty2

schmetty2

Stammgast
Hab' ne 7490 und zur Zeit keine Laborversion drauf.
Ist Deine Dect aktuell 03.83?
 
B

Bahni

Fortgeschrittenes Mitglied
Aktor Versionsnummer steht bei mir 03.59
Kann ich die Updaten?
Wenn du den Task manuell (mit den Play Pfeil links unten) ausführst wird dann bei dir etwas angezeigt?
 
Zuletzt bearbeitet: