Toggle Wifi Api 29 in Tasker blockiert

  • 23 Antworten
  • Neuester Beitrag
Diskutiere Toggle Wifi Api 29 in Tasker blockiert im Automatisierung - Tasker im Bereich Tools.
H

hugn

Stammgast
Seit heute kann Tasker plötzlich WLAN nicht mehr ausschalten. Verwende das Poco F3 und es war auch kein Update des Systems seit Wochen da. Wie kann von jetzt auf sofort Google plötzlich diese Funktion blockieren?
Ach, das Gerät ist nicht gerootet
IMG_20220617_212921.jpg
 
holms

holms

Ikone
@hugn Hallo, funktioniert bei mir weiterhin.

Was nicht mehr funktioniert seit einer Weile, ist das Umschalten, während das Gerät ansonsten im Flugmodus ist. Ist das so bei dir?
 
H

hugn

Stammgast
Nein einfach WLAN aus. Z.B. wenn man nicht mehr in der Nähe eines Funkmastes ist. Bis gestern hat es immer funktioniert.IMG_20220618_100624.jpg
 
holms

holms

Ikone
@hugn Ok..

Installiere die "Tasker Settings" von hier (Version 1.4.0) - hast du anscheinend nicht:
Releases · joaomgcd/TaskerSettings

Öffnen der App nicht nötig. Danach sollte es gehen.
 
Zuletzt bearbeitet:
Skyhigh

Skyhigh

Philosoph
Kleiner Zusatz:
Du musst ggf TaskerSettings aber die Berechtigungen erteilen welche es benötigt um WLAN schalten zu können. Also zumindest Standort.
Kommt auf die Softwareänderungen seitens des Herstellers an
 
Zuletzt bearbeitet:
H

hugn

Stammgast
Das hat funktioniert.
Trotzdem merkwürdig, dass es plötzlich nicht mehr ging.
Danke 🙋
 
Skyhigh

Skyhigh

Philosoph
So merkwürdig ist das nicht. Diese Thematik gibt's schon seit längerem. Ich vermute knapp 2 Jahre.

Wieso es bei dir jedoch erst Jetzt meckert, kann ich dir aber auch nicht sagen
 
H

hugn

Stammgast
Das mit merkwürdig ist nur darauf bezogen, dass es plötzlich nicht mehr ging.
Hatte absolut keine Updates zuvor, Taster lief monatelang problemlos. Gehe davon aus, dass ich die Strings eh schon installiert hatte, weil sonst würde es gar nicht funktionieren.
Naja egal, nun geht's ja wieder
 
holms

holms

Ikone
Skyhigh schrieb:
Du musst ggf TaskerSettings aber die Berechtigungen erteilen welche es benötigt um WLAN schalten zu können. Also zumindest Standort.
Nicht nötig, meine ich. Verwechselst du WiFi mit WLAN?
 
H

hugn

Stammgast
Gestern hat mein Poco F3 ein Update bekommen und nun kann ich schon wieder nicht per Tasker WLAN aktivieren oder deaktivieren...
Tasker settings sind natürlich installiert....

Gibt es hier vielleicht auch eine einfache Lösung?
 

Anhänge

Zuletzt bearbeitet:
holms

holms

Ikone
@hugn Und die Berechtigung aus dem Screenshot erteilt?
 
H

hugn

Stammgast
@holms ja aber das System will jedesmal eine Berechtigung, nix da mit einmal für immer erteilt... 😡
 
holms

holms

Ikone
@hugn Hmm. Sicherheitshalber:

Hast du Tasker bereits mal per adb Berechtigungen erteilt.

Tasker Settings ist Version 1.4.0?
 
H

hugn

Stammgast
@holms
Ja per ADB um AOD aktivieren und deaktivieren zu können.
Settings sind 1.4.0

Das aktuelle Problem ist 100% mit dem Poco Update gekommen
 
Skyhigh

Skyhigh

Philosoph
Dann hängt das möglicherweise auch mit Poco zusammen.
Manche Hersteller erweitern den Funktionsumfang von Android durch eigene Berechtigungen.

Welche Android Version/Security patch version ist denn bei dir aktuell installiert?
 
Skyhigh

Skyhigh

Philosoph
Den selben Stand (abgesehen von den Hersteller Modifikationen) hat mein A52s auch. Dort funktioniert das Umschalten des WiFi noch immer problemfrei.
Dementsprechend tippe ich tatsächlich auf eine Änderung seitens Poco.
 
H

hugn

Stammgast
@Skyhigh das wäre echt doof. Bald kann ich mir ein verhasstes iPhone zulegen, die Vorteile von Android schwinden monatlich...

Gibt's vielleicht ne Möglichkeit die Rechte per ADB dauerhaft zu setzen?
 
holms

holms

Ikone
hugn schrieb:
Bald kann ich mir ein verhasstes iPhone zulegen
Na, da geht ja noch weniger benutzerdefiniert zu steuern 😁

hugn schrieb:
die Vorteile von Android schwinden monatlich...
Naja, die Vorteile deines Pocos, wenn es denn daran liegt.

Evtl. nach dem Update die adb-Berechtigungen nochmal vergeben.
 
H

hugn

Stammgast
@holms
Aber welche adb Berechtigungen? Sind ja so einige und vorher waren nur die Settings für WLAN umschalten notwendig...
 
Ähnliche Themen - Toggle Wifi Api 29 in Tasker blockiert Antworten Datum
2
9