[GELÖST] BQ Aquaris X2 - ADB/Fastboot - Flash von TWRP als Recovery: "FAILED (Write to device failed / command failed)"

  • 7 Antworten
  • Neuester Beitrag
Diskutiere [GELÖST] BQ Aquaris X2 - ADB/Fastboot - Flash von TWRP als Recovery: "FAILED (Write to device failed / command failed)" im bq Aquaris X2 / X2 Pro Forum im Bereich bq Forum.
flaschenhals2020

flaschenhals2020

Neues Mitglied
Vorab:
IT Begeisterter, mit nicht so großer Affinität zum Programmieren.
Bisher nur LG G2mini's, S3's gerootet oder mal cyanogenmod draufgepackt.
Nutze Windows. Einige Begriffe und IT Gebiete verstehe ich gut, aber nicht alles.

Morgen zusammen,

ich bin jetzt langsam an einem Punkt angekommen, an dem mir jegliche Motivation flöten geht, sich mal ein Custom ROM anzulegen, um weg von dem Google-beherrschenden OS zu kommen. Bin jetzt nach zig Stundenlanger suche am Ende meiner Ideen angekommen. Das Netz spuckt auch nichts mehr aus, was mir sinnvoll erscheint oder womit ich nicht vielleicht mein Smartphone "softbricken" oder wie man das nennt, könnte. Vielleicht übersehe ich hier etwas ... ich habe mir extra nen Account zugelegt, weil es hier genau für dieses Handy ja ein Unterforum gibt. Ich werde im Nachfolgenden alles, was ich bisher herausgefunden habe, möglichst ordentlich auflisten und mit Grafiken unterstützen.

Hintergrund:
Ich habe mir das Smartphone extra gebraucht von jemanden geholt, um damit "rumspielen" zu können- im besten Fall erhoffe ich mir das Handy als neues main-Handy, dass endlich größtenteils von Google befreit ist, weil Lineage OS drauf laufen würde. Nachdem ich alle technischen specs, für alle offiziell von Lineage OS unterstützen Geräte verglichen habe, kam ich zu dem Entschluss, dass das Aquaris X2 im Moment die beste Möglichkeit ist.
MicroSD Karten Unterstützung / Dual SIM / Halbwegs gute Kamera / USB-C, USB 2.0 / 3,5mm Klinkenanschluss

Nun habe ich das Gerät letztens bekommen und bin fieberhabt daran, diese offizielle Anleitung abzuarbeiten:
Install LineageOS on zangya | LineageOS Wiki


Schritt 1: ADB und Fastboot einrichten. (Using ADB and fastboot | LineageOS Wiki)
✓ Erledigt. In der Windows Umgebungsvariable auch unter dem Punkt Path "%USERPROFILE%\adb-fastboot\platform-tools " eingetragen,
sodass ich von jedem beliebigen Punkt aus die Konsole starten und mit ADB & Fastboot arbeiten kann :)

Schritt 1.5 USB Debugging aktivieren und OEM Sperre deaktivieren in den Entwickleroptionen
✓ Der OEM button war bei mir ausgegraut, ich konnte das erst nicht deaktivieren (OEM Button grayed out)
Nachdem ich irgendwann auf das hier gestoßen bin, fand ich heraus, dass ich mein Handy kurz mit dem Internet verbunden muss, damit man diesen Button doch betätigen kann. USB Debugging ließ sich problemlos aktivieren.

Schritt 2: "Install the universal adb driver and reboot." | Using ADB and fastboot | LineageOS Wiki
✓ NEIN. Das klappte NICHT. Ich musste stundenlang suchen, bis ich das hier gefunden habe: ADB device list is empty
Mit DIESEN Treibern konnte ich im Windows Geräte Manager das machen, was er in dem kleinen Tutorial beschrieben hat.
Erst DANN erkannte "adb devices" mein Gerät und listete es auf.

Schritt 3: "Unlocking the bootloader" | Install LineageOS on zangya | LineageOS Wiki
✓ WIEDER (!) Fehler in der Anleitung! >=(
Irgendwie reagiert Fastboot bei mir sensibel wenn ich erst "fastboot devices" eingebe und danach den Befehl um entsperren des bootloaders. Da kommen dann Fehlermeldungen.
Erst wieder eine andere Anleitung half mir weiter .... diese hier.
Also erst "adb reboot bootloader" und dann, sobald er im bootloader war, "fastboot flashing unlock".
Das klappte dann, aber erst am Laptop wo noch Windows 7 läuft. Hier fing ich an auf anderen Rechnern es zu versuchen, wenn es auf meiner Main Kiste nicht klappte (Windows 8.1). Dann klappte das enstperren, ich bestätigte die Abfrage mit den volume buttons. Perfekt.

Schritt 4: "Installing a custom recovery using fastboot" | Install LineageOS on zangya | LineageOS Wiki
Möp möp mööp ... da stehe ich nun.
Diese Schei$e will einfach nicht funktionieren :/ Egal was ich versuche, ich habe das Netz durchgewühlt und umgekrempelt- nichts half.
Da ich aber gesehen habe, dass viele sich in der Modding Szene rumtreiben, die durchaus aus D/A/CH kommen, bin ich jetzt hier mit meinem Problem.
Konkret ist mein Problem, dass fastboot das twrp image nur sendet- aber nicht schreiben kann. Hierzu nun detaillierte Screenshots. Ich bitte wirklich, dass jemand mir da weiterhelfen mag. Ich habe es an insgesamt vier verschiedenen Rechnern ausprobiert. Die USB driver vom Hersteller, also die .inf Treiber lassen sich nicht im device manager beim Smartphone installieren, lediglich die universal usb driver und die google usb adb driver. Aber ich meine.... solange er das Gerät im Bootloader Modus aufgelistet bekommt in der Konsole, passt doch eigentlich alles... er erkennt das Gerät ja. Ich habe es schon mit fast allen Treibern zwischendruch versucht. Er will einfach nicht schreiben bzw. manchmal meldet er auch, dass keine Partition vorliegen würde oder so...

------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------


Sollte ja alles stimmen, oder?








Egaaaal von welchem Rechner, egal in welcher Form ich versuche TWRP auf die... recovery Parition....? zu schreiben- es geht nicht. Ich weiß nicht wieso und ich verzweifle gerade echt :/ Ich habe nahezu alles USB Ports an allen Rechner abgeklappert, es scheint was anderes zu sein. Kabel auch schon mal ein anderes genommen. Das gefällt mir irgendwie nicht, weil das so in keinen anderen Tutorials zu sehen ist.


Ihr seid meine letzte Hoffnung, ansonsten muss ich dieses super tolle Handy wieder verticken :/

UPDATE: ES HAT GEKLAPPT!!!
Näheres hierzu, etwas weiter unten in dem Thema hier oder klick mich hier einfach :)
 
Zuletzt bearbeitet:
wolder

wolder

Guru
Meld dich mal bei der slack an!
@canal Well, I don't have more time today to keep on testing. I think a way to flash so I'll share with you.

What I did (NOT SURE IF IT'S THE FASTEST WAY).

Flash latest RC (boot + system + vendor images)

Once flashed, boot to recovery and perform a wipe data. Once it has done, reboot to bootloader (not to system).

Then run "fastboot boot recovery_MODEL.img" (It'll boot TWRP). Once TWRP had booted, You should go to Advanced then choose ADB SIDELOAD.

Once you're on screen, tap to the right then run "adb sideload lineage.zip" from lineageos.org.

I don't know if there is a faster way, i'll keep checking it this days. Also i found a way to install TWRP but it's mostly broken so i'll not share it for now.
Du kannst twrp nicht flashen, da es keine Recovery gibt. Es gibt ein twrp in der du nur starten kannst. Dort musst du alles löschen und kannst dann los flashen, per sideload z.B.
LOS bringt eine eigene Recovery mit.
 
Zuletzt bearbeitet:
flaschenhals2020

flaschenhals2020

Neues Mitglied
Hi Wolder! Danke für die schnelle Antwort- so langsam kapiere, ich was da los sein könnte .... nur so ganz habe ich noch nicht verstanden was ich machen muss, muss ich ehrlich gesagt gestehen. Ich richte mich ja ziemlich nach der offiziellen Anleitung.
Die wollen ja, dass ich jetzt eine custom recovery, in dem Fall TWRP, dass ich das irgendwie ... installiere oder flashe...
Danach soll bzw. will ich nur noch LOS und SuperSU installieren, zum Root Rechtemanagement.

Ich hoffe wirklich, das ist nicht zu viel verlangt ... aber könntest du mir vielleicht grob beschreiben wie ich vorgehen muss jetzt mit dem TWRP Image...? Muss ich als erstes irgendwie alles platt machen...? So habe ich das verstanden... mit welchem Befehl nochmal genau...? Ist mir leider wirklich wichtig, nicht dass ich da plötzlich auf dem Schlau stehe und ein mehr oder weniger kaputtes System habe^^
 
wolder

wolder

Guru
Du musst mit der richtigen twrp.img und Fastboot ins twrp starten, nicht flashen.
In twrp musst du alles löschen (wipe).
Also factory reset und wipe Data. Alle deine Daten gehen verloren.
Dann kannst du per sideload oder wenn du die Datei auf deinem Handy hast LOS und supersu oder magisk installieren.
 
flaschenhals2020

flaschenhals2020

Neues Mitglied
Vielen Dank! Nur noch eine letzte Frage- weißt du zufällig den/die Befehle, wie ich die twrp.img Datei "starte"...?
 
wolder

wolder

Guru
flaschenhals2020 schrieb:
Vielen Dank! Nur noch eine letzte Frage- weißt du zufällig den/die Befehle, wie ich die twrp.img Datei "starte"...?
Fastboot Boot twrp.img

Vorsicht mit anderen Anleitungen. Die vom X sind nicht passend zum X2. Da gibt es schon Unterschiede.
 
Zuletzt bearbeitet:
flaschenhals2020

flaschenhals2020

Neues Mitglied
NACHTRAG: ES HAT GEKLAPPT!!!
Vorab: Ich bin überglücklich, mitteillen zu können, dass es doch noch spät Abends und mit Hilfe eines Entwicklers geklappt hat, zudem ich durch ein Mitglied hier im Forum den Kontakt hergestellt bekommen habe- eher gesagt einer Gruppe.
Da ich mir vorstellen kann, dass ich nicht der einzige bin, der damit Probleme hat/hatte/haben wird, will ich hier noch so gut es geht das beschreiben, was mir geholfen hat- es wird bestimmt nicht zu 100% jedem mit dem ähnlichen oder gleichen Problem weiterhelfen, aber ich bin mir sehr sicher, dass es zumindestens neue Denkanstöße ermöglichen könnte. Also, ich knüpfe mal an mein Problem von ganz oben an:

1. Ich habe versucht mittels fastboot das TWRP image zu "flashen". Dank @wolder habe ich, leider zu spät, erkannt, dass es stimmt und ich das irgendwie nicht auf ein recovery flashen kann, weil keines existiert.
Eigenltich steckte in dieser Antwort schon die Lösung auf all meine Probleme und im Endeffekt stehe ich jetzt an der Lösung, in dem ich indirekt oder auch direkt genau das gemacht habe, was wolder @wolder geschrieben hat.

Sich anhand des Tutorials von Kuketz zu orientieren hat mich leider auf die falsche Fährte gebracht-
Ich habe von der offiziellen Website die aktuelle Firmware runtergeladen, weil das in seiner Anleitung stand. Von hier an verbrachte ich die meiste Zeit mit einer unnötigen Fehlersuche. Laut Anleitung sollte man die firmware entpacken und dann die Batch (.bat) Datei ausführen.
Das führt nur zu Problemen und zerstörte im Endeffekt mein Android OS, weil der flash und Löschvorgang der Batchdatei in der Mitte stecken blieb- toll. Btw- die cmd als Admin ausführen musste ich in den nächsten Schritten nicht. Teilweise brachte das noch mehr Probleme und Fehlermeldung mit sich. Mehrere Stunden bastelte ich mit dem Kollegen in der Gruppe an der batch Datei herum ... bis er mich irgendwann fragte, ob ich es dann schonmal an anderen Rechnern versucht habe. Das hatte ich heute in der Tat ja, aber da habe ich noch versucht, TWRP zu flashen.... nicht davon zu booten...

2. Ich nahm also mein nächstbestes Notebook, verband das Telefon, war im fastboot modus und ich meine als ich dann
fastboot boot [twrpdatei.img]
(Ich weiß nicht, welches Wissen hier der Leser jetzt hat, aber die twrp Datei, die ich für das X2 hier in dem Post unter dem Punkt TWRP gefunden habe, diese muss in dem adb-fastboot Ordner liegen, dort wo die adb.exe auch ist. Wenn man dort rechtsklickt in dem Ordner an eine leere Stelle, während man shift gedrückt hält, kommt bei Windows die Option "Terminalkonsole in diesem Ordner" oder so öffnen.
Dann ist man passenderweise in dem Ordner und dann klappt so ein Befehl auch wie oben, weil man mit der Konsole schon in dem Pfad ist, wo das image liegt. So muss man nicht einen Pfad angeboten, wo die image Datei liegt.)
eintippte, kamen zum ersten Mal zwei "Okay" Meldungen.
Ich hatte es geschafft, das Smartphone startete nun mit der TWRP Oberfläche!

3.
Antwort: Ich habe nach rechts gewischt :)

4. Nun tat ich all das, was laut offizieller Anleitung auch getan werden sollte:
  • Now tap Wipe.
  • Now tap Format Data and continue with the formatting process. This will remove encryption and delete all files stored in the internal storage.
  • Return to the previous menu and tap Advanced Wipe, then select the Cache and System partitions and then Swipe to Wipe.
Resultat: Es gab sehr viele Fehler Meldungen, dass irgendwie nicht auf Datenpfade zugegriffen werden konnte, "mounting", davon war oft die Rede ...

5. Nachdem der Kram gelöscht war, macht ich mich daran, Lineage OS 16 und SuperSU (das Addon) [su (arm64)] zu installieren.
Hierbei war wieder der nächste Fehler in der offiziellen Anleitung: Ich konnte den Kram nicht von der CMD aus flashen...
Also schob ich die LOS 16 und die SuperSU Addon .zip auf eine leere microSD Karte. Diese steckte ich in das Gerät und ging auf "install".
Ich wählte nur die LOS .zip erstmal aus und hakte auch nichts von den zwei Optionen an "Optional to select: Zip signature verification" and "reboot after installation is complete" .
Es kamen auch hier eine Menge an Fehlermeldungen auf ....

6. Nachdem ich das getan habe, habe ich danach due SuperSU zip ausgewählt und diese installiert. Dies sollte aber nichts bringen, wie ich später merkte.

7. Ich klickte dann im TWRP auf reboot system oder etwas dieser Art, er lud ein wenig, verlief sich vielleicht wieder im bootloader, aber danach erschien das LineageOS Logo und ich war überglücklich. Alles schien zu funktionieren. Und es klappte- das OS war da!!!! <3

Extra Hinweise:
Hier noch ein paar extra Hinweise, auf die ich erst kommen musste:
- Ich konnte in den Entwickleroptionen nur Root deaktivieren oder für die ADB ermöglichen- doof, wenn ich aber Apps Root Rechte gewähren möchte. Ich musste danach nochmal in den recovery Modus, also Gerät aus und dann mit ganz viel Glück und Lautstärke+ & Power Button.
Im LineageOS eigenen Recovery Modus ging ich dann auch auf installieren, patch oder irgendwie sowas und wählte dort nochmal die SuperSU Addon Zip aus. Diese wurde nun richtig installiert! Nach einem Reboot und viel Geduld konnte ich nun in den Entwickleroptionen unter dem Punkt root Berechtigungen oder so auch für Apps die Root Erlaubnis festlegen. SuperSU als App an sich, wie man sie sich von deren offizieller Seite herunterladen kann, funktionierte nicht. Stattdessen, als ich eine root-checker App benutzte, kam eine eher vom System aussehende Abfrage, ob man das den gewähren möchte. Egal. Es klappt!

- Interner und Externer Speicher wird nicht angezeigt bei Lineage OS 16
Da war ich erst irritiert, aber in den Einstellungen musste man einfach nach USB suchen und dort kann man einfach einstellen, dass zwischen dem PC und dem Gerät der Daten/Medien Austausch stattfinden darf :) Dann wurden mir der interne wie der Speicher der SD Karte korrekt angezeigt.

Sollte mir noch etwas einfallen oder auffallen, werde ich das hier nachträglich schreiben- hoffe ich kann vielleicht dem ein oder anderen ein paar Nerven ersparen^^


20200314_211120_cleaned.jpg20200314_212144_HDR_cleaned.jpg20200314_214336_cleaned.jpgcmd.PNGmal recovery mal normal.PNGerfindetdasgeraet.PNGalleskorrekt.jpg

Ja, komm, ne...
@wolder Danke. Kam leider jetzt etwas zu spät. Habe mich an der Anleitung von dem Kuketz gehangelt. Waren gute neue Ansätze dabei wie z.B. fastboot flashing unlock_critical ; das habe ich sonst in keiner Anleitung gehabt. Oder auch "Firmware Update".
Da fingen dann die ersten Probleme an. In der mitgelieferten Firmware vom Hersteller, die man erst entpacken sollte und dann die .bat ausführen sollte, die neueste Firmware blieb wieder bei irgendeinem Punkt stehen und hat scheinbar nicht mehr gesendet im Fastboot.
Eine ältere Firmware genommen- klappte alles scheinbar reibungslos .... jetzt geht das bishere Android OS nicht mehr und ich komme nur mit Glück in den Fasboot Modus. Ge"brickt", wie man wohl glaube ich so schön sagt. Habe noch Glück, dass ich das Gerät immer noch iwie ansprechen kann per Konsole.

Habe das dann erstmal ignoriert und dann versucht, twrp zu flashen, wie in der Anleitung beschrieben. (Natürlich mit einem passenden TWRP.img)
Nope.

Für mich wars das dann wohl an der Stelle. Es war einfach ein Versuch, nach Jahren mal wieder ne Custom ROM zu nutzen, weil ich gemerkt habe, wie google mithört, obwohl ich wirklich alles nur erdenklich-deaktivierbare deaktiviert habe was das betrifft. Google traue ich seit dem zu 0,00%. Jetzt fühle ich mich lediglich mit einer ziemlich guten Mikrofon Blocker App sicher, die den Mic Zugang ganze Zeit blockiert, es sei denn, man muss mal telefonieren.
Es ist einfach schade zu sehen, dass google-freie OS`e nahezu nicht existieren- Apple ist jetzt auch nicht ganz unschuldig mit SIRI denke ich mal. Schade, ich habe in Lineage OS echt meine letzte Hoffnung auf ein halbwegs gutes Gewissen gesehen. Aber nach jetzt wirklich jedem ausprobieren ... schade. 120€ verballert, aber damit habe ich komplett gerechnet. Mal gucken ob ich da irgendwie noch was hinkriege ansonsten habe ich ein kaputtes Smartphone. Schade, dass das irgendwie die letzte Erinnerung an eine Alternative für Android sein wird- nochmal will ich das Risiko nicht eingehen mit einem nächsten Handy. (War ja jetzt als zweithandy vorerst gedacht, kam als Alternative in Frage weil es halt so Dinge wie microSD support hatte etc. wie oben am Anfang des Themas genannt)

Dennoch. Danke euch für die ganzen Tipps, das hat mir doch noch ein wenig neues gezeigt und was vielleicht hätte klappen können, aber ... ich hoffe auf ein Wunder, dass vielleicht irgendein Hersteller ... das mal von Haus aus mitbringt, also Lineage OS... glaube ich aber irgendwie nicht, weil das ja ... mit den Prinzipien von der freien community oder so nicht ganz klappen könnte.
 
Zuletzt bearbeitet:
Ähnliche Themen - [GELÖST] BQ Aquaris X2 - ADB/Fastboot - Flash von TWRP als Recovery: "FAILED (Write to device failed / command failed)" Antworten Datum
7
1
39