Lösung des "standby aufweck Problems" ?

  • 50 Antworten
  • Neuester Beitrag
Diskutiere Lösung des "standby aufweck Problems" ? im Cat Nova Forum im Bereich Cat Forum.
dickenseck

dickenseck

Stammgast
To stop battery drain & prevent screen from waking every few minutes - **only for original Kogan ROM**

(with thanks to hallokitty for this fix)
This happens because the tablet keeps looking for the 3G signal it cannot ever receive. To fix this, go to System/app using Root Explorer from the Market, delete (or rename) phone.apk and TelephonyProvider.apk. You will immediately start getting errors but just use the reset button at the back of the tablet and when you reboot the problem has been solved. If you ever want to restore these apk's (e.g. if you want to use a 3G modem) just flash the phone+telephony zip file below using clockwork mod.

Lt. den xda-developern sollte auch das app: Auto Airplane Mode linderung schaffen.


Hab leider mein tablet nicht mit in der Arbeit um es zu testen...
 
Zuletzt bearbeitet:
I

ichbinneu

Neues Mitglied
Hilfe, ich kann kaum englisch. Danke
 
andycat

andycat

Erfahrenes Mitglied
Es gibt im Market auch English für Anfänger.
Du wirst nicht umhin kommen englisch zu lesen.
Viele seiten verlinken sich auf englischsprachige Seiten.
 
dickenseck

dickenseck

Stammgast
Da steht eigentlich nur das es möglich ist das, dass tablet die ganze Zeit nach einer 3G internetverbindung sucht die es aber niemals bekommen kann. (kein 3g modul eingebaut)

Mit Hilfe von einem app namens root-explorer könnte man nun die Dateien phone.apk und TelephonyProvider.apk unbennen, damit android diese nicht mehr am System findet.
 
andycat

andycat

Erfahrenes Mitglied
Kann aber im ernstfall zur unbrauchbarkeit des Pads führen.
Wenn man im system irgendetws löscht.
Man sollte schon wissen was man da tut.
 
Zuletzt bearbeitet:
dickenseck

dickenseck

Stammgast
oh ja!
Für Anfänger ist das nichts.
Finger weg!!!

Das app das dort vorgeschlagen wurde kann man aber ohne Bedenken testen.:cool2:
 
Zuletzt bearbeitet:
S

Shadow1978

Neues Mitglied
Danke getestet und geht :) So langsam wird das was mit dem Ding ^^
 
dickenseck

dickenseck

Stammgast
:scared:

Von wegen ein feature das uns an das eingeschaltene Wlan erinnert!
Doch ein Bug.:cool2:
Hoffe, dass sich nun die standbyzeit erheblich verlängert.

Hast du sie einfach unbenannt oder gleich gelöscht?

mfg
 
S

Shadow1978

Neues Mitglied
Ne hab sie nur umbenannt. (ich bin doch nicht verrückt)

Bei der Phone.apk gab es dann witzige Meldungen und es wurde nen reset nötig, bei TelephonyProvider.apk passierte gar nix ^^

Nach nem Neustart war aber alles bestens und bis jetzt ist das "Feature" auch weg.
 
dickenseck

dickenseck

Stammgast
Alles klar,
Na dann werd ich sobald ich daheim bin und endlich rooten kann mal das nervige feature beseitigen.
Vielleicht genügt es ja nur die Phone.apk umzubenennen. (diese Zicke)
Mal testen...
 
S

Shadow1978

Neues Mitglied
Achja das rooten gestaltete sich etwas öhm abenteuerlich ... aber mit SuperOneClick und ein wenig Hilfe aus dem Forum (der Teil mit dem Treiber) gings dann doch. Mal sehen was JuiceDefender in Sachen Akkuleistung noch rausholt (Gute Erfahrungen bei allen meinen anderen Geräten) ...
 
A

andten

Fortgeschrittenes Mitglied
sooooo, ich habs dann mal auch getan .... mal wieder :). mal schauen obs was bringt.
 
andycat

andycat

Erfahrenes Mitglied
Euch sollte klar sein ,dass dann kein UMTS-Stick mehr funktioniert.
 
dickenseck

dickenseck

Stammgast
Ist klar! kann man aber sehr schnell wieder Rückgängig machen.

Hab nun mein tab auch gerootet und diese Modifikation durchgeführt...jedoch ohne Erfolg.

Shadow1978, hast du bevor du die Dateien unbenannt hast das tab im Flugmodus gehabt?
Mit was für einem app hast du sie unbenannt? (ich rootexplorer)

mfg
 
A

andten

Fortgeschrittenes Mitglied
bei mir auch dasselbe, hat nichts gebracht. hab einfach aus der phone.apk ne phone22.apk draus gemacht und das mit der anderen auch. mmhhhh ...........:huh:
 
H

hamillton

Neues Mitglied
andten schrieb:
bei mir auch dasselbe, hat nichts gebracht. hab einfach aus der phone.apk ne phone22.apk draus gemacht und das mit der anderen auch. mmhhhh ...........:huh:
Hi, kannst du bitte sagen in elchen Ordner die beiden .apk sind?
 
andycat

andycat

Erfahrenes Mitglied
ALso bei mir bringt das nix.
Er wacht immer noch auf.Würg
 
A

andten

Fortgeschrittenes Mitglied
hamillton schrieb:
Hi, kannst du bitte sagen in elchen Ordner die beiden .apk sind?
im ordner system/app findest du diese
 
dickenseck

dickenseck

Stammgast
Yeah! geschafft!

Also das Ganze funktioniert auch ohne die Dateien zu modifizieren.

Man muss "einfach" in der build.prop folgende Zeilen hinzufügen:

wifi.supplicant_scan_interval=180
pm.sleep_mode=1
ro.ril.disable.power.collapse=0

Das führt dazu, dass sich das Wlan im standby schlafen legt und nach dem aufwecken sofort wieder verfügbar ist!

Spart Strom und das beste! "Discolicht" Adieu! :cool2:

Also bitte, liebes Cat-team! Tut was! Das Tab ist gut, hat aber Fehler die ihr sicher beseitigen könnt wenn ihr nur wollt.
Ein funktionierendes und gut supportetes tablet verkauft sich doch sicher noch besser!
 
Zuletzt bearbeitet:
Appqueen

Appqueen

Fortgeschrittenes Mitglied
Hey dickenseck,
das ist ja echt klasse, aber die Lösung war eigentlich schon fast zu simpel.

Hoffentlich entsteht jetzt nicht das xy-Problem... wenn man x macht , passiert y :cool2::cool2:

Ich behalte den Thread weiter im Auge und werde das dann mal beim Cat und beim Epic ausprobieren.

LG Gruss Tanja