Mitglieder surfen ohne Werbung: Jetzt kostenlos registrieren!

TWRP Kingkong mini

  • 19 Antworten
  • Neuester Beitrag
Diskutiere TWRP Kingkong mini im Cubot King Kong Mini Forum im Bereich Cubot Forum.
G

gubben

Fortgeschrittenes Mitglied
TWRP zu flashen hat nach einigen Schwierigkeiten geklappt, ich schaffe es aber nur selten ins Recovery.

Ins Bootmenu komme ich inzwischen zuverlässig, allerdings mit Power und Vol up gedrückt halten. Mit Vol down kommt ein Menü mit chinesischen Schriftzeichen. Im Web gibt es alternative Beschreibungen.

Nach der Auswahl des Recovery kommt meistens der auf dem Rücken liegende Androide.

Ich wollte eigentlich versuchen eine GSI Rom zu flashen. Dazu müßte aber TWRP mal rund laufen.

Hat einer von euch mehr Erfolg gehabt?
 
G

Gabberlein

Experte
TWRP kannste auch mit dem Tool all in One Flashen hier

TOOL ALL IN ONE

Infos zu deinem CUBOT wären hier erbracht zuwenig Infos kann keiner Helfen.
 
G

Galego

Neues Mitglied
gubben schrieb:
TWRP zu flashen hat nach einigen Schwierigkeiten geklappt, ich schaffe es aber nur selten ins Recovery.
Ins Bootmenu komme ich inzwischen zuverlässig, allerdings mit Power und Vol up gedrückt halten. Mit Vol down kommt ein Menü mit chinesischen Schriftzeichen. Im Web gibt es alternative Beschreibungen.
Nach der Auswahl des Recovery kommt meistens der auf dem Rücken liegende Androide.
Ich wollte eigentlich versuchen eine GSI Rom zu flashen. Dazu müßte aber TWRP mal rund laufen.

Hat einer von euch mehr Erfolg gehabt?
Schau mal hier vorbei
S: klein - Cubot King Kong Mini? – Kaufberatungen für Android-Smartphones

Evtl. könnte einer der Mods die Threads zusammenführen, oder eine eigene Kategorie für das KK mini aufmachen.

cu
Galego
 
T

Textonly

Neues Mitglied
gubben schrieb:
TWRP zu flashen hat nach einigen Schwierigkeiten geklappt, ich schaffe es aber nur selten ins Recovery.
Das ging mir zu Anfang lange genauso. Gib nicht auf!

gubben schrieb:
Ins Bootmenu komme ich inzwischen zuverlässig, allerdings mit Power und Vol up gedrückt halten. Mit Vol down kommt ein Menü mit chinesischen Schriftzeichen. Im Web gibt es alternative Beschreibungen.
Power + VolUp ist richtig und sollte wenn alles geklappt hat dazu führen, daß eine Meldung von wegen "Orange State" und "Device cannot be trusted" kommt und dann "Select Boot Mode:" erscheint. Dort kann man zwischen Recovery (das gewünschte), Fastboot und Normal wählen. Das Menü mit den chinesischen Schriftzeichen ist wenig hilfreich ohne Chniesischkenntnisse (oder welche Sprache das auch immer ist) und bietet auch nicht viel...vermutlich sowas wie Werksreset und ein paar Funktionen für Hardwaretests (da bin ich zwischenzeitlich versehentlich mal gelandet, und Teile der Menüeinträge waren Englisch). Wenn man da landet einfach abbrechen und erneut versuchen.

gubben schrieb:
Nach der Auswahl des Recovery kommt meistens der auf dem Rücken liegende Androide.
Das ging mir zu Anfang auch oft so und brachte mich fast zur Verzweiflung. Der auf dem Rücken liegende Androide ("NO COMMAND") ist wohl ein Zeichen dafür, daß das TWRP wieder überschrieben wurde.

Ich weiß leider nicht mehr genau welcher Ansatz am Ende Abhilfe brachte. Als TWRP das erste mal richtig funktionierte, habe ich gleich ein Backup aller Partitionen gemacht (eine sdcard ist dazu praktsich). Dann habe ich verschiedene Ansätze probiert:
  • data-Partition formatiert (wie Werksreset - man verliert installierte Apps und Daten wie Fotos etc)
  • Cache wipe
  • no-verity-opt-encrypt-6.1.zip zu flashen versucht
  • nicht immer im richtigen Bootmodus gelandet
  • mit fastboot TWRP-Recovery immer mal wieder neu geflashed

Probier mal bitte folgendes: Wenn TWRP gerade funktioneirt (du also das TWRP-Menü siehst): Gerät gleich noch mal neu booten und wieder ins TWRP booten. Wenn dir das Drücken der richtigen Tasten zum richtigen Zeitpunkt gelang: Ist das TWRP noch da? Wenn das Drücken der Tasten nicht gelang: Neu flashen und noch mal probieren. Wenn das TWRP so reproduzierbar startet: Einmal das richtige System starten, hochfahren lassen, neustarten und versuchen, jetzt ins TWRP zu kommen. Ists noch da? Ich hatte den Eindruck daß das hochfahrende Original-Android-System das TWRP überschreibt. Probier aber bitte selber vorher aus.

Aktuell verwende ich das Image Lineage OS 16.0, lineage-16.0-20191017-UNOFFICIAL-treble_a64_bvN.img.xz. Ich habe es entpackt, mit adb push auf die sdcard geschrieben und dann mit TWRP geflashed.

Sobald man LineageOS laufen hat, kann man unter Einstellungen/System/Erweitert/Entwickleroptionen den Punkt "Erweiterter Neustart" aktivieren (Entwickleroptionen müssen freigeschaltet sein). Wenn man dann die Power-Taste drückt und Reboot wählt, kann man auswählen, daß das Gerät als nächstes im Recovery-Modus starten soll. Das macht es sehr viel einfacher den aufzurufen.

LineageOS 16.0 läuft etwas runder als LineageOS 17.1. Letzteres bootet auch auf dem Gerät und kann verwendet werden, stürzte bei mir aber gelegentlich ab und bootete neu. Zudem gab es einige Störungen beim Audio, denen ich noch nicht auf den Grund gegangen bin. Alles konnte ich noch nicht probieren da ich noch auf eine physikalisch ins Gerät passende Nano-Simkarte warte (meine ist einfach zu alt dafür).
 
G

gubben

Fortgeschrittenes Mitglied
Vielen Dank für deine ausführliche Antwort textonly.
Ich hatte zwischenzeitlich mal die Stockrom geflasht, twrp wieder drauf und lineage 17 geflasht. Kam allerdings nur bis zu einem bootloop. Einige Versuche später war twrp dann wieder futsch.
Jetzt bin ich wieder auf Stockrom und richte gerade wieder alles ein.
Ich werde mir mal eins von meinen alten Handys einrichten und dann mit dem KKmini weiterbasteln, bis ich ein brauchbares OS drauf habe.
Das macht jedenfalls Mut zu lesen,daß andere meine Probs auch schon hatten.
 
G

gubben

Fortgeschrittenes Mitglied
So, nun hat es geklappt.
Nach dem twrp flashen das usb-kabel abgezogen und gleich mit power und vol+ ins Bootmenu und ins twrp gelangt. Dann gewiped - data, cash, dalvik und danach Magisk.ZIP installiert. Anschließend lineage 16.0 in System installiert und gebootet.
Nun will ich mal testen.
 
PurpleZ

PurpleZ

Neues Mitglied
Ich bin auch soweit das ich die entpackte .img (ist doch richtig) auf die system Partition flashe?

Wenn ich das tue bekomme ich nur ein bootloop mit dem Cubot Logo?

Muss ich da noch was beachten?
 
G

gubben

Fortgeschrittenes Mitglied
TWRP scheint ja zu laufen. Gewiped hast du auch? Welche img versuchst du zu installieren?
 
PurpleZ

PurpleZ

Neues Mitglied
Hallo,

habe alles hinbekommen, ich habe zwei Fehler gemacht:

Man muss die vbmeta.img mit dem Befehl flashen

fastboot --disable-verity --disable-verification flash vbmeta vbmeta.img

.... und ich habe die falsche IMG installiert... man muss arm32 mit binder64 nehmen, das habe ich durch die Trebl App raus bekommen.

Allerdings noch einen Fehler habe ich, Magisk oder SuperSU bekomme ich nicht installiert, die sind anch dem flashen einfach nicht da????
 
G

gubben

Fortgeschrittenes Mitglied
Einstellungen - System - Erweitert -Entwickleroptionen - Rootzugriff
Vorher 7x auf Build-Nummer, weißt du sicher
 
R

rosalynd

Neues Mitglied
Hallo gubben,

mit Magisk bekomme ich es nicht hin. Es wird einfach nicht installiert. Ich habe allerdings 2 Probleme:
Unter Einstellungen\System\Erweitert\Entwickleroptionen\
habe ich nur "Root-Debugging" in LineageOS 17.1
Übersehe ich da etwas?

Wie bei PurpleZ kann ich zwar in TWRP das Magisk.zip installieren - es zeigt jedoch keine Auswirkung...

Nebenbei ich kann beim Start von TWRP die Partition nicht entschlüsseln, trotz korrekter PIN. Könnte dies das Problem sein?

Ich habe Makisk v 20.3 und v20.4 versucht ohne Erfolg

Danke
 
Zuletzt bearbeitet:
PurpleZ

PurpleZ

Neues Mitglied
Zum entschlüsseln hat mir das geholfen:
Disable_Dm-Verity_ForceEncrypt_03.04.2020.zip

und falls du den Text "Orange bla bla" beim Booten nicht haben willst, kannst du noch das hier flashen:
orange_state_disabler_MTK Only.zip

Das mit Magisk haben wohl anscheinend alle, wie ich bei xda gelesen haben, die jetztige Version von magisk unterstützt wohl noch nicht das Handy.

edit: Und diesen "Root Rechte" in den Entwickleroptionen haben nur manche Handys aber das KingKong mini offensichtlich nicht, ich habe diese Einstellung auch nicht gefunden.
 

Anhänge

  • Disable_Dm-Verity_ForceEncrypt_03.04.2020.zip
    3,4 MB Aufrufe: 6
  • orange_state_disabler_MTK Only.zip
    126,6 KB Aufrufe: 7
Zuletzt bearbeitet:
PurpleZ

PurpleZ

Neues Mitglied
Also ich habe es hinbekommen aber habe dadurch dann kein TWRP mehr.

Wenn man die zwei imges flasht

fastboot flash boot patched_boot.img
fastboot flash recovery patched_recovery .img

tja aber das flasht einen dann TWRP weg und man muss das Android mit erweiterten Neustartoptionen neu starten (Recovery)
Danach hat man root, aber kein TWRP mehr XD

und wenn ich das twrp wieder drauf flashe ist der root wieder weg XD
 

Anhänge

  • patched_boot.img
    8,6 MB Aufrufe: 1
  • patched_recovery.img
    13,9 MB Aufrufe: 1
G

gubben

Fortgeschrittenes Mitglied
rosalynd schrieb:
Unter Einstellungen\System\Erweitert\Entwickleroptionen\
habe ich nur "Root-Debugging" in LineageOS 17.1
Übersehe ich da etwas?
Ich habe LOS 16, da kommt dann "Root-Zugriff" mit 4 Optionen.
Zu den übrigen Problemen fällt mir nichts mehr ein. Ich habe damals auch rumprobiert bis es lief und den bei mir erfolgreichen Weg dann hier notiert. Seitdem läuft das Handy bestens, so daß ich auch keine Notwendigkeit hatte, mich nochmal damit zu befassen.
Meine Twrp und Magiskversionen waren wohl die im März aktuellen.
 
PurpleZ

PurpleZ

Neues Mitglied
Ja IHR habt schon recht aber der Root Zugriff wurde ab 17 raus genommen

LineageOS 17.1: Android 10 bildet die Basis und streicht den Root-Zugriff
Beitrag automatisch zusammengefügt:

deswegen gibt diesen Eintrag bei uns nicht, ich habe aber keine Lust auf 16 zu gehen zumal 17 sehr stabil läuft!

da verzichte ich lieber auf Root.
Beitrag automatisch zusammengefügt:

Man braucht ein spezielles SU-binary tool füe Linage OS damit man SU Rechte bekommt, das wird in Magisk eigentlich mitgeliefert.

Siehe hier:
LineageOS Downloads
 
Zuletzt bearbeitet:
R

rosalynd

Neues Mitglied
Ich danke euch!

Also fasse ich 3Optionen zusammen:

- LineageOS 16 & Root (und TWRP im recovery)
- LineageOS 17 & Root (kein TWRP im recovery)
- LineageOS 17 & TWRP (kein Root)

Da ich gerne Android 10 (LOS 17) incl Rootzugriff muss ich auf TWRP verzichten oder es bei Bedarf umflashen:
fastboot boot twrp_3.3.1.img
Aber im Normalfall wird kein TWRP gebraucht (oder übersehe ich da etwas)
 
PurpleZ

PurpleZ

Neues Mitglied
ja so sieht es wohl aus, aber ich denke mal das wir nur auf eine neue Version von Magisk warten müssen.

ja das ist korrekt im normalfall brauchst du das twrp eh nicht. eine neue LOS IMage kann man ja auch mit fastboot flashen über PC.
 
Zuletzt bearbeitet:
PurpleZ

PurpleZ

Neues Mitglied
Habe ich euch gebastelt, wenn schon kein Root dann ne schöne Oberfläche was man haben möchte und was nicht.
Die Open Gapps Aroma Installer Edition erlaubt euch auszusuchen welche Apps drauf haben wollt und welche nicht.
 

Anhänge

  • open_gapps-arm-10.0-pico-aroma-20200711.zip
    98,7 MB Aufrufe: 0
R

rosalynd

Neues Mitglied
Hallöle,

hat es mittlerweile jemand geschafft ROOT auf dem LOS 17.1 zu werden?

Leider funktionieren die Sensoren nicht bei der "LineageOS 17 & Root (kein TWRP im recovery)"-Lösung nicht. So ist z.B. der Lagesensor nicht aktiv und das Smartphone kann keine automatische Rotation des Displays vornehmen :-(

Gibt es ggf. einen unoffiziellen Magisk-Pätch?

Grüße
 
Ähnliche Themen - TWRP Kingkong mini Antworten Datum
2
7
0