Custom Rom [ Lineage 14.1 - 7.1.2 Nougat] für Cubot Max

h0sch180

h0sch180

Stammgast
Threadstarter
Hier findet Ihr in Zukunft immer das aktuelle Lineage 14.1 mit den letzten Security Patches.

In Zukunft muss ich die ROMs nicht mehr porten wie bisher und muss warten bis es bei einem ähnlichen Handy was neues gibt, sondern kann diese direkt aus dem Quellcode übersetzen. Ein riesiges Dankeschön an dieser Stelle geht definitiv an @seluce, er hat mir extrem geholfen den notwendigen Device und Vendor Tree zu bauen.
In diesem Zuge haben wir auch gleich noch einen Device Tree für den TWRP erstellt, so dass dieser jetzt auch zeitnah nach einer Veröffentlichung hier bereit stehen wird.



Device und Vendor Tree:
h0sch180 - Overview

ChangeLog:
20190501 - initial mit Sicherheitspatches 04.05.2019
20190504 - Bluetooth fix, Sicherheitspatches 04.05.2019
20190518 - OMS Support, MicroG Support, Sicherheitspatches 05.05.2019
20190621 - Sicherheitspatches 05.06.2019
20190709 - WifiDisplay Fix (Miracast), Sicherheitspatches 05.07.2019
20190813 - Sicherheitspatches 05.08.2019
20190812 - Sicherheitspatches 05.09.2019

Neu Installation:
1. Custom Recovery Booten (Power- und Volume+ Taste) ((TWRP))
2. Lösche Dalvik, Cache, System und Data
3. ROM installieren
4. OpenGapps oder MicroG (ab 20190518) installieren
5. Optional Magisk / SuperSu installieren
6. Dalvik löschen
7. Handy neustarten

Update Installation:
1. Custom Recovery Booten (Power- und Volume+ Taste) ((TWRP))
2. ROM installieren
3. OpenGapps oder MicroG (ab 20190518) installieren
4. Optional Magisk / SuperSu installieren
5. Dalvik löschen
6. Handy neustarten

Was geht:
- Alles, bis auf Live-Display

Vorraussetzung:
- TWRP 3.3.0 --> TWRP-Recovery Cubot Max V3.3.0

Download ROM:
lineage-14.1-20190501-UNOFFICIAL-MAX.zip
lineage-14.1-20190504-UNOFFICIAL-MAX.zip
lineage-14.1-20190518-UNOFFICIAL-MAX.zip
lineage-14.1-20190621-UNOFFICIAL-MAX.zip
lineage-14.1-20190709-UNOFFICIAL-MAX.zip
lineage-14.1-20190813-UNOFFICIAL-MAX.zip
lineage-14.1-20190912-UNOFFICIAL-MAX.zip

Download OpenGapps:
The Open GApps Project
(ARM64 --> 7.1 --> Variante)

Download MicroG mit PlayStore:
MicroG-Installer_PlayStore.zip

Download MicroG mit FakeStore:

MicroG-Installer_FakeStore.zip

Download Magisk:

Magisk-v18.1.zip

Download SuperSu:
SuperSU-v2.82-201705271822.zip


Screenshot_20190428-012908.png Screenshot_20190428-013006.png Screenshot_20190428-013120.png Screenshot_20190428-013024.png


Wenn Dir meine ROM's gefallen, darfst du meine Arbeit hier auch gerne honorieren.
 
Zuletzt bearbeitet:
h0sch180

h0sch180

Stammgast
Threadstarter
Lineage 7.1.2 + Security Patch 05.04.2019 ist da!
 
seluce

seluce

Erfahrenes Mitglied
Magst du bitte Screenshots machen wie ich z.b hier gemacht habe?
https://www.needrom.com/download/n-lineageos-14-1/

Würde das gerne so mit Screenshots bei Dir auf Needrom ergänzen

Needrom wurde soweit aktualisiert:
https://www.needrom.com/download/max-lineage-osandroid-7-1-2/

- ROM is now built by source instead port
- all latest feature and security updates by LineageOS 14.1
- increased patch security level to 2019-04-05
- added OMS (overlay themes) support
- added a lot of different patches to fix logcat errors
- increase minior battery life
 
Zuletzt bearbeitet:
h0sch180

h0sch180

Stammgast
Threadstarter
@seluce
OMS Support ist noch nicht in der aktuellen ROM mit drin, kommt beim nächsten Build
 
K

kokesilv

Neues Mitglied
funktioniert das Bluetooth nicht mit dir?
 
h0sch180

h0sch180

Stammgast
Threadstarter
@kokesilv
Ist behoben, neues ROM gibt es morgen früh.
Danke
 
B

Beck1972

Neues Mitglied
Hallo!
Wieso funktioniert Bluetooth nicht? Ich habe das fehlerhafte EOM installiert und alle Apps eingerichtet. Nun stelle ich fest, dass Bluetooth nicht funktioniert. Kann ich das neue, fehlerbereinigte ROM als Update installieren oder muss ich wieder eine Neuinstallation durchführen?
Ist das obige ROM v. 28.4. mit dem funktionierenden Bluetooth?
Danke.
 
seluce

seluce

Erfahrenes Mitglied
Die 20190428 hat alles wieder funktionsfähig.

Du kannst einfach im TWRP folgendes löschen:
Dalvik, System und Cache

Einfach dann die neue ROM im TWRP installieren. Wenn du "data" nicht mit wipest (und nur die drei oben genannten), dann bleiben deine Einstellungen und Apps vorhanden.
 
Zuletzt bearbeitet:
B

Beck1972

Neues Mitglied
Hallo Seluce,
Was ist mit der Update-Install-Anleitung von oben? Ist die nicht gültig? Demnach müsste ich nur im letzten Schritt Dalvik/Cache löschen. Ist diese Einleitung nicht sauber? Was ist der Unterschied zu Deiner Wegbeschreibung?
 
seluce

seluce

Erfahrenes Mitglied
Es gibt kaum einen Unterschied. Durch die oben genannte Methode von H0sch wird die ROM "drüber installiert" und die Dateien werden ersetzt.

Geht natürlich auch. Durch das Entfernen der 3 Partition (über meinem Weg), wird vorher alles sauber entfernt und dann wird das System neu installiert
Durch das Behalten von der Partition "data" bleiben aber deine Einstellung und Apps erhalten.

Nachtrag: Wenn es Dir so wichtig ist da alles reibungslos funktioniert, dann bitte nicht direkt am ersten Tag eine neue Version installieren und erstmal abwarten. Es lohnt manchmal erstmal abzuwarten, falls eine Version doch Fehler enthalten sollte. Diese werden in der Regel schnell behoben. Und wenn man dann erst Tage später ein Upgrade macht, dann sollte es keine Probleme geben
 
B

Beck1972

Neues Mitglied
Hallo Seluce, ich habe sowieso mein Max an diesem Wochenende neu aufgesetzt, deswegen habe ich gleich zu der neuen ROM-Version gegriffen, ohne darüber nachzudenken, dass diese Fehler beinhalten könnte.
Habe ich richtig verstanden gem. Deinem Vorschlag gehe ich folgendermaßen vor:
1. TWRP starten
2. Löschen - Erweitertes löschen wählen
3. nur Dalvik/ART Cache, System und Cache markieren und löschen. Data, interner Speicher und Micro SD-Karte nicht löschen
4. Dann gleich ohne Neustart das ROM installieren
5. Danach gleich neu starten.
Ist das so korrekt, damit ich eine saubere Installation bekomme, aber ohne dass meine Apps und die Einstellungen in meinen Apps verschwinden?

Und noch Fragen:
Muss ich nach dem 4. Schritt OpenGaaps und Magisk wieder installieren?
Muss ich vor dem Neustart (also vor dem 5. Schritt) Dalvik -wie TWRP vorschlägt- löschen?


nochmals vielen Dank.
 
Zuletzt bearbeitet:
seluce

seluce

Erfahrenes Mitglied
Korrekt, du hast es vollkommen richtig verstanden.

Und ja, bei der Methode muss einmal OpenGapps und Magisk wieder installiert werden. Weil das nicht in /data/ gespeichert wird, sondern im /system/ und boot.img
Daher kannst du die Paritions löschen -> direkt ROM installieren -> dann OpenGapps -> Neustart
Wenn alles wie gewohnt funktioniert -> nochmal ins TWRP und Magisk hinterher installieren

Solange /data/ Partition nicht entfernt wird, dann passt alles. Das ist die elementare Partition mit deinen ganzen Einstellungen, Apps, etc.
 
B

Beck1972

Neues Mitglied
Muss man nach der Installation von OpenGaaps und vor dem Neustart nochmals Dalvik löschen?

Nach Deiner Methode bekomme ich also eine richtig saubere Neuinstallation ohne die Apps und die Einstellungen verloren zu haben und neu einrichten zu müssen?
 
seluce

seluce

Erfahrenes Mitglied
Brauchst du nicht 2x entfernen.

Ja, das ist korrekt. Wenn du es genauso so machst, dann bleibt alles erhalten
 
B

Beck1972

Neues Mitglied
Hallo Seluce,

dann muss man bei jedem Update nicht immer wieder alles neu einrichten oder auch aufwendig irgendwelche Backups anlegen und zurückspielen mit Titanium Backup oder ähnlichen Apps. Ich kenne mich damit nämlich gar nicht aus. Und ich traue diesen ganzen Backups nicht wirklich.

Nochmals vielen Dank für die Beantwortung meiner unzähligen und akribischen Fragen.
 
K

kokesilv

Neues Mitglied
Diese Zusammenstellung geht super gut, vielen Dank
 
O

Osnh

Neues Mitglied
@h0sch180

Erst einmal vielen Dank für die gute Arbeit die du in dieses Projekt reingesteckt hast. Ich habe diese neue ROM installiert und (fast) alles funktioniert super. Offensichtlich gab es ja mit der ersten Version ein Problem mit Bluetooth. Ich habe die zweite Version installiert. Da ich über ein Bluetooth Ohrhörer mir sehr viel vorlesen lasse, hat die Übertragung anfangs mit dem Voice Aloud Reader noch funktioniert. Pocketbook hat von Anfang an nicht funktioniert. Ich habe auf die Pico Sprachausgabe umgestellt und das gleiche Ergebnis bekommen. Der Bluetooth Ohrhörer funktioniert bei anderen Geräten eineandfrei. Im Auto wird auch keinen Ton übertragen. Seltsam ist das der Voice Reader am Anfang funktioniert hat. An der Kopplung liegt es nicht ich habe sie mehrfach gelöscht und neu gekoppelt. Hast du eine Ahnung was man noch machen kann?
-- Dieser Beitrag wurde automatisch mit dem folgenden Beitrag zusammengeführt --
Ergänzung zu der vorherigen Meldung
die Ton Ausgabe über Lautsprecher und Kabelohrhörer funktioniert bestens
 
Oben Unten