Surnia (LTE) CyanogenMod 13.0.x (Android 6.0.1 Marshmallow) (Moto E 2015, 4G LTE, XT1524) [ROM][surnia]

  • 75 Antworten
  • Neuester Beitrag
Diskutiere CyanogenMod 13.0.x (Android 6.0.1 Marshmallow) (Moto E 2015, 4G LTE, XT1524) [ROM][surnia] im Custom-ROMs für Motorola Moto E (2015) im Bereich Root / Custom-ROMs / Modding für Motorola Moto E (2015).
B

Bebeto

Neues Mitglied
@ooo
Ich kapiere das mit der Verschlüsselung noch nicht so ganz.
Manchmal wird bei mir der Speicher im Windows Explorer nur in Form der SD-Karte dargestellt, manchmal als Adoptable Storage.

Ich würde gerne meine SD-Karte als interner Speicher einbinden. Ich dachte das macht dann Android bzw. CM13 automatisch sofern man dies in den Speichereinstellungen so auswählt. Dabei wird die SD-Karte dann verschlüsselt, oder???

Wofür benötige ich dann den Workaround bzw. wofür muss man die Motorola Firmware Back-to-Stock flashen?
 
O

ooo

Lexikon
@Bebeto - Kein Problem.

Zur SD-Karte:
  • Tragbarer / Mobiler Speicher > Am Rechner werden "Interner Speicher" und "SD-Karte" gleichzeitig angezeigt
  • Adopted Storage > Anwender-Daten im "echten" internen Speicher > Anzeige am Rechner "Interner Speicher"
  • Adopted Storage > Anwender-Daten auf der SD-Karte > Anzeige am Rechner "SD-Karte"
    (Beim Adopted Storage sind die Anwender-Daten entweder komplett im internen Speicher oder komplett auf der SD-Karte.)
  • Adopted Storage allgemein > Die am Phone zu sehenden "Apps"-Verzeichnisse sieht man am Rechner überhaupt nicht, egal, ob man Apps verschiebt oder nicht


Zur Verschlüsselung:
  • Tragbarer / Mobiler Speicher > Karte wird nie verschlüsselt
  • Adopted Storage > Karte wird bei der jeder Formatierung als Adopted Storage automatisch verschlüsselt, i. d. R. macht man das nur einmalig.

    Diese Verschlüsselung der SD-Karte hat nichts mit der Telefon-Verschlüsselung zu tun, die man unter

    Einstellung > Sicherheit > Telefon verschüsseln (Nennt sich auch FDE = Full Device Encryption)

    machen kann.

    Die aktuelle CM Nightly für das Phone kann diese Telefon-Verschlüsselung (= Verschlüsselung der data-Partition) momentan nur nicht.
    Deswegen muss man das über die Stock-ROM machen. - Dort geht das dann (als Vorbereitung, um dann bei CM eine bereits verschlüsselte data-Partition zu haben). - Deswegen der Begriff "Workaround" in der Checkliste oben.

  • Die Verschlüsselung der SD-Karte ist immer unabhängig von der Verschlüsselung des Telefons. - Das sind zwei verschiedene Dinge
  1. Verschlüsselung der SD-Karte > SD-Karte wird verschlüsselt (bei der Formatierung) > Aus die Maus
  2. Verschlüsselung des Telefons > data-Partition wird verschlüsselt, sonst nichts (Die Lockscreen-Sperre ist dann das "Passwort", auch im TWRP)
  3. Im TWRP gibt es zusätzlich die Option ein Backup zu verschlüsseln. - Das ist ein extra Passwort und nicht das Lockscreen-Passwort zum Entschlüsseln der data-Partition. - Damit werden die Backup-Dateien verschlüsselt (wie bei normalen .zip-Dateien auch möglich)
[How-To] Daten retten von als intern eingebundener SD Karte
[How-To] SD Karte gleichzeitig als Interne Speichererweiterung und Mobilen Speicher benutzen (Marshmallow)
___

N008 schrieb:
Nebenbei: Gibt es eigentlich eine Möglichkeit, ein verschlüsseltes, nicht gerootetes Gerät, das im Bootloop hängt, ohne factory reset zu fixen bzw. die Daten zu sichern? ADB wurde leider nicht aktiviert.
Nein. - Das wäre ja dann so, also ob eine schweizer Bank einen Tresorraum mit einer 5 Meter dicken Stahltür hat, und wenn man um das Gebäude herum geht, befindet sich auf der Rückseite eine japanische Schiebetür aus Papier ...

(Wenn der Bootloader entsperrt ist - gerootet muss es nicht sein, kann man ein TWRP mit einer root shell via fastboot booten, um evtl. doch noch etwas zu retten. - Deswegen ist es auch eine gute Idee, ein Phone zu verschlüsseln, wenn der Bootloader offen ist.)
 
Zuletzt bearbeitet:
B

Bebeto

Neues Mitglied
@ooo
Erst mal super vielen herzlichen Dank für die tollen Forumsbeiträge zum Surnia. Echt gut gelungen. Ich habe mir auch einige weitere Beiträge durchgelesen und gleich meine 128GB SD-Karte in einen internen und externen Speicher aufgesplittet. Hat (zumindest bis jetzt) gut funktioniert. Das mit der Verschlüsselung ist mir jetzt auch klar. Dankeschön!
Mein Telefon (bzw. die data-Partition) ist nun nicht verschlüsselt. Ist das aus eurer Sicht ein gravierendes (Sicherheits)Problem?

Ein wirklich kritisches Problem habe ich allerdings mit meiner Telefon-App. Ich habe jetzt die Nightly vom 24.5.2016 aufgespielt und seither kann ich keine Telefonate mehr führen. Bei ein- und ausgehenden Anrufen erscheint ohne Ton das blinkende CM-Logo für ca. 30 Sekunden und das Telefon reagiert auf keinerlei Eingaben mehr. Danach erscheint der Sperrbildschirm und man kann alles wieder normal bedienen (außer eben in der Telefon-App Anrufe führen). Den Telefonanbieter selbst findet das Telefon (Klarmobil). Bei der Nightly vom 20.2.2016 war das ursprünglich alles kein Problem. Ich habe auch schon mal im Google-Store eine andere Telefon-App installiert, aber gleiches Verhalten.

Kennt jemand das Problem? Habe ich vielleicht einfach nur eine falsche Einstellung gewählt? Kann ich ggf. einfach wieder ein älteres Nightly aufspielen und testen ob dann alles wieder einwandfrei funktioniert (dirty flash)?
 
O

ooo

Lexikon
Fehlende Verschlüsselung + offener Bootloader:
Wenn du dein Phone nicht aus der Hand gibst bzw. es nicht länger unbeaufsichtigt herum liegen lässt, dann ist das kein Problem.

Telefon/Bootloops:
Welches Open GApps-Paket hast du installiert (pico, nano, ...)?
Hast du noch die originale CM Telefon App oder dir das weginstalliert mit einem GApps Paket, das die App Google Dialer/Phone installiert?
Die "großen" Open GApps Pakete sind zu groß für die System-Partition und verursachen dann Abstürze/Fehler.
 
Zuletzt bearbeitet:
B

Bebeto

Neues Mitglied
@ooo
Diesmal habe ich eine "große" Open GApps installiert, die Stock-Variante. Beim letzten mal hatte ich die Pico-Variante. Könnte also durchaus sein, dass es daran liegt.

Kann ich nach einem Wipe (z.B. factory reset) einfach die Pico-Variante flashen? Oder am besten CM auch nochmal komplett neu installieren?
(Habe noch keine wichtigen Daten drauf)
 
O

ooo

Lexikon
Im Start-Posting unter Punkt 6. steht, wie man ein GApps-Paket wegbekommt. - Allerdings muss man ab CM 13 immer die Nightly und die GApps in der gleichen TWRP Session installieren (also direkt hintereinander. - Factory Reset (= Wipe data) ist nicht nötig.

Aber da du keine wichtigen Daten hast, tu dir selbst einen Gefallen und nimm direkt den Vollversions-Zip der Nightly@2016-05-26 und die aktuellste Open GApps Pico oder Nano, mach einen TWRP > Wipe > system, data, caches und installier dir das nochmal sauber über das TWRP. - Deine als Mobiler Speicher/Adopted eingerichtete SD Card vorher komplett sichern, weil sie im Phone danach nicht mehr funktionieren wird und du sie neu formatieren musst.
 
B

Bebeto

Neues Mitglied
@ooo
Wie du richtig vermutet hast, und wie in deinem Start-Postig bereits beschrieben war, die "große" Stock Open GApp war schuld. Jetzt funktioniert die Telefon-App wieder einwandfrei. Ich habe wieder die Pico von Mitte Mai installiert. Zuvor versuchte ich noch die aktuelle Nano vom 26.5. zu installieren, bekam aber stets "error 64".

Nochmal ein Lob für die tollen Postings. Da steht fast alles perfekt beschrieben drin (man muss es nur gründlich lesen). Ich hatte mich zuvor auf dem xda-Forum versucht, die Infos sind dort aber nicht so kompakt und übersichtlich wie hier. Echt Cool :)
 
O

ooo

Lexikon
Nimm nächstes Mal die Open GApps Version 6.0 > ARM (nicht ARM64), falls es das war.

#64 - Incompatible device architecture: Your device has been detected as having a different kind of architecture then the package used. Like arm vs arm64 vs x86 etc. Install the correct Open GApps version for your device.

Solution: Use a compatible version of the Open GApps package for your device's architecture.
Quelle:
FAQ · opengapps/opengapps Wiki · GitHub
 
B

Bebeto

Neues Mitglied
So, jetzt habe ich dank der Unterstützung in den verschiedenen Foren, für meine Familie und mich gleich mehrere Moto E's mit CM13 aufgesetzt und erste Tests gemacht. SIM-Karten sind noch nicht eingesetzt aber alle übers WLAN mit dem Internet verbunden. Das klappt auch bis auf die Installation von Google Hangouts recht gut. Zukünftig wollte ich über Hangouts mit meiner Frau und Kindern mobil kommunizieren (z.B. Chat, Videotelefonie, etc.). Nur habe ich jetzt das Problem, dass die eingehenden Anrufe von den Handys ganz unregelmäßig signalisiert werden. Oft zeitlich verzögert und dann ohne Klingelton sondern nur stumm als Message-Box innerhalb von Hangouts. Vielleicht ist dies nur ein Problem von Hangouts, aber auf meinen beiden vorhandenen Kindle-Tablets, auf welchen ich CM12 am Laufen habe, wird jeder Anruf sofort signalisiert und angezeigt. Lediglich die Moto Es mucken.

Danach wurden alle erst mal runtergefahren und landeten für zwei Wochen ausgeschaltet in der Schublade. Als ich diese jetzt wieder rausholte waren alle drei vollständig entladen (0% Akku-Kapazität). Ich weiß noch als ich die Handys kaufte, da lagen diese mit dem original Betriebssystem mehrere Monate in der Schublade bis ich mich an CM13 rantraute und hatten danach noch mehr als die Hälfte an Akku-Kapazität.

So richtig überzeugen kann mich CM13 deshalb noch nicht. Für die Sache mit Hangouts kann CM13 wahrscheinlich nichts, aber die Sache mit dem Energiehunger kann doch ziemlich nerven. Trotzdem, toll dass die Community das Modell so gut unterstützt. Ich bleibe jedenfalls dabei. :thumbup:
 
O

ooo

Lexikon
Verlust pro Monat Lagerung sind ca. 3 %.
Bist du sicher, dass die Phones korrekt geladen waren und wirklich aus?
Lithium-Ionen-Akkumulator – Wikipedia

Hangouts (auch andere Apps) könnte evtl. auch deswegen nicht so gut funktionieren, weil es als optimierte App markiert ist.
Einstellung > Akku > Menü oben rechts > Akku-Leistungsoptimierung > Alle Apps > Hangouts > Nicht optimieren
 
derAltePopov

derAltePopov

Neues Mitglied
Moin zusammen. Ich bekomme Open GApp pico / nano nicht zum Laufen. Die Installation im TWRP sieht zwar gut aus, aber z.B. vom Playstore ist nichts zusehen.
Ich habe einen Squid-Kernel, TWRP 3, CM13 (nightly von gestern) und wollte noch eben Open GApp istallieren.

Ick habe die Pakete schon mal einzeln rübergeschoben, aber dabei haben sich der Google-Framework-Dienst sekündlich abgeschossen. Funktioniert hat es trotzdem nicht.
Wisst ihr Rat?
 
O

ooo

Lexikon
@derAltePopov - Moin, moin. - Ich würde das machen:

TWRP > Backup > machen
TWRP > Wipe > Advanced > System
TWRP > Install > Auswahl <vollversion-nightly-xyz>.zip > Auswahl <opengapps-xyz>.zip > Swipe to Install
TWRP > Reboot system

Testen

(TWRP > Backup > machen?)
TWRP > Install > Auswahl <squid-kernel>.zip > Swipe to install
TWRP > Reboot system

Testen

___

Vllt. hängt es auch (nur) mit der aktuellen Open GApps zusammen. - Dann das obige mit einem älterem zip probieren. - Einfach immer weiter nach unten scrollen, bis zum gewünschten Datum.

(Edit: Nightly und GApps müssen bei CM 13 immer direkt in der selben TWRP Session zusammen installiert werden.)
 
Zuletzt bearbeitet:
derAltePopov

derAltePopov

Neues Mitglied
Im Moment sieht es auch mit den neuesten Versionen gut aus. Mein Fehler bestand darin eine normal TWRP 3.0.2 zu benutzen und nicht die TWRp surnia. Jetzt tuts.
Danke fürs Hirn-Reset.
 
O

ooo

Lexikon
Die Nightly @ 2016-07-11 hat jetzt die neuesten Sicherheitspatches (Juli 2016) integriert.

Diesmal bereits gleich zwei:
July 1, 2016: [2016-07-01]
July 5, 2016: [2016-07-05]

Das nenne ich überlicht-schnell ... :thumbup:
___

(Sicherheitspatch-Level der Stock-ROM: Lenovo/Motorola, go home ... :mad2:)
 
Zuletzt bearbeitet:
N008

N008

Ambitioniertes Mitglied
Sehr gut! :thumbsup:

Mit der Nightly vom 12. Juli wurden nun auch ein paar kleinere Bugs gefixed. Der Wechsel zwischen zwei Liedern im Stock Music Player per Lautstärkewippe bei ausgeschaltetem Display funktionierte seit einiger Zeit nicht mehr. Außerdem blieb zuletzt "DND" weiterhin aktiv, auch wenn der Wecker (hörbar) geklingelt hatte. In der Auswahlliste für die Schnelleinstellungen fehlten einige Icons. Letzteres hatte natürlich keinerlei Auswirkungen auf Funktion oder Usability des Geräts. :laugh:

Unter Einstellungen > Gestensteuerung finden sich nun übrigens zwei neue Optionen, die aktuell noch im Betastadium sind. So kann man das Gerät in den "DND" Modus versetzen, wenn man es mit dem Display nach unten flach auf den Tisch legt.

Ein mitunter etwas nerviger Fehler besteht allerdings weiterhin: Wenn man den WLAN Adapter deaktiviert, kann man ihn nicht sofort wieder aktivieren, sondern muss ein wenig warten.

Und noch eine Frage am Rande: Kann es sein, dass unter CM 13.0 in den Systemprofilen der Sperrbildschirm grundsätzlich nicht mehr deaktiviert werden kann, wenn man sich zum Beispiel im heimischen WLAN Netz befindet?
 
O

ooo

Lexikon
Ich kenne das Problem mit der Bildschirmsperre (ging wochenlang nicht).
Seit einer Woche (oder länger) allerdings schon.

Ich habe es so eingerichtet und es funktioniert einwandfrei:
  • Einstellungen > Bildschirmsperre > Displaysperre > (erstmal wieder zurück auf) Wischen
    (Dadurch erreicht man, dass in den Profilen die Einstellung "Bildschirmsperre" nicht ausgegraut/gesperrt ist und man sie wieder ändern kann.)
  • Einstellungen > Bildschirmsperre > Automatisch sperren > Sofort
  • Einstellungen > WLAN > Auswahl <eigenes W-LAN> (einrichten bzw. anmelden und beim folgenden Profile-Einrichten erstmal aktiv lassen)
  • Einstellungen > Systemprofile > AN
  • Einstellungen > Systemprofile
    > 1. Profil z. B. "W-LAN" anlegen/ändern
> Auslöser "WLAN" > Auswahl <eigenes W-LAN> > Auswahl "Beim Verbinden"
> WLAN > Auswahl "Einschalten"
> Bildschirmsperre > Auswahl "Nicht nach PIN oder Passwort fragen" oder "Bildschirmsperre deaktivieren"
(Tipp: Zusätzlich "Datenverbindung" evtl. auch "ausschalten", damit kein Traffic-Volumen unnötig futsch ist, wenn das W-LAN weg ist, aber Mobilfunk noch da, aber "Daten automatisch synchronisieren" "anschalten", falls gewünscht, sonst auch "ausschalten")
  • Einstellungen > Systemprofile
    > 2. Profil z. B. "Kein W-LAN" anlegen/ändern
> Auslöser "WLAN" > Auswahl <eigenes W-LAN> > Auswahl "Beim Trennen"
> WLAN > Auswahl "Ausschalten"
> Bildschirmsperre > Auswahl "Systemstandard"
(Tipp: Auch hier zusätzlich "Daten automatisch synchronisieren" und "Datenverbindung" evtl. "ausschalten", damit kein Traffic-Volumen unnötig futsch ist - die zwei Profile 1. und 2. arbeiten dann besser zusammen)
  • Einstellungen > Systemprofile
    > Alle anderen Profile in der Liste löschen (also alle, außer Profil 1. und 2. von oben)
  • Einstellungen > Bildschirmsperre > Displaysperre > Auswahl Muster oder PIN oder Passwort
  • Einstellungen > Bildschirmsperre > Trust Agents > Anbieter für vertrauenswürdige Profile > aktivieren
    (alle anderen Trust Agents evtl. erstmal deaktivieren, falls vorhanden; später bei Bedarf wieder aktivieren und erneut testen)
Testen
  • z. B. einfach über QuickToggle W-LAN ein/aus, muss die Profile automatisch umstellen und auch die Bildschirmsperre de-/re-aktivieren
  • oder bei aktiviertem W-LAN/W-LAN-Profil den Router abschalten (Stecker ziehen) und warten, was passiert und dann schauen, wie sich die Bildschirmsperre verhält ...
  • oder einfach das Haus verlassen, um aus dem Funkbereich des LANs zu kommen ... (muss auch nach kurzer Zeit auf "Kein W-LAN" umschalten plus aktiver Bildschirmsperre)
(Tipp: Wenn man es ganz automatisch haben möchte, muss im Profil "Kein W-LAN" der Wert "WLAN" auf "Unverändert lassen" oder "Einschalten" gesetzt sein ...)
-- Dieser Beitrag wurde automatisch mit dem folgenden Beitrag zusammengeführt --
N008 schrieb:
Ein mitunter etwas nerviger Fehler besteht allerdings weiterhin: Wenn man den WLAN Adapter deaktiviert, kann man ihn nicht sofort wieder aktivieren, sondern muss ein wenig warten.
Das funktioniert bei mir instantan (sofort) - Nightly @ 2016-07-12
Ich habe die Netzwerk-Treiber/das Modem aus der Motorola Stock-Firmware MM 6.0 und setze keinen squid2-Kernel ein.
(Baseband-Version M8916_2020629.41.03.21.51R)

Falls da etwas verrutscht sein sollte (z. B. CM 12 Nightlies setzen die W-LAN Firmware und die Sensor Services auf ältere bzw. andere Versionen zurück), flashe ich (nach einem TWRP Backup) immer die komplette MM Stock-ROM mit Komplett-Boot bis in den Homescreen/Launcher, um nachzusehen, ob das Phone die Firmware-Treiber (Sensor Services) auf die originalen zurücksetzen möchte > Es kommt dann eine entsprechende Benachrichtigung.
Erst danach mache ich einen Clean Install der aktuellen CM 13 Nightly.
Das alte CM 13-data kann man sich dann aus dem vorherigen TWRP Backup wieder herstellen.

(Es kann aber auch am Router liegen, oder daran, dass man DHCP verwendet, anstatt - wie ich - eine statische IP im Phone für das W-LAN.)
 
Zuletzt bearbeitet:
O

ooo

Lexikon
Nightly@2016-08-04 - Sicherheitspatches August 2016

Die Mädels werden immer besser:
Datum der ROM ist 04. August 2016 und das Patch-Level ist auf den 05. August datiert ... *LOL*

Die Versions-Nr. wurde jetzt von CM 13.0 auf CM 13.0.1 angehoben.

(Siehe Screenshot)
 

Anhänge

N008

N008

Ambitioniertes Mitglied
Ich hoffe ja, dass wir mit Nougat (CM14) auch positiv überrascht werden. ;)

Dein workaround bzgl. automatischem De-/Aktivieren der Bildschirmsperre hat funktioniert. Bin aber mit dem Verhalten nicht ganz zufrieden, weil manchmal der Bildschirm hakt/kurz einfriert o.ä. Aber das ist nicht schlimm.

Ich habe mein Gerät nie auf Stock Android 6.x.x aktualisiert. Es lief recht bald Cyanogenmod. Meine Baseband-Version ist daher M8916_200608.08.02.58.15R. Vielleicht werde ich mich bei meinem nächsten "Frühjahrsputz" an Deiner Anleitung hier entlanghangeln. Aber als störend empfinde ich auch dieses Buggchen nicht. ;)