pds.img zerschossen -> Bootloop bei jeder Rom-Installation

  • 34 Antworten
  • Neuester Beitrag
Diskutiere pds.img zerschossen -> Bootloop bei jeder Rom-Installation im Custom-ROMs für Motorola Razr i im Bereich Root / Custom-ROMs / Modding für Motorola Razr i.
okadererste

okadererste

Guru
[Edit Moderator] um den Zusammenhang zu verstehen: Beiträge wurden aus https://www.android-hilfe.de/forum/.../rom-motorola-razr-i-one-jb-4-1-2.495754.html herausgelöst[/Edit]

Was mach ich falsch?

Ich habe die neuste Version geflasht und mein RI startet nicht.
Es kommt das Bootloader unlook dann kommt das Boot Logo und für eine Millisekunde die sprachauswahl. Dann geht es wieder aus und alles wieder von Anfang.

Dann habe ich mit RSD die RetailEU 4.1.2 geladen und alles nach Anleitung gemacht, so wie es auf Seite 1 beschrieben ist. Kein Erfolg. Wieder nur Start bis kurz vor der Sprachauswahl.
Dann wieder die Android Version. Die läuft komplett durch alles geht nur habe ich kein WLan mehr. Ich kam den Reglerbewegen und auch den WLANcode nur kommt kein wlansymbol und auch keine Verbindung.

Benutze alle Sachendie in der Anleitung verlinkt sind.
RSD Lite 6.1.5
 

Anhänge

Zuletzt bearbeitet von einem Moderator:
FourOne

FourOne

Fortgeschrittenes Mitglied
Vermutlich eine kaputte bzw beschädigte psd Partition, diese enthält die Daten für Dein Wlan bzw die Mac Adresse etc. Das ganze ist vorher nicht passiert weil Du keinen clean-flash gemacht hast, mit dem clean-flash passiert das leider.

Um das zu verifizieren guck mal ob Deine Seriennummer noch angezeigt wird, wenn nicht gibt jetzt 2 Möglichkeiten - entweder Du hast ein Backup der Partition gemacht, oder Du besorgst Dir eins von jemand mit einem anderen RAZR i.

Ich kann Dir erklären wie Du das Backup beziehst und einspielst, aber leider ist Deine einzigartige Mac-Adresse und die Seriennummer im Gerät dann futsch.

Das Problem wirst Du wahrscheinlich auch mit jeder anderen Full-Rom haben, deswegen war mein Projekt auch anfangs ein Mod - hatte das Problem auch und wusste eine ganze Zeit lang nicht warum.

Auf dem Screen ist aber meine Rom nicht geflash oder?, weil das ist das falsche Build Datum und der falsche Kernel...


EDIT:

Zum beziehen des Backups:
Code:
adb shell
su
dd if=/dev/block/mmcblk0p12 of=/storage/sdcard1/pds.img
exit
exit
Dieses dann in den von der externen SD-Karte in den ADB Ordner kopieren.

Zum einspielen des Backups (muss im selben Ordner liegen wie ADB):
Code:
adb push pds.img /data/local/tmp
adb shell
su
chmod 777 /data/local/tmp/pds.img
dd if=/data/local/tmp/pds.img of=/dev/block/mmcblk0p12
exit
exit
adb reboot
 
Zuletzt bearbeitet:
okadererste

okadererste

Guru
Seriennummer ist "unknown"

Backup ist nicht vorhanden.
Hat jemand ens das er mir zu Verfügung stellen kann?

Der ursprüngliche Beitrag von 15:33 Uhr wurde um 15:53 Uhr ergänzt:

wie gebe ich deine Befehle ein
momentan steht bei mir c:\adb tools
 
Cua

Cua

Ehrenmitglied
wenn du in dem Ordner bist, wo adb.exe und deine pds.img drin liegen, einfach die Zeilen, so wie sie da stehen nacheinander abtippen und Enter drücken
 
okadererste

okadererste

Guru
Bei der Zeile SU steigt er schon aus.
Gibt es eine ADB oder verschiedene.

Ich habe ja auch kein backup und so auch nichts zum einspielen.
Ich bin da vollkommen neu auf dem Gebiet .
 
FourOne

FourOne

Fortgeschrittenes Mitglied
"su" geht nur wenn Dein Gerät geootet ist, kann Dir leider mein Backup nicht geben weil ich meinem Kumpel versprochen habe das nicht weiter rumzureichen - kann Ihn auch verstehen sonst haben bald zig Geräte seine Seriennummer & Mac-Adresse.
 
okadererste

okadererste

Guru
habe diese Seite angewendet.

Du schreibst aber im tutorial das man ein clean-flash machen soll
hier kann es helfen einen Datenwipe bzw einen Clean-Flash mit RSDlite zu machen.
Habe wieder Wlan.
Jetzt versuche ich deine Rom zu installieren.
Hoffe das es jetzt geht und nicht wieder im Bootloader hängen bleibt.
 
Zuletzt bearbeitet:
FourOne

FourOne

Fortgeschrittenes Mitglied
Du hast den pds-fix vom Atix installiert?

Und ja, wenn man seine pds nicht vorher kaputt gemacht hat funktioniert das auch - die korrupte bzw zerstörte Partition kommt weder vom flashen mit RSDlite noch von einer Rom. Warum die bei mir z.B. leer war weiß ich selbst nicht, vielleicht habe ich die ausersehen mal in CWM formatiert, weiß nicht so genau.
 
okadererste

okadererste

Guru
Hab ich gar nicht gesehen das es von Atrix ist.:ohmy::ohmy::ohmy:

Einfach nach anleitung....Klappt...
Deine Version drauf gemacht. Bin gerade am einrichten... Das was ich bis jetzt gesehen habe...TOP:thumbsup:
 
FourOne

FourOne

Fortgeschrittenes Mitglied
Das war aber Riskant, aber solang es geht - bin aber echt unschlüssig ob das so gut ist, da sind auch gerätespezifische Einstellungen in der Partition.
 
okadererste

okadererste

Guru
Systemversion: 91.2.26001.XT890.Retail.en.EU
Modelnummer: Motorola Razr i
Android Version: 4.1.2
Baseband-Version: SUNRISE_SMB_REV30_V2_R3_ENZO_1251.B_S
Kernel-Version: 3.0.91 omar@Riegel #1 SMP PREEMPT Fri Aug 16.18:19.37 CDT 3013
AP flex-Version
GAS_EMEA_USASMIJBRTEU_P007 GAS_EMEA_USASMIJBRTEU_A005
Build-Nummer: 9.8.21-50_SMI-26.1358455837
Build-Datum
: Thu Nov 11.11:11:11 CET 1982

Wie gesagt.Alles was ich probiert habe,bei dieser ROM ,funktioniert.

Ich habe noch keine Sim Karte drin.Wie es dann aus sieht kann ich noch nicht sagen.
Ich werde berichten.

Eventuell hat ja bis da eine psd.img für mich.
Bei einem Auto würde ich sagen: Unfallwagen zum Ausschlachten:cool2:
 
Otandis_Isunos

Otandis_Isunos

Ehrenmitglied
Also ganz ehrlich? Ich hab in meinem Leben bis jetzt 1x die PDS Partition zerschossen und das auch nur, weil ich MANUELL drin rumgespielt habe, aber das war auch kein Androide, sondern n Motorola V8 :D

Ich hab noch NIE n Backup von gemacht. Denke mal, dass ist eher so ne extreme Ausnahme wenn man sich die kaputtschießt, wie auch immer das möglich ist.

Denn zumindest früher war es nicht möglich, dass man die PDS extern flasht, weils schlicht nicht vorgesehen ist/war. Was evtl sein kann, dass es bei einem Cleanflash durch Repartitionierung was schief gelaufen ist.
 
FourOne

FourOne

Fortgeschrittenes Mitglied
Beim Atrix schein es so zu sein das wenn man die intere SD-Karte formatiert zu 100% die pds im Eimer ist - Ob nun das OTA-Update, das flashen via RSDlite oder das formatieren der Karte, es gibt genug Leute die von ähnlichen Problemen berichtet haben auf xda.
 
Cua

Cua

Ehrenmitglied
Ich habe die Diskussion um pds.img mal in einen neuen Thread ausgelagert, damit die Sache nicht irgendwann untergeht.
 
Otandis_Isunos

Otandis_Isunos

Ehrenmitglied
Ja, beim Atrix. Das ist aber das EINZIGE Gerät von Motorola wo ich sowas bisher gelesen habe. Milestone, Defy, Defy+, RAZR (egal welches) haben die Probleme in der Regel nicht.

K.a. was beim Atrix anders ist, aber im normalfall kannst dir die PDS auf keinen Fall zerschießen. Das man die PDS vom Atrix nimmt war in der Tat äussert riskant, denn in der Original-PDS vom RAZRi gibts ne Datei Names Factory, die die Factory-ID enthält und bspw so ausschaut:

root@smi:/pds/factory # cat fti
UG6563BB TA32403TT713Z P3E413Z SLG6432BB SCMINI_I
Das das Ri das überhaupt so übernommen hat, ist n Wunder :) Mach sowas nie wieder!
 
FourOne

FourOne

Fortgeschrittenes Mitglied
Naja, ich habe das Problem nur erklärt warum es bei Custom-Roms zu dem Fehler kommt. Das wie und warum ist wahrscheinlich auch für den Nutzer unerheblich, und jeder der das jetzt liest kann zumindest so wie schon erklärt ein Backup machen.

Das mit der Atrix pds, die enthält ja auch die Screen & CPU Frequenz - deswegen war der Fix für die so wichtig. Das einzige was wir für die Custom-Roms brauchen ist der WLanschlüssel, der wird im Update-Script immer gelinkt. Hat man den nicht mehr führt das zu Bootloop's oder Wlan Problemen...

Habe auch bei Mototola angefragt ob die mir die pds partition wiederherstellen können bzw aushändigen dürfen, die meinten wenn dann könnte datRepair das fixen. Aber da unlocked bin nur gegen bares, und ich weiß nicht ob sich das lohnt bzw was das kosten soll.
 
Otandis_Isunos

Otandis_Isunos

Ehrenmitglied
Ich hab grad mal nachgeschaut. Das einzig wirklich wichtige in der PDS ist die Factory-ID, ne WLAN.bin und bisschen Securitykram.

Sind im Grunde 5 Dateien, der Rest ist leer :p

Ja okay und die MAC-Adresse vom Modem.

Also nicht weiter wild ehrlich gesagt.

Dennoch, ein Backup zu haben scheint nicht schlecht zu sein, für den äußerst unwahrscheinlichen Fall :) PDS bei datRepair zu reparieren lassen lohnt sich nicht, da die meist das Board tauschen, was teuer ist.

Vorallem hat man da auch Glück das man überhaupt flashen konnte :) Denn wo ich mir damals beim V8 die PDS zerschossen hab, ging auch ein flashen nicht mehr :p
 
zheka99

zheka99

Erfahrenes Mitglied
Das mit dem Update lernt jeder, wenns dann zu spät ist.

Ich hatte komischerweise auf dem Defy sowas gehabt.
 
Otandis_Isunos

Otandis_Isunos

Ehrenmitglied
Beim Defy? oO Da hab ich nur Beiträge gefunden, wo die pds Partition ausversehen MANUELL! formatiert wurde. Der Rest betrifft nur das Atrix.

Stellt sich mir jetzt die Frage: Aus welchem Grund ist es ausgerechnet bei 1! RAZR i jetzt so der Fall. Kann also nur ein Zufall sein, denn sonst hätte man schon lange gewarnt auf xda ;)
 
FourOne

FourOne

Fortgeschrittenes Mitglied
Es ist nicht bei einem RAZR i so, es gab zahlreiche berichte mit dem Problem des Bootloops.