Nexus 5 bootet plötzlich nicht mehr

  • 12 Antworten
  • Neuester Beitrag
Diskutiere Nexus 5 bootet plötzlich nicht mehr im Google Nexus 5 Forum im Bereich Weitere Google Geräte.
B

BFish

Neues Mitglied
Moin,
ich hoffe, in diesen leeren Hallen liest noch jemand mit ;)

Meine Mutter hat mir gestern ein Nexus 5 zugeschickt, das sie nicht mehr zum Leben erwecken konnte. Hat mich anfangs verwundert, weil ich das Gerät problemlos einschalten und laden konnte und Sicherungen von Nachrichten und Fotos erstellt habe. Auffällig war nur die Zeit bei 00:00h, bis zum ersten Kontakt zum NTP. Als ich das Teil dann mal rebooten wollte, kam es nur bis zum weißen Google Schriftzug auf schwarzem Grund. Vor einigen Jahren habe ich mal Lineage 14.1 installiert, also bin ich über Vol- und Power direkt in TWRP 3.2.1 und habe mich dort mal laienhaft umgeschaut. Aufgefallen ist, dass ich nichts mounten konnte, der freie Speicherplatz mit 0MB angegeben wird und in irgendwelchen Logs mit freundlichen roten Buchstaben drauf hingewiesen wird, dass bestimmte Pfade z.B. unter "/Data ..." nicht gemountet werden konnten. Ein Versuch das Lineage Image neu zu installieren, brachte ähnliche Meldungen und den Error 7.

Bevor ich etwas zu viel formatiere oder lösche, wollte ich hier mal nach dem richtigen (sicheren) Vorgehen fragen. Vielleicht weiß auch jemand, wie so etwas kommen kann.

Besten Dank im voraus.
 
Toronto

Toronto

Senior-Moderator
Teammitglied
BFish schrieb:
ich hoffe, in diesen leeren Hallen liest noch jemand mit ;)
Na klar :) Die Nexus 5 Hallen gehören zu den schönsten Hallen, die ich kenne.

Dein Problem sieht allerdings nicht so gut aus. Es kann natürlich sein, dass der freie Speicherplatz wirklich 0 MB beträgt und das System damit nicht klar kommt. Das wäre dir aber beim Erstellen der Sicherungen aufgefallen, oder?

Ich weiß nicht genau, was du mit "sicheren" Vorgehen meinst. Da du die Daten schon gesichert hast, würde ich versuchen ein komplett frisches Image von LineageOS zu flashen: Google Nexus 5 (hammerhead) - LineageOS ROMs
Alle Daten gehen dabei natürlich verloren, aber man würde einen Softwarefehler ausschließen. Allerdings habe ich bei deiner Fehlerbeschreibung die Befürchtung, dass das Mainboard oder der Speicher den Geist aufgibt...
 
B

BFish

Neues Mitglied
Toronto schrieb:
Na klar :) Die Nexus 5 Hallen gehören zu den schönsten Hallen, die ich kenne.
haha, okay, dann danke für das Echo.

Das wäre dir aber beim Erstellen der Sicherungen aufgefallen, oder?
denke schon, zumal ich noch Updates von Apps eingespielt habe.

... würde ich versuchen ein komplett frisches Image von LineageOS zu flashen
Hatte ich gemacht (s.o.)

Allerdings habe ich bei deiner Fehlerbeschreibung die Befürchtung, dass das Mainboard oder der Speicher den Geist aufgibt...
Also ich habe gestern nochmal versucht, die Installation wie bei Lineage beschrieben, durchzuführen. Also "format data" und "advanced wipe". Aber ich bekomme immer dieselben Fehlermeldungen, dass ein Haufen Pfade nicht gemountet werden kann. Am PC würde ich auf einen Festplatten Fehler schließen und die dann austauschen. Was mich allerdings wundert ist, dass ich das Lineage Image problemlos per adb auf /sdcard kopieren konnte.
 
Toronto

Toronto

Senior-Moderator
Teammitglied
Ich bin mir gerade nicht sicher, welche Dateien bei LineageOS geflashed werden. Du könntest noch versuchen ein normales Factory Image zu flashen (inklusive boot.img, recovery.img, system.img usw.). Quasi nach dieser Anleitung, wobei du auch den Wipe durchführen lassen solltest: [How-To] Android Factory Image ohne Datenverlust flashen
Das würde ausschließen, dass du beschädigte Systemdateien hast. Wenn auch das nicht hilft, habe ich auch keine Ideen mehr, außer einen Hardwaredefekt.
 
B

BFish

Neues Mitglied
Toronto schrieb:
Du könntest noch versuchen ein normales Factory Image zu flashen (inklusive boot.img, recovery.img, system.img usw.).
Werde ich versuchen, danke für den Link. Ich denke aber, dass auch das nicht funzen wird. Da vom Formatieren bis zum Wipen alles misslingt, weil Verzeichnispfade nicht gemountet werden können, wird es jede Neuinstallation schwer haben.
Wenn auch das nicht hilft, habe ich auch keine Ideen mehr, außer einen Hardwaredefekt.
Ich werde mich wohl etwas mehr mit der Hardware von so einem Schlau-Fon beschäftigen müssen. Liegt der Bootloader in einem anderen Speicher(bereich)? Wenn ich auf der TWRP Konsole df ausführe bekomme ich ~977000 freie Blöcke angezeigt, was den 0 MB widerspricht. Liegt die Systempartition woanders? Kann man da nicht Befehle ausführen, um der Hardware näher auf den Zahn zu fühlen?

Naja, das Ding wäre aufgrund des geringen Gewichts schön zum Wandern gewesen. Danke für dein Hilfe. Zumindest war in einer der schönsten Hallen mal wieder was los ;)
 
Toronto

Toronto

Senior-Moderator
Teammitglied
Du könntest auch noch den folgenden Befehl versuchen (das löscht auch alle Daten, aber das ist ja mittlerweile egal):
Code:
fastboot format userdata
Das hilft wohl, wenn das System verschlüsselt war. Diese Lösung hat jemand auf Reddit erwähnt, der ein sehr ähnliches Problem hatte, wie du: https://www.reddit.com/r/Nexus6P/comments/3qnzz0
Wie die Speicherbereiche beim Nexus 5 aufgebaut sind, weiß ich leider nicht. Ja, ich kann vollkommen verstehen wie ärgerlich es ist, dass das Nexus 5 nicht mehr funktioniert. Ich habe meins damals beim Kartfahren kaputt bekommen. Man habe ich mich geärgert.
 
B

BFish

Neues Mitglied
Ja, sieht so ähnlich aus. Scheitert bei mir im Moment daran, dass zwar adb das Gerät erkennt, fastboot aber nicht. Aber wenn TRWP nicht formatieren kann, warum sollte es fastboot können.
Ich gehe mal von einem Hardware Fehler aus. Schließlich hat es bei meiner Mutter mal nicht funktioniert, dann nach dem Versand zum Glück wieder und beim nächsten Reboot wieder nicht.
Ich lasse es mal liegen, eventuell stolpere ich mal über einen Hardware-Freak.
Nochmals danke und nicht vergessen: nie beim Kartfahren telefonieren! ;)
Screenshot.jpg
 
Firetime

Firetime

Stammgast
Tut mir Leid für das (wahrscheinlich) defekte Nexus 5.
Das hier war in der Tat eine der schönsten Hallen. ^^

Ich selbst habe auch noch ein Nexus 5 in Verwendung, das ich aber am kommenden Wochenende gegen ein Pixel 4a ersetzen werde. War auf jeden Fall ein echt super Gerät.
 
M

.mo

Lexikon
Zuletzt bearbeitet:
B

BFish

Neues Mitglied
Danke für eure Antworten.
.mo schrieb:
Sorry, aber die Seite kommt mir etwas suspekt vor. Kaum Informationen, Links zu 'private policy' and 'terms of service' gehen zu Google und es werden auch noch Daten gesammelt.
Wüsste auch nicht, was es besser machen sollte als TWRP und genau das versuche ich erst mal als Notnagel auf dem Fon zu lassen.
Trotzdem Danke.
 
S

schultorizor

Ambitioniertes Mitglied
@BFish liegt daran, dass das Tool direkt von Google kommt.
 
B

BFish

Neues Mitglied
liegt daran, dass das Tool direkt von Google kommt.
Sag ich ja: suspekt ;)
Also ich denke, dass ich mir TWRP bewahre und es vielleicht mal mit den handelsüblichen Linux Befehlen versuche, mit denen man Partitionen oder ganze Speichermedien überprüfen kann. Sofern solche installiert sind. Bringt ja nix, irgendetwas flashen zu wollen, wenn das Ziel defekt ist.