Pixel 3a XL WLAN-Telefonie klappt nicht (Pixel 3a XL)

  • 10 Antworten
  • Neuester Beitrag
Diskutiere WLAN-Telefonie klappt nicht (Pixel 3a XL) im Google Pixel 3 / Pixel 3 XL / Pixel 3a / Pixel 3a XL Forum im Bereich Google Forum.
E

Evelyne01

Fortgeschrittenes Mitglied
Hallo, mit meinem Pixel 3a XL klappen WLAN-Telefonate nicht.

Ich habe zwei Karten von O2 drin. Und O2 berechnet WLAN-Telefonate so, als sei man im Inland.

Nun bin ich gerade in der Türkei, habe gutes WLAN, mein Pixel ist auf WLAN-Telefonie eingestellt, aber: Es klappt nicht. Offenbar war mein soeben geführtes Telefonat nach Deutschland über die normale Verbindung durchgeführt worden, was natürlich teuer ist.

Testweise habe ich mal den Flugmodus aktiviert, plus WLAN. Mit dieser Einstellung kann ich noch nicht einmal telefonieren. (Mein Dual-SIM-Gerät fragt wie üblich, welche SIM ich für den Anruf verwenden will, aber beide SIM-Karten sind “ausgegraut”, also nicht verwendbar, siehe beigefügter Screenshot.)

Schau ich mir meinen Telefonverlauf an, so sehe ich allerdings, dass *manche* ältere Telefonate durchaus per WLAN liefen.

Was mache ich falsch? Merci vielmals!

Screenshot_20211116-152021.jpg
 
C

chk142

Lexikon
Normalerweise wird doch oben in der Leiste angezeigt, ob man mit WLAN-Telefonie verbunden ist, wenn man die Benachrichtigungsleiste zwei mal runter zieht. Schau mal, was da bei dir steht.
 
A

AraldoL

Fortgeschrittenes Mitglied
Falls das WLAN mit dem du verbunden bist mittels Firewall nur bestimmte Ports durchläßt (Surfen, Email usw.) kann es sein daß die für WLAN-Call nötigen Ports geblockt sind. Dann geht trotz eingeschaltetem WLAN-Call nix, das liegt dann aber nicht am Telefon oder am Netzbetreiber.

Im ip-phone-forum gab es vor einiger Zeit mal einen längeren Thread daß hierzulande auch an einer AVM FritzBox im normalen WLAN die WLAN-Calls klappen aber im Gastnetz "ab Werk" nicht. Mit Diskussion was man ggf. zusätzlich freigeben muß damit es geht. Scheint also gar nicht mal so selten zu sein wobei ich nicht weiß ob das in aktuellen Fritzbox-Firmwares immer noch so ist.
 
Zuletzt bearbeitet:
E

Evelyne01

Fortgeschrittenes Mitglied
chk142 schrieb:
Normalerweise wird doch oben in der Leiste angezeigt, ob man mit WLAN-Telefonie verbunden ist, wenn man die Benachrichtigungsleiste zwei mal runter zieht. Schau mal, was da bei dir steht.
2mal runterziehen? Da steht nichts besonderes (Screenshot wurde allerdings nicht während eines Telefonates gemacht):

Screenshot_20211116-162834.jpg
Beitrag automatisch zusammengefügt:

AraldoL schrieb:
Falls das WLAN mit dem du verbunden bist mittels Firewall nur bestimmte Ports durchläßt (Surfen, Email usw.) kann es sein daß die für WLAN-Call nötigen Ports geblockt sind.
Also, ich habs mit 2 verschiedenen WLANs versucht. Einmal mit dem Vodaphone Wifi, das hier in der Wohnung ist, und mit dem wir alle Dienste nutzen können. Zweitens mit dem Hotspot, den mir mein Kollege hier gerade mal gegeben hat. Kein Unterschied.

Liegt es womöglich daran, dass ich in der Türkei bin?
Beitrag automatisch zusammengefügt:

Ich habe im O2 Forum nun einen merkürdigen Hinweis gefunden:

Bei meinen Google Pixel oder Oneplus Smartphone funktioniert kein WIFI-Calling mit o2 - warum denn nicht?
Damit WIFI-Calling funktionieren kann, muss leider der Hersteller des Geräts die Provider-Konfigurationen bereits in der Firmware integriert haben.

Denn das Smartphone muss selbstständig eine Verbindung zum IP Multimedia Subsystem (IMS) von o2 aufbauen. Wenn diese Daten fehlen, weil ein Hersteller diese Provider-Konfigurationen nicht in die Firmware integriert (aus welchen Gründen auch immer), dann kann auch leider kein WIFI-Calling funktionieren. (da das Smartphone keine Verbindung zum IMS herstellt)

Es ist also Sache des Hardware-/Smartphone-Herstellers, alle IMS Provider-Konfigurationen (am besten von weltweit allen Anbietern) in die Firmware zu übernehmen, damit WIFI-Calling bei möglichst allen Smartphones und Anbietern funktioniert.
Der Beitrag ist von 2018. Ich möchte ungern glauben, dass ich WiFi-Calling nicht nutzen kann, weil Google das nicht implementiert hat!

In einem anderen comment heisst es:

laut einem Thread bei Android-Hilfe, soll VoLTE und WIFI-Calling beim Pixel 3 im Zusammenhang mit o2 funktionieren
Ich habe allerdings das 3a.

Ich bin nun verwirrt, zumal ich glaube, dass ich einige frühere Telefonate bereits per WiFi getätigt habe. (Wenn ich die Telefonie-Chronik aufrufe, sehe ich neben manchen Telefonaten das WLAN-Symbol.)
Beitrag automatisch zusammengefügt:

Hier in unserem Forum schrieb aber @romurmel im Juni 2020:

Ich bin im Netz von O2 und habe hier in und um Dresden überall 4G. Sei es nun Surfen oder Telefonieren. VoLTE und Wifi Calling, alles Top mit dem Pixel 3a.
 
Zuletzt bearbeitet:
A

AraldoL

Fortgeschrittenes Mitglied
Evelyne01 schrieb:
Der Beitrag ist von 2018. Ich möchte ungern glauben, dass ich WiFi-Calling nicht nutzen kann, weil Google das nicht implementiert hat!
Das mit "nicht implementiert" war früher, sollte längst überholt sein. In der Software des Telefons gibt es eine Tabelle mit allen Provider-IDs weltweit, und darin auch Zusatzinfos z.B. welche Features unterstützt werden, welche Provider untereinander kostenloses Roaming anbieten usw. Als damals die Telekom-Tochter Congstar neu VoLTE und WLAN-Call einführte war eine Zeitlang ein Problem für Pixel-Nutzer weil das Pixel zwar beides gekonnt hätte aber laut der Tabelle noch nicht "wusste" daß es bei Congstar geht. Da konnte man beides erst gar nicht einschalten wenn eine Congstar-SIM-Karte drin war. Ich hatte zum selben Zeitpunkt mit gleicher Firmware und Telekom-SIM die Optionen und es funktionierte. Da haben manche Leute die Tabelle manuell bearbeitet und per ADB reinkopiert damit es ging. Irgendwann kam die Info in die Firmware und es geht direkt. Zu O2 hab ich da nichts gelesen (außer irgendwelchem Durcheinander daß die Verfügbarkeit von VoLTE und WLAN-Call für Ex-EPlus-Kunden anders war als für "richtige" O2-Kunden wenn ich das richtig erinnere) aber das war vermutlich ähnlich, daß es einfach gedauert hat bis das Telefon es für diesen Provider erlaubte.

Da es bei dir schon mal geklappt hat kann das also nicht daran liegen, außerdem würden sonst die Schalter zum Aktivieren vermutlich komplett in der GUI fehlen.
 
E

Evelyne01

Fortgeschrittenes Mitglied
Okay, ich habe eine halbe Lösung: Nach dem Aktivieren der Option WLAN-Telefonie einen Neustart durchführen. Damit klappt es tatsächlich. Sehr merkwürdig, und nur halb befriedigend.

Ich hätte nun wirklich gerne oben im Statusfeld die entsprechende Anzeige, wenn WLAN-Telefonie aktiviert ist. Laut der o2-Webseite soll das Symbol so aussehen:

löschWLAN.jpg
Wobei ich davon ausgehe, dass das nicht nur während des WLAN-Telefonats angezeigt wird, sondern immer.
 
Chefingenieur

Chefingenieur

Senior-Moderator
Teammitglied
Evelyne01 schrieb:
Ich hätte nun wirklich gerne oben im Statusfeld die entsprechende Anzeige, wenn WLAN-Telefonie aktiviert ist. Laut der o2-Webseite soll das Symbol so aussehen:
Nicht beim Pixel, aber du kannst im Sperrbildschirm erkennen ob WLAN Call aktiv ist.
Steht dann oben rechts "WLAN Call"
 
E

Evelyne01

Fortgeschrittenes Mitglied
Ah! Im Sperrbildschirm steht bei mir oben links

WLAN - WLAN

(Sind ja auch beide SIMs auf WLAN-Telefonie eingestellt.)

Oh, und wenn ich nun zweimal runterwische, sieht es so aus:

Screenshot_20211116-200819.jpg

Ich hätte diese Anzeige wirklich gerne permanent oben. Nun ja. Danke allerseits :)
 
C

chk142

Lexikon
Ich frage mich gerade, was diese doppelte "WLAN"-Anzeige da soll...
 
A

AraldoL

Fortgeschrittenes Mitglied
Es sind 2 SIM-Karten im Gerät aktiv (1x "normal", 1x eSIM). Beide arbeiten derzeit per WLAN-Call statt LTE, darum keine Empfangsbalken sondern die Info WLAN. Mit nur einer SIM stünde es auch nur 1x da.
 
C

chk142

Lexikon
Okay. Kenn ich so von meinen Geräten halt nicht, weil ich immer nur 1 Sim-Karte verwende. Bei mir steht da einfach eine Laufschrift. "MedionMobile WLAN-Telefonie" oder so ähnlich.
 
Zuletzt bearbeitet:
Ähnliche Themen - WLAN-Telefonie klappt nicht (Pixel 3a XL) Antworten Datum
2
6