Wenn das WLAN unsichtbar ist, baut das DHD keine Verbindung auf!?

  • 33 Antworten
  • Neuester Beitrag
Diskutiere Wenn das WLAN unsichtbar ist, baut das DHD keine Verbindung auf!? im HTC Desire HD Forum im Bereich Weitere HTC Geräte.
Aurora

Aurora

Fortgeschrittenes Mitglied
Hallo,

ich habe da mal ne Frage... und zwar habe ich keine Wlan Verbindung, wenn die SSID (also das Wlan) versteckt ist. Wenn ich es sichtbar gemacht habe, baut das Handy wieder eine Verbindung auf. :cursing: Ist das normal?! :confused2:

...und ja ich habe es bereits manuell eingegeben und es geht trotzdem nicht. Da steht jedoch nichts mit "WLAN ist Unsichtbar" oder sowas, dass man ankreuzen könnte.

Ich habe immernoch die Original O2 Software (1.38.207.1) trauf. :glare: ...wie sieht es in euren Menus aus, könnte ihr so eine einstellung vornehmen? -vlt. liegt es ja am alten Softwarestand...

Danke für die Hilfe
 
Handymeister

Handymeister

Foren-Manager
Teammitglied
Hallo,

das ist wohl leider bei allen Androiden so.

Viele Grüße
Handymeister
 
Aurora

Aurora

Fortgeschrittenes Mitglied
Echt jetzt?

...also bei meinem alten N95 konnte man das auch schon einstellen..., das muss doch hier auch funktionieren!
....
 
Lion13

Lion13

Ehrenmitglied
Nein, es funktioniert unter Android m.W. nicht!

Das Verstecken der SSID ist im übrigen sowieso in keinster Weise ein Sicherheitsgewinn, da jeder frei verfügbare Netzwerk-Sniffer diese (unverschlüsselt) gesendete Information mitlesen kann. Wenn das WLAN mit WPA/WPA2 (AES) verschlüsselt ist, hat die SSID in keinster Weise Einfluß auf die Sicherheit. Das wird leider immer wieder in diversen Publikationen und Webseiten falsch kommuniziert...
 
Aurora

Aurora

Fortgeschrittenes Mitglied
Aha, Danke für die Info! Kann geclosed werden!

Gruß
 
AndroidJunkie

AndroidJunkie

Experte
Handymeister schrieb:
Hallo,

das ist wohl leider bei allen Androiden so.

Viele Grüße
Handymeister
Das stimmt so nicht ganz...
AFAIK tritt das "Problem" nur auf, wenn die Verbindung AES verschlüsselt ist. Ich hatte bisher einen Router mit max 802.11g, dort war SSID Broadcasting deaktiviert und die Verbindung WPA2/TKIP gesichert. Dort hat sowohl mein Milestone als auch mein DHD ohne Probleme das Netz gefunden. Nun hab ich einen Router nach 802.11n. Ergo muss AES aktiv sein um die volle Bandbreite nutzen zu können. Sobald AES aktiv ist, connectet das DHD nicht mehr.

Nachtrag:
Es sind einige Tickets dazu im Android Issue Tracker, zb:
http://code.google.com/p/android/issues/detail?id=1041

Ebenso wird dieses Tool empfohlen:
http://www.androidpit.de/de/android...arcus905.wifi.ace/WiFi-Advanced-Config-Editor
Hiermit soll man angeblich Netze ohne SSID manuell eintragen und flaggen können... Ich habs aber nicht getestet ;)
 
Zuletzt bearbeitet:
Lion13

Lion13

Ehrenmitglied
AndroidJunkie schrieb:
Sobald AES aktiv ist, connectet das DHD nicht mehr.
Generell nicht, oder nur wenn die SSID unsichtbar ist?

AES wäre schon die bessere Wahl, da es laut Meinung vieler Experten deutlich sicherer ist als TKIP...
 
AndroidJunkie

AndroidJunkie

Experte
Lion13 schrieb:
Generell nicht, oder nur wenn die SSID unsichtbar ist?

AES wäre schon die bessere Wahl, da es laut Meinung vieler Experten deutlich sicherer ist als TKIP...
Die Kombination von unterdrücktem SSID Broadcast und AES gefällt Android wohl nicht ... ;)
Das Miese daran: Du hast nun die Wahl zwischen deaktiviertem Broadcasting oder Bandbreite. Denn mit AES bekommst Du keine Verbindung und ohne AES bekommst Du nicht die vollen 300mbit (brutto).

PS: Ja, AES ist "sicherer" als TKIP. Liegt einfach am Algorithmus...
 
Zuletzt bearbeitet:
Lion13

Lion13

Ehrenmitglied
Wobei ich dann die Bandbreite bevorzugen würde - wie gesagt, ein Verstecken der SSID ist ohnehin eher sinnlos... :D
 
AndroidJunkie

AndroidJunkie

Experte
Stimme ich dir zu, daher broadcastet meine Router nun auch schön durch die Gegend.

Wer eine versteckte SSID als (alleiniges) Sicherheitsmerkmal anerkennt, der sollte gar nicht funken dürfen :D
 
P

Povver

Gast
Also bei mir Funktionier das ganze sehr gut, du musst halt nur den Namen des WLAN eingeben (bein DHD gibts dafür so ein Punkt in der WLAN Einstellungen), dann weiß dein WLAN im Handy das es ein verstecktes ist und es danach suchen muss, wenn du es einrichtes wenn es Sichtbar ist und du es dann unsichtbar machst, dann weiß sies dein WLAN im DHD nicht mehr und sucht nicht danach, war sogar bei meinem Eierphone so!
 
Fr4gg0r

Fr4gg0r

App-Anbieter (Werbung)
Handymeister schrieb:
Hallo,

das ist wohl leider bei allen Androiden so.

Viele Grüße
Handymeister
Hier im Haus ist das Wlan Netz unsichtbar und wpa2 verschlüsselt, klappt.
 
AndroidJunkie

AndroidJunkie

Experte
Aber nur TKIP, oder?
 
M

mittelhessen

Lexikon
Bei mir klappts im G-Standard bei an zwei verschiedenen W-Lan Routern jeweils ohne SSID-Broadcast und mit WPA2 (AES) problemlos. Dass man das Netzwerk manuell eintragen muss, versteht sich von selbst, da es durch den fehlenden Broadcast vom normalen W-LAN Client nicht dargestellt wird.
 
Aurora

Aurora

Fortgeschrittenes Mitglied
Povver schrieb:
Also bei mir Funktionier das ganze sehr gut, du musst halt nur den Namen des WLAN eingeben (bein DHD gibts dafür so ein Punkt in der WLAN Einstellungen), dann weiß dein WLAN im Handy das es ein verstecktes ist und es danach suchen muss, wenn du es einrichtes wenn es Sichtbar ist und du es dann unsichtbar machst, dann weiß sies dein WLAN im DHD nicht mehr und sucht nicht danach, war sogar bei meinem Eierphone so!
...kannst du von dem punkt mal ein Foto online stellen? ob mit digicam oder screenshot ist egal!

Gruß
 
M

mittelhessen

Lexikon
Dazu braucht man ja nicht wirklich einen Screenshot! Der entsprechende Menüpunkt ist eigentlich leicht zu finden und selbsterklärend: Menü->Einstellungen->Drahtlos und Netzwerke-> WLAN-Einstellungen->WLAN-Netzwerk hinzufügen
 
Aurora

Aurora

Fortgeschrittenes Mitglied
Ja Nee, scho klar!:glare:

Das hab ich auch schon gefunden, aber wenn ich das eingebe und dann fertig bin passiert nichts.:sad:
Er logt sich nicht in das unsichtbare Netzwerk ein. Auch einen Menupunkt "WLAN unsichtbar" gibt es nicht. Daher sollte er mal ein Screenshot von dem Punkt machen. (ist nicht Böse gemeint!)

Gruß
 
M

mittelhessen

Lexikon
Aurora schrieb:
Das hab ich auch schon gefunden, aber wenn ich das eingebe und dann fertig bin passiert nichts.:sad:
Die SSID alleine reicht natürlich nicht! Der richtige Verschlüsselungsalgorithmus, die richtige Authentifizierungsmethode und das korrekte Verschlüsselungspasswort müssen natürlich auch eingetragen werden. Weiterhin muss das Handy als Client auf dem Router eingetragen sein (MAC-Filter, DHCP, ...). Wenn dann nicht geht, liegt ggf. an anderen Parametern die unter die Grundlagen einer WLAN-Einrichtung fällen und nicht unbedingt DHD-spezifisch sind.

Aurora schrieb:
Auch einen Menupunkt "WLAN unsichtbar" gibt es nicht. Daher sollte er mal ein Screenshot von dem Punkt machen.
Von dem Menüpunkt redet auch gar keiner! Deswegen gibt es ihn auch nicht. Er schreibt nur, dass du deinem DHD die versteckte SSID mitteilen (eintragen) sollst, damit es sich mit dem versteckten Netzwerk verbinden kann.
 
Dirk

Dirk

Experte
mittelhessen schrieb:
Weißt du, wie lange es braucht, um eine „Zugelassene“ MAC-Adresse zu finden? Ganz genau EIN EINZIGES gesendetes Paket.

Weißt du, wie lange es dauert, die MAC-Adresse zu ändern? Selbst unter Windows unter 30 Sekunden mit Bordmitteln.

MAC-Filter sind genau so „sicher“ die deaktivierter SSID-Broadcast.
 
M

mittelhessen

Lexikon
Dirk schrieb:
Weißt du, wie lange es braucht, um eine „Zugelassene“ MAC-Adresse zu finden? Ganz genau EIN EINZIGES gesendetes Paket.

Weißt du, wie lange es dauert, die MAC-Adresse zu ändern? Selbst unter Windows unter 30 Sekunden mit Bordmitteln.

MAC-Filter sind genau so „sicher“ die deaktivierter SSID-Broadcast.
Und was willst du mir/uns damit jetzt sagen? Ich glaube nicht, dass du mich über WLAN-Sicherheit aufklären musst. :-D Wenn du dir das Thema durchgelesen hättest, wüsstest du, dass der TO Probleme hat, sein DHD mit einem AP oder Router zu verbinden. Es geht dabei nicht darum, wie wirksam die einzelnen Mechanismen sind, sondern dass es Parameter gibt (wie eben z. B. eine MAC-Filterung), die bei entsprechender Einstellung das Verbindungen (über ganz normale WLAN Clients!) verhindern!

Wenn ichs richtig verstanden habe, möchte sich der TO "ganz normal" mit (s)einem WLAN verbinden und sich nicht einhacken.