Videowiedergabe schlecht (Banding)

  • 2 Antworten
  • Neuester Beitrag
Diskutiere Videowiedergabe schlecht (Banding) im Huawei Ideos X3 (U8510) Forum im Bereich Weitere Huawei Geräte.
Maniaxx

Maniaxx

Stammgast
Habt ihr bei dunklen Videos auch starkes Banding, quasi so schwarze Löcher? Ich habe es mit einem Testbild ausgemessen. Die Störungen treten in den unteren 8 Farbstufen (16 Farben bei RGB565) auf. Wenn ich die Helligkeit des Videos um 8 Punkte anhebe (x264 Encoding) sind die Störungen weg.

Habt ihr das auch schon mal bemerkt oder bin ich der Einzige, der das sieht? :razz:

Edit:
'debug.sf.hw=1' in Kombination mit 'MX Player' scheint das zu verstärken. Link

Android 2.3.7
Cyanogenmod 7.1 Benru-v2
MX Player
 
Zuletzt bearbeitet:
mblaster4711

mblaster4711

Ikone
Am PC schaut das "schwarze Loch" Video "normal" aus oder sieht du dort auch die "fehler"?

Bei aller Liebe zum X3, darf man nicht vergessen das es kein High-End Gerät ist, sondern technisch in etwa auf dem Stand meines 2 Jahren alten Milestone ist.
Und daher lieber etwas Banding bei der Wiedergabe von Videos als extremes Ruckeln.

Sent from my Milestone using Tapatalk
 
Maniaxx

Maniaxx

Stammgast
Am PC sieht's normal aus. Nicht dass im Cyanogenmod vielleicht veraltete Displaytreiber drin sind, daher frage ich ja, ob das normal ist.

Ich habe mal Testvideos erstellt. Sicherlich ein Extrembeispiel, weil fast alles dunkel ist. Bei normalem Videos tritt das meist nur stellenweise auf. Video 2 und 3 sind Ansätze das zu umgehen, was auch mit geringen Verlusten funktioniert.

1) Original
- Korrekt an Schwarzpunkt ausgerichtet
- Viele Artefakte

2) Limiting
- Unteren 4Bit abgeschnitten (16 Farben)
- "Defekte" Farben eingeschwärzt.

3) Shifting / Scaling
- Spektrum um 8 (von 255) Punkte angehoben
- Bild wird heller
 

Anhänge

  • BandingTest.7z.zip
    2,8 MB Aufrufe: 61