Nicht nur für das P780: IMEI wiederherstellen

  • 23 Antworten
  • Neuester Beitrag
Diskutiere Nicht nur für das P780: IMEI wiederherstellen im Lenovo Allgemein im Bereich Lenovo Forum.
blur

blur

Lexikon
Hi,

da ich mehrmals per PN gefragt wurde wie das geht, habe ich mich entschlossen ein kurzes Tutorial zu schreiben.
Dieses Tutorial trifft bestimmt auch auf andere Geräte mit nem MTK-Prozessor zu.
Nach dem Flashen von neuen Roms ist fast immer die IMEI weg
(eigentlich sind es 2, aber IMEI 1 und 2 sind identisch).

Ich stelle die IMEI immer mit den MTKDroidTools her.
Nötig sind hierzu Rootrechte.
Wer eine Rom ohne Root flashen will, muss sich zuerst mal um Root kümmern:
https://www.android-hilfe.de/forum/...80-sicherung-ohne-root-und-rooten.541453.html

Das Gerät starten, USB-Debugging aktivieren und mit USB verbinden.
Dann sieht das so aus:




die IMEIs sind ohne Wert "null" und neben der gelben Checkbox ist zu sehen, dass die Tools Root auf dem Phone gefunden haben.
Jetzt nur noch den Button drücken und die Frage bejahen:





jetzt sollte auf dem Phone die Frage kommen, ob dem Prozess Rootrechte geben werden sollen,
dem müsst ihr natürlich zustimmen.

Dann solltet ihr nach kurzer Zeit das zu Gesicht bekommen:




Erst wenn die Checkbox grün ist und das Gerät Root hat, macht es Sinn die IMEI wiederherzustellen.
Die IMEI steht beim P780 auf dem Akku.





2x die IMEI eintragen,
Reboot und dann sollten eure eingetragenen Werte zu sehen sein.
 
D

Drehstoff1981

Ambitioniertes Mitglied
Danke für die tolle Anleitung.Hab das jetzt auch so gemacht wie beschrieben leider bricht MTK Droid Root&Tools v.2.5.3 mitten im Root ca bei 60% ab.Danach kann ich auch das Tool nicht mehr bedienen
 
blur

blur

Lexikon
Drehstoff1981 schrieb:
leider bricht MTK Droid Root&Tools v.2.5.3 mitten im Root ca bei 60% ab.Danach kann ich auch das Tool nicht mehr bedienen
hast du denn vor dem Rootversuch das gelbe Viereck mit dem Satz dahinter gesehen, Pic Nr. 1?
 
D

Drehstoff1981

Ambitioniertes Mitglied
Ja steht genau das gleiche da wie bei mir.Mach den Root mit Rootgenius jetzt
 
blur

blur

Lexikon
? aber wenn das gelbe Viereck mit dem Satz dahinter erscheint,
hat Dein Gerät Root
 
D

Drehstoff1981

Ambitioniertes Mitglied
Hab es jetzt mit Rootgenius gemacht und diesmal bleibt auch die imei gespeichert also das geht jetzt zumindest.Leider das Problem mit dem Netz ist immer noch vorhanden.Hab mir auch jetzt mal diese rom geladen Lenovo P780_S125_130529 leider ohne erfolg

Der ursprüngliche Beitrag von 19:24 Uhr wurde um 19:25 Uhr ergänzt:

Das Flashen hat geklappt aber immer noch kein Netz!
 
blur

blur

Lexikon
Wie sieht es in den Einstellungen aus, Über das Telefon -> Status -> IMEI-INfo
 
D

Drehstoff1981

Ambitioniertes Mitglied
Imei /Steckplatz 1) steht meine IMEI drinnen
darunter steht IMEI SV (Steckplatz 1 )
und ein Wert

Der ursprüngliche Beitrag von 19:32 Uhr wurde um 19:33 Uhr ergänzt:

Wenn ich auf sim status gehe kommt netzwerk unbekannt; signalstärke 0dBm 99ASU
art des Mobilfunknetz Unbekannt
servicestatus außer betrieb
Roaming keins
Mobilfunknetz nicht verbunden
 
blur

blur

Lexikon
Kein Wert in der Steckplatz 2?

Und wenn du auf SIM-Status gehst, hast Du da irgendne Signalstärke?

EDIT
Du antwortest ja schneller als man fragt ;)
 
D

Drehstoff1981

Ambitioniertes Mitglied
Dachte mir das es weiterhelfen würde. Hab kein Stecvkplatz 2 im Status stehen da ich keine Sim drinnen hab vielleicht?
 
blur

blur

Lexikon
IMEI Problem gelöst, aber trotzdem keine Netzwerk,
keine Ahnung warum.

Kann jetzt nur noch ein Modem-Problem sein.
Ich hatte schon die unterschiedlichsten drauf und nie dieses Problem gehabt,
welche Modem-Version steht bei Dir in den Einstellungen?
 
D

Drehstoff1981

Ambitioniertes Mitglied
Baseband Version V15,2013/05/27 16:29

Der ursprüngliche Beitrag von 19:41 Uhr wurde um 19:44 Uhr ergänzt:

Leider will er nie die ZIP datei über Recovery installieren kommt immer installation abortde ohne wert habe auch keine häckchen um was anzuklicken wie du mir per pm sagtest
 
blur

blur

Lexikon
die v15 lief bei mir auch,
aber da könntest du mal aktualisieren.
Das machst Du besser mit dem RootExplorer und der .img-datei
 
D

Drehstoff1981

Ambitioniertes Mitglied
Kannst mir kurz beschreiben wie?Zip entpacken und über den root explorer mounten?
 
blur

blur

Lexikon
genau, die .img aus der zip holen und die modem.img im Ordner überschreiben.
Vorher mounten, aber das schlägt der RootExplorer sowieso vor.
Danach unbedingt wieder dieselben Rechte setzen
rw-r-r--

EDIT:
Ordner /system/etc/firmware/
unter Android 4.4.2 gibt es da auch noch ne
modem_1_3g_n.img
die hatte ich dann auch noch gleich mit derselben modem.img überschrieben.
 
D

Drehstoff1981

Ambitioniertes Mitglied
ok hab ich gemacht leider hab ich unter firmware kein ordner android 4.4.2 da ich ja ne alte rom drauf gemacht hatte so mach jetrzt nen reboot
 
blur

blur

Lexikon
sorry, habe ich mich nicht klar ausgedrückt.
Android 4.4.2 meinte das System, keinen Ordner.
 
D

Drehstoff1981

Ambitioniertes Mitglied
leider nix auch signalstärke immer noch 0

Der ursprüngliche Beitrag von 20:02 Uhr wurde um 20:02 Uhr ergänzt:

mach jetzt nochmal format und mach dann die 4.4.2 drauf und probiere das ganze von vorne
 
blur

blur

Lexikon
bei needrom hatte ein User ein ähnliches Problem,
da lag es dann an der Berechtigungen für die Modem-File
 
D

Drehstoff1981

Ambitioniertes Mitglied
hab es wie du gesagt hast eingestellt rw-r-r--

Der ursprüngliche Beitrag von 20:05 Uhr wurde um 20:05 Uhr ergänzt:

kann es an den apn liegen?

Der ursprüngliche Beitrag von 20:05 Uhr wurde um 20:07 Uhr ergänzt:

apns-conf.html welche berechtigungen hast du da? liegt im system / etc