Lifetab bleibt beim Starten hängen - USB Stick nicht sicher entfernt

  • 39 Antworten
  • Neuester Beitrag
Diskutiere Lifetab bleibt beim Starten hängen - USB Stick nicht sicher entfernt im Medion Lifetab P9516 Forum im Bereich Medion Forum.
G

Grimmsfrank

Neues Mitglied
Hallo
ich habe folgendes Problem: Habe an mein Lifetab einen USB-Stick angeschlossen um Musikdateien mit Total Commander zu kopieren. Bin während des Kopiervorgangs in eine andere App gewechselt, Nach einer halben Stunde war das Kopieren erst bei 3 Prozent. Wollte den Vorgang abbrechen, ging aber nicht (mit Abbrechen Button). Dann dachte ich den USB Stick zu entfernen, über Einstellungen, Speicher USB Stick entfernen: Ging aber auch nicht.
Habe dann einfach den USB Stick abgezogen, da blieb Total Commander hängen. Wollte das Lifetabrunterfahren, blieb aber 5 Minuten auf dem Fenster HERUNTERFAHREN hängen. Habe es dann über den EIN-AUS Button 8länger gedrückt halten) ausgeschaltet. Bleibt seitdem beim Starten beim Medion Schriftzug hängen.
Habe das Lifetab gerootet und SU Rechte.

Folgendes probiert:
SD Card und SIM Card entfernt (startet trotzdem nicht)
Ein - Aus Button 30 sec gedrückt gehalten (startet trotzdem nicht)
Im APX Modus gestartet (habe allerdings keinen Laptop, da ich in Nepal unterwegs bin), da kommt nur ein schwarzer Bildschirm

Sind 3 bis 4 Dateien drauf die ich unbedingt brauche, z.B. mein Tagebuch der letzten 2 Monate in Nepal

Kann mir jemand helfen?

Frank
 
Ameisentaetowierer

Ameisentaetowierer

Erfahrenes Mitglied
Hallo Frank.

Das mit Nepal hättest du wirklich nicht schreiben müssen <Neid>

Für dein Tab sieht es leider schlecht aus. Das Verhalten kenne ich von ICS bei korruptem /data Dateisystem.
Normalerweise lässt sich das nicht mehr ohne PC/Kabel/CD retten.
Ich meine aber, dass beim ersten mal, als ich das hatte, ein wiederholter Neustart (gefühlte 50 x?) dazu führte, dass es erstmal wieder lief.
Wenn dir das gelingen sollte, mach sofort eine Sicherung!

Wenn du wieder einen PC zur Verfügung hast, kannst du mit meiner CD /data hart formatieren. Aber dann sind alle Daten weg.

Wenn du die Daten retten willst, brauchst du ebenfalls meine CD und ein wenig Unix know-how. Aber das müsste ich selbst nochmal durchspielen und kann für nix garantieren.

Viel Spaß noch in ... 8)
Micky
 
G

Grimmsfrank

Neues Mitglied
Hallo Micky
Hab das mit Nepal ja nur erwähnt, damit jeder gleich weiss, dass ich mitunter nicht so schnell antworten kann :) (Stromausfälle jeden Tag, kein Zugang zu Computer etc.). Aber Neid ist u.U. angebracht, haben aktuell 30°C. Fliege aber am Montag zurück :-( und habe dann wieder meinen Laptop. Deine CD hab ich schon mal runtergeladen als Du mir geholfen hast das Tablet zu routen. Bin jetzt aktuell bei 35 x an und ausschalten. Jetzt ist das Akku bei 0%. Muss erst mal aufladen. Ich hoffe es klappt noch, mein Tagebuch wäre mir wichtig.
Ich melde mich wieder, vielen Dank erst mal. Ich hoffe Du kannst mir weiter helfen wenn ich wieder in D. bin.
Frank
 
G

Grimmsfrank

Neues Mitglied
Hallo Micky

ich bin wieder daheim angekommen und hab gleich mal Deine CD vorgekramt...
Tablet an den Laptop angeschlossen, Laptop mit CD gebootet, Tablet im APX Modus gestartet. Dann einmal M gedrückt (Menü Lifetab). Hab dann die Option 15 gewählt (check/repair filesystem). Ist durchgelaufen, hab danach 25 eingegeben (Exit). Auf Lifetab war dann ein liegender Roboter mit Warnschild zu sehen. Lifetab ausgeschaltet und vom Laptop abgeklemmt.
Leider bleibt das Tab aber immer noch beim Medion Schriftzug hängen.
Hab auf dem Monitor des Lifetab zwischendurch eine Zeile gelesen (Backup data oder so was ähnliches)...

Hab da sicher was übersehen. Kannst Du mir nun weiterhelfen um wieder an meine Daten zu kommen?

Gruß

Frank
 
Ameisentaetowierer

Ameisentaetowierer

Erfahrenes Mitglied
Hallo Frank,

ich gehe davon aus, dass auf deinem Tab ICS mit dem Stock-Recovery läuft.
Wenn nicht, bitte korrigiere mich!

Was ich vorhabe erfordert das CWM-Recovery.
Das kannst du mit Hilfe meiner CD flashen.
Wenn du das CWM-Recovery geflasht hast und es mit "reboot system now" beenden willst, solltest du den Hinweis bekommen, dass das ICS das Recovery überschreiben/löschen wird und dir die Option geben, dies zu verhindern.
Ob du das machst oder nicht, bleibt dir überlassen. Nach meiner Erfahrung schadet es nicht, das CWM-Recovery zu behalten.

Wenn das CWM-Recovery läuft, kannst du dich per "adb shell" vom Computer aus auf dem Tab anmelden.
Von meiner CD geht das mit dem Punkt 6, von Windows aus brauchst du die entsprechenden Treiber, etc.
Wenn's irgendwie geht, probiere das mit Windows, dann kannst du gleichzeitig basteln und hier lesen/schreiben...ausser du hast noch ein 3. Gerät...

Jetzt zu deinem Problem:
Normalerweise passiert sowas nur, wenn die /data Partition defekt ist.
Yves hat die Anordnung der Patitionen sehr schön hier (http://www.avi-plus.com/media/kunena/attachments/211/partitions_LT-P9516_2012-10-22.png) dargestellt.
Auf der Zeichnung ist das die Partition 12 mit dem Namen mmcblk0p7

Zunächst solltest du schauen, was passiert, wenn Android versucht, diese Partition zu mounten.
Voraussetzung: Auf dem Tab läuft CWM-Recovery, das Kabel ist angeschlossen und "adb shell" funktioniert.
Code:
~ # mount /data
~ # dmesg | tail -5
<6>[   17.877585] android_work: sent uevent USB_STATE=CONFIGURED
<4>[   27.552874] adbd (103): /proc/103/oom_adj is deprecated, please use /proc/103/oom_score_adj instead.
<6>[   30.930333] EXT4-fs (mmcblk0p7): mounted filesystem with ordered data mode. Opts: (null)
Der Befehl "mount /data" versucht die Partition zu mounten.
"dmesg | tail -5" zeigt die letzten 5 Zeilen des Kernellogs an.

Wahrscheinlich wird bei dir was anderes stehen, was meine Vermutung über die Ursache bestätigen würde.

Wenn ein Fehler bei "mount /data" kommt, lässt sich mmcblk0p7 nicht mounten.
Um das zu reparieren gibt es das Tool "e2fsck", aber ob das hilft, hängt davon ab, wie stark /data beschädigt ist.
Code:
~ # e2fsck -pv /dev/block/mmcblk0p7
/dev/block/mmcblk0p7: clean, 29839/3375104 files, 5983301/6740984 blocks
In meinem Beispiel ist alles gut...
Aber wie sieht das bei dir aus?
 
G

Grimmsfrank

Neues Mitglied
Hallo Micky,

Stock-Recovery? Wie finde ich das raus? Hab hier im Forum mal nach Stock-Recovery gesucht, 4 Themen gefunden... Werde ich aber leider auch nicht schlau draus. Was ist Stock- und was CWM Recovery?

Ameisentaetowierer schrieb:
Ob du das machst oder nicht, bleibt dir überlassen. Nach meiner Erfahrung schadet es nicht, das CWM-Recovery zu behalten.
Müsste es hier heißen: "das Stock Recovery zu behalten"?

Das mit der adb-shell Geschichte hab ich doch schon mal beim rooten des Tablets durchgeführt. Bin danach meine ich nicht mehr über adb-shell an das Tablet ran gekommen, funktionierte nur 1x. Das lief doch über den cmd Befehl bei Windows, oder?

Ameisentaetowierer schrieb:
Zunächst solltest du schauen, was passiert, wenn Android versucht, diese Partition zu mounten.
Voraussetzung: Auf dem Tab läuft CWM-Recovery, das Kabel ist angeschlossen und "adb shell" funktioniert.
Code:
~ # mount /data ~ # dmesg | tail -5 <6>[ 17.877585] android_work: sent uevent USB_STATE=CONFIGURED <4>[ 27.552874] adbd (103): /proc/103/oom_adj is deprecated, please use /proc/103/oom_score_adj instead. <6>[ 30.930333] EXT4-fs (mmcblk0p7): mounted filesystem with ordered data mode. Opts:
Läuft das auch über Pkt. 6 auf Deiner CD? Falls ich das mit adb-shell nicht hinbekomme...

Gruß
Frank
 
Zuletzt bearbeitet von einem Moderator:
Ameisentaetowierer

Ameisentaetowierer

Erfahrenes Mitglied
Hallo Frank,

wenn du ICS hast, hast du sehr wahrscheinlich auch das Stock-Recovery.

Ich meinte schon, dass CWM-Recovery nicht schadet.
Das Stock-recovery nutzt dir eh nichts mehr, da es vom Hersteller keine Updates mehr geben wird.

Ja, adb brauchtest du auch zum rooten von Windows aus.

Stimmt, adb shell geht von meiner CD.
Aber von Windows aus hätten wir eine Möglichkeit mehr, deine Daten zu retten.

Erstmal müssten wir feststellen, ob es tatsächlich an /data liegt.
Wenn es daran liegt, gibt es 2 Möglichkeiten.
- e2fsck kriegt es soweit repariert, dass das Tab erstmal wieder startet -> sofort Daten sichern
- /data lässt sich per CWM mounten, aber das Tab startet nicht -> hier brauchen wir Windows
- /data ist komplett kaputt... Leider verloren

Warum hast du keine externe SD benutzt? Damit passiert das nicht.

Für alle die hier mitlesen:
Wenn ihr ICS habt, wird euch das früher oder später auch passieren.
Deshalb regelmässige Backups machen oder wichtige Daten gleich auf die externe SD speichern...UND ein Backup machen!

Was die Windows-Treiber betrifft kann ich dir nicht weiterhelfen.
Aber hier im Forium gibt es bestimmt einige Windows-Cracks, die wissen, was zu tun ist.

Edith meint:
Mir ist gerade eingefallen, dass es auch ohne Windows gehen sollte wenn du eine formatierte Micro-SD hast .. und /data gemountet werden kann.
 
Zuletzt bearbeitet:
G

Grimmsfrank

Neues Mitglied
Hallo Micky
bin mit Deiner CD nun etwas weiter gekommen.
Wenn du das CWM-Recovery geflasht hast und es mit "reboot system now" beenden willst, solltest du den Hinweis bekommen, dass das ICS das Recovery überschreiben/löschen wird und dir die Option geben, dies zu verhindern.
Habe CWM-Recovery geflasht, reboot system now ausgewählt. Dann kam auf Lifetab folgendes Bild (siehe Anhang).

Habe Yes ausgewählt, war das nun i.O.?

Bin jetzt im Forum im ADB-Thread unterwegs, ich hoffe es kann mir jemand helfen. Habe über adb-shell keinen Zugriff auf LT.

Zunächst solltest du schauen, was passiert, wenn Android versucht, diese Partition zu mounten.
Voraussetzung: Auf dem Tab läuft CWM-Recovery, das Kabel ist angeschlossen und "adb shell" funktioniert.
Edit: Also das CWM-Recovery läuft jetzt (siehe Anhang), Kabel ist dran. Nur hab ich keinen Zugriff über adb shell. Könnte es über die CD probieren? Aber dann hab ich ja kein Windows. Oder kann ich nun über Lautstärke +/- den Punkt "mount /data" anwählen und ausführen?

Bin etwas ratlos, da ich mit dem adb shell (APX) nicht weiter komme.

Frank
 

Anhänge

Zuletzt bearbeitet:
G

Grimmsfrank

Neues Mitglied
Hallo Micky

habe das Lifetab mit Deiner CD im CWM-Recovery gebootet.
Dann Punkt 6 (adb shell) ausgeführt.
Hier hab ich mount /data eingegeben
Es kam keine Fehlermeldung, siehe Foto
Wie komme ich weiter (Oder besser: Komme ich weiter?) ?

Gruß
Frank
 

Anhänge

Ameisentaetowierer

Ameisentaetowierer

Erfahrenes Mitglied
Sieht doch schonmal gut aus!

Dann könnte auch eine/die Konfiguration des ICS eine Macke haben und es kommt deswegen nicht hoch.
Schwierig mit der Ferndiagnose.


Bin nicht zu hause, deshalb sind folgende Infos nicht geprüft.

Die externe SD kannst du über CWM mounten (mount /external_sd)
Ansonstent mit "mount /external_sd" (?)
Das dir von Android bekannte "/sdcard" befindet sich jetzt/hier in "/data/media" bzw. ist das gleiche/selbe.
Also ist dein alter Ordner "/sdcard/Download" jetzt unter "/data/media/Download" zu finden.

Einige Kommandos:

cd /data/media (kennst du schon)
ls (dateien anzeigen)
ls -la (dito, nur länger)
cp (copy)
df (zeige mir die gemounteten Dateisysteme)
mount (dito, nur anders)

auch interessant:
dmesg | tail -10

Zeigt die letzen 10 Meldungen des Kernels.
Dort könnten auch Fehler angezeigt werden, die beim mounten nicht zu sehen waren.

Wenn die externe SD korrekt gemountet ist (mit "df" überprüfen) folgendes zur Datensicherung machen:

cd /data/media
cp -r * /external_sd/ (das kopiert ALLES, was unter /sdcard war/ist auf die externe SD)
cd /
umount /data
umount /external_sd

Jetzt kannst du die externe SD rausnehmen
 
G

Grimmsfrank

Neues Mitglied
Ouououou Micky

ich denke und hoffe, wir sind auf dem richtigen Weg.
Mit Hilfe der Befehle konnte ich die Daten, die ich benötige, sehen. Sind also vorhanden...
Leider konnte ich die external_sd nicht mounten. Fehlermeldung war: external_sd not found in /xxxx/xxxxx (xxx steht für ein Verzeichnis, welches ich mir nicht gemerkt habe. Wollte grad ein Foto machen da schaltete das LT ab). AAaaaaarrrrggghhh

Dummerweise ging genau hier mein Tablet aus, 0% Akkuladung. Und ich dachte, dass es die ganze Zeit über USB geladen wurde. Konnte nicht mehr unmounten, ich hoffe das wird nun kein Problem. Lade gerade auf...

Frage nun: warum konnte ich die sd-card weder über adb shell noch über CWM mounten? CWM Fehlermeldung war lediglich Can't mount external_sd...
Kann ich nicht auch eine Festplatte o.ä. auf meinem Laptop mounten und dahin kopieren? Aber muss wahrscheinlich Speicher im Lifetab sein...

Grüße, nun mit etwas wachsender Hoffnung
Frank
 
Ameisentaetowierer

Ameisentaetowierer

Erfahrenes Mitglied
Das mounten von /external_sd sollte auch vom CWM-Recovery aus gehen. (sorry, habe überlesen, dass du es schon versucht hast)
Wahrscheinlich hast du dich vertippt. (scheinbar nicht.... oder /external_sd steht nicht in /etc/fstab)
/xxx/xxx war /etc/fstab, die Datei, in der drinsteht, welche Partition wo gemountet werden soll/kann

Falls du dich vertippt hast:
Die Shell kann sowas wie "autocompletion"
Wenn du "cd /ext" tippst und dann die Tabulatortaste drückst, sollte er den Begriff vervollständigen.
Damit musst du weniger tippen und schließt gleichzeitig Tippfehler aus.
Wenn du kein /external_sd hast, kann du es einfach mit
mkdir /external_sd
anlegen....hält aber nur bis zum nächsten Boot!


Um zu prüfen, ob dein Tab überhaupt die externe Karte erkannt hat, kannst du auch
ls -la /dev/block
eingeben.
Das zeigt dir eine Liste von Blockdevices/Partitionen.
Die interne Karte ist
/dev/block/mmcblk0
Die externe SD-Karte ist
/dev/block/mmcblk1
Die erste nutzbare Partition auf der externen SD-Karte ist
/dev/block/mmcblk1p1

Wenn du diese Partition komplett manuell mounten willst, lautet das Kommando
mount /dev/block/mmcblk1p1 /external_sd
Du solltest ggf auch nochmal prüfen, ob das Verzeichnis "/external_sd" überhaupt existiert:
ls -la /
Zeigt dir alle Dateien/Verzeichnisse im Hauptverzeichnis.
Verzeichnisse haben ganz vorne ein "d" stehen.

Das mit der externen Festplatte geht...und würde auch mit der internen gehen.
Aber das ist ohne Linux-Knowhow kompliziert.
Das mit dem Tab und der SD-Karte ist einfacher.
Es wäre noch einfacher, wenn Windows nicht so einen Tanz um das USB-Zeug machen würde...
 
Zuletzt bearbeitet:
G

Grimmsfrank

Neues Mitglied
Hallo Micky,

ich denke, ich bin wieder etwas weiter. Mein Nepaltagebuch2013.doc ist wahrscheinlich hin? (Siehe Foto 3 von 3)

Aber die geplanteAusgaben.xls scheint er kopiert zu haben (Siehe Foto 3 von 3), nur nicht auf die externe SD-Card (sondern auf sd-ext, wo immer das auch ist). Konnte die externe SD-Card nicht mounten, es gibt auch kein external_sd Verzeichnis. Es existiert aber ein Verzeichnis sd-ext, da hab ich die geplante Ausgaben hinkopiert. Mounten konnte ich sd-ext leider auch nicht.

Hab mal ein paar Bilder gepostet, ich hoffe Du erkennst meinen Fehler?

Der Fehler ist wohl, dass die externe SD-Card immer noch nicht gemountet ist.

Muss erst mal ins Bett, hab immer noch etwas Nepaltime in mir (5 Stunden weiter)

Gute Nacht

Frank
 

Anhänge

Zuletzt bearbeitet:
Ameisentaetowierer

Ameisentaetowierer

Erfahrenes Mitglied
Hallo Frank,

I/O error ist ganz übel, scheint ein HW Defekt zu sein.
Wenn /external_sd nicht existiert, kannst du es anlegen:
mkdir /external_sd

Dein Kopierversuch dürfte vergebens sein.
CWM läuft komplett im Hauptspeicher.
Nur wenn du eine Partition auf ein Verzeichnis gemountet hast, kannst du dort auch die Hardware schreiben/nutzen.
Das siehst du mit dem Befehl
df

Wobei
mount /dev/block/mmcblk1p1 /sd-ext
eigentlich hätte funzen sollen.

Probier mal
mount /sd-ext
Der Slash ist wichtig
 
Zuletzt bearbeitet:
G

Grimmsfrank

Neues Mitglied
Guten Morgen Micky

so, hab die SD-Card gemountet. Kann Dateien nun kopieren. (siehe Foto 1 von 2).
Leider haben alle Dateien die Größe 0 kb (siehe Foto 2 von 2)
Hab ich einen Fehler gemacht?
Oder ist alles auf data/media defekt?
Ich benötige 4 Videos aus dem Foto Verzeichnis und 1 Datei aus dem Excel Verzeichnis.
Für mein Tagebuch (I/O Error) gibt es wohl keine Chance mehr?

Gruß
Frank


EDIT:

Hey Micky,

bin weiter gekommen... Das Problem sind die Leerzeichen in Dateinamen und Verzeichnisnamen... Kann "geplante Ausgaben.xls" nicht kopieren; Fehlermeldung: "Kann geplante nicht finden".
Kann im Verzeichnis Fotos/Nepal2013 auch nicht ins Verzeichnis "Tanka Handy" wechseln. Hier helfen wahrscheinlich die Anführungszeichen oben? (Fiel mir grad so ein)

Die Dateien hatten 0 kB da ich den Kopiervorgang *.* (alles im Verzeichnis Bibek) nach 30 min abgebrochen habe. Hab nochmal versucht nur 4 Filme zu kopieren und nur eine Exceldatei -> HAT GEKLAPPT JUCHUUUU Hab jetzt die Filme, die verloren waren, zurück.

Nur wie komme ich an die Dateien mit dem Leerzeichen? Ich versuche nochmal die Anführungszeichen...

Und gibt es eine Chance für mein Tagebuch? Ich bräuchte nur einen Ausschnitt aus der Datei, die letzten 2 von 9 Wochen. Den Rest hab ich...

Gruß
Frank

Nochmal EDIT:

Micky, ich hab es. Die Anführungszeichen waren es. Habe mit
cp "geplante Ausgaben.xls" /external_sd
meine Excel Daten wieder zurück.

Mittlerweile zeigt er mir mein Nepaltagebuch2013.doc" schon gar nicht mehr an. War vorher der I/O Error. Wenn Du keine Idee mehr hast wäre das die einzige Datei, die nun verloren ist. Gerade die war mir noch sehr wichtig, auf die 4 Videos hätte ich eher verzichten können...

Was mache ich nun mit dem Lifetab? Kann ich es mit der CD wieder zum Leben erwecken? Format Data und dann Jelly Bean drauf? Oder wegen des I/O Errors einschicken? Was meinst Du?

Gruß Frank

PS: Trink mal nen Kaffee auf das gelöste Problem... Vielen Dank für Deine erfolgreichen Bemühungen
 

Anhänge

Zuletzt bearbeitet:
Ameisentaetowierer

Ameisentaetowierer

Erfahrenes Mitglied
Hallo Frank,

danke für Kaffee und Kuchen!

Das mit dem Tagebuch tut mir leid.
Ist das tatsächlich ein Wordformat?
Dann würden wahrscheinlich einezelne gerettete Datenblöcke auch nicht weiterhelfen.

Und wenn die Datei nicht mehr anzeigt wird...vermutlich zerlegt sich da was immer mehr...
Probier' mal

umount /data (falls es gemountet ist)
e2fsck -yv /dev/block/mmcblk0p7 (3 x wiederholen)
mount /data
cd /data/lost+found
ls -la

In /data/lost+found liegen die Datenblöcke, die e2fsck keinen Dateien zuordnen konnte.
Daraus die Dateien wieder zu rekonstruieren ist mehr als schwierig.
Insbesondere wenn es keine reinen ASCII-Dateien sind.
Aber einen Versuch ist es wert.

Wenn du alle Daten gerettet, bzw. aufgegeben hast, kannst du versuchen, mit "hard format /data" von der CD die /data Partition komplett zu löschen.
Danach kannst du mit "adb shell" überprüfen, ob es ein Hardwaredefekt ist:

dd if=/dev/block/mmcblk0p7 of=/dev/null bs=1048576

Das liest jeden Datenblock der /data Partition. Dauert ziemlich lang!

Wenn es dabei wieder IO-Fehler gibt, kannst du das Tablet einschicken. Es hat wahrscheinlich noch Garantie, oder?
Wenn es keine IO-Fehler gibt, kannst du JB installieren.

Viel Glück
 
G

Grimmsfrank

Neues Mitglied
Hi Micky

hab das e2fsck drei mal durchgeführt. ls-la zeigt ... siehe angehängtes Foto...

Muss ich da jetzt was auf die ext. SD-Card kopieren? Ist da überhaupt was?

Frank
 

Anhänge

Ameisentaetowierer

Ameisentaetowierer

Erfahrenes Mitglied
Hallo Frank,

nein, da ist nichts zu kopieren.
Aber versuch mal den Vorschlag von e2fsck zu nutzen:

e2fsck -b 32728 /dev/block/mmcblk0p7

Vielleicht hilft das.
Habe da selbst nicht sooo viel Erfahrung.
 
G

Grimmsfrank

Neues Mitglied
Hi Micky

bringt mich auch nicht weiter (glaub ich :))) )
Hab noch mal 3 Bildschirmfotos eingestellt, sieht aber denke ich nicht gut aus...

Gibst Du grünes Licht für den I/O Check und anschl. Neuinstallation bzw. einschicken an Medion? Oder hast Du noch eine Idee.

Frank
 

Anhänge

Ameisentaetowierer

Ameisentaetowierer

Erfahrenes Mitglied
Habe gerade nochmal gesucht.

dumpe2fs sollte eine Liste der Backup Superblöcke anzeigen.
Ich finde aber kein dumpe2fs bei mir.
Scheint nicht bei CWM dabei zu sein.

Dann grünes Licht!