"Haltestelle" Bootloader

  • 37 Antworten
  • Neuester Beitrag
Diskutiere "Haltestelle" Bootloader im Motorola Moto G5 Forum im Bereich Motorola Forum.
Vicid

Vicid

Ambitioniertes Mitglied
Hi, ich hab ein, nicht gravierendes, Problem mit meinem Bootloader.
Jedesmall wenn ich im System "Reboot" auswähle macht der vorgang im bootloader nen "Stop" und ich muss manuell "START" drücken um in mein System(bzw. Recovery) zu gelangen.
Woran liegt das?

Selbiges passiert, wenn ich vom Recovery Reboot (System oder Recovery) wähle. Immer macht der Bootvorgang nen Halt im Bootloader.

Mir ist aufgefallen, dass ich im Bootloader mein Gerät, wenn ich es per USB angeschlossen habe, über "adb devices" nicht aufgelistet bekomme..(screeny)

ach ja, und das nicht gravierende Problem bedeutet aber doch auch, dass ich manschmal, auch wenn ich "START" auswähle, um somit das System zu starten, wieder in den Bootloader zurückgeworfen werde(beim zweiten START hats aber bislang dann imemr geklappt das System zu booten*toitoitoi :/ )!!!
 
Zuletzt bearbeitet:
D

Dr.No

Ehrenmitglied
Wenn du uns noch sagst welches Phone und welche Rom (Custom, Stock) du drauf hast, wäre das mehr als hilfreich.
 
Zuletzt bearbeitet:
R

rudolf

Lexikon
Ein Bootloader kann kein ADB.

Android läuft: ADB
Bootloader läuft: Fastboot
 
Zuletzt bearbeitet:
nik

nik

Senior-Moderator
Teammitglied
Wenn da was wegen "Your device software cannot be checked for corruption[...]" steht, dann hat liegt das am entsperrten Bootloader und ist normal. Weiter hinten steht dann, dass bei Nicht-Betätigung ganz normal gestartet wird. Es ändert sich in dem Fall also nichts, außer dass ein Start länger wegen dieser Meldung dauert.
Das zu umgehen ist meines Wissens nach leider nicht möglich.
 
Vicid

Vicid

Ambitioniertes Mitglied
Sorry, ich dachte meine Daten vom Telefon+ROM wird meinem Profil entnommen. Hier also nun die Infos zu Telefon+ROM:
- Moto G5
- LineageOS 15.1-20180213-UNOFFICIAL-cedric (also 64bit twrp)

nik schrieb:
Wenn da was wegen "Your device software cannot be checked for corruption[...]" steht,
Hi nik, danke für Deinen Beitrag, aber nein, so ne Nachricht hab ich nicht erkennen können.

@rudolf: Danke für die Info. ich bin beim Thema immernoch n dummy, hab aber die Hoffnung, dass der Funke mal dauerhaft überspringt :) [Problem ist, dass ich nur alle Jahre mal n Phone so, mit ROm install+root usw., bearbeite]
Meine Situation ist die, dass ich bei hochgefahrenem Phone
und aktiviertem Dev- Einstellungen und aktiviertem "adb debugging"
nach der eingabeaufforderung, bei
a) minimal adb, und bei
b) android sdk- im platform-tools-ordner- ,
(ja ich beide Varianten installiert..)
jeweils die gelinkte Nachrichten erhalte.

im bootloader selber und mit dem eintrag "fastboot adb devices" bzw. fastboot adb bzw. fastboot adb device(weil ich den richtigen Befehl grad nicht weiß) hier der Screenshot.

das Phone im recovery sich befindend
1) hier der Befehl "adb devices" im sdk-platform-tools-ordner
2) hier der Befehl "adb devices" im minimal adb ordner
3) hier der Befehl "fastboot adb devices"(was ja, wie Du, rudolf, erwähnt hast, keinen Sinn macht) im minimal adb -ordner
 
Vicid

Vicid

Ambitioniertes Mitglied
also ich muss mich entschuldigen,
und ich bin auch neu hier im Forum oder in Foren im Allgemeinen, aber...

ich sollte nur ein Problem pro Thema schildern.
Also bennene ich mein Problem hier nochmal wie folgt und lasse die anderen Probleme bei Seite:

Ich bin im bootloader (/fastboot-modus nennt sich das glaub ich auch) und versuche mit dem Befehlt "fastboot adb devices"
über meinen PC eine Kommunikation mit meinem Phone herzustellen. Leider antwortet mein Telefon nicht wie man hier am Screeny erkennen kann.

Mein Phone ist das Moto G5 und ich hab das ROM "LineageOS 15.1-20180213-UNOFFICIAL-cedric" (also 64bit twrp) geflasht.
auf meinem PC hab ich natürlich die Motorola Treiber und die Minimal ADB & fastboot treiber v1.4.3 installiert.
dev einstellungen sind auf "on" und ich hab, bevor ich in den bootloader gestartet habe, das "adb debugging" dort in den dev einstellungen aktiviert.

hab ich nun was vergessen? bzw steht noch eine Frage offen bevor man mir in dieser Frage helfen kann?
Welche Ursachen kann der Kommunikationsfehler haben?
 
R

rudolf

Lexikon
Adb ist wenn das Android läuft, Fastboot ist wenn du im Bootloader/Fastboot bist. Das eine hat mit dem anderen nichts zu tun.
Entweder fastboot <befehl> ODER adb <befehl> aber nicht fastboot adb ...
Auch nicht adb <befehl> im Fastboot modus.

Mir ist auch nicht klar was du überhaupt tun möchtest.
 
Sunny

Sunny

Urgestein
@rudolf
Was ist denn da der Unterschied [emoji56]
Also zwischen ADB und Fastboot?
Was wäre denn ein Fastboot und was ein ADB Befehl?
 
Vicid

Vicid

Ambitioniertes Mitglied
das ist mir auch gerade aufgefallen! sorry! ://
also Phone wird angezeigt.. (bin grad einfach bissl überfordert, da kommt sowas dann dabei raus :/, nochmal sorry und Danke für die Geduld!)

dann probier ich jetzt nochmal "adb devices" angezeigt zu bekommen,
indem ich erstens die dev options und "adb debugging" aktiviert habe
zweitens ins recovery starte bzw im system einfach hochgefahren bleibe..

das nun gemacht antwortet mein Phone nicht, wie hier zu sehen

was ich machen will ist: diese "haltestelle" bootloader loswerden
sodass ich nicht immer zuerst im Bootloader "START" drücken muss um ins System(oder recovery) zu gelangen,
wenn ich vorab restart im system(oder recovery) ausgewählt habe (und zwar hab ich dann in diesem Fall nicht restart in Bootloader ausgewählt , sondern restart system bzw. restart recovery..aber nein, ich komme imemr zuerst in den bootloader).

mein bootvorgang macht immer im bootloader halt, obwohl ich nicht vol down+ power drücke...

ich wollte diese Lösung anwenden, aber dafür muss mein Phone auf den adb befehl antworten.
 
Sunny

Sunny

Urgestein
@Vicid
Es kommt darauf an, deinem Handy wenn es hochgefahren ist auch die "Debugging Anfrage" zu erlauben.
Nur wenn diese Debugging erlauben Info auf deinem Gerät bei PC Verbindung erscheint und du diese erlaubt hast, klappt das auch mit den ADB befehlen.
Wenn du auf dem Handy alles korrekt autorisiert hast und nicht klappt, liegt es meist an den PC Treibern
 
Zuletzt bearbeitet:
Vicid

Vicid

Ambitioniertes Mitglied
oh ja der fiingerabdruck meines handies!
daran hatte ich gar nicht mehr gedacht, weil es auch nicht mehr aufgepoppt war. aber klar, es kann sein, dass ich ausversehen ablehnen ausgewählt hatte... wie kann man die abfrage wieder aufkommen lassen?


hab grad einfach versucht dev einstellungen zu deaktivieren und wieder zu aktivieren, inklusive adb debugging, aber die fingerprint abfrage poppt nicht auf...
 
Sunny

Sunny

Urgestein
@Vicid
In den Entwickler Optionen die Authorisation aufheben und neu erlauben.
Dann sollte das Fenster mit der Frage wieder aufgehen
-- Dieser Beitrag wurde automatisch mit dem folgenden Beitrag zusammengeführt --
Vicid schrieb:
dev einstellungen zu deaktivieren und wieder zu aktivieren...
Du solltest auch eine Option haben in den Entwickler Optionen, die Authorisation zum PC aufzuheben. Diese Option ist meist ein oder zwei Optionen unter OEM Unlock oder USB debugging....
Dann wieder aktivieren und das Fenster sollte auf poppen (wenn die Treiber stimmen)
 
Zuletzt bearbeitet:
Vicid

Vicid

Ambitioniertes Mitglied
will nicht funzen :(

ich hab die einstellung als 3. Eintrag unter Android debugging gefunden, mit der Bezeichnung" Revoke USB debugging authorizations.
Bei Auswahl komtm die Meldung "Revoke acess to USB debugging from all computers you've prevsiouly authorized? -> Ok

hab dann dev options auch deaktiviert und nochmal aktiviert , in der hoffnung das löst dann den Fingerprint aus.. negativ.

hab auch pc + phone neugestartet. negativ.

Es scheint wohl dass das Aufheben fehlschlägt oder es zumindest weiterhin , entweder an meinem PC oder auf meinem Phone ne Datei gibt die den Fingerprint noch abbildet?!
 
Sunny

Sunny

Urgestein
@Vicid
Kannst du mir einen Screenshot vom device tree hier posten?
Als was wird das Handy am PC erkannt
 
Vicid

Vicid

Ambitioniertes Mitglied
device tree sagt mir nichts
und wenn ich bei youtube n video tutorial - how to make a device tree - suche, dann finde ich nur mindestens 30 minuten videos zum thema..
oder ist das weniger kompliziert?


EDIT: kann es sein, dass ich am privacy guard einstellungen vorgenommen habe, die den fingerprint unterdrücken? da bin ich grad am Schauen
 
Vicid

Vicid

Ambitioniertes Mitglied
achso, der gerätemanager, hier bitte.

und ich hab noch win7 installiert


EDIT: ich bin im moment als standardbenutzer angemeldet,
kann aber natürlich auch ADMIN
 
Sunny

Sunny

Urgestein
@Vicid
Das gelbe Ausrufezeichen sagt dir das du ein Problem mit den Treibern hast
 
Vicid

Vicid

Ambitioniertes Mitglied
und fastboot devices im bootloader hat er mir aber die nr meiner beiden moto g5 phones' angezeigt..
aber ok.. klar.. mhm motorola treiber neuinstallieren?


EDIT: Wär übrigens erst in 3 Monaten auf die Idee gekommen im Gerätemanager zu gucken ://
 
Sunny

Sunny

Urgestein
@Vicid
Binsch gerade am überlegen, ich habe leider ein komplett anderes Handy, ich kann nur versuchen es allgemein zu erklären.
Suche eben paar Screenshots zusammen falls nötig...
Wenn du im Gerätemanager auf dein Gerät und dann auf Treiber aktualisieren gehst, anschließend die Treiber auf dem PC bzw Lokal suchen lassen.
Du solltest eine Auswahl an Treibern bekommen....wenn du da was mit ADB composite siehst, installieren....
Dann solltest du über Adb zugreifen können