Jetzt kostenlos registrieren: Mitglieder surfen ohne Werbung!

TWRP auf Moto G7 Plus

  • 24 Antworten
  • Neuester Beitrag
Diskutiere TWRP auf Moto G7 Plus im Motorola Moto G7 Plus Forum im Bereich Motorola Forum.
C

Charly-1

Neues Mitglied
Hallo zusammen, bin neu hier und weiß, daß ich in der falschen Abteilung bin. Habe nun seit Wochen alle möglichen Seiten und Artikel durchsucht und gelesen.
Hilft aber nichts. Möchte mein G7 plus rooten und habe ale möglichen Anleitungen durch. Aber bisher nicht geschafft TWRP permanent zu installieren. Bei früheren
Motos gab's nie Probleme. Einmal hatte ich's geschafft, aber da kam ich aus TWRP nur noch durch Neuinstallion des Stockroms wieder raus. OEM ist entsperrt.
Version ist OPWS30.61-21-14. twrp-3.4.0-0-lake.img und twrp-installer-3.4.0-0-lake.zip und das neueste Magisk. Es bleibt nichts. Nach Neustart ist nichts mehr da.
Im Fastboot steht ganz oben in roter Farbe: AP Fastboot Flash Mode (Secure). Komme auch ins orginale Recovery mit den diversen Tastendrücken nicht mehr rein.
Vieleicht hat auf diesem Wege noch jemand einen Tipp für mich !
MfG Charly
 
BOotnoOB

BOotnoOB

Lexikon
@Charly-1 Du bist jetzt der zweite, der von diesem Problem berichtet. Habe selber ein Moto G6 plus und kenne mich wirklich gut mit Motorola und root aus. Ich mache dir mal ein boot.img fertig, dass bereits mit TWRP 3.4.0-0 gepatcht ist. Poste gleich einen Link dazu.
Übrigens ist deine Build-Nr. QPWS30.61-21-14. Der erste Buchstabe gibt die Android-Version an. ;-)
Beitrag automatisch zusammengefügt:

Unter dem Link hier findest du eine .zip und darin enthalten sind zwei Dateien:

boot_bak.img (=> das originale Image als Backup)
boot_twrp.img (=> mit TWRP gepatcht)

Entpacke die .zip in den ADB-Ordner auf deinem PC und installiere das mit TWRP gepatchte boot.img über Fastboot mit diesem Befehl:
Code:
fastboot flash boot boot_twrp.img
Danach startest du aus dem Fastboot-Menü heraus direkt die Recovery mittels Vol+/- und Power.
 
Zuletzt bearbeitet:
C

Charly-1

Neues Mitglied
@BOotnoOB
Erstmal Danke !!
Gerade erledigt. Tut sich nichts. Es erscheint wieder das alte Recovery. Dabei ist mir gerade aufgefallen:
Baseband: <not found> erscheint im Recovery.
Wird wohl nichts mehr.
 
BOotnoOB

BOotnoOB

Lexikon
@Charly-1 "Baseband <not found>" wird im Bootloader-Menü und nicht in der Recovery angezeigt!!
Beitrag automatisch zusammengefügt:

Weißt du überhaupt, was die Recovery ist und wie man sie startet?
 
Zuletzt bearbeitet:
C

Charly-1

Neues Mitglied
@BOotnoOB Bootloader-Menü meinte ich. In meinem alten E5 klappte das mit der Recovery.
Im G7 plus habe ich es bis jetzt noch nie geschafft ins Recovery zu kommen.
Ausschalten. Dann Power und Volume - drücken um ins Bootloader-Menü zu kommen.
Dann wieder Power und Volume + kurz drücken, aber da kommt nichts. Bei meinem alten E5
konnte man dann auswählen, was man ändern will. Habe diese Anweisungen aus diversen Foren
so oft gelesen, aber es ändert nichts. Bin eigentlich ein Leser. Ihr seit das erste Forum,wo ich mich
angemeldet habe. Habe es auch schon mit "Flash boot_a" versucht, wie schon mal gelesen.
Mache nun seit 1986 mit Computern rum, und es nervt mich, wenn was nicht so läuft.
Also nochmal Danke ! Irgendwann wird's schon mal klappen, hoffe ich😉
 
BOotnoOB

BOotnoOB

Lexikon
@Charly-1
Charly-1 schrieb:
Dann wieder Power und Volume + kurz drücken, aber da kommt nichts.
Aber du siehst doch, dass Power und Vol+/- das Menü navigieren. Hab dir das auf dem Screenshot auch hingeschrieben. Du musst Vol- drücken, bis du anstatt "Start" den Eintrag "Recovery" siehst. Dann mit Power auswählen.
 

Anhänge

C

Charly-1

Neues Mitglied
@BOotnoOB
BOotnoOB schrieb:
Dann mit Power auswählen.
Danke ! Das ist schon klar. Aber ich kann da drücken solange ich will, ich komme immer wieder auf <Start>,
als ob gar kein Recovery vorhanden wäre.
 
BOotnoOB

BOotnoOB

Lexikon
@Charly-1 Mit Vol+/- blätterst du durch die verschiedenen Optionen (Power Off, Reboot Bootloader, Recovery, Logs und diverse Dev-Tools, bei denen keiner die genaue Bedeutung kennt). Wenn du dann mit Power bestätigst, springt die Auswahl wieder auf "Start"??
Beitrag automatisch zusammengefügt:

Grundsätzlich gibt es drei Arten, die Recovery zu starten:
- die erste funktioniert anscheinend nicht
- im laufenden System kannst du am PC per ADB oder auf dem Gerät selbst mit einer Terminal-App in die Recovery rebooten
- letzte Möglichkeit wäre über Fastboot mit
Code:
fastboot boot <twrp.img>
Beitrag automatisch zusammengefügt:

Oder warte mal... Kann es sein, dass bei dir
Vol- = scroll menu
Vol+ = select
Power = Reboot

ist??
 
Zuletzt bearbeitet:
C

Charly-1

Neues Mitglied
BOotnoOB schrieb:
fastboot boot <twrp.img>
Das funktionierte immer. Vor deinem Image habe ich das schon gehabt. Dann habe ich die die Patches und Magisk
installiert, aber nichts. Wenn ich das ungepatchte Image per Fastboot flash schreibe, komme ich aus TWRP nicht mehr raus.
Nur indem ich das org. Boot.img wieder drauf schreibe. Tastenkombinationen funktionieren nicht.
 
BOotnoOB

BOotnoOB

Lexikon
@Charly-1 Hast du die alternative Steuerung ausprobiert?

BOotnoOB schrieb:
Oder warte mal... Kann es sein, dass bei dir
Vol- = scroll menu
Vol+ = select
Power = Reboot

ist??
 
C

Charly-1

Neues Mitglied
BOotnoOB schrieb:
Hast du die alternative Steuerung ausprobiert?
Selbstverständlich habe ich das probiert. Ich kann mit + und - scrollen und drücken wie ich will,
es ändert nichts. Ich komm nicht in's recovery.
 
BOotnoOB

BOotnoOB

Lexikon
@Charly-1 Alles, was mir noch einfällt:
- hast du vielleicht die FW mit falschen Befehlen geflasht? Bei XDA werden zu 95% falsche Befehle gepostet.
- kannst du sonst die anderen Optionen dort auswählen, z.B. die Logs?

Ich würde jetzt zuerst versuchen, den Slot zu wechseln.
Code:
fastboot -aa => setzt _a auf aktiv
fastboot -ab => setzt _b auf aktiv
Das Bootloader-Menü gibt es auf beiden Slots separat. Vielleicht stimmt etwas damit nicht. Du kannst es auch mit dem bootloader.img neu flashen.
Ansonsten habe ich keine Ahnung. Hab selber gerade auch alle Dev-Tools aktiviert und konnte TWRP booten, also daran liegt es auch nicht.

Was sagt denn
Code:
fastboot getvar all
Den Output könntest du hier auch mal posten, vielleicht steht was brauchbares drin. Musst nur deine IMEI rausnehmen.
 
C

Charly-1

Neues Mitglied
BOotnoOB schrieb:
fastboot getvar all
Verückt ! Habe fastboot -aa eingegeben und lande im TWRP. Komme aber erst wieder raus wenn ich auf Slot B
boote. In TWRP kann ich ansonsten weder System noch Recovery booten. Bei Recovery lande ich im Bootmenü,
klicke auf Start und lande wieder in TWRP. Das selbe bei System !
 

Anhänge

  • Fastboot get var.txt
    3,1 KB Aufrufe: 1
BOotnoOB

BOotnoOB

Lexikon
@Charly-1 Immerhin... 😂
Aber ich kann das nicht nachvollziehen, nur teilweise.
Ein boot.img und ein recovery.img sind ja gleich aufgebaut. Ich kenne das Phänomen, wenn ein recovery.img als boot.img geflasht wird. Damit kannst du natürlich nicht das System starten, sondern startest nur noch die Recovery, egal was du wählst. Das würde dazu passen, dass du bei "Start" in die Recovery bootest.
Aber du müsstest auch von TWRP aus über System/Recovery wieder in TWRP landen, wenn dem so wäre. Da du im Bootloader landest, passt auch die Theorie nicht.

Keine Ahnung, was da schief läuft. Aber so ist das nicht gedacht. Sollte es nicht helfen die Stock FW zu flashen, wirst du wohl mit diesem seltenen Bug leben müssen. Auf logische Weise lässt sich das für mich nicht erklären.

Dein Output ist auch nicht auffällig.
 
C

Charly-1

Neues Mitglied
Habe die Stock FW geflasht. Bin gerade dabei alles wieder einzurichten. Danach werde ich mal versuchen,
ob ich's nicht doch noch hinbekomme. Nur, wie Du schon geschrieben hast, wiedersprechen sich die ganzen
Anleitungen aus dem Netz. Danke für Deine Bemühungen !!
 
BOotnoOB

BOotnoOB

Lexikon
@Charly-1 Kein Ding! Bei XDA kannst du dich immer an Anleitungen halten, die mit dem Thread direkt in Verbindung stehen und auch vom TE gepostet wurden. Nur bei denen, die auf Seite 56/138 von einem User mit 3 Posts verfasst worden sind, würde ich nicht blind vertrauen. :) Ganz besonders die Flashbefehle!
Ansonsten kannst du auch gerne mich fragen.
 
C

Charly-1

Neues Mitglied
BOotnoOB schrieb:
Ansonsten kannst du auch gerne mich fragen.
Werde gerne darauf zurück kommen, wenn's wieder zwickt 😉
Wo ich immer nicht klar komme, ist der Anfang: Image flashen oder nur booten ?
Bei deinem braucht man ja nichts patchen. Aber mit Magist komme ich ins schleudern.
Das brauche ich bei deinem wohl schon ?
 
BOotnoOB

BOotnoOB

Lexikon
Inzwischen spielt sich bei den Geräten alles komplett im boot.img ab. Grundsätzlich besteht es aus
- Kernel
- ramdisk.img (root-Verzeichnis "/" + Recovery!)
- dtb.img (Device Tree Blobs)

Das normale twrp.img ist genauso aufgebaut. Um jetzt die Stock Recovery zu ersetzen, werden beide Images entpackt (Magisk stellt dazu ein Tool) und das Stock ramdisk.img wird durch das von TWRP ersetzt. Alles wieder zu einem boot.img packen und fertig.
Das geht nicht mit Fastboot, aber in TWRP ist das möglich, weil du eine Shell/Terminal brauchst. Daher TWRP nur booten, um dann die installer.zip zu flashen. Die macht das, was ich oben beschrieben habe.

Magisk geht u.a. auch an das ramdisk.img, aber patcht es nur und ersetzt es nicht.

Das bedeutet, du kannst nicht erst Magisk installieren und danach TWRP. Denn TWRP würde das mit Magisk gepatchte ramdisk.img einfach rausschmeissen und ersetzen. Magisk wäre dann wieder weg.

Ich hoffe, dass war einigermaßen verständlich... :)
 
C

Charly-1

Neues Mitglied
BOotnoOB schrieb:
Ich hoffe, dass war einigermaßen verständlich
Ganz toll ! Ich bin gerade zu meiner Überraschung in Recovery gekommen.
Reboot system now
Reboot to Bootloader
Apply update from ADB
Apply update from SD card
Wipe data/factory reset
Mount/system
View recovery logs
Run lokale test
Power off.
Hab's abgetippt, weil ich nicht weis wie man im recovery einen Sceenshot macht.
Es schaut jetzt schon besser aus. Vieleicht klappt's ja noch 🙂
 
BOotnoOB

BOotnoOB

Lexikon
Aha, geht doch! Der Rest sollte ja dann kein Problem mehr sein.

Charly-1 schrieb:
Hab's abgetippt, weil ich nicht weis wie man im recovery einen Sceenshot macht.
In TWRP funktioniert es ganz normal mit Vol- und Power gleichzeitig, aber Stock... keine Ahnung.
 
Ähnliche Themen - TWRP auf Moto G7 Plus Antworten Datum
6
0
14