Moto Z Play rooten

  • 14 Antworten
  • Neuester Beitrag
Diskutiere Moto Z Play rooten im Motorola Moto Z (Play) Forum im Bereich Weitere Motorola Geräte.
A

Arlic

Neues Mitglied
ich habe derzeit ein Problem: Das letzte Handy, was ich gerootet habe, war ein Galaxy S1 und seitdem hab ich mich mit dem Thema auch nicht mehr beschäftigt.

Ich habe keine Ahnung mehr wie genau das abläuft.

Zur Zeit habe ich ein Moto z play in Nutzung, was für mich auch noch vollkommen ausreichend ist. Aber der letzte Sicherheitspatch von 2018 bereitet mir etwas Sorge. Also will ich was aktuelles draufspielen.
Android Version aktuell: 8.0.0
Sicherheitspatch 01.08.2018

Ich bin auf diesen Thread gestoßen:
Root Laien-Guide – Root / Custom-ROMs / Modding für Moto Z

Der ist aber nun auch schon was älter. Gilt das so noch? Wenn nein: kennt jemand eine gute Anleitung auf Deutsch oder Englisch?

Danke :)
 
Zuletzt bearbeitet:
cptechnik

cptechnik

Moderator
Teammitglied
Die allererste Frage wäre ja,... Hast du wirklich dass allererste Z Play, oder ein neues?
 
A

Arlic

Neues Mitglied
Ja ein Play z ohne Nummer... Von 2016? Glaube ich.
 
cptechnik

cptechnik

Moderator
Teammitglied
Ungetestet, ja...
Ich denke da tut sich nicht viel...
Ich habe mal flüchtig drüber gesehen,...
Motorola/Lenovo hat da die Politik seit Jahren nicht geändert...
  • Werkzeuge (fastboot, evt Treiber) herunterladen, installieren...
  • Bootloader öffnen
    • Bootloader-Änderung in den Entwickler-Optionen freischalten (ca seit 2014er Geräte)
    • mit fastboot Freischalt-String erzeugen,
    • bei Motorola mit Freischalt-String den Freischalt-Code anfordern,
    • mit fastboot und Freischalt-Code den Bootloader ensperren
  • mit
    • installiertem/geflashtem (TWRP)
    • oder einmalig gebootetem Custom-Recovery die SuperUser-App (Magisk, das andere Projekt wurde aufgegeben) installieren,
  • und jetzt haste es gerootet, und könntest noch CustomROM über das Custom-Recovery installieren...
(Ich selber habe nur G's, und bin nur der Moderator, der den Thread jetzt in die Z-Ecke geschubbst hat... ;) )
 
Zuletzt bearbeitet:
A

Arlic

Neues Mitglied
Danke schon mal!

Ich habs mal mit dem Uraltlink von mir oben versucht, bin aber an aktuellen Windows patches gescheitert... mit stehen bestimmte Funktionen nicht mehr zur Verfügung.

Mit deiner Anleitung hab ich es auch versucht, finde aber nicht, wo ich den Freischalt-String (IMEI) bei Motorola eingeben kann um den Code zu erhalten.
Wo hast du deine Informationen denn her? Oder hast du zufällig den passenden Link? :)
 
Zuletzt bearbeitet:
RappZapp

RappZapp

Fortgeschrittenes Mitglied
Älter, aber passt.


  • Werkzeuge (fastboot, evt Treiber) herunterladen, installieren...
  • Bootloader öffnen
    • Bootloader-Änderung in den Entwickler-Optionen freischalten (ca seit 2014er Geräte)
    • mit fastboot Freischalt-String erzeugen,
    • bei Motorola mit Freischalt-String den Freischalt-Code anfordern,
    • mit fastboot und Freischalt-Code den Bootloader ensperren
  • mit
    • installiertem/geflashtem (TWRP)
    • oder einmalig gebootetem Custom-Recovery die SuperUser-App (Magisk, das andere Projekt wurde aufgegeben) installieren,
  • und jetzt haste es gerootet, und könntest noch CustomROM über das Custom-Recovery installieren..


Treiber ist installiert. Freigeschaltet bekommen habe ich das Moto Z Play, wird im Handy auch angezeigt.
(OEM Entsperrung , Bootloader ist bereits entsperrt)

Wenn ich nun TWRP versuche zu installieren, kommt das:

Suggestion [3,General]: Der Befehl fastboot wurde nicht gefunden. Er ist jedoch am aktuellen Ort vorhanden. Windows PowerShell lädt Befehle nicht standardmäßig vom aktuellen Ort. Wenn Sie diesem Befehl vertrauen, geben Sie stattdessen ".\fastboot" ein. Weitere Informationen erhalten Sie unter "get-help about_Command_Precedence".
PS C:\Program Files (x86)\Minimal ADB and Fastboot> .\fastboot flash recovery twrp.img
(bootloader) slot-count: not found
(bootloader) slot-suffixes: not found
(bootloader) slot-suffixes: not found
(bootloader) has-slot:recovery: not found
target reported max download size of 534773760 bytes
sending 'recovery' (16916 KB)...
OKAY [ 0.436s]
writing 'recovery'...
(bootloader) Image size exeeded partition limits
(bootloader) Preflash validation failed
FAILED (remote failure)
finished. total time: 0.454s
PS C:\Program Files (x86)\Minimal ADB and Fastboot>


Was läuft da falsch? Danke schon einmal
 
RappZapp

RappZapp

Fortgeschrittenes Mitglied
Nachdem ich nun TWRP installiert bekommen habe, kann ich das Custom Rom nicht installieren
Es kommt immer "Error 7" = lineage-17.0-20200103-UNOFFICIAL-addison.zip

Eben hab ich einmal die "lineage-16.0-20190510-UNOFFICIAL-addison.zip" getestet...das klappte, bootet gerade. Bin gespannt, ob ich dann zur Android 10 komme ;)
 
RappZapp

RappZapp

Fortgeschrittenes Mitglied
Bleibt bei Error 7...
 
cptechnik

cptechnik

Moderator
Teammitglied
RappZapp schrieb:
Der Befehl fastboot wurde nicht gefunden. Er ist jedoch am aktuellen Ort vorhanden. Windows PowerShell lädt Befehle nicht standardmäßig vom aktuellen Ort.
Windows Problem, kann ich als Linuxer nix zu sagen...
Aber ein Problem ist hüben wie drüben, ... richtige Rechte um die Datei (Fastboot) auszuführen und Treiber installiert zu haben... (letztes fällt unter Linux weg 😎)


RappZapp schrieb:
target reported max download size of 534773760 bytes
sending 'recovery' (16916 KB)...
unterschiedlich groß
(nur mal so grob überschlagen... wenn Bytes mit 534 anfängt, kann 16000kb nicht dass richtige Maß sein...)

und
RappZapp schrieb:
Image size exeeded partition limits
passt nicht rein...

... also noch mal kontrollieren, was kommt wo hinein, und ist für welches Gerät, hast du alles richtige verwendet... und schlimmer noch als dass ich kein Windows habe, ich habe dieses Gerät nicht...😲💨
 
Zuletzt bearbeitet:
RappZapp

RappZapp

Fortgeschrittenes Mitglied
haha...danke

Seltsamerweise sind es einige, die das Problem haben.
Ich habe nun minimal adb portable antpackt, die letzte TWRP für das MotoZPlay da rein kopiert. (TWRP.img umbenannt).
Aber es kommt immer der blöde Fehler.

C:\Users\ac\Downloads\minimal_adb_fastboot_1.4.3_portable>fastboot flash recovery twrp.img
(bootloader) slot-count: not found
(bootloader) slot-suffixes: not found
(bootloader) slot-suffixes: not found
(bootloader) has-slot:recovery: not found
target reported max download size of 534773760 bytes
sending 'recovery' (21520 KB)...
OKAY [ 0.546s]
writing 'recovery'...
(bootloader) Image size exeeded partition limits
(bootloader) Preflash validation failed
FAILED (remote failure)
finished. total time: 0.583s

C:\Users\acema\Downloads\minimal_adb_fastboot_1.4.3_portable>


23 Gb frei...was meckert der.. ;) Andere Größe nun, aber trotzdem schon komisch


Kann man irgendwo die letzte Stock bekommen (Android 8.0), ich glaub, ich würde zurück gehen. Bringt mir nichts, wenn ich nicht mit Magisk den Root verbergen kann und Onlinebanking machen kann.
So verweigert mein Onlinebanking den Zugriff...wohl wegen der Custom Rom...
 
cptechnik

cptechnik

Moderator
Teammitglied
Bank wechseln...! :flapper:
Computer-OS wechseln,
und wenn das alles nicht hilft, ganz am Schluss... Smaatfoon wechseln... 🙊🙈😎

Ich kann dir nur verraten, dass ich in den neuen Moto G Varianten keine Recovery Partition mehr habe... das wird dann alles in die Systempartition integriert...
Ich auch unter anderem wegen der Root-Erkennung von der Kreissparkasse weg bin...
Und ich wegen der ganzen Treiberei von Windows weg bin... hilft dir das weiter, nein nicht wirklich... 🙊

Ich hoffe ja noch dass ich ein anderer Nutzer dieses Fohnz (Moto Z) meldet...
BITTE MELDE DICH!
 
RappZapp

RappZapp

Fortgeschrittenes Mitglied
:)

Die Tochter benötigt bald eh ihr erstes Telefon.....kauf ich mir halt ein neues.

Muss mich mal umschauen, was da so passt.

Danke erst einmal. ;)
 
RappZapp

RappZapp

Fortgeschrittenes Mitglied
Hab eben noch etwas getestet.....rooten war nun mit SuperSu problemlos möglich.....aber die Android 10 wollte noch immer nicht.
Egal...nun lass ich 9.0 drauf und gut.
 
RappZapp

RappZapp

Fortgeschrittenes Mitglied
Gibt es nur das LineageOS Android 10 (11) für das Moto Z Play? Hab kein anderes gefunden...
Evtl. klappt es ja mit einem anderen Rom :)
 
Zuletzt bearbeitet:
RappZapp

RappZapp

Fortgeschrittenes Mitglied
PS: Hab nun mehrfach gelesen, das die 10er nicht funktionieren soll.