WLAN Probleme - Diskussionsthread

  • 20 Antworten
  • Neuster Beitrag
T

ThePinky7777

Neues Mitglied
Threadstarter
Weil der andere Beitrag zu unübersichtlich wurde hab ich hier nun eine Finale zusammenfassung wie man das Problem beseitigen kann:
- WLAN Verbindungsabbrüche
- WLAN schlechter Empfang
Vorher saß ich direkt neben dem router und hatte alle 5 mins nen verbindungsabbruch.

ich hab wie es aussieht ne funktionierende konfig nun hinbekommen, d.h. scheint die WLAN Verbindung raltiv stabil zu sein, hatte zumindest keine abbrüche mehr, und konnte mich im haus bewegen was vorher kaum möglich war.

Also als erstes die /System/etc/wifi/tiwlan.ini (erfordert Rootrechte! Also Handy Rooten)

Editieren.

Anleitung wie man das machen kann hier:
WLAN Verbindungsprobleme

Ich habe folgende Sachen Editiert, und bin mit dem Endergebnis ganz zufrieden:
- Testdownload 1GB ohne abbruch der Verbindung
- Verbindung bleibt locker 1 Stunde bestehen (kein Bock mehr gehabt länger zu schauen obs noch abbricht)
- Freund mit HTC HD2 hat exact gleichen Empfang, sogar 1-2db schlechter mit dem WIFI Analyzer App.

folgende Werte wurden angepasst:

ORIGINAL WERTE schrieb:
TxPower = 205
HT_Enable=1
TxPerChannelPowerLimits_2_4G_OFDM = 24,24,24,24,24,24,24,24,24,24,24,24,24,24
AutoPowerModeDozeMode = 3
AutoPowerModeActiveTh = 0
AutoPowerModeDozeTh = 0
Clsfr_Type = 1
desiredPsMode = 1 # Global Power save delivery protocol (1 - UPSD, 0 - Legacy)
QOS_wmePsModeBE = 1 # Power save delivery protocol for BE AC (1 - UPSD, 0 - Legacy)
QOS_wmePsModeBK = 1 # Power save delivery protocol for BK AC (1 - UPSD, 0 - Legacy)
QOS_wmePsModeVI = 1 # Power save delivery protocol for VI AC (1 - UPSD, 0 - Legacy)
QOS_wmePsModeVO = 1 # Power save delivery protocol for VO AC (1 - UPSD, 0 - Legacy)
RxAggregationPktsLimit = 5
TxAggregationPktsLimit = 8
AutoPowerModeActiveTh = 0
AutoPowerModeDozeTh = 0
TxPerRatePowerLimits_2_4G_Normal = 1d,1f,22,26,27,29
TxPerRatePowerLimits_2_4G_Degraded = 1a,1f,22,25,25,27
TxPerRatePowerLimits_2_4G_Extreme = 16,1d,1e,20,24,25
BurstModeEnable = 0
PsPollDeliveryFailureRecoveryPeriod = 200
SendTspecInReassPkt = 1
MODIFIZIERTE WERTE schrieb:
TxPower = 250
HT_Enable=0
TxPerChannelPowerLimits_2_4G_OFDM = 6f,6f,6f,6f,6f,6f,6f,6f,6f,6f,6f,6f,6f,6f
AutoPowerModeDozeMode = 2
AutoPowerModeActiveTh = 15
AutoPowerModeDozeTh = 8
Clsfr_Type = 3
desiredPsMode = 0 # Global Power save delivery protocol (1 - UPSD, 0 - Legacy)
QOS_wmePsModeBE = 0 # Power save delivery protocol for BE AC (1 - UPSD, 0 - Legacy)
QOS_wmePsModeBK = 0 # Power save delivery protocol for BK AC (1 - UPSD, 0 - Legacy)
QOS_wmePsModeVI = 0 # Power save delivery protocol for VI AC (1 - UPSD, 0 - Legacy)
QOS_wmePsModeVO = 0 # Power save delivery protocol for VO AC (1 - UPSD, 0 - Legacy)
RxAggregationPktsLimit = 0
TxAggregationPktsLimit = 0
AutoPowerModeActiveTh = 2
AutoPowerModeDozeTh = 1
TxPerRatePowerLimits_2_4G_Normal = 1d, 1f, 22, 26, 27, 27
TxPerRatePowerLimits_2_4G_Degraded = 1a, 1f, 22, 24, 26, 27
TxPerRatePowerLimits_2_4G_Extreme = 16, 1d, 1e, 20, 24, 25
BurstModeEnable = 1
PsPollDeliveryFailureRecoveryPeriod = 20
SendTspecInReassPkt = 0
Erklärung:
TxPower
>> Gibt an wieviel Strom auf die Antenne geleitet wird, minimal Wert 0 maximal 250. es wird sich vermutlich im baterie verbrauch bemerkbar machen, aber hey wenns WLAN nicht funzt bringt mir 20% längere Akku dauer auch nix... :D Aber Ihr könnt ja selbst rumtesten, um so niedriger um so geringerer strom verbrauch aber auch vermutlich schlechterer empfang.
Teils hatte ich auch mit 140 guten Empfang, beim anderen WLAN dann aber nur mit 250...

HT_Enable=0
>> Deaktiviert 802.11n (man hat dann nur noch max 54Mbit an WLan speed, aber hey DSL 16000 sind auch nur 16 Mbit, ergo... lueft nach oben is noch genug :D und das 802.11n aktiviert macht wohl probleme mit manchen routern.

TxPerChannelPowerLimits_2_4G_OFDM
>> Gibt an pro Channel wie stark der maximal strom sein darf auf die antenne, sprich hier war 24 vor eingestellt, aber 50 is wohl der DEFAULT normalerweise, weiß der geier warum, und wir haben das bissl nach oben korrifiert auf 6f, bissl mehr power schadet nie. 14 werte weil mans für jeden einzelnen channel einstellt. channel = WLAN Channel, gibts 14 stück im 802.11g bereich.
Könnte mit schuld an der misere sein weil eben 24 nicht dem Default von 50 entspricht.

AutoPowerModeDozeMode
>> Hm ich übersetze es mal doze = schlaf Modus oder so. laut spezifikation ist default nun mal 2 und nicht 3 als wert, d.h. er soll nur kurze zeit pennen zwischen den intervallen wo er kein WLAN hat und nach einem suchen soll, so interpretier ich das, wer besser weiß kanns gern erklären :D
2 = Short Doze
3 = Long Doze

AutoPowerModeActiveTh
>> Entscheidet anhand der pakete die so eintrudeln bei WLAN verbindung ob er nun im activen modus ist. Standard wert ist hier 15, aber in original config wars 0, wobei laut spezifikation hier mindestens ne 2 stehen muss.
URSACHENARLARM

AutoPowerModeDozeTh
>> Entscheidet wie oberer wert, nur eben wann die WLAN verbindung quasi weg ist und er in passiv modus fallen soll. hier Standard wert laut spezifikation 8, eingestellt war 0 Original.... mindestens 1 sollte hier stehen laut spezifikation.
URSACHENALARM

Clsfr_Type
>> hm, schwer zu erklären jedoch laut spezifikation sollte hier ne 3 stehen und nicht wie in der original konfig ne 1


PsMode Werte:
Kurz ausgedrückt das ist irgendwie das Power management vom WLAN, 1 = Software gesteuert, 0 Hardware gesteuert.
URSACHENALARM
Ich vermute stark das irgend ne Software in Android irgendwie das WLAN falsch ansteuert Power Management mäßig und es deshalb irgendwie oft in standby geht und daher die verbindung abbricht, aber nur so ein Gefühl :D

Restliche Werte beeinflußen ebenfalls den Strom auf die Antenne in den verschiedenen Statusen die das WLAN einnehmen kann, also aktiv, passiv, sonstwas :D Und teils werden Kontrollpaket funktionen deaktiviert, die aber bei anderen ini Files auch nicht aktiviert waren (wo die leute keine probleme hatten, ergo.... vermutlich überflüssig sind).

SUMMA SUMMARUM:
vermutlich verbraucht das WLAN so mehr strom und wurde auch deshalb so mies konfiguriert, aber kein WLAN is halt auch nicht geil, und wenn ich dann halt täglich das Handy laden muss dann is das halt so, das schicksal haben alle anderen Marken auch wie Samsung, HTC usw... warum solls uns besser gehen :D

ihr könnt ja berichten ob euch das was gebracht hat oder nicht. Bei mir läufts jetz wie Gift :D




Aja, natürlich übernehm ich keine garantie, Verantwortung sonst was,
bei mir hats funktioniert und wer will kanns ausprobieren,
theoretisch sollte dadurch nix kaputt gehen können da alles werte im Toleranz Bereich.
laut den englischen links vorne jedoch sollte man unbedingt das 802.11n deaktvieren (Wert: HT_Enable=0) weil wenn das an ist könnten die settings
das gerät heiß werden lassen, weil mehr saft auf antenne...

hier die Links aus denen ich viele ideen hatte:
http://forum.xda-developers.com/show...1067106&page=5
http://processors.wiki.ti.com/index....erModeDozeMode

Und mithilfe in dem Beitrag hier:
https://www.android-hilfe.de/forum/motorola-pro-plus.706/wlan-staerke-problem.306950.html

Danke an alle die mir die inis gegeben haben :D
Und allen anderen nun ein stressfreies WLAN :D
 
Zuletzt bearbeitet:
F

Flat Eric

Fortgeschrittenes Mitglied
Könntest du deine Datei in den Anhang anfügen?
 
T

ThePinky7777

Neues Mitglied
Threadstarter
So hat leider neweile gedauert...
da ist meine Datei die ich zur Zeit verwende.
 

Anhänge

  • tiwlan.ini.txt
    16.1 KB Aufrufe: 250
P

pnaumann

Neues Mitglied
Das ist schon eine Frechheit, ein Gerät mit einem solche WLAN-Bug auszuliefern.
Ich hatte das Erlebnis 5 Minuten nach dem Auspacken und der ersten Inbetriebnahme. Das WLAN fiehl aus und der Router musste neu gestartet werden.
Mit der Änderung "HT_Enable=0" war die Sache erledigt.
Ein prima Beitrag von ThePinky7777.
 
P

pse

Ambitioniertes Mitglied
:thumbup: Sehr geil! Ich habe heute mein Pro plus zurück bekommen. Mainboard wurde getauscht. Mit dieser Änderung ist Wlan wirklich viel stabiler als vorher. Leistungaufnahme ist höher, merkt man sofort wegen der Wärmeentwicklung. Aber was solls :tongue:
Und ja, falls jemanden interessiert. Der Holo-launcher macht wirklich einen sehr guten Eindruck. Zusammen mit den Änderungen für Wlan wächst die "Liebe" zu Motorola wieder ein wenig :razz:
 
P

pse

Ambitioniertes Mitglied
Ich habe heute ein Problem gemerkt. Wobei ich nicht sicher bin, ob es mit den Einstellungen der ini-Datei zusammenhängt.
Das Problem ist, dass wenn mein Akku schwach ist, also ca <15% dann wird zwar Wlan-signal voll angezeigt, jedoch leuchtet das Symbol grau, anstatt blau. Das heißt dass keine aktive Datenverbindung da ist. Dann wechselt es zu blau... und irgendwann wieder grau. Also ein Anzeichen dafür, dass die Verbindung irgendwie bricht.

Hätte jemand auch so ein Problem und weiss vielleicht woran es liegen könnte.

Gruß
 
S

smartfan

Neues Mitglied
Irgendwie scheint das wlan eine Energiesparfunktion zu haben. Bei mir ist das wlan-Symbol beim Einschalten nach längerem Nichtgebrauch des Handys ganz verschwunden und erscheint dann kurz darauf wieder. Plötzlich werden auch die gepuschten Emails abgerufen. Das heißt, zwischenzeitlich war das wlan abgeschaltet, obwohl alle Schalter auf ein stehen.

Das spart natürlich Energie, aber Emails werden nicht zeitnah gepuscht. Wenn man sich beim Fritzrooter die wlan-Verbindung ansieht, steht da auch Power Save. Habe ich bei sonst keinem Handy gesehen. Ich weiß nicht wo man das abschalten kann.
 
P

pse

Ambitioniertes Mitglied
Ich habe seit gestern wieder massiv Probleme mit WLAN. So bald Wlan an ist, verliert es ständig die IP. Die Balken wechseln ständig zu grau. Echt nervig!!!
Das Problem kann ich nicht wirklich nachvollziehen. Vor 3 Tagen habe ich es aus der Garantie bekommen. Gleich gerootet, WLAN-ini geändert wie oben. Dann läuft es super bis gestern!
 
T

ThePinky7777

Neues Mitglied
Threadstarter
smartfan schrieb:
Irgendwie scheint das wlan eine Energiesparfunktion zu haben. Bei mir ist das wlan-Symbol beim Einschalten nach längerem Nichtgebrauch des Handys ganz verschwunden und erscheint dann kurz darauf wieder. Plötzlich werden auch die gepuschten Emails abgerufen. Das heißt, zwischenzeitlich war das wlan abgeschaltet, obwohl alle Schalter auf ein stehen.

Das spart natürlich Energie, aber Emails werden nicht zeitnah gepuscht. Wenn man sich beim Fritzrooter die wlan-Verbindung ansieht, steht da auch Power Save. Habe ich bei sonst keinem Handy gesehen. Ich weiß nicht wo man das abschalten kann.
tritt das mit meiner Lösung oben immernoch auf ?
Weil sollte theoretisch nicht :D

Der ursprüngliche Beitrag von 13:18 Uhr wurde um 13:19 Uhr ergänzt:

pse schrieb:
Ich habe seit gestern wieder massiv Probleme mit WLAN. So bald Wlan an ist, verliert es ständig die IP. Die Balken wechseln ständig zu grau. Echt nervig!!!
Das Problem kann ich nicht wirklich nachvollziehen. Vor 3 Tagen habe ich es aus der Garantie bekommen. Gleich gerootet, WLAN-ini geändert wie oben. Dann läuft es super bis gestern!
Handy mal neu gestartet, und Router auch, kann ja auch ein anderes Problem sein ?

Also bei mir geht bis Heute alles Prima mit den Modifikationen, wobei ich das WLAN nur bei bedarf anschalte, um akku laufzeit zu sparen.

aber wenns an ist hab ich mit der config oben keine probleme

Der ursprüngliche Beitrag von 13:19 Uhr wurde um 13:21 Uhr ergänzt:

pse schrieb:
Ich habe heute ein Problem gemerkt. Wobei ich nicht sicher bin, ob es mit den Einstellungen der ini-Datei zusammenhängt.
Das Problem ist, dass wenn mein Akku schwach ist, also ca <15% dann wird zwar Wlan-signal voll angezeigt, jedoch leuchtet das Symbol grau, anstatt blau. Das heißt dass keine aktive Datenverbindung da ist. Dann wechselt es zu blau... und irgendwann wieder grau. Also ein Anzeichen dafür, dass die Verbindung irgendwie bricht.

Hätte jemand auch so ein Problem und weiss vielleicht woran es liegen könnte.

Gruß
Ja das hab ich auch irgendwie gemerkt aber keine Lösung, gefühlt wenn der akku leerer ist, wird auchs WLAN schlechter...
Wie gesagt, das fiel mir auch schon auf, aber Lösung in dem Fall >> Laden :D:D
 
S

smartfan

Neues Mitglied
@ThePinky7777:

Mein wlan läuft jetzt auch bei ausgeschaltem Bildschirm, damit ist der Empfang von Email-Push möglich.

Ich hatte übersehen, dass es noch eine Wlan-Einstellung im Menu "Erweitert" gibt: "Wlan Standby-Richtlinie". Dort stand als Standard "Wenn Display sich abschaltet", geändert auf "Nie".

Damit ist natürlich der Stromverbrauch höher aber immer noch akzeptabel.
 
N

nikmam

Neues Mitglied
Bin mit meinem Pro+ eigentlich sehr zufrieden.
Wenn ich zu Hause bin gehe ich über wlan ins Internet. Hab eine easybox.
Das hat bis jetzt auch immer geklappt. Seit ein paar Tagen kann ich mit wlan nicht mehr ins internet. IP Adresse wird abgerufen und der Versuch schlägt fehl.
Kann mir jemand helfen, was ich tun kann.
 
P

Polki

Neues Mitglied
Ich kann nicht direkt was zu der Eaysybox sagen, aber ich habe mir sagen lassen das es bei den Leiterbahnen speziell im Wlan Bereich zu Temperatur Problemen kommen kann wenn man von draußen rein kommt....

Denke ein Tauschversuch über Datrepair wäre nicht verkehrt bin sehr zufrieden mit meinem Razr i :thumbsup:
 
N

nikmam

Neues Mitglied
Vielen Dank für deine Antwort, aber ich bin ansonsten sehr zufrieden mit dem Pro+. Ich habs wegen der Tastatur gekauft und möchte die auch weiterhin haben.
Hab jetzt mal einen reset beim Router gemacht und jetzt funktionierts gerade wieder aber wahrscheinlich nicht lange
 
P

Polki

Neues Mitglied
Hatte ich auch komm vom Pre3 ist jetzt mit der Bildschirmtastatur aber auch OK. Viel Glück
 
C

clasgeo

Neues Mitglied
nikmam schrieb:
Hab jetzt mal einen reset beim Router gemacht und jetzt funktionierts gerade wieder aber wahrscheinlich nicht lange
Da hast du Recht... Die Lösung deines Problems wurde hier schon mehrfach gepostet. Du musst dein Gerät rooten und in einer ini-Datei beim WLAN den 802.11n-Standard abschalten: http://www.dev-eth0.de/losung-fur-abbrechende-wlan-verbindung-mit-defy/
Funktioniert genau so auch bei unserem Pro Plus :)

LG, Georg


Gesendet von meinem MB632 mit Tapatalk 2
 
G

Gero181

Gast
Hey
ich hab folgendes Problem
wenn ich große Datenmengen übers Wlan lade, bricht mein Wlan alle 5 mb ab manchmal gehts auch weiter aber nie am Stück, wie zum Beispiel bei Navigon wlan-downloads 600MB... ziemlich nervig, weil das Handy einfach die Verbindung verliert
gibts da irgendeine Lösung?
LG Gero
 
G

Gero181

Gast
Hey
also mir hat eine tiwlan.ini nur teilweise geholfen
zwar verliert mein Pro+ jetzt nicht mehr komplett die verbindung, dafür verliert es beim download alle paar sekunden die verbindung(graues symbol, davor war die wlanverbindung komplett getrennt)
gibts dazu iwas was ich noch testen kann
habe mir auch deine ini angeschaut und mit deinem ersten Post abgeglichen, hast du dort neue werte eingetragen??
LG gero
 
C

clasgeo

Neues Mitglied
Mit welchem Standard (Geschwindigkeit) wird die Verbindung zum Router hergestellt (802.11 b, g, n)? Wie ist die Signalstärke? Firmware des Routers aktuell? Klappt die Verbindung mit anderen Geräten (PC) zum Router problemlos?

LG, Georg

Gesendet von meinem MB632 mit Tapatalk 2
 
G

Gero181

Gast
also ich hab am Handy schon den n standard abgeschaltet, allerdings schafft das der router glaub gar nicht, bin mir da aber nciht sicher, signalstärke reicht von inneren punkt bis zu vollem empfang, je nach dem wo ich mich befinde, der abbruch kommt aber bei jeder stärke vor, firmware des routers hab ich schon geuptdatet, alles andere klappt ohne probleme: pc via lan-kabel, laptop wie wlan, 2 weitere handys via wlan
ich denk da läuft was im handy schief
lg Gero
 
C

clasgeo

Neues Mitglied
Gero181 schrieb:
ich denk da läuft was im handy schief
Ja das sieht ganz danach aus. Leider fällt mir dazu auch nichts ein. Ein Factory Reset dürfte nichts bringen, da das wohl ein Fehler der Motorola-Software ist. Oder hast du irgendwelche Apps installiert, die die WiFi-Funktion verändern?
Das ist ja nicht der einzige Bug dieses an sich tollen Geräts...

LG, Georg

Gesendet von meinem MB632 mit Tapatalk 2
 
Oben Unten