(Gelöst): AP Fastboot Flash Mode (S) (Flash Failure)

  • 26 Antworten
  • Neuester Beitrag
Diskutiere (Gelöst): AP Fastboot Flash Mode (S) (Flash Failure) im Motorola Xoom 2 Forum im Bereich Weitere Motorola Geräte.
G

GlennH

Neues Mitglied
Moin Moin,

beim Einschalten meines Xoom2 bekomme ich noch folgenden freundlichen Hinweis:
AP Fastboot Flash Mode (S) (Flash Failure)
0A.6B (sha-h13f845, 2011-11-17 16:40:56)
eMMC Info: Size 16G

Device is LOCKED, Status Code: 0

Battery OK
OK to Program
Connect USB
Data Cable
Durch Drücken beider Lautstärke-Tasten + Power bekomme ich das:
Boot Mode Selection Menu (0A.6B)
Vol Up Selects, Vol Down Scrolls

Available Boot Modes:
Normal Powerup
Recovery
usw.
Wenn ich "Normal Powerup" auswähle, bootet das Tablet ohne weitere Probleme und ist betriebsbereit.

Nach dem nächsten Reboot bzw. aus- und wieder einschalten, gibt's dann erneut die Fehlermeldung "AP Fastboot Flash Mode (S) (Flash Failure)".

"Recovery" und "wipe data/factory reset" und "wipe cache partition" funktionieren auch. Ändern nur leider nichts am Boot-Fehler.

Ich wollte heute früh einen neuen Bootloader installieren und hab' leider erst zu spät gesehen, dass dies derzeit noch gar nicht möglich ist, da der Bootloader gelocked ist. Ge-rooted ist es aber.

Bei meinen Versuchen ist offensichtlich irgendetwas schief gegangen.

Ich hatte es auch per SDK und "adb reboot bootloader" und "fastboot oem unlock" probiert. Klappt natürlich nicht ... aber hab' ich dabei den Fehler irgendwie fabriziert?

Schlimmstenfalls muss ich wohl auf ICS warten - in der Hoffnung, dass dann ein komplett neues Image inclusive Bootloader geschrieben wird.

SBF gibt's nicht, oder?

Danke und Grüße,

Glenn.
 
Zuletzt bearbeitet:
Fieser-Kardinal

Fieser-Kardinal

Experte
Der User Loader009 hat mal ein Dump hier zur Verfügung gestellt, da könntest du den bootloader evtl. wieder auf stock bringen. Evtl. stellt er dir auch nochmals einen Dump zur Verfügung. Schreib ihn mal per PN an.

Welche Version vom Xoom 2 hast du? Also genaue Build Version?
 
Zuletzt bearbeitet:
G

GlennH

Neues Mitglied
Fieser-Kardinal schrieb:
Welche Version vom Xoom 2 hast du? Also genaue Build Version?
Hallo Kardinal,

danke für Deine Hilfe.

Die Systemversion lautet: 0.268.6.MZ616.Retail.en.EU
Build: 1.6.0_268.6-MZ616

Falls das hier jemand gerootet hat, würde ich mich über die Boot- und Recovery-Partition freuen ... :)

Wie man das erstellt, steht in diesem Threat: https://www.android-hilfe.de/forum/motorola-xoom-2.499/recovery-und-boot-images.228272.html

Nchantmnt schrieb:
um die Partition als block ausfindig zu machen tippt bei adb shell oder im terminal Emulator ein: "su" enter "cat /proc/partitions" enter

Führt jetzt diese befehle in adb shell oder terminal Emulator aus

dd if=/dev/block/mmcblk1p11 of=/sdcard/boot.img
dd if=/dev/block/mmcblk1p12 of=/sdcard/recovery.img
Sobald die images erstellt sind einfach über adb pull auf den computer laden.
Loader009 schreibe ich mal an.

Grüße
 
Fieser-Kardinal

Fieser-Kardinal

Experte
Falls du bis heute abend keine Antwort erhalten hast, kann ich dir die beiden Images anfertigen. Dauert aber, bin erst ab ca. 20Uhr evtl. zu Hause.
 
G

GlennH

Neues Mitglied
Hey, das wäre spitze!

Mach' Dir keinen Stress. Auf einen Tag mehr oder weniger kommt's nun auch nicht an. Das Tablet liegt eh' im Büro und da komme ich erst morgen früh wieder hin.

Danke Dir ... :thumbsup:
 
L

Loader009

Stammgast
Sorry, bin die nächste Zeit nicht daheim, daher hab ich "eigentlich" alle Dateien nicht in greifbarer Nähe...
Allerdings fand ich auf meinem Tablet (den ich natürlich mitnahm) noch die Images, natürlich unverpackt.
Ganz wichtig, bevor ihr flasht, überprüft die Datei mit einem Hashchecker, nicht dass ihr ne fehlerhafte Datei habt!
Die Hashes editiere ich gleich hinein.
boot: kostenlos Dateien hochladen bei File Upload X
recovery: kostenlos Dateien hochladen bei File Upload X

Ich hoffe man hat nichts dagegen, dass ich die Links diesmal nicht per PM geschickt habe, sondern sie öffentlich zur Verfügung stelle...
Mittlerweile sind diese Dateien so verteilt, dass es keinen Unterschied mehr machen sollte.
Greetz

edit: Hier die Hashes
boot MD5: 025c639321ac5a8c87718e6b237f47b4
boot SHA-1: f9f8c1c4a3ece93ba5f2d4549050b7ef64f8c1c5

recovery MD5: 3f3b4a39e10f6245d8dc76b33c56651d
recovery SHA-1: d544d31d1de3451d801bcbcc24fcee7f83717145
 
Zuletzt bearbeitet:
G

GlennH

Neues Mitglied
Danke für den Upload ...

... leider kann ich mich bei http://www.fileuploadx.de/ nirgends anmelden oder registrieren. Ich komme nicht auf die Website, da sofort Zugangsdaten verlangt werden ...

Kommt da Jemand drauf und kann die Dateien woanders ablegen?
 
L

Loader009

Stammgast
Scheinbar haben die den "service" kurz nach meinem Upload eingestellt...
Jedenfalls gehts jetzt nicht mehr, hier nochmal bei nem anderen Hoster:
boot: XOOM2-0.268.6.MZ616.Retail.en.EU-boot.img
recovery: XOOM2-0.268.6.MZ616.Retail.en.EU-recovery.img

Sorry für diese Seite voll mit Werbung, meine übliche Hochladeseite läuft mit dem Tablet nicht >.<
Greetz

PS: Den Hashcheck nicht vergessen!
Flasht ihr defekte Dateien, kann ich nicht sagen, ob das XOOM2 dann noch reparabel ist (von der Userseite).
 
G

GlennH

Neues Mitglied
Perfekt!

Hat alles geklappt. Boot & Recovery geflashed, Tablet läuft wieder ... :)

Gut gemacht und Danke!
 
Fieser-Kardinal

Fieser-Kardinal

Experte
Ich hab ein großes Problem beim Xoom 2 WIFI Only meiner Freundin.

Sie hat einen Factory Reset gemacht. Der lief durch. Seitdem steckt das Tab bei IP ADresse beziehen fest, wenn es sich ins WLAN verbinden möchte. Stelle ich auf statische IP Addresse um geht es sofort.

Root ist leider auch weg, obwohl Superuser die SU findet kann er kein Root bekommen. Andere Apps die Root brauchen funktionieren auch nicht.

Seltsamerweise scheint er auch immer eine andere WLAN MAC ADresse zu bekommen, jedenfalls wechselt die ständig :(

Ich weiß nimmer weiter...

System Version: 0.268.4.MZ615.Retail.en.EU
Firmware: GAS_EMEA_UCATBLT1WIRTCOREEU_P005
Build Number: 1.6.0_268.4-M615

Erneuter Versuch zu rooten schlägt auch fehl: :(

[*][*] XYZ: Motorola XYBoard/Xoom2 Root Exploit (Windows version)[*] by Dan Rosenberg (@djrbliss)[*][*] Before continuing, ensure USB debugging is enabled, that you[*] have the latest Motorola drivers installed, and that your tablet[*] is connected via USB.[*][*] Press enter to root your tablet...
Drücken Sie eine beliebige Taste . . .[*][*] Waiting for device...
* daemon not running. starting it now *
* daemon started successfully *[*] Device found.[*] Deploying payload...
2076 KB/s (540030 bytes in 0.254s)
chmod: permission denied
/data/local/xyz: permission denied[*] Rebooting device...[*] Waiting for tablet to reboot.
/data/local/xyz: permission denied[*] Rebooting device again...[*] Waiting for tablet to reboot.[*] Attemping persistence...
remount failed: Operation not permitted
failed to copy 'su' to '/system/bin/su': Read-only file system
chmod: permission denied
ln: permission denied
failed to copy 'busybox' to '/system/xbin/busybox': Read-only file system
chmod: permission denied
/system/xbin/busybox: not found
failed to copy 'Superuser.apk' to '/system/app/Superuser.apk': Read-only file sy
stem[*] Cleaning up...
/data/local/xyz: permission denied
rm: permission denied[*] Rebooting...[*] Exploit complete![*] Press any key to exit.
Drücken Sie eine beliebige Taste . . .
 
Zuletzt bearbeitet:
Big Smoke

Big Smoke

Ambitioniertes Mitglied
G

GlennH

Neues Mitglied
Ich hatte es bei meinem Problem letztens über "Beide Lautstärketasten + Power" ins Recovery-Menü geschafft und dort einen "Factory Reset" durchgeführt.

Der Motorola-Support empfahl mir aber, unter "Einstellungen -> Datenschutz -> Auf Werkszustand zurücksetzen" zu benutzen.

Ob es bei den unterschiedlichen Methoden auch jeweils unterschiedliche Ergebnisse gibt, weiss ich nicht. Es kann aber nicht schaden, beides durchzuführen.

Den Dan Rosenberg - Root hab' ich auch durchgeführt - ohne Probleme. Zumindest mit meinem MZ616 funktioniert er. Beim MZ615 sollte es auch klappen, denke ich.

Über WLAN-Probleme liest man in den verschiedenen Xoom2-Foren in Verbindung mit Honeycomb immer wieder.
Aufhänger - ohne Funktion - Crashes - spontane Funktion - Reboot ... sämtliche Möglichkeiten sind dort wohl gegeben.
Wenn es bei Dir mit einer statischen IP funktioniert, sollte dies ein gangbarer Weg bis ICS sein.

"USB Debugging" ist natürlich wichtig.

Sorry, weiter weiß ich leider auch nicht bei Deinem Problem.

Grüße
 
Fieser-Kardinal

Fieser-Kardinal

Experte
Big Smoke schrieb:
"USB debugging" eingeschaltet ?

Gruß
Natürlich ;)

GlennH schrieb:
Ich hatte es bei meinem Problem letztens über "Beide Lautstärketasten + Power" ins Recovery-Menü geschafft und dort einen "Factory Reset" durchgeführt.

Der Motorola-Support empfahl mir aber, unter "Einstellungen -> Datenschutz -> Auf Werkszustand zurücksetzen" zu benutzen.

Ob es bei den unterschiedlichen Methoden auch jeweils unterschiedliche Ergebnisse gibt, weiss ich nicht. Es kann aber nicht schaden, beides durchzuführen.

Den Dan Rosenberg - Root hab' ich auch durchgeführt - ohne Probleme. Zumindest mit meinem MZ616 funktioniert er. Beim MZ615 sollte es auch klappen, denke ich.

Über WLAN-Probleme liest man in den verschiedenen Xoom2-Foren in Verbindung mit Honeycomb immer wieder.
Aufhänger - ohne Funktion - Crashes - spontane Funktion - Reboot ... sämtliche Möglichkeiten sind dort wohl gegeben.
Wenn es bei Dir mit einer statischen IP funktioniert, sollte dies ein gangbarer Weg bis ICS sein.

"USB Debugging" ist natürlich wichtig.

Sorry, weiter weiß ich leider auch nicht bei Deinem Problem.

Grüße
Der Factory Reset wurde über Settings -> Privacy -> Factory Reset durchgeführt. Wie gesagt, das ging beim ersten Mal auch problemlos.

Nach dem Reboot aber bekommt man via DHCP keine IP Addresse mehr. Anscheinend ändert sich die MAC Addresse des WLAN Moduls auch immer wieder.

Wenn man jetzt einen erneuten Factory Reset über die Einstellungen -> Datenschutz machen möchte und man klickt beim zweiten mal auf Alles löschen, passiert jedoch rein gar nichts. Darauf habe ich im Recovery nochmals einen Factory Reset durchgeführt. Aber keines löst das Problem mit dem WLAN oder dem nicht mehr rootbaren Tab.

Root ist ebenso weg und lässt sich auch nicht erneut rooten, da chmod keine Permission dafür hat, ich vermute dass das komplette Filesystem read only ist. adb remount geht nicht, da keine permission.
 
Fieser-Kardinal

Fieser-Kardinal

Experte
Hab nun ein System Dump gefunden, aber wie flashe ich das nun? *grübel* Hmm, leider keine .img, sondern nur die Daten aus /system in einer .zip, das bringt mir wenig denke ich :(
 
Zuletzt bearbeitet:
L

Loader009

Stammgast
Ein System Dump bringt dir nichts, da nach allen Berichten, die ich kenne, danach ein Full-Brick zustande kam.
Ohne Fastboot Flashfiles konnte man das Xoom 2 dann nicht mehr retten, ergo Support.

Falls du immernoch ins System kannst, kannst du versuchen (mit Vorsicht zu genießen) den "Dump" mit deinem System zu vergleichen.
Du solltest nicht versuchen, den Dump auf dein Xoom 2 zu kopieren, da die zip-Dateien soviel ich weiß keine Rechteverwaltung besitzt, wie tar-Dateien.

Meine Vermutung im übrigens, du hast eine bestimmte Datei überschrieben oder geändert, die die MAC von WLAN,
Bluetooth etc. beherbergte und nun sind sie "Pfutsch", sodass du jedes mal ne neue bekommst.
Wie das passieren konnte und welche Datei es ist, kann ich dir nicht sagen, Vermutung halt.
Greetz
 
Fieser-Kardinal

Fieser-Kardinal

Experte
Es wurde definitiv keine Datei überschrieben, lediglich der Factory Reset wurde durchgeführt. Damit fingen die Probleme an. :( Meiner Recherche nach scheint dabei was am WLAN Supplicant geändert worden zu sein.

Gesendet von meinem ASUS Transformer Pad TF300TG mit Tapatalk 2
 
L

Loader009

Stammgast
Kannst du irgendwie checken, ob sie die BlueTooth MAC ebenfalls jedesmal ändert?
Ansonsten dürftest du recht haben.

Wenn was an wpa_supplicant (nicht WLAN Supplicant) geändert wurde, dann eigentlich höchstens die config.
Ich weiß, dass bei Debian Distributionen diese config unter /etc/wpa_supplicant steckt, aber das bringt dir ohne Root ohnehin nichts.

Du kannst Lumberjack (ein Log-Viewer oder wie man die nennt) auch ohne root ausführen, damit könntest du prüfen, ob was nicht stimmt.
Rein theoretisch könntest du auch den terminal emulator laden, nach /system/sbin gehen und schaun, ob dort die Datei "su" ist.
(Mit dem Befehl "ls" werden alle Dateien und Ordner aufgelistet, mit "ls -l" gibts ne Detailliertere Liste, ist aber nicht nötig.)
Was passiert, wenn du im Ordner /system/sbin die Datei su ausführst? (Mit "./su" wird eine Datei ausgeführt.)
Greetz
 
Fieser-Kardinal

Fieser-Kardinal

Experte
Hab die wpa_supplicant.conf unter /etc/wifi/ gefunden. Recht leer, nur 5 Einträge drin.

Die su Datei ist unter /system/bin vorhanden. Der sbin Ordner ist leer. Busybox scheint weg zu sein. Im Terminal Emulator kann ich nicht mal nen cd Befehl absetzen, ls kennt er auch nicht, sehr seltsam.

Gesendet von meinem ASUS Transformer Pad TF300TG mit Tapatalk 2
 
L

Loader009

Stammgast
Die wpa_supplicant.conf ist uninteressant, der Grund ist recht einfach, da drin ist bei üblichen Linux Distributionen die Login-Daten für WPA/WPA2 APs bzw. die config für wpa_supplicant.
Auch sonst werden die MAC Adressen für die einzelnen interfaces (network interface heißt es normalerweise, im normalen Linux (beziehe mich hier immer auf Debian/Ubuntu) findet man den Ordner "/etc/network" und dort die "interfaces.conf" (oder so ähnlich, habs nicht genau im Kopf), allerdings hat Android sowas nicht) nicht im /etc Ordner sein, da der /etc Ordner normalerweise durch einen Wipe gelöscht wird (nehme ich an.)

Du hast aber recht, die Datei su ist in /system/bin vorhanden.
Du kannst su mit "/system/bin/su" ebenfalls ausführen, falls cd, ls etc. nicht vorhanden ist.
Leider kann ich aber ab dann nicht mehr weiterhelfen, denn dann wird es Androidspezifisch.
Rein theoretisch würde ich an deiner Stelle erstmal eine Busybox runterladen (als .apk), dieses dann auf das Xoom 2 kopieren und mit dem Terminal Emulator mit Superuser rechten ausführen.
Ausführen geht genauso wie mit su. Du nutzt den absoluten Pfad "/sdcard/busybox.apk".
Geht das nicht, so weiß ich leider nicht, wie man aus dem Terminal Emulator eine apk ausführt.
Theoretisch müsste man die apk-Datei irgendwie ausführbar machen, aber ohne busybox?
Vielleicht mit dem ES-File Explorer, wenn der keine Busybox dazu braucht.
Greetz


PS: Für den Fall, in dem Terminal Emulator unter Einstellungen
Shell "/system/bin/sh -" (inklusive Bindestrich)
Startbefehl "export PATH=/data/local/bin:$PATH"


edit: Mir fällt ein, du kannst die Busybox Dateien (chmod, ls etc. pp.) im Grunde mit dem Absoluten Pfad ebenfalls ausführen.
Aber was passiert denn nun, wenn du su ausführst?
 
Zuletzt bearbeitet:
L

Loader009

Stammgast
Wie siehts aus, hat sich inzwischen was geändert?