Odys Vision - Rooten & Firmware

  • 34 Antworten
  • Neuster Beitrag
Oma7144

Oma7144

Lexikon
Threadstarter
Liegt unter Windows/Benutzer/Dein Name/.android.


:thumbup:
 
W

wofris

Fortgeschrittenes Mitglied
Oma7144 schrieb:
Liegt unter Windows/Benutzer/Dein Name/.android.


:thumbup:
Das nennt man wohl Déjà-vu
Das war so um 1996 - als ich dieses Erlebnis hatte
Das Ergebnis war - seitdem habe ich mich nie wieder mich für Linus interessiert.

Es gibt (unter XP) kein solches Verzeichnis.
Ein Ordner mit dieser Syntax ".android" wird nie von einem Windows-Prg angelegt.
Es gibt: C:\Dokumente und Einstellungen\Username_x\
Meinst du diesen Ordner? Muß dort ein Verzeichnis ".android" mit der adb_usb.ini angelegt werden? Oder was verstehe ich falsch?
 
hävksitol

hävksitol

Ehrenmitglied
wofris schrieb:
Es gibt (unter XP) kein solches Verzeichnis.
Ein Ordner mit dieser Syntax ".android" wird nie von einem Windows-Prg angelegt.
Es gibt: C:\Dokumente und Einstellungen\Username_x\
Meinst du diesen Ordner? Muß dort ein Verzeichnis ".android" mit der adb_usb.ini angelegt werden? Oder was verstehe ich falsch?
Bei mir (Windows XP!) existiert dieser Ordner (den ich nicht angelegt habe, sondern der ganz offenbar vom Android-SDK erzeugt wurde) als:

C:\Dokumente und Einstellungen\<mein Nutzername>\.android

und eben dort befindet sich auch eine (also wohl: die) adb_usb.ini.
 
Zuletzt bearbeitet:
Oma7144

Oma7144

Lexikon
Threadstarter
Ei der Daus! Da gibt es doch tatsächlich noch mehr so unseriöse Sachen mit dem Punkt ...

... ich habe die nicht angelegt ;-)




:thumbup:
 

Anhänge

W

wofris

Fortgeschrittenes Mitglied
hävksitol;3321005 schrieb:
Bei mir (Windows XP!) existiert dieser Ordner (den ich nicht angelegt habe, sondern der ganz offenbar vom Android-SDK erzeugt wurde) als:

C:\Dokumente und Einstellungen\<mein Nutzername>\.android

und eben dort befindet sich auch eine (also wohl: die) adb_usb.ini.
Android-SDK ... - Hab ich, als android-sdk_r18-windows.zip
Das habe ich entpackt nach C:\android-sdk-windows
Und nun?
Kann/soll ich nun einfach einen Ordner: C:\Dokumente und Einstellungen\<mein Nutzername>\.android anlegen?
Sorry, ich bin Windows-User, seit über 18 Jahren, und kenne mich damit recht gut aus. Ich will einfach nur ein wenig mehr über Tablets (und Android) erfahren/lernen/...
Es gibt auch kaum vernünftige Literatur zu dem Thema, alles geht in Richtung "learnig by doing" - und das erzeugt halt Fragen/Reibungspunkte/.../.../...what ever
Ich will doch nur einmal das verdammte Vision als root sehen.
Und dahinter das nächste Problem (für mich) lösen: wie kann ich auf die externe Micro-sdcard vom Tablet lesen und schreiben.
 
hävksitol

hävksitol

Ehrenmitglied
Um das Vision zu rooten , muss man back to the roots, und diese liegen in diesem Fall hier. Zitat aus dem dort verlinkten Beitrag:

Things You Need


  • A PC running Windows Vista or Windows 7
  • The Android SDK which has to be installed in your PC (click here for install details)
Du musst das SDK also nicht nur entpacken, sondern auch installieren - dann bekommst Du nicht nur die erforderliche Ordnerstruktur, sondern auch die ADB-Umgebung, ohne die das Editieren von ini-Dateien nutzlos ist (weil ADB nicht funktioniert & das Tablet nicht erkannt wird).


PS: Wenn Du Lesestoff über Android suchst, schau doch mal hier unter Punkt 16 rein.
 
W

wofris

Fortgeschrittenes Mitglied
hävksitol;3321422 schrieb:
Du musst das SDK also nicht nur entpacken, sondern auch installieren
Das habe ich befürchtet.
Und ich befürchte weiter das es, trotz Installation, nicht funktionieren wird da auf diesem PC kein Java installiert ist.
Aber trotzdem Danke für deine Antworten. Nun weiß ich wenigstens warum es nicht funktiuniert. Und auch das ich wohl nie ein Tablet als root sehen werde.
/Ironie on/
Dabei wollte ich doch nur die Motorhaube aufmachen und einen Blick auf den Motor werfen. Viel Aufwand wenn ich vorher erst eine komplette Werkstatt einrichten muß um die Motorhaube zu entriegeln.
/Ironie of/
-:)
 
hävksitol

hävksitol

Ehrenmitglied
wofris schrieb:
Das habe ich befürchtet.

(..)

Kein Grund zur Panik: ADB geht auch deutlich kleiner, s. hier (aber da Du ja das SDK bereits auf der FP hattest, bin ich selbstverständlich davon ausgegangen, daß Du es auch installieren wolltest & würdest ;)).
Also: Root marsch!
 
W

wofris

Fortgeschrittenes Mitglied
hävksitol;3323330 schrieb:
Kein Grund zur Panik: ADB geht auch deutlich kleiner, s. hier
Genau das habe ich verwendet. Und von dort (C:\adb) auch die Win USB-Treiber installiert. Und dann eben hängengeblieben an .android das nicht auf meinem LW vorhanden ist.
Und, da kein SDK und kein Java, wohl auch nicht erscheint. Und damit kein Speicherort um die adb_usb.ini anzulegen -> folglich kein root.
 
hävksitol

hävksitol

Ehrenmitglied
wofris schrieb:
Genau das habe ich verwendet. Und von dort (C:\adb) auch die Win USB-Treiber installiert.
Es wäre nett gewesen, diese Abweichung von der hier im Thread niedergelegten Vorgehensweise an uns zu kommunizieren, das hätte uns nämlich (aller Wahrscheinlichkeit nach) den ".android-Zinnober" erspart und Du hättest (hoffentlich) bereits ein gerottetes Vision.

Starte also ADB mit angeschlossenem Vision und versuche die nötigen Dateien zu pushen.

Viel Erfolg!
 
W

wofris

Fortgeschrittenes Mitglied
hävksitol;3323877 schrieb:
Es wäre nett gewesen, diese Abweichung von der hier im Thread niedergelegten Vorgehensweise an uns zu kommunizieren
Habe ich doch, der Beitrag von spearson78 bzw. der Folgebeitrag vom Oma7144 verweisen doch auf diese adb-Datei.
hävksitol;3323877 schrieb:
Starte also ADB mit angeschlossenem Vision und versuche die nötigen Dateien zu pushen.
Das funktioniert (wohl) nicht. Im Tablet ist bei Entwickleroptionen -> USB-Debugging -> aktiviert
Superuser.apk und su ins Verzeichnis adb kopiert.
Tablet im Standby über usb an den PC angeschlossen -> 2 LW erscheinen - Im usb-Manager werden die beiden LW und ein Gerät adb irgendwas angezeit
Im Vereichnis adb cmd.exe (dos-Prompt) gestartet
Dort eingegeben: adb wait-for-device -> return
Cousor springt eine Zeile runter, blinkt -> und die Box reagiert nicht mehr. Keine Eingabe über die Tastatur, return, ...
Wenn ich anstelle der Dos-Box die Datei devices.bat starte erhalte ich einmal eine Meldung: Waiting for device ... - Der Echo-Befehl in der Batch-Datei und ansonsten keine Reaktion.
Soweit war ich gestern auch schon, war aber der Meinung das es an dieser adb_usb.ini liegt das keine Verbindung zustande kommt.
 
hävksitol

hävksitol

Ehrenmitglied
wofris schrieb:
Habe ich doch, der Beitrag von spearson78 bzw. der Folgebeitrag vom Oma7144 verweisen doch auf diese adb-Datei.
Nur, daß wir nicht aneinander vorbei reden: Ich bezog mich in meiner entsprechenden Äußerung auf das ADB-Treiber-Pack von Wusel, bei dem nicht zu erkennen war, daß Du es benutzt hast. in der Tat verweist nämlich - ganz anders von Dir postuliert - keiner der beiden Beiträge von spearson78 darauf. Hingegen erwähnt der erste explizit die bewusste adb_usb.ini, nach deren Position im Dateisystem Du doch gefragt hattest, so daß man ganz klar annehmen musste, Du folgtest dem Weg von spearson78, um ADB fürs Vision zu etablieren, um dann anschließend - wie von Oma verlinkt - zu pushen.
Zwar verweist der Beitrag von Oma auf einen Beitrag, in dem dann erst auf Wusels ADP-Pack verlinkt wird, aber Omas Beitrag hatte ja klar das Ziel, lediglich die Befehle, die zum Pushen nötig sind, anzugeben. Denn zu diesem Zeitpunkt sollte die ADB-Infrastruktur ja schon (wie von spearson beschrieben) "stehen" - ein "Mischen" von Spearsons Vorgehensweise und Wusels ADB-Pack, wie von Dir praktiziert, war also nirgends vorgesehen, und insofern betrachte ich meinen Formulierung, daß Du "abgewichen" bist, ohne das zu kommunizieren, weiterhin als gerechtfertigt.


wofris schrieb:
Das funktioniert (wohl) nicht. (..)
Hier ist guter Rat teuer, da aus der Ferne die Diagnose schwer (bis unmöglich) fällt. Das einzige, was klar scheint, ist, daß die ADB-Treiber fürs Vision nicht installiert sind, woraus möglicherweise zu schließen ist, daß Wusels-ADB-Pack nicht beim Vision funktioniert.

Ohne die Installation des Android-SDKs (und/oder weitere Infos von spearson78) geht es bei Dir aber wohl nicht weiter.
 
wusel

wusel

Stammgast
wofris schrieb:
Das funktioniert (wohl) nicht.
Siehe Ergänzungen zu meinem Post:
https://www.android-hilfe.de/forum/odys-allgemein.1691/adb-connecten.187726.html#post-3313403

Der ursprüngliche Beitrag von 14:35 Uhr wurde um 14:44 Uhr ergänzt:

wofris schrieb:
Das installieren der USB-Treiber für Windows hat funktioniert. Das Vision wird erkannt.
Aber bei diesem Schritt:
habe ich ein Problem.
Der o.g. Schritt und auch der Beitrag mit dem Kindle haben als OS beide Linux.
Wo (= in welchen Ordner) muß die Datei adb_usb.ini denn bei einem Windows-Systen angelegt bzw. kopiert werden?
war vielleicht blöde dass ich direkt auf das Archiv verlinkt habe anstatt auf den Original-Post ...
dort findest Du nämlich genau diese Info am Ende des Posts (ADB_AddVendor.vbs) ...
 
W

wofris

Fortgeschrittenes Mitglied
Ach fühle ich mich gut.
Ich bin am Grinsen das meine Ohren Besuch haben.
wofris schrieb:
...
Es gibt: C:\Dokumente und Einstellungen\Username_x\
...
Muß dort ein Verzeichnis &quot;.android&quot; mit der adb_usb.ini angelegt werden?
Ich war ja soooooooooo nah dran :)

Mit der neuen adb-1.0.29.7z (wo das Script ADB_AddVendor.vbs drin ist) funktionierte es.
Superuser.apk ist drauf und läßt sich starten.

Dank an hävksitol - das er nicht die Geduld verloren hat
Dank an wusel - für den entscheidenden Hinweis.

Nun zum rooten eine letzte Frage:
Wie sehe ich ob ich als root unterwegs bin bzw. wie schalte ich root ein / aus ?
 
wusel

wusel

Stammgast
wofris schrieb:
Wie sehe ich ob ich als root unterwegs bin bzw. wie schalte ich root ein / aus ?
garnicht. Zunächst mal bist Du genauso unterwegs wie immer; erst wenn Du eine App installierst die root erfordert dann kommt beim Start ein Dialog (von der Superuser.apk) mit eine Frage 'Erlauben? JA/NEIN' ...
also probier z.B. mal den ES FileExplorer oder ähnliche Apps und konfiguriere in den Einstellungen root-Zugriff ...
 
Oben Unten