Cwm twrp adb

  • 12 Antworten
  • Neuester Beitrag
Diskutiere Cwm twrp adb im Onda V975M Forum im Bereich Onda Tablet Forum.
S

SciBee

Neues Mitglied
Konnte jemand schon eine funktionierende CWM oder TWRP oder einen ADB Treiber für das V975M testen?
Wenn ja - unter welchem ROM?
Bei mir mit Kitkat Beta2 finden CWM und TWRP keine kompatiblen Tabs bzw. Telephone und ADB funktioniert nur im Recovery mit Sideload Modus.
Da gibt's dann aber keine Sicherung, sondern nur die Installationsmöglichkeit.
Im voll gestarteten Tab-Zustand passt kein ADB Treiber bei mir und "adb devices" bleibt dann natürlich leer. Das Device VID_1F3A&PID_1002&MI_01 in die inf-Datei des Treibers zu patchen hilft leider auch nicht - keine Kommunikation obwohl der Treiber erfolgreich gestartet wurde (Win7x64).
USB-Debug ist natürlich enabled.

Würde gerne einen Full-Dump machen, um leichter das ROM wechseln zu können, war aber bisher erfolglos. :sad:
BTW: die Russen, auf die zwecks CWM immer wieder verwiesen wird haben in ihrem 138 Seiten Thread auch nichts, bemerken aber wohl, daß über sie geschrieben wird und suchen selbst danach :rolleyes2:
Dann gibt's sogar ein Crowd funding Projekt dafür - da tut sich aber auch nichts.
Weiß jemand mehr?:confused2:
 
S

SciBee

Neues Mitglied
Den Universaltreiber hatte ich zuerst probiert. Aber ein Blick in seine inf-Datei zeigt, daß dort eben die Device ID des V975M fehlt. Darum wird der Treiber nicht installiert.
Wenn man die Inf um die ID ergänzt wird er zwar gestartet, aber adb kann nicht darüber mit dem Gerät reden.
s.o.
 
S

SciBee

Neues Mitglied
Sorry für die späte Antwort - ich musste erst Mal Registry und System von den Treiberleichen befreien.
Google Latest Treiber funktioniert leider auch nicht.
Per Default fehlt die ID und trägt man sie ein startet der Treiber wieder, aber adb spricht nicht mit dem V975M - same procedure.
Mein Galaxy-III funktioniert an der selben Schnittstelle incl. Treiber problemlos.
Ach ja - das komplett installierte Android-SDK mag auch nicht mit dem Onda reden. Jedenfalls nicht mit der V4.4.2 Kitkat Beta2.

Hat das jemand am Laufen?
Wenn ja - in welcher Konstellation?
FW Version?
Treiber Version von...?

TWRP und CWM sind auch noch offene Möglichkeiten. Hat da schon jemand was getestet?
 
M

MB525

Fortgeschrittenes Mitglied
Der letzte Treiber läuft bei mir. Händisch ADB composite Device ausgewählt und Fehlermeldung ignoriert. ADB läuft.
 
S

SciBee

Neues Mitglied
Habe ich auch versucht - auch ohne den Treiber zu patchen.
Wird auch gestartet aber "adb devices" gibt weiter eine leere Liste aus. Funktioniert also bei mir nicht.
Welche FW verwendest Du?
Bei mir - Anhang...
 

Anhänge

M

MB525

Fortgeschrittenes Mitglied
KK 4.4.2v1 vom 14.03.2014, mass storage mode. 7x64, ADB device "12345678900".
 
Zuletzt bearbeitet:
S

SciBee

Neues Mitglied
Jetzt funktioniert ADB endlich!
Es lag nicht am ROM, sondern an der Einrichtung von ADB.

Bezogen auf das Android-SDK sind folgende Schritte erforderlich:

  • Android-SDK installieren. Updates laden. Guides dazu gibt's genug...
  • In SDK-Programmverzeichnis\sdk\tools in einem CMD Fenster als Admin ausführen: "android.bat update adb".
    Dadurch wird unter "C:\Users\Benutzername\" ein Verzeichnis ".android" mit Inhalt erzeugt.
  • In "C:\Users\Benutzername\.android" die Datei "adb_usb.ini" editieren.
  • In einer neuen Zeile den Wert "0x1F3A" - die ID des V975M - eintragen, speichern.
  • Das V975M einstecken; USB-Debugging enablen.
  • Im Gerätemanager den Treiber (Google Latest von unten) manuell installieren. ID muß nicht in den Treiber gepatcht werden, da sonst seine Zertifizierung verloren geht.
    Dann sollte ein "Android Composite ADB Device" im Gerätemanager erscheinen.
  • In SDK-Programmverzeichnis\sdk\platform-tools in einem CMD Fenster als Admin ausführen: "adb kill-server" (falls schon mal gestartet)
  • Ausführen "adb devices"
Danach erscheint endlich die Seriennummer des Geräts - die wohl bei allen gleich ist. Ich erhalte jetzt auch "12345678900" und die steht als Serial in den Geräteinfos.
 
S

SciBee

Neues Mitglied
Ich bastle gerade an einer CWM Recovery für das V975M V1 herum und habe dazu noch ein paar Newbie-Fragen::confused2:

Der Compiler läuft schon mal durch mit dieser BoardConfig.mk (für V1):
Code:
USE_CAMERA_STUB := true

# inherit from the proprietary version
-include vendor/onda/v975m/BoardConfigVendor.mk

TARGET_NO_BOOTLOADER := true
TARGET_BOARD_PLATFORM := meson8
TARGET_CPU_ABI := armeabi-v7a
TARGET_CPU_ABI2 := armeabi
TARGET_BOOTLOADER_BOARD_NAME := k12_MA975M8
TARGET_CPU_VARIANT := cortex-a9
TARGET_ARCH_VARIANT := armv7-a-neon

BOARD_KERNEL_CMDLINE := 
BOARD_KERNEL_BASE := 0x10008000
BOARD_KERNEL_PAGESIZE := 2048

# fix this up by examining /proc/block on a running device
# Boot image size is 33554432 bytes
# You can double check it with fdisk -l /dev/block/boot
BOARD_BOOTIMAGE_PARTITION_SIZE := 0x2000000
# Recovery image size is 33554432 bytes
# You can double check it with fdisk -l /dev/block/recovery
BOARD_RECOVERYIMAGE_PARTITION_SIZE := 0x2000000
# System image size is 1073741824
# You can double check it with fdisk -l /dev/block/system
BOARD_SYSTEMIMAGE_PARTITION_SIZE := 0x40000000
# user data image size is 4294967296 bytes
# You can double check it with fdisk -l /dev/block/data
BOARD_USERDATAIMAGE_PARTITION_SIZE := 0x100000000
BOARD_FLASH_BLOCK_SIZE := 131072

TARGET_PREBUILT_KERNEL := device/onda/v975m/kernel

#BOARD_HAS_NO_SELECT_BUTTON := true
# Use this flag if the board has a ext4 partition larger than 2gb
BOARD_HAS_LARGE_FILESYSTEM := true
  • TARGET_BOARD_PLATFORM := meson8 stammt aus default.prop der gedumpten Original Recovery Partition
  • TARGET_BOOTLOADER_BOARD_NAME := k12_MA975M8 stammt aus default.prop der gedumpten Original Recovery Partition
  • BOARD_KERNEL_BASE := 0x10008000 stammt aus output.txt der Enpacker Routine des Recovery
  • BOARD_KERNEL_PAGESIZE := 2048 stammt aus output.txt der Enpacker Routine des Recovery
  • Die Partitionsgrößen sind aus dem laufenden System mit o.g. Kommandos ermittelt
Alle anderen TARGET_... Parameter sind geraten.
Frage1:
Könnte jemand die Werte überprüfen bzw. korrigieren oder ergänzen?

Frage2:
Das resultierende Recovery.img ist 8,7MB groß. Das Fake update.zip 1,8MB. Kann das hinkommen?

Ich bekomme das V975M V1 nicht in den Fastboot Mode und kann das Recovery darum nicht mit "fastboot boot recovery.img" testen ohne einen Brick zu riskieren.
Frage3:
Kann mir jemand erklären, wie ich das Teil in den Fastboot Modus bekomme?

Hier auch noch die recovery.fstab

Code:
# mount point    fstype    device        [device2]

/boot       mtd         boot
/cache      yaffs2      cache
/data       yaffs2      userdata
/misc       mtd         misc
/recovery   mtd         recovery
/sdcard     vfat        /dev/block/mmcblk0p1        /dev/block/mmcblk0
/system     yaffs2      system
/sd-ext     ext4        /dev/block/mmcblk0p2
 
C

corax

Fortgeschrittenes Mitglied
Hallo

Zunächst mal @Scibee, vielen dank für deinen TWRP Mod ;)
Vielleicht kannst du mir hier weiter helfen. In englisch kapier ich es halt nicht so ;)

Zur Zeit läuft mein Onda mit deinem TWRP, zozak rom v3 based 1.1.0, TrickserMod und GravityBox

Ich würde jetzt gerne das killjoy script und pureperformac x ausprobieren in der hoffnung die letzten hänger auch noch loszuwerden.
Jetz bekomme ich den ADB treiben nicht installiert. Also sdk liegt im root C: Über den den SDK Manager habe ich den den treiber updaten/ install lassen.
Die adb_usb.ini unter C:\Users\....\.android sieht jetzt so aus, editiert mit txt editor

# ANDROID 3RD PARTY USB VENDOR ID LIST -- DO NOT EDIT.
# USE 'android update adb' TO GENERATE.
# 1 USB VENDOR ID PER LINE.
0x1F3A

Im Geräte Manager unter Laufwwerke sehe ich das onda und ganz oben habe ich ADB interface stehen mit gelben ausrufezeichen.
Die cmd gibt mir das aus siehe Anhang .

Selbst wenn ich den Treiber manuell suche und den Pfad C:\sdk\extras\google\usb_driver bekomme ich nur die Meldung Keinen Treiber gefunden. Was habe ich denn falsch gemacht?
 

Anhänge

hävksitol

hävksitol

Ehrenmitglied
Hello Arqtico,
welcome to the board. Please provide a German Google translation of your preceding posting, so that non-English users can follow the discussion and profit from your contribution. Thank you.

Hallo, Arqtico,
willkommen im Forum. Bitte liefert eine Google-Übersetzung Deines Beitrags nach, so daß auch nicht-englische Nutzer der Diskussion folgen und von Deinem Beitrag profitieren können. Danke.