WLAN Probleme - Sporadisch - Kein Traffic trotz Verbindung

M

mbefore305

Stammgast
213
Seit einiger Zeit habe ich WLAN Probleme. Obwohl mit der Fritzbox Verbunden fliessen keine Daten.
Das komtm plötzlich und sporadisch. Die Fehlersuche gestaltet sich schwierig.
Fritxbox 7590; dazu Raspberry Pihole. Fehler liegt aber entweder am Handy oder der Fritz.
Da meistens Aus/Einschalten des Wlan am Handy ausreicht, kann es ja nicht Pihole sein.
Seltsam ist in der Fritz, das das Handy in der Liste der ungenützten Verbindungen immer mehrmals auftaucht
- mit steigender Anzahl und unterschiedlichen IP Adressen - obwohl ich die Option "nutze immer die gleich IP Adresse"
in der Fritzbox gesetzt habe.

Gibt es eine Möglichkeit im Handy WLAN komplett zurück zu setzen? Ich kann noch nicht einmal die Fritzbox
komplett entfernen. Sobald ich Wlan einschalte verbindet sich das Handy mit der Fritz ohne PW Anfrage.

Handy ist auf dem neusten Stand (Android 11), der Fehler war aber auch vorher schon da. Hatte gehofft, durch
das Update würde das behoben.
 
Ich hatte vorgestern spätabends ein ähnliches Problem, weiß aber nicht, ob es mit deinem Problem zu tun hat. Auf Tablet und Reno2 kein Datenfluss, trotz Verbindung, Nvidia Shield meldete auch keine Internetverbindung, das Kuriose jedoch ist, der aktuelle Film auf Netflix lief weiter, bis zum Ende und so lange puffert Netflix definitiv nicht vor. Ich vermute stark, dass es an der Fritzbox liegt (habe die 7590 an Vodafone Kabel). Am Kabelmodem war, laut LEDs, auch alles in Ordnung. Nach Fritzbox Neustart war alles wieder ok.
 
Zuletzt bearbeitet:
  • Danke
Reaktionen: mbefore305
Fehler der Fritz schliesse ich bei mir aus, da in der Regel WLAN aus und wieder an am Handy die Probleme behebt. Aber es passiert immer wieder. Bin jetzt nicht ganz sicher, aber es scheint mir oft, wenn ich in Play Store Updates starte.
 
  • Danke
Reaktionen: Kamika242
Schalte mal Mesh aus, sofern Du noch Repeater etc. im Netz hast. Solche Fehlerbilder hatte ich mit Fritz-Mesh auch...
 
  • Danke
Reaktionen: Kamika242
Bei mir liegt das eigentlich immer an der Fritzbox. Nach einem Neustart geht es wieder wie gewohnt. Läuft allerdings seit längerer Zeit jetzt problemlos.
 
  • Danke
Reaktionen: Kamika242
Gestern im Betrieb hatte ich es auch, da gibt es keine Fritzbox. Und es fing wieder an, als ich mal im Play Store war.
Werde wohl mal ein komplettes Reset des Oppo machen müssen. Schade, das es wohl keine Möglichkeit gibt den Geräte Cache komplett zu löschen.
 
  • Danke
Reaktionen: Kamika242
unterschiedliche IP-Adressen kommen eigentlich nur zustande, wenn das Oppo unterschiedliche(zufällige) Mac-Adressen im WLAN verwendet. Schalte das doch mal ab...
 
  • Danke
Reaktionen: Kamika242
Wie kann ich das ändern/abschalten? Finde keine Option.
Dachte, die MAC-Adressen sind fest im Gerät gesetzt?
 
  • Danke
Reaktionen: Kamika242
Das muss Dir leider jemand sagen, der Oppo kennt. Vielleicht in den Sicherheitsoptionen. Oder suche mal in den Einstellungen nach "Mac" oder "zufällig".
 
  • Danke
Reaktionen: Kamika242
Nee. die MAC-Adresse ist fix im Gerät gesetzt. Unterschiedliche IP-Adressen sind normal da die vom Server (z.B. Fritzbox) dynamisch vergeben werden, außer man setzt dort (in der Fritzbox) einen Haken bei "Diesem Gerät immer die gleiche IP-Adresse zuweisen". Dann wird die IP-Adresse reserviert für das Gerät mit der entsprechenden MAC-Adresse. Für ein Handy aber in der Regel unwichtig. Wird eher bei stationären Geräten verwendet die von anderen Geräten über die IP-Adresse gesucht werden. Z.B. NAS oder Sat-Receiver.
 
Zuletzt bearbeitet:
  • Danke
Reaktionen: Kamika242, mbefore305 und Wattsolls
Richtig. MAC ist erstmal fix. Google hat aber mit Android 9 oder 10, bin mir jetzt nicht sicher, die Option eingeführt wahlweise für z.B. öffentliche Netze die MAC auf zufällig zu setzen. Soll halt für ein bisschen weniger Nachverfolgung sorgen.
 
  • Danke
Reaktionen: Kamika242
Bei Xiaomi wird die Adresse erstmal zufällig gesetzt. Bei anderen Herstellern muss man das Netz als "Heimnetz" deklarieren, um eine feste Mac zu identifizieren.

Aber schaue doch einfach in der Fritzbox nach, ob Du da viele Geräte hast...
 
  • Danke
Reaktionen: Kamika242
Also die Mac Adresse ist immer die gleiche im Oppo und der Fritzbox.
Im Handy war die Option "Duale WLAN Beschleunigung" eingeschaltet. Das habe ich jetzt mal deaktiviert.
In der Fritzbox war "Immer gleiche IP" deaktiviert. Eigentlich setze ich den haken immer, hab' ich wohl vergessen

Werde mal weiter beobachten. Aktuell sind die doppelten Einträge in der Fritz verschwunden.
 
  • Danke
Reaktionen: Kamika242
Beim Reno2 gibt es die Option "Datenschutz - Mac-Adresse des Gerätes" oder "Beliebige Mac-Adresse", dies legt man pro WLAN-Verbindung fest, dazu auf das Ausrufezeichen im Kreis hinter dem entsprechenden Netzwerk klicken.

Screenshot_2021-07-08-12-32-27-38.jpg Screenshot_2021-07-08-12-32-54-56.jpg

Bei meinem Heimnetzwerk habe ich die Mac-Adresse des Gerätes eingestellt, bei Fremdnetzwerken eine zufällige (Standard).

Die Mehrfacheinträge des gleichen Gerätes in der Fritzbox rühren eben von den zufälligen Mac-Adressen her. Hier nutzt auch "Immer die gleiche IP-Adresse vergeben" in der Fritzbox nichts, da die IP an die Mac-Adresse des Gerätes gebunden ist. Hast du bei der nächsten Verbindung eine andere Mac-Adresse, wenn der Datenschutz auf "Zufällig" steht, gibts natürlich auch ne andere IP-Adresse.
 
Zuletzt bearbeitet:
  • Danke
Reaktionen: mbefore305 und Wattsolls
Also cih klicke auf das "i" neben dem verbundenem Netzwerk. Dann komme ich auf "Details2.
Da steht IP Adresse, Geschwindigkeit, etc. aber nicht bzgl. MAC-Adresse oder Datenschutz.
Seltsam.
 
Doch, da gibt es den Punkt "Datenschutz", wie auf dem Bildschirmfoto. Kann mir nicht vorstellen, dass die Optionen von Reno2 zu Reno2 unterschiedlich sind.
 
Das wundert mich auch. Bist Du auch schon auf Android 11 / ColorOS 11 - CPH1907NV77_11_F.55
 

Anhänge

  • FritzDetails.jpg
    FritzDetails.jpg
    47,6 KB · Aufrufe: 129
  • Wow
Reaktionen: Kamika242
Ich weiß nicht genau, ich habe auch jedem Gerät in meinem Netzwerk direkt eine feste IP vergeben (Statisch), die von der Fritzbox zugewiesene und dort fest eingestellte, vielleicht taucht die Option "Datenschutz" dann erst auf? Kann ich mir aber nicht vorstellen.
Hast du wirklich das Reno2 oder das Reno2 Z?


Bei mir ist die Firmware mit CPH1907_11_F.55 bezeichnet. Ich hab die Option aber schon seit Erwerb des Handies aktiv, die ist also nicht neu.

Edith sagt: Geh mal in die Entwickleroptionen und schau, ob du die Option ganz oben auf dem Bildschirmfoto aktiv hast:

Screenshot_2021-07-08-19-45-51-47.jpg

Wenn jedoch nicht aktiv, sollte dein Reno2 aber eh immer die gleiche Mac-Adresse haben.
 
Zuletzt bearbeitet:
Also es ist definitiv das Reno 2 (ohne Z).
Meine FW hat noch ein NV im Namen.
Mac Random ist deaktiviert in den Entwickler Optionen.
Ich habe jetzt wieder so viel mit den Einstellungen gespielt, auch auf der Fritz, muss jetzt mal beobachten.
Ich mag keine sporadischen Probleme

Danke allen für Eure Hilfe!
 
  • Danke
Reaktionen: Kamika242
mbefore305 schrieb:
Mac Random ist deaktiviert in den Entwickler Optionen.

Eben deshalb fehlen auch die benannten, erweiterten Optionen in deinen WLAN-Einstellungen. Es ist gut möglich, dass "Beliebige Mac-Adresse" immer aktiv ist, auch wenn der Schalter auf "Aus" ist, dir deshalb aber nur die zusätzlichen Menüpunkte nicht angezeigt werden. Deshalb Schalter aktivieren, ggf. Neustart machen, schauen, ob das Menü da ist und dann in deinem Heimnetzwerk und wo sonst nötig, feste Mac einstellen.
 
Zuletzt bearbeitet:

Ähnliche Themen

Kamika242
Antworten
0
Aufrufe
505
Kamika242
Kamika242
Andro-Dösbaddel
  • Andro-Dösbaddel
Antworten
3
Aufrufe
786
Kamika242
Kamika242
G
  • Gamerheat
Antworten
6
Aufrufe
2.819
Gamerheat
G
Zurück
Oben Unten