Sony Xperia XZ - Diskussionsthread zur Firmware 41.3.A.2.24 (Android 8 Oreo)

  • 33 Antworten
  • Neuster Beitrag
K

kickers2k1

Ambitioniertes Mitglied
Threadstarter
Mir wird gerade nen Update auf 41.3.A.2.24 eingespielt, ich bin gespannt
 
Olley

Olley

Lexikon
Hab ich gestern auch bekommen war wohl nur Sicherheitspatch für Dezember.
 
F

flipdacrip

Experte
Echt Hammer, wie schnell Sony ist :thumbup:
Ist mein erstes Sony, daher meine positive Überraschung.

Wie groß war denn das Update?
Nach wie vor Android 8.0, oder?
Sind die "hüpfenden" WLAN-Verbindungspfeile weg, von denen ich hier öfters mal gelesen hab?

Grüße
 
K

kickers2k1

Ambitioniertes Mitglied
Threadstarter
Um die 250 MB und die Pfeile springen immer noch, Version steht auch noch bei 8.0.0.

Es steht ein Softwareupdate (v. 41.3.A.2.24) für Ihr Gerät zur Verfügung. Aktualisieren Sie die Software Ihres Geräts und genießen Sie die neuen Funktionen, die bessere Leistung, die Geschwindigkeit und die behobenen Probleme. Sie können die Software direkt in Ihrem Gerät aktualisieren. Es ist einfach und es ist kein Backup erforderlich.

Ist aber wohl Standartext
 
F

flipdacrip

Experte
Ah ok.

Hier steht ein Changelog: Sony Xperia XZ December 2017 OTA Update 41.3.A.2.24 - Android Infotech

Firmware Features
  • Upgraded to Same Android Oreo 8.0 With Latest Security Patch Updates.
  • New Notifications Design
  • Improved Wifi Performance.
  • New Settings Menu Design
  • Multi-Window View
  • Notification Direct Reply
  • Custom DPI Support
  • Added Status Bar Icon Options
Bin gespannt, was ihr in Richtung Performance (hatten ja doch auch ein paar Schwierigkeiten) und in Richtung Batterielaufzeit sagt.

Welche Kameraversion ist denn aktuell mit dabei? Bei der letzten 8.0er Version war es die 1.5.A.0.17. Evtl. hat sich hier ja nochmal etwas getan ;-)
 
Zuletzt bearbeitet:
Olley

Olley

Lexikon
Also die hüpfenden Verbindungspfeife sind immer noch wenn man lautlos oder/und NFC aktiv hat, tanzen die icons immer noch... Schade.
Sind die bei Sony blind oder finden die das toll?. [emoji58]
 
H

HEberh

Stammgast
@Olley o.k. Du hast ja recht das die hin und her hüpfen, aber die frage ist doch, ist das ein optischer Mangel oder geht das Gerät deshalb schlechter?
 
Olley

Olley

Lexikon
Schlechter nicht, ist ein optischer Mangel, nicht mehr, nicht weniger.
 
H

HEberh

Stammgast
@Olley o.K. dann werden wir wohl erstmal damit leben müssen. Was ich natürlich nicht weiß ob dies auch mit anderen Launchern genau das selbe ist, und ob es bei anderen Geräten mit Android 8.0 auch so ist (z.B. Pixel Geräten).
 
K

kickers2k1

Ambitioniertes Mitglied
Threadstarter
@flipdacrip Kameraversion ist jetzt die .18
 
G

Gonz05

Neues Mitglied
Seit ich das Update vor einigen Tagen installiert habe, funktionieren auf meinem XZ die seitlichen Lautstärke Tasten nicht mehr. Geht das noch sonst jemandem so? Gibt es hierfür irgendwo eine Einstellungsoption?
 
R

Radioaktiv

Neues Mitglied
Den Patch habe schon länger drauf. Die Lautstärke Tasten funktionieren, dafür andere Sachen nicht...

- WLAN CALL (Telekom), wo kann ich den aktivieren?
- Akku Laufzeit ist mies, mit Nougat hatte ich zur Mittagspause noch 85-90%, heute sind es 60-70% (gleiche Apps, gleiche Nutzung)
- apxHD, wieso kann das nicht in den Entwicklerioptionen eingestellt werden? Damit der Sound über Bluetooth endlich wieder wie bei Andro 5.1 ist.
- automatische Displayhelligkeit, wird hell und dunkel in sekundentakt..

Das größte Ägernis ist aber der WLAN. Seit dem Update verbindet sich das XZ gar nicht erst oder nur instabil mit dem bekannten WLAN Netzwerken. Auch das neu einrichten und der notwendige Factory Reset (Apps gingen auf und Zu und es blieb hängen) nach dem OTA Flash des Andro hat keine Hilfe gebracht...

Gernell ist die Performance schon gut, an vielen Ecken ist schneller und besser zu bedienen, wenn die fünf Punkte nicht wären...
 
D

Danny_Wilde

Experte
Ein Factory Reset muss gerade nach einem größeren Versionssprung nicht unbedingt alle Fehler beheben. Um ganz sicher zu gehen sollte man vor dem OTA Update schon einen Reset durchführen. Sollte jetzt irgendwie ein Fehler in der Firmware sein, wäre es die beste Lösung die Firmware neu zu flashen und zu wipen. Daten natürlich vorher sichern. Ist natürlich ärgerlich, das du erst alles neu eingerichtet hast, aber ich würde diesen Weg gehen.
 
Olley

Olley

Lexikon
@Radioaktiv

WLAN call, aktivierst du in den Wlan Einstellungen, funktioniert bei mir einwandfrei bei o2. Und das mit aptx HD kann ich auch aktivieren, allerdings nutze ich Sony Kopfhörer und die haben LDAC, das wird je nach Gerät automatisch aktiviert. Akku läuft auch Wunderbar hab jetzt noch 50% seid 4:45 uhr morgens. Das mit der Helligkeit habe ich jedoch auch, ist sehr empfindlich geworden. Screenshot_20171218-164505.png

Screenshot_20171218-164917.png
 
R

Radioaktiv

Neues Mitglied
@danny
Danke für den Tipp. Wie sollte der Flash aussehen, über das Xperia Flash Tool?

@Olley
Die Einstellung habe ich gar nicht. Ich hatte zu Beginn das Telekom Branding mit Telekom OS. Dann habe ich mit dem Xperia Flash Tool die normale ohne Branding geflasht. Diese Originale 7.1 hat sich dann auf Oreo upgedatet...

Hier ein Screenshot meiner WLAN Einstellungen...

[Screenshot_20171218-224055.png

Wenn der WLAN Call nicht in der originalen FW drin ist, wo dann? Bei der 7.1 original Sony FW gab's das ja auch...

Langsam verstehe ich die Welt nicht mehr, mein Akku ist schnell leer, WLAN Call nicht vorhanden, genau den brauche ich, weil ich viel im Ausland bin, das WLAN ist instabil und in den Entwickleroptionen kann ich den Audio Codec nicht umstellen... Das kann doch nicht alles am unsauberen Update liegen?

Indemfall, wieder alles sichern. Dann Flaschen mit wipe?

EDIT:
Da mich das ganze so aufregt, habe ich alles gesichert, einen Factory Reset gemacht und per Flashtool die gleiche FW nochmal geflasht. Der WLAN Call fehlt in den Einstellgungen noch immer... Wie sich der Rest entwickelt, kann ich erst die nächsten Tage sagen.

Evtl. muss ich noch ne olle Telekom Oreo flashen... :/
 
Zuletzt bearbeitet:
Olley

Olley

Lexikon
Ja richtig. Dein Problem ist Telekom, du brauchst die telekom gebrandete fw sonst gehts nicht mit WLAN call.
 
R

Radioaktiv

Neues Mitglied
Olley schrieb:
Ja richtig. Dein Problem ist Telekom, du brauchst die telekom gebrandete fw sonst gehts nicht mit WLAN call.
Jetzt echt? Mit der Custom Nougat ohne Branding ging es ja auch und ich konnte es auswählen und nutzen... Was macht jemand, der das Gerät selbst kauft und dann eine O2, Telekom oder Vodafone Karte reinsteckt, muss der dann erst mit dem Flashtool was anderes darüber bügeln und sein Handy "branden"?

Akutell muss ich nicht ins Ausland und werde warten, ob der WLAN Call mit 'nem Update nachgeschoben wird. Sonst flashe ich vor der Reise ins Ausland nochmal neu... Immerhin scheint das WLAN nun schonmal stabil zu laufen und das OS an sich nochmal einen Tick flotter.

Danke vielmals für eueren Tipp @Danny_Wilde und @Olley
 
Olley

Olley

Lexikon
@Radioaktiv, o2 hat keine brandings aus diesem grund bin ich auch dort. Bei Vodafone und telekom ist es anders. Das Problem hatte ich auch beim Google Pixel, mit o2 kein WLAN call nur wenn ich eine Telekom sim eingelegt habe gings, da Telekom ja damals exklusiv das Pixel vertrieben hat. [emoji6]
 
R

Radioaktiv

Neues Mitglied
Achso ok... und welche FW hast du aktuell geflasht, dass der WLAN Call funktioniert?

Ich verstehe es einfach nicht, dass meinem XZ der WLAN Call im OS trotz der Telekom SIM nicht auftaucht. Die Custom 7.1.1 konnt es ja auch.
Wenn man sich ein freies Gerät kauft und dann eine Telekom SIM einlegt, sollte der WLAN Call ja auch funktionieren.
 
Olley

Olley

Lexikon
Ich habe die costum de drauf, also ohne Branding, mit der Vodafone Software die damals hier drauf war gings auch nicht. Die Einstellung taucht erst garnicht auf, sowie bei dir jetzt. Das Problem liegt an Telekom, wenn sie das fürs XZ nicht freigegeben, sondern nur per branding dann ist das leider so. Beim S8 isses bei mir genauso wie bei dir. Deswegen hab ich noch das XZ da funktioniert alles mit o2. [emoji16]
 
Oben Unten