Aquaris X/X Pro - Firmwareupdate mit Root

P

Pacer

Erfahrenes Mitglied
Threadstarter
Falls es hier falsch sein sollte, bitte separieren.

Hat schon jemand bei einem gerooteten Handy ein Update auf 1.3.4 ohne Brick und mit Beibehaltung der alten Daten geschafft?

bin da nach meinem letzten Fehlschlag bisschen vorsichtig.
 
loopi

loopi

Ehrenmitglied
Ich kann hierzu im Moment nichts beitragen, aber habe mal ein eigenes Thema daraus erstellt, da dies meist ein eigenes größeres Thema wird bei jedem Modell.
 
Zuletzt bearbeitet:
blur

blur

Lexikon
Bedeutet das, dass Du schon ein TWRP nutzt und gerootet hast?
Interessant wäre das Rooten mit Magisk, dafür gibt es dann ein Uninstaller-Tool zum temporären Unroot.
 
einfachGaer

einfachGaer

Ambitioniertes Mitglied
Ich habe das ota Update mit installiertem twrp und magisk gemacht. Nach dem Update wurde mein Handy zwangs verschlüsselt und die Recovery sowie root waren nicht mehr vorhanden. Aquaris X
 
einfachGaer

einfachGaer

Ambitioniertes Mitglied
Nein, ohne einer Deinstallation. Hatte mich auch gewundert, hat aber geklappt.
 
blur

blur

Lexikon
Sorry, leider verstehe ich noch nicht ganz.
Klar, Recovery und Root ist nach einem Update weg, aber was bedeutet das "zwangs verschlüsselt"?
 
einfachGaer

einfachGaer

Ambitioniertes Mitglied
Mit zwangs verschlüsselt meine ich, dass mein Handy ohne Verschlüsselung ausgeliefert und nach dem Update beim Hochfahren verschlüsselt wurde. Ich konnte dabei nicht eingreifen.
 
einfachGaer

einfachGaer

Ambitioniertes Mitglied
Ja dieser ist noch unlocked. Auch die Warnung beim Start des Handys war gleich nach dem Update noch vorhanden. Ich habe direkt nachdem das Handy hochgefahren ist, in den fastboot modus gebootet und konnte twrp ohne Probleme flashen.
 
P

Pacer

Erfahrenes Mitglied
Threadstarter
Hat bei mir ebenfalls mit OTA Update geklappt.
 
blur

blur

Lexikon
Ich will von 1.3.4 kommend ein OTA Update auf die 1.3.5 machen, aber lande dann, wenn der Updateprozess einen Neustart machen will immer wieder im TWRP Recovery.
Egal wie, ich kann das auch nicht überspringen mit den Lautstärketasten.
Und wenn ich dann aus der TWRP-Recovery weiterboote, kommt die Meldung, Aktualisierungsfehler.
Habe es bereits mehrmals versucht.

Hat wer eine Idee, wie ich doch ein OTA-Update hinbekomme?
-- Dieser Beitrag wurde automatisch mit dem folgenden Beitrag zusammengeführt --
Ich will ja meine Einstellungen und Daten erhalten, könnte ich es über fastboot mit der veränderten Batchdatei probieren, das hatte ich für das X Plus gefunden:
[Root] Firmware Update trotz Root [bq Aquaris X5 Plus]

2.) Die Datei 8976_fastboot_all_images.bat dahingehend modifiziert, dass ich die Passage „fastboot flash userdata userdata.img“ entfernt, um meine Daten zu erhalten.
 
P

phryneas

Neues Mitglied
Ich habe soeben erfolgreich auf 1.3.5 geupdated.

Meine Vorgehensweise:

Ich habe die neueste firmware .zip von Support - Aquaris X heruntergeladen und doppelt entzippt.

Dann habe ich in der 8953_fastboot_all_images.bat die folgenden Zeilen entfernt:

fastboot erase boot
fastboot flash userdata userdata.img
fastboot flash recovery recovery.img
fastboot flash boot boot.img


Die userdata-Zeile muss definitiv entfernt werden, weil das Handy sonst komplett gewiped wird.

Bei der recovery und boot war ich mir nicht sicher: mit dem offiziellen BQ-Tool wird der Bootloader gesperrt, wenn man ein Update ausführt. Wenn man ihn dann wieder entsperren will wird das Handy gewiped. Um auf Nummer sicher zu gehen habe ich die beiden also auch auskommentiert.

Nachdem man diese Änderungen gemacht hat kann man die 8953_fastboot_all_images.bat ausführen.

Ergebnis: Das System ist auf 1.3.5 geupdated, ich habe keine Daten verloren.
Bootloader ist weiterhin unlocked und critically unlocked.

Soweit also alles in Ordnung.
Root ist weg, das war zu erwarten. Was mich erstaunt: TWRP ist weg und muss mittels `fastboot flash recovery twrp-3.1.1-0-bardock.img` neu geflasht werden.
Dann kann man das Gerät auch erneut rooten. (`adb sideload Magisk-v12.0.zip` und gut ist.)
 
blur

blur

Lexikon
Uff, ich dachte, ich könnte mir es einfach machen mit einem OTA-Update.
Nachdem das nicht wollte, habe ich via Recovery den Magisk-Uninstaller installiert, danach ging nichts mehr "Device corrupted ...." - da habe ich erst mal, unabhängig vom Wetter, tüchtig geschwitzt.

Aber ich kam ja noch in Fastboot und konnte so dann die 1.3.5 flashen.
Vorher die 4 Befehle, so wie @phryneas das vorgeschlagen hat, aus der Batch-Datei entfernt und
voila, so habe die 1.3.5 und sogar noch meine Einstellungen und Daten und nix ist mehr corrupted.
:thumbsup:
 
blur

blur

Lexikon
Zwei Dinge waren und blieben bei mir komisch, Root blieb erhalten und ich konnte WLAN nicht einschalten.
Habe dann eine Restore von 1.3.4 gemacht und noch mal mit der angepassten Batch-Datei geflashed, immer noch kein WLAN.

Musste dann den bitteren Weg gehen die Firmware komplett zu flashen, nun geht WLAN wieder, aber natürlich waren meine Daten weg.
Immerhin, mit Titanium waren meine 45 Apps schnell wieder da.
 
P

phryneas

Neues Mitglied
Whoa, das ist Weird - bei mir geht WLAN noch. Da würde mich jetzt interessieren, welche Erfahrungen andere gemacht habem.
 
blur

blur

Lexikon
Es kann gut sein, dass ich mir vor der Aktion ein Problem eingehandelt hatte und deshalb das WLAN nicht mehr wollte.
Nachdem ich über das Recovery den Magisk Uninstaller flashen wollte, hatte ich in der selben Sekunde einen Blackscreen und danach "Device corrupted".
 
einfachGaer

einfachGaer

Ambitioniertes Mitglied
Bei mir das selbe verhalten wie bei blur, jedoch ohne den uninstaller. Danach habe ich das Update nocheinmal drüber gebügelt aber nur userdata.img aus dem Script entfernt. Der bootloader war immer noch geöffnet und ich konnte gleich hinterher im fastboot modus twrp flashen und Magisk installieren.
 
blur

blur

Lexikon
Beim nächsten Update werde ich auch nur das userdata.img rausnehmen. Recovery und Root ist ja schnell wiederhergestellt.
-- Dieser Beitrag wurde automatisch mit dem folgenden Beitrag zusammengeführt --
Eine Sache war noch merkwürdig nach der vollen Installation der Firmware:
Magisk bekam kein Root. Im Magisk Manager stand, dass die aktuellste Version die 12.0 installiert ist, trotzdem kein Root.
Das Ganze zweimal erfolglos probiert.
Beim dritten Mal das Gerät nicht hochfahren lassen (fastboot reboot gelöscht), sondern gleich TWRP und danach Magisk installiert,
und siehe da Root war vorhanden.
 
blur

blur

Lexikon
Jetzt habe ich ein schnelles und komfortables Update auf 1.3.6 hinbekommen.
userdata.img und recovery.img aus der Batchdatei rausgenommen,
danach direkt in das TWRP-Recovery gebootet um Magisk zu installieren.
Weiter hochfahren fertig - alles ist da.
:thumbsup:
 
Oben Unten