Mediapad CMR-W09 bricked?

  • 20 Antworten
  • Neuester Beitrag
Diskutiere Mediapad CMR-W09 bricked? im Root / Custom-ROMs / Modding für das Huawei Mediapad M5 10.8 im Bereich Huawei MediaPad M5 10.8 Forum.
N

Nico2422

Neues Mitglied
Hallo,

ich hoffe das mir hier vielleicht jemand helfen kann. Ich bin mit meinem Latein für mein CMR-W09 am Ende.
Ich habe versucht mein Tablet zu rooten was auch bis zu einem gewissen Grad funktioniert hat.
Vorgegangen bin ich nach der Anleitung von XDA um mein Tablet auf die 161 Firmware downzugraden, das hat auch alles geklappt und ich
konnte danach den Bootloader unlocken.

Danach musste ich 2 Ordner unter Cust sowie Version von normal auf eu umbenennen, sodass das Tablet wieder als CMR-W09 richtig erkannt und alle Updates
durch die Systemaktualisierung aufgespielt werden konnten. Ich habe danach versucht Magisk aufzuspielen und bei Version 9.0.1.190 das Tablet zu rooten. Dabei ist mir ein Fehler unterlaufen und ich dachte -kein Problem- fängst eben wieder von vorn an.

Als ich wieder die 161 aufspielen wollte, ist irgendetwas völlig schiefgegangen. Es scheint als wurde der Bootloader überschrieben bzw. beschädigt. Das Tablet zeigt jetzt beim Starten nur ein grünes Bild mit einem blauen und einem roten Balken an. Es bootet zwar in das System aber es fehlen grundlegende Informationen. der Playstore ist nicht mehr da genauso werden nur noch die absolut nötigsten Apps angezeigt. Unter Einstellungen über das Tablet steht nicht mehr CMR-W09, sondern nur noch CMR bzw. CMRXX.
Ich glaube ich habe versehentlich etwas Wichtiges gelöscht bzw. nicht wieder hergestellt.

Ich hoffe ich habe es einigermaßen Verständlich beschrieben.

Es hat vorher alles mit den heruntergeladenen Firmware Versionen funktioniert, aber jetzt bekomme ich gar nichts hin.
Hat jemand eine Idee was ich noch versuchen könnte? Oder kann mir helfen?

Vielen Dank

Nico
 
Zuletzt bearbeitet:
rene3006

rene3006

Inventar
Das Tab mal aus.
Dann Lautstärke plus drücken und mit USB an Steckdose anschließen, dabei Lautstärke plus weiter halten.
Nun sollte eigentlich die eRecovery erscheinen, dort Wlan verbinden und downloaden lassen.
 
N

Nico2422

Neues Mitglied
Hallo,

danke für die Antwort. Ich hatte das mit der eRecovery schon probiert. Leider klappt es nicht, das Tablet schreibt jedes Mal einen Fehler.
Ich hatte mich jetzt noch weiter belesen und denke, dass ich versehentlich die NVME Partition beschädigt habe. Wenn ich das richtig verstehe gibt es dann keine Möglichkeit das Tablet zu reparieren.
 
rene3006

rene3006

Inventar
@tecalote
Hast du hier noch eine Idee?
 
tecalote

tecalote

Guru
@rene3006 Ja, habe ich.
@Nico2422 Lade diese Firmware von hier herunter :

Huawei MadiaPad M5 CMR-W09 hw eu HLRCF Cameron-W09A 9.0.1.160(C432E3R1P3T8) Firmware 9.0.0 r3 EMUI9.0.0 05014XYA [androidhost.ru].zip - AndroidHost.RU

Man braucht dazu einen Browser wie Brave - da die Website werbeverseucht ist. Aber die Firmwares, die dort "lagern" sind original Huawei Firmwares und zwar volle Versionen anstelle von FullOTA Firmwares.
D.h. sie eignen sich wunderbar für eine Reparatur.

In Brave muß man auf das Brave Schutzschild Symbol klicken und dort auf den Pfeil nach unten mit den erweiterten Optionen. "Verbindung auf https upgraden" sowie "scripte blockieren" ausschalten, aber generelles Schutzschild anlassen - dann klappt der Download.

Die heruntergeladene zip mit 7zip entpacken. Den Inhalt gegebenenfalls weiter entpacken, bis man den Ordner Software öffnen kann. Darin befindet sich der Ordner "dload"
Darin sollte nun entweder eine Update.zip oder Update.app sein, sowie ein Unterordner oder mehrere mit der jeweiligen Modell cust zip.

Den Ordner dload mit dem gesamten Inhalt ins Hauptverzeichnis der SD Karte oder USB-OTG kopieren.
Das Gerät im ausgeschalteten Zustand mit Vol+ und Vol- und Powertaste (alle gleichzeitig drücken) starten und die Tasten gedrückt halten - bis das Gerät ins EMUI Recovery bootet und die Firmware Installation beginnt - in dem Moment die Tasten auslassen.

Wenn es 100% durchläuft, ist das Gerät wieder in Ordnung. Die Firmware resetet alles und repariert alles.
Wenn es nicht klappt, ist bloß die Recovery Partition beschädigt.
In dem Fall wäre es notwendig, vorab die Recovery Partition zu reparieren um die Firmware flashen zu können (das ist eine eigener Vorgang).
Erstmal so probieren.
 
Zuletzt bearbeitet:
rene3006

rene3006

Inventar
@tecalote
Stimmt an Dload habe ich diesmal überhaupt nicht gedacht.
 
N

Nico2422

Neues Mitglied
Super, Danke für die Mühe 😀.
Ich probiere es, sobald ich alles heruntergeladen habe geht nur langsam voran (12 Stunden zeigt er).
 
tecalote

tecalote

Guru
@Nico2422 Sag Bescheid. Ich kann erst am späten Abend wieder rein gucken, bin jetzt dann auf Arbeit.
Aber ich antworte auf jeden Fall.
 
rene3006

rene3006

Inventar
@Nico2422
Feedback wäre dann erwünscht.
 
N

Nico2422

Neues Mitglied
So, kurze Rückmeldung.

Vielen Dank für Eure Hilfe.

Das Update lief Fehlerfrei durch und ist jetzt wieder einigermaßen nutzbar. Der Startbildschirm ist immer noch seltsam (grüner Bildschirm mit rotem und blauem Balken) und in dem Updatepaket sollte eigentlich laut der beiliegenden Anleitung noch das Vendor Update liegen.
Das fehlt aber leider. Dadurch scheint das Tablet nicht als EU Tablet erkannt zu werden.

Was positiv ist, der Playstore sowie die wichtigeren Apps sind wieder da. :)

Anbei versuche ich 2 Bilder anzuhängen eines von dem Vendor Problem und das Tablet wird jetzt als CMR erkannt (vorher CMR-W09)
habt Ihr da vielleicht noch eine Idee?

Dankeschön :)
 

Anhänge

tecalote

tecalote

Guru
@Nico2422 Die Vollversion enthält das Vendor Update (bloß nicht sichtbar, sondern in der Custom update.app / oder zip integriert)
Frage : Hattest Du den kompletten Inhalt des Ordners "dload" auf die Speicherkarte kopiert?
Denn wenn Du nur die Hauptfirmware genommen hast, dann fehlt das.

Solltest Du aber alles vom Ordner dload in der Ordner Struktur - wie es unter dload vorhanden ist exakt so kopiert haben - dann liegt es daran, weil Du beim Root das hw/normal geändert hast auf nur eu? (Richtig wäre hw/eu).
 
N

Nico2422

Neues Mitglied
@tecalote Ich habe den gesamten Ordner Inhalt kopiert alles, was im dload Ordner in dem Archiv war.

Das mit dem umbenennen des Ordners hatte ich versucht wieder rückgängig zu machen aber der Ordner unter Version fehlt leider.
Ich versuche das aber gleich nochmal.
 
tecalote

tecalote

Guru
@Nico2422 Ich habe mir interessehalber die Firmware heruntergeladen.
Es ist so, dass die Firmwares von der Seite unterschiedlich gepackt sind.
Bei der Version muß man nur die heruntergelade zip 1x entpacken und nicht weiter.
Man holt dann einfach den dload Ordner aus dem Ordner "Software" raus und kopiert diesen zum flashen - so wie er ist (die darin befindlichen zip Dateien darf man nicht entpacken!!)

So wie der dload Ordner (mit dem Unterordner, indem die "update_sd_CMR-W09_hw_eu.zip" ) ist, muß das geflasht werden.
Damit sollte das Problem eigentlich behoben sein.
 

Anhänge

N

Nico2422

Neues Mitglied
Genau so hab ich das gemacht ich habe nur den dload Ordner kopiert mit der Update.zip und dem CMR-W09_hw_eu Ordner darin ist die
update_sd_CMR-W09_hw_eu.zip.

Ich hab das alles so gelassen und als Endergebnis die beiden oberen Bilder bekommen.

Ich hab schon ein paar Tablets und Telefone gerootet bzw. mit Costum roms geflasht, aber das Huawei ist das zickigste. 😄
 
tecalote

tecalote

Guru
@Nico2422 Ich melde mich morgen wieder - irgendeine Lösung sollte es geben. Ich wüsste da noch ein paar.
Erstmal Guten Rutsch ins Neue Jahr :)
 
N

Nico2422

Neues Mitglied
Danke, wünsche ich auch. 😀
 
tecalote

tecalote

Guru
@Nico2422 Wenn Dein Gerät jetzt nur noch als CMR und nicht als CMR-W09 erkannt wird - bzw. Vendor und Contry Info fehlt - dann bedeutet es, dass Du bei dem fehlgeschlagenen Root-Versuch bzw. dem Downgrade durch irgendwas die Infos in deiner oeminfo vom Gerät beschädigt hast.
Das lässt sich nicht ohne weiteres in Ordnung bringen.

Ich brauche zunächst die genauen Systeminfos über Fastboot Modus. Im Terminal folgende Befehle eingeben und als Textdatei oder Screenshot speichern und hier posten:
Code:
fastboot devices
fastboot oem get-product-model
fastboot getvar vendorcountry
fastboot oem get-build-number
fastboot getvar rescue_enter_recovery
fastboot oem oeminforead-SYSTEM_VERSION
 
N

Nico2422

Neues Mitglied
Hallo,

@tecalote anbei der gewünschte Screenshot. Leider nicht sehr ergiebig. 😟
Bitte nicht wundern, dass es die 9.0.1.182 ist. Ich hatte mir von Androidhost nochmals testweise diese heruntergeladen. Aber das Ergebnis ist dasselbe egal, welche ich flashe.
 

Anhänge

tecalote

tecalote

Guru
@Nico2422 Ist klar. Die Firmware enthält alles - mit Ausnahme der "oeminfo"
Diese ist auf Deinem Gerät beschädigt und daher müsste diese repariert werden.
Wenn die oeminfo wieder in Ordnung gebracht wäre und man flasht dann die Firmware nochmal, wäre wieder alles perfekt.

Nun ist es nicht einfach unter EMUI 9 für dieses Modell die oeminfo zu reparieren.
Ich überlege mir was und melde mich innerhalb ein paar Tagen wieder - sobald mir eine Lösung dazu einfällt.
 
N

Nico2422

Neues Mitglied
Hallo,

ich habe das jetzt über die letzten Wochen immer mal wieder versucht zu flashen und zu reparieren. Leider klappt es nicht. Ich bekomme die OEMinfo nicht wiederhergestellt.

So langsam würde ich dann erstmal aufgeben und hoffen, dass Euch vielleicht noch was einfällt bzw. es irgendwann möglich wird das Wiederherzustellen.
Trotzdem will ich nochmal Danke sagen für Eure Hilfe. :)
 
Ähnliche Themen - Mediapad CMR-W09 bricked? Antworten Datum
0