Nexus4 Bootet immer in TWRP

  • 7 Antworten
  • Neuester Beitrag
Diskutiere Nexus4 Bootet immer in TWRP im Root / Custom-ROMs / Modding für Google Nexus 4 im Bereich Google Nexus 4 Forum.
sirbender

sirbender

Stammgast
Hallo,

ich habe neulich TWRP und LineageOS vom 31.01.2017 installiert. Mein Nexus4 lief super damit.

Nun wollte ich gestern das neuste LineageOS aufspielen ueber die System-Update Funktion in Android.

Davor habe ich in TWRP gebootet und ein Backup erstellt. Danach neu gestartet und in Android die Update-Funktion angestossen. Es sagte mir nach dem Download, dass es nun ins Recovery bootet und das Update installiert.

Es hat auch in TWRP gebootet aber nichts ist passiert. Es wurde nichts installiert. Einfach nur das TWRP Menue war zu sehen. Also hab ich neu gebootet. Es landete aber wieder im TWRP Menue. Trotz mehrerer Neustarts landete ich immer wieder in TWRP.

Auch ein Wipe und Neustart fuehrte wieder ins TWRP. Auch ein Restore des Backups fuehrte wieder ins TWRP.

Ich bin im Moment ratlos. Was kann ich tun?

vielen Dank,
sb
 
S

Seibertino

Ambitioniertes Mitglied
Das ist weil dein Nexus 4 genauso wie ein Huawei Systemupdates über das Original Recovery macht.
 
S

Seibertino

Ambitioniertes Mitglied
Ist der Bootloader deines Gerätes unlocked und/oder hast du root
 
S

Seibertino

Ambitioniertes Mitglied
sirbender schrieb:
Hallo,

ich habe neulich TWRP und LineageOS vom 31.01.2017 installiert. Mein Nexus4 lief super damit.

Nun wollte ich gestern das neuste LineageOS aufspielen ueber die System-Update Funktion in Android.

Davor habe ich in TWRP gebootet und ein Backup erstellt. Danach neu gestartet und in Android die Update-Funktion angestossen. Es sagte mir nach dem Download, dass es nun ins Recovery bootet und das Update installiert.

Es hat auch in TWRP gebootet aber nichts ist passiert. Es wurde nichts installiert. Einfach nur das TWRP Menue war zu sehen. Also hab ich neu gebootet. Es landete aber wieder im TWRP Menue. Trotz mehrerer Neustarts landete ich immer wieder in TWRP.

Auch ein Wipe und Neustart fuehrte wieder ins TWRP. Auch ein Restore des Backups fuehrte wieder ins TWRP.

Ich bin im Moment ratlos. Was kann ich tun?

vielen Dank,
sb
Aber wie ich das sehe versucht das Smartphone dauernd das Update zu machen aber es hat nicht das richtige recovery..Wenn dein Bootloader unlocked ist wovon ich ausgehe da du TWRP hast könntest du über fastboot das Original Recovery.img flashen..dann müsste das Update eigentlich starten und dein Handy nach dem Update wieder Rebooten..Danach kannst du ja wieder TWRP flashen
 
A

AraldoL

Fortgeschrittenes Mitglied
Es gab gerade vor ein paar Tagen ein Update von TWRP für Mako: 3.0.3.0, das sollte eigentlich das Problem nicht mehr haben. Selber sehe ich das Mitte kommender Woche, habe inzwischen auch LineageOS 14.1 drauf mit TWRP-3.0.3.0 aber seit Installation gab es für mich noch kein Update. Dienstag sollte eigentlich das nächste Weekly Build erscheinen dann erfahre ich ob der Bootloop noch existiert.

Ansonsten wäre die Alternative, OTA-Updates mit dem eingebauten Updater nur laden aber nicht installieren lassen. Dann selber in TWRP booten und von dort die Zip-Datei manuell flashen. Das umgeht den Bootloop auch, bequemer wäre es aber natürlich wenn es direkt mit dem Updater funktioniert.
 
sirbender

sirbender

Stammgast
Vielen Dank an euch alle fuer die Informationen und Hilfe. Ich flashe gerade TWRP für Mako: 3.0.3.0 und danach das aktuelle LineageOS vom 7ten Februar. Ich hoffe dann funktioniert es wieder.

Mein Bootloader ist natuerlich entlocked. Ein Root habe ich mir von TWRP aber nicht 'legen' lassen. Ist das vielleicht ein Grund fuer die Boot-Schleife? Oder liegt es einfach am fehlerhaften TWRP?

Wie ist es eigentlich mit den woechentlichen Updates von LineageOS? Kann man die einspielen und es laeuft alles wie vorher? Oder muss man immer wieder die GApps usw. neu aufsetzen und Apps neu installieren?
 
fazerdirk

fazerdirk

Experte
Zu 1. Es liegt an TWRP
Zu 2. Nein ... läuft wie vorher.