R/W Mount funktioniert nicht

  • 30 Antworten
  • Neuester Beitrag
Diskutiere R/W Mount funktioniert nicht im Root / Custom-ROMs / Modding für Huawei Ascend P1 im Bereich Huawei Ascend P1 Forum.
S

Skyes

Neues Mitglied
Hallo zusammen,

habe mein P1 auf Android 4.1.1 aktualisiert. Danach auch nach Anleitung im Forum gerootet. Die App "Root Checker" bestätigt, daß es gerootet ist.

SuperSU läuft und auch LBE Security Master. Mein Problem: Ich kann das /system Verzeichnis nicht zum Schreiben mounten, kann also die hosts-Datei durch AdAway nicht anpassen lassen und auch das GPS-Log Problem nicht lösen.

Die Meldung von Total Commander ist wie in der Shell auch: "Re-mount fehlgeschlagen, mount: Read-only file system". SuperSU meldet, daß Root-Berechtigungen erfolgreich an Total Commander gegeben wurden.
In der Shell nach Eingabe von "su" kommt der gleiche Fehler.

Hat jemand von Euch eine Idee woran es liegen kann? :confused2:

Grüße,
Skyes
 
vetzki

vetzki

Guru
Welche fehler kommt denn bei su?
Umd wie vorhin schon geschrieben wurde, wäre die Ausgabe von dmesg|tail interessant (könnte allerdings ohne root rechte schwierig werden) sollte aber über adb funzen.
 
S

Skyes

Neues Mitglied
Hallo Vetzki,

Bei su gibt es keinen Fehler, das funktioniert. dmesg|tail liefert:
sh: tail: not found
write: Broken pipe

dmesg liefert eine wahnsinnig lange Ausgabe, denke das müßte irgendwie gefiltert werden.
 
vetzki

vetzki

Guru
Sorry, tail kommt vmtl. mit busybox, deswegen das not found (tail dind die letzten paar zeilen (siehe screenshot)
 

Anhänge

S

Skyes

Neues Mitglied
Alles klar, nun klappt die Ausgabe, das kommt:

root@android:/ # dmesg|tail
<6>[16193, busybox] [14559.338470] EXT4-fs (mmcblk0p13): re-mounted. Opts: (null)
<6>[16194, toolbox] [14559.343963] EXT4-fs (mmcblk0p13): re-mounted. Opts: (null)
<6>[16195, mount] [14559.348205] EXT4-fs (mmcblk0p13): re-mounted. Opts: (null)
<6>[16196, toolbox] [14559.352386] EXT4-fs (mmcblk0p13): re-mounted. Opts: (null)
<6>[8553, kworker/u:1] [14570.057922] qt1060 2-0012: key 1 keycode158 pressed* status=2 oldstatus=0
<6>[6333, kworker/u:2] [14570.175201] qt1060 2-0012: key 1 keycode158 released* status=0 oldstatus=2
<6>[6333, kworker/u:2] [14571.690765] qt1060 2-0012: key 1 keycode158 pressed* status=2 oldstatus=0
<6>[6333, kworker/u:2] [14571.799285] qt1060 2-0012: key 1 keycode158 released* status=0 oldstatus=2
<6>[8553, kworker/u:1] [14572.932952] qt1060 2-0012: key 0 keycode172 pressed* status=1 oldstatus=0
<6>[8553, kworker/u:1] [14573.111785] qt1060 2-0012: key 0 keycode172 released* status=0 oldstatus=1

Hilft das weiter?
 
Mufflon

Mufflon

Stammgast
Ich denke, es liegt an SuperSu, das funktioniert nicht richtig. Nach einem Tip von Vetzki habe ich aus dem Market Superuser von koush, damit klappt es jetzt bei mir. Das überschreibt die su-binaries in /sytem/bin und /system/xbin. Danach ist Supersu nutzlos, das kannst du dann in den Apps löschen.

Bye, Klaus
 
D

Dirk74

Ambitioniertes Mitglied
Meinst Du das Superuser von clockworkmod?

Damit sieht es irgendwie immer noch genauso aus.

Der Befehl SU klappt. Allerdings steht bei mir nicht root@android:/ sondern u0_a18@android:/ ?????
 
Zuletzt bearbeitet:
vetzki

vetzki

Guru
$ oder # ?

Der ursprüngliche Beitrag von 18:38 Uhr wurde um 18:43 Uhr ergänzt:

Skyes schrieb:
Alles klar, nun klappt die Ausgabe, das kommt:

root@android:/ # dmesg|tail
<6>[16193, busybox] [14559.338470] EXT4-fs (mmcblk0p13): re-mounted. Opts: (null)
<6>[16194, toolbox] [14559.343963] EXT4-fs (mmcblk0p13): re-mounted. Opts: (null)
<6>[16195, mount] [14559.348205] EXT4-fs (mmcblk0p13): re-mounted. Opts: (null)
<6>[16196, toolbox] [14559.352386] EXT4-fs (mmcblk0p13): re-mounted. Opts: (null)
<6>[8553, kworker/u:1] [14570.057922] qt1060 2-0012: key 1 keycode158 pressed* status=2 oldstatus=0
<6>[6333, kworker/u:2] [14570.175201] qt1060 2-0012: key 1 keycode158 released* status=0 oldstatus=2
<6>[6333, kworker/u:2] [14571.690765] qt1060 2-0012: key 1 keycode158 pressed* status=2 oldstatus=0
<6>[6333, kworker/u:2] [14571.799285] qt1060 2-0012: key 1 keycode158 released* status=0 oldstatus=2
<6>[8553, kworker/u:1] [14572.932952] qt1060 2-0012: key 0 keycode172 pressed* status=1 oldstatus=0
<6>[8553, kworker/u:1] [14573.111785] qt1060 2-0012: key 0 keycode172 released* status=0 oldstatus=1

Hilft das weiter?
Hmm. Mich hatte interessiert ob ein fehler kommt, sieht aber normal aus (einzig hast du öfter neu gemountet, weils 4x hintereinander auftaucht, 1. mal: rw -> 2. Mal: ro -> 3. rw -> 4. ro, oder hast du immer mit mount -o rw,remount ... neu gemountet?)
Achja wie hast du denn busybox installiert:confused: Dafür muss ja system auch rw gemountet werden n
 
Mufflon

Mufflon

Stammgast
Dirk74 schrieb:
Meinst Du das Superuser von clockworkmod?

Damit sieht es irgendwie immer noch genauso aus.

Der Befehl SU klappt. Allerdings steht bei mir nicht root@android:/ sondern u0_a18@android:/ ?????
Schau einfach mit einem Dateimanger unter /system/bin/ und /system/xbin nach, ob das su-binary das richtige Datum hat.
Nein, nicht das von cwm. Suche im Market nach superuser und koush, dann bekommst du das angezeigt. Das ist ein richtiges Open-Source-Programm.

Bye, Klaus
 
S

Skyes

Neues Mitglied
Hallo nochmals,

Busybox habe ich einfach aus dem Playstore mit Smart Install installiert. Ich verstehe es nicht, Total Commander kann /system nicht rw mounten, AdAway schlägt auch fehl. Ich habe nun auch eine Fehlermeldung:
root@android:/ # dmesg|tail
[...]
<2>[28071, mount] [22560.466857] EXT4-fs error (device mmcblk0p13): ext4_remount:4323: Abort forced by user
<3>[1, init] [22561.113037] init: untracked pid 28072 exited
[...]

Noch jemand eine Idee?:crying:
 
D

Dirk74

Ambitioniertes Mitglied
Mufflon schrieb:
Schau einfach mit einem Dateimanger unter /system/bin/ und /system/xbin nach, ob das su-binary das richtige Datum hat.
Nein, nicht das von cwm. Suche im Market nach superuser und koush, dann bekommst du das angezeigt. Das ist ein richtiges Open-Source-Programm.

Bye, Klaus
Ich finde nur das

https://play.google.com/store/apps/details?id=com.koushikdutta.superuser&feature=search_result#?t=W251bGwsMSwyLDEsImNvbS5rb3VzaGlrZHV0dGEuc3VwZXJ1c2VyIl0.


Die Su-Datei ist vom 19.06.13, aber unter /system/bin/ nur 0,00 B groß.
 
Zuletzt bearbeitet:
Mufflon

Mufflon

Stammgast
Ja, das ist die richtige. Die tut es bei mir, keine Probleme seit dem ich die drauf habe.

Bye, Klaus

Okay, gerade wieder ausprobiert und wie der Teufel es will: Geht nicht. Also liegt es nicht an der su, muss irgendetwas mit dem Dateisystem zu tun haben oder weiss der Henker was.
 
Zuletzt bearbeitet:
vetzki

vetzki

Guru
Habt ihr alle die gleichen rom drauf oder verschiedene?
 
Mufflon

Mufflon

Stammgast
Ich habe die 315. Hat denn jemand mit dieser EMUI 1.5 keinerlei Probleme, die system-Partition r/w einzubinden? Und welche supersu-Version ist dann im Spiel?
Wie gesagt, wenn ich das handy neu starte, klappt es, aber nur kurze Zeit, manchmal nur einmal, manchmal auch 2 mal, aber spätestens beim 3. Mal geht es nicht mehr.

Bye, Klaus
 
vetzki

vetzki

Guru
Ich hab das handy ner bekannten geliehen, war/ist auch 315 drauf. Weiß aber nicht ob ich mehrmals hintereinander neu gemountet habe, ein Problem is mit nie auf gefallen (war aber zu der Zeit schon ersatzhandy von daher wenig in betrieb). Gerootet hatte ich auch mit superuser von koush.
 
D

Dirk74

Ambitioniertes Mitglied
Ich nutze die B315. Die Probleme habe ich auf zwei verschiedenen P1. Ich habe es mit der SuperSU aus der Rooting-Anleitung und der Superuser App von CWM versucht.
 
Mufflon

Mufflon

Stammgast
Ich habe jetzt Superuser-3.1.3-arm-signed.zip, UPDATE-SuperSU-v1.04.zip mit allen Updates und eben Superuser von koush genutzt, bei allen das gleiche. Jetzt bleibt mir nur noch Root_EmoUi_4.1.zip, da ist allerdings busybox mit drin. Jetzt muss ich erst mal mein altes busybox deinstallieren und dann mal sehen, ob sich etwas ändert. Wenn nicht, muss ich halt damit leben.

Bye, Klaus
 
Mufflon

Mufflon

Stammgast
Okay, mit der Root_EmoUi_4.1.zip geht es auch nicht, immer noch das gleiche Verhalten. Ich gebe es auf. Mal sehen, ob es bei der 1.6, die ja im August kommen soll, besser wird. Wenn nicht auch egal, so oft muss man ja mit root-Rechten ja nichts machen. Dann muss man eben einmal aus- und wieder einschalten.

Bye, Klaus
 
vetzki

vetzki

Guru
Root rechte gehen ja, oder? /system rw zickt? (oder hab ichs danach verstanden?)