Root und Recovery

  • 645 Antworten
  • Neuester Beitrag
Diskutiere Root und Recovery im Root / Custom-ROMs / Modding für Huawei Ascend P1 im Bereich Huawei Ascend P1 Forum.
chyt

chyt

Fortgeschrittenes Mitglied
Ich habe langsam die Nase voll...

Beim rooten (downgegradet B219) wenn cwm .img starte und install zip from sd card auswähle erstmal kam die Nachricht aufm PC: "viva treiber installation fehlgeschlagen" oder so. Das Handy macht natürlich garnichts. Bootet ins cwm, nur arbeitet nicht. Im sdk platform-tools eingegeben "fastboot devices" erscheint nur ein "?"
Also fastboot driver installation fehlgeschlagen.

Habe versucht alst ADB device, sooner single ADB, und sogar android fastboot device zu installieren, erfolglos. Was mache ich falsch??

Übrigens die Genotools funzt auchnicht. Kein SU, kein Root. Früher mit dem stock 219 da gab es kein Problem.
 
Andy

Andy

Ehrenmitglied
Hä, wenn du ins CWM Recovery ist alles gut. "install zip from sdcard" auswählen hast du gemacht oder wie? Du musst dir dann die Superuser.zip auswählen und installieren, die du dir natürlich vorher auf die Speicherkarte kopiert hast. Oder hast du das gemacht. Formuliere mal nen vernünftigen Satz dann versteht man dich auch.
 
chyt

chyt

Fortgeschrittenes Mitglied
Ich verdammter Ausländer:flapper:

Ich habe alles nach den Anweisungen im ersten Post gemacht.

Also das Handy letzendlich in cwm gebootet, install zip from sd card ausgewählt, dann erstmal im win die Fehlermeldung ertappt, dann macht das P1 garnichts, ich sehe nur das cwm logo mit dem Hut aufm Bildschirm. Wenn erneut den Power Knopf drücke krieg ich das cwm bootbildschirm zurück mit den Optionen.

Besser kann ich es nicht beschreiben :blushing:

edit:

Es gibt eine Anleitung zum sdk+fastboot installation
hier
Dort steht zwei verschiedene benötigte driver version
-Android ADB device (handy normal)
-Android bootloader device (handy bootloader modus)

wäre das hier erwähnte "Android sooner single ADB interface " eine 2in1 Version?

Sorry für die viele Fragen, ich möchte das Dingsbums endlich verstehen (so teilweise mindestens)

edit 2.0:
Lösung:

ich habe den ESET Smart Security 6.0 Virenschutz gesperrt und dann Genotools verwendet. Das P1 B219 ist damit jetzt gerootet :drool:
 
Zuletzt bearbeitet:
chyt

chyt

Fortgeschrittenes Mitglied
Yep B532 gerootet, mit Hilfe von Morpheus's Driverpack :love:

Gapps mit dem cwm image flashen ist o.k..?
 
M

morpheus620

Android-Guru
Ja,ist Ok ;)
 
keviiko1996

keviiko1996

Fortgeschrittenes Mitglied
Hat jemand die ADB Sooner Treiber für mich?
Ich habe sie nicht mehr installiert und kann sie nirgends finden. ._.
 
keviiko1996

keviiko1996

Fortgeschrittenes Mitglied
Vielen Dank! :)
 
T

tisona

Neues Mitglied
Hallo zusammen,

Ich bin auch fast am verzweifeln. Bei mir, so denke ich, hängt es bei Punkt 3:
3. "adb.exe reboot bootloader" eingeben um das P1 in den fastboot Modus zu versetzen.


In der Konsole erscheint folgendes:
F:\p1\sdk\platform-tools>adb.exe reboot bootloader
adb server is out of date. killing...
* daemon started successfully
Auf dem P1 erscheint dann das Orangene Huawei Symbol und das wars dann.

Ich denke mal das dort nicht "adb server is out of date. killing..." stehen dürfte. Geh ich da recht in der Annahme?
 
Andy

Andy

Ehrenmitglied
Wenn es im beim Huawei Logo stehen bleibt und nicht durchbootet, bist du im fastboot Modus und es können Eingaben mit dem Befehl "fastboot" gemacht werden.
 
Nicky_xD

Nicky_xD

Ambitioniertes Mitglied
@tisona
Doch das ist normal, der hat sich ja bei dir danach auch erfolgreich neu gestartet ;) Bis da hin alles richtig und wie MorphX schon sagte, das P1 ist auch im Fastboot Modus, jetzt müsstest du dann theoretisch mit der Installation des Treibers weiter machen. Also Anleitung weiter folgen...

Für alle die den Treiber nicht haben, die sollten in der Android SDK mit installiert werden, nicht vergessen das Paket mit den Platform Tools mit auszuwählen.
 
Zuletzt bearbeitet:
T

tisona

Neues Mitglied
Danke euch beiden,
Jetzt hat es geklappt. Bin weitergekommen :)
 
G

goowoo

Neues Mitglied
Hallo zusammen!

Kann es sein, das mit der B315 aktuell kein root möglich ist?

CWM und "Superuser-3.1.3-arm-signed.zip" melden zwar eine erfolgreiche Installation, jedoch taucht keine Datei /system/bin/su auf, wenn ich anschließend mit adb shell drauf schaue. Wie zu erwarten ist, ist dann natürlich das Apps mit root Zugriff nicht funktionieren.

Ist das Problem bekannt?
Kommt CWM in der Version 5.8....irgendwas aktuell mit ext4 noch nicht klar?
 
Mufflon

Mufflon

Stammgast
Das Problem habe ich auch. Ich habe verschiedene SuperSu Apps ausprobiert, immer das gleiche. Dann habe ich das Su-Binary direkt mit dem "adb push" Befehl direkt nach /system/xbin kopiert, aber sobald ich neu reboote ist die Su zwar noch da, aber die Grösse beträgt immer 0 Byte. Dann habe ich festgestellt, dass die System-partition voll ist, also mehr als 99%. Habe dann unter /System/app die SprachPack.apks gelöscht und danach fast 15 MegaByte Platz gehabt, das klappt aber immer noch nicht. Ich denke, weil der belegte Platz immer noch 98% beträgt und aus Sicherheitsgründen wird dann nichts mehr installiert, immer erst unter 95% soweit ich mich recht erinnere.
Also, hat bei der 315 schon jemand su installieren können? Wenn das nicht geht, werde ich wieder auf die Stock zurück gehen, pbwohl mir Emui sehr gut gefällt.

Bye, Klaus
 
G

goowoo

Neues Mitglied
Deine Idee war Gold wert :D

Wenn man sich von HwWeatherClock.apk trennen kann, hat man 90% Belegung und ab dann läuft die root-Installation wie gewohnt und überlebt die reboot.

Herzlich dank :)
 
chyt

chyt

Fortgeschrittenes Mitglied
Ich habe mit dem angehängten File die B315 gerootet, ohne weitere Probleme...
 

Anhänge

  • Root_EmoUi_4.1.zip
    1,1 MB Aufrufe: 98
Mufflon

Mufflon

Stammgast
Ich habe das HwHelpCenter.apk gelöscht, nun ging es auch.

Bye, Klaus
 
M

momo_280

Ambitioniertes Mitglied
Mufflon schrieb:
Ich habe das HwHelpCenter.apk gelöscht, nun ging es auch.

Bye, Klaus
Ich hab das selbe Problem, bekomme aber ohne root auch die Wetter und Hilfe-Apk nicht gelöscht. Wie habt Ihr denn das angestellt?
 
G

goowoo

Neues Mitglied
Du musst in CWM booten

Anschließend kannst du über adb shell arbeiten:

1. mount /system
2. cd /system/app
und dort kann man sich dann austoben, was das löschen betrifft.
 
Mufflon

Mufflon

Stammgast
Oder du bootest den TWRP, dort unter Mount /System mounten, dann unter Advance den Dateimanger aufrufen. Damit kann man als Laie etwas besser arbeiten, wenn man mit den Linux-Befehlen nicht so klar kommt.
Ich habe auch mit der Adb-Shell unter Linux gemacht.

Bye, Klaus