T2 Pro wechselt städig die MAC-Adresse

  • 31 Antworten
  • Neuester Beitrag
Diskutiere T2 Pro wechselt städig die MAC-Adresse im Root / Custom-ROMs / Modding für Huawei MediaPad T2 10.0 Pro im Bereich Huawei MediaPad T2 10.0 Pro Forum.
MDXDave

MDXDave

Ehrenmitglied
Nein, nix mit Emui Recovery. ALLES IN TWRP durchführen.
 
hadis

hadis

Stammgast
Oh man hab den Swipe to Factory Reset" völlig übersehen. Beide Wipe's liefen durch. Die Nerven ... oh oh ... Sorry
-- Dieser Beitrag wurde automatisch mit dem folgenden Beitrag zusammengeführt --
Ja, ok aber wie bekomme ich das Restore File in den TWRP Ordner, ohne Möglichkeit in dessen Ordnerstruktur eingreifen zu können?
 
Zuletzt bearbeitet:
MDXDave

MDXDave

Ehrenmitglied
Wieso kannst du die Ordnerstruktur nicht verändern? Pack das Ding auf deine microSD-Karte.
 
hadis

hadis

Stammgast
Also das "TWRP-3.1.1-0-Federer.img" auf die SD und dann entpacken oder wie? ist das gemeint?
 
MDXDave

MDXDave

Ehrenmitglied
Nein. Du packst das B006-Backup auf die SD-Karte nach TWRP/BACKUPS/<SNR>, dann bootest in den Bootloader, flashst oder bootest in TWRP und machst dort ein Factory Reset unter Wipe. Anschließend stellst du das Backup über RESTORE wieder her.
 
hadis

hadis

Stammgast
Gut .. Habe jetzt auf der SD die "TWRP/BACKUPS/<SNR>" Ordner erstellt und in SNR (SNR vom Tab) den 2008 Ordner samt Inhalt eingestellt. Das Verzeichnis TWRP war vorher nicht existent. Gleiches Ergebnis ... findet nichts.
-- Dieser Beitrag wurde automatisch mit dem folgenden Beitrag zusammengeführt --
Also der Ordner 2008... ist auf SD vorher schon gewesen.
 
MDXDave

MDXDave

Ehrenmitglied
Und in TWRP hast du auch bei Select Storage den externen Speicher ausgewählt?

Die Seriennummer ist übrigens ne 8-12 stellige Zeichenkette, nicht die IMEI/Produkt Seriennummer. Am Besten erstellst du eifnsch mal ein Backup in TWRP (von beispielsweise der Boot-Partition), dann siehst du wo die Daten landen.
 
hadis

hadis

Stammgast
Ja, die SN habe ich vorher ... beim Bootloader entsperren notiert ... ist also bekannt :). Gut dann mach ich mal ein BackUp aus TWRP heraus. Danke für Deine Geduld ... sicher nicht einfach mit mir.
-- Dieser Beitrag wurde automatisch mit dem folgenden Beitrag zusammengeführt --
bekomme ne Fehlermeldung:

Can not create '/external_sd/TWRP' folder (I/= error) Failed to make backup folder.

Was nun? Backup sollte von Boot sein
-- Dieser Beitrag wurde automatisch mit dem folgenden Beitrag zusammengeführt --
OK jetzt hats geklappt
-- Dieser Beitrag wurde automatisch mit dem folgenden Beitrag zusammengeführt --
So ... sieht gut aus :1f605: es scheint das BackUp läuft durch ... jetzt bei 50%. DANKE für Deinen KickStart :1f44d:
-- Dieser Beitrag wurde automatisch mit dem folgenden Beitrag zusammengeführt --
SOOOO ... das Pad ist wieder am Leben und auf Stock B006. Jetzt einrichten und das WLan testen.

Herzlichen Dank für die Geduld, die Du zweifelsohne aufbringen musstest.

Ein schönes Wochenende wünsche ich Dir und Deiner Familie :1f64f:
-- Dieser Beitrag wurde automatisch mit dem folgenden Beitrag zusammengeführt --
Gut ... soweit ... nur ich kann kein WLan auswählen es ist ausgegraut und der Schalter hat keine Wirkung. Aber die MAC-Adresse schein stabil zu sein. Allerdings ist es die, welche ich selbst editiert habe. Fängt also mit cc:bb.aa: ... an und nicht die welche ich in
LineageOS
gesehen habe. Nun vielleicht hast Du ja noch eine Idee dazu. Für heute ist erstmal gut mir qualmt die Rübe.

Schönen Abend und Danke für die Hilfe
-- Dieser Beitrag wurde automatisch mit dem folgenden Beitrag zusammengeführt --
Oh .. kam ins WLan nach Neustart und bei den erweiterten Eigenschaften zum WLan gerade nochmal die Mac getestet und "same Game again" sie wechselt wieder. Naja Morgen ist auch ein Tag.
 
Zuletzt bearbeitet:
MDXDave

MDXDave

Ehrenmitglied
Also wechselt sie auch mit der B006? :1f633:
 
hadis

hadis

Stammgast
Hi MDXDave

Si ... tut sie ... die MAC unter der Stock B006. Sorry das ich mich erst jetzt melde. Ich hatte die Faxen dicke für heute und alles bei Seite gelegt. Morgen werde ich noch die B002 Recovery testen und wenn es zum selben Ergebnis kommt ... muss ich wohl auf das Nativ-Android flashen.
Das fände ich nicht so prickelnd, aber um das Tab nutzen zu können muss es wohl sein.

Danke für Deine Hilfe bis hier her und noch nen super schönen Abend
 
Zuletzt bearbeitet:
hadis

hadis

Stammgast
Moin MDXDave

Hab die Recovery der B009 von Dir gerade gesehen, DANKE dafür, bin sie gerade am herunterladen. Aber zuerst probiere ich die B002 Recovery aus. Hab sie auch schon auf dem T2 geladen und die lief ohne Probs durch. Also schauen wir mal was passiert.

Gerade startet das Personalisieren des Tabs.

ERFOLG ... die MAC-Adresse scheint unter der B002 stabil, bei jedem erneutem Einwählen ins WLan ... bisher. Aus TWRP heraus habe ich eine Installation von TWRP als APP sowie SuperSU abgelehnt, also nicht installiert, somit dürfte es nicht gerootet sein und auch kein TWRP auf dem Pad existent? Also wäre dann das T2, bis auf den offenen Bootloader wieder " jungfräulich"? Sodass ein eventuelles Update von B002 auf zB. B006 ohne abrupten Stop durch TWRP unterbrochen werden kann ... oder?
Die B006 wird mir auch schon im Updateprogramm von EMUI angezeigt.

Ich teste das mal ;-) und wenn es nicht klappt (MAC wieder springt) ... das Ganze wieder von vorn.

Werde berichten
-- Dieser Beitrag wurde automatisch mit dem folgenden Beitrag zusammengeführt --
So Update lief nicht durch ... befürchte das Spiel geht von vorne los :1f629:. Also ... ich weiß nicht, woran es lag, das dass OTA Update nicht durchlief. Liegt es jetzt am offenen Bootloader oder hat TWRP immer noch Reste im System verteilt liegen gelassen?
Das OTA-Update auf B006 wird wieder angezeigt, aber das Tab geht ins WLan = MAC-Adresse scheint stabil ... ich kontrolliere das mal in der FB. Ja stabil :1f602:.
Gut ich werde jetzt mit den TWRP BackUps von B006 & B009 das Tab auf den neusten Stand bringen. Mal sehen ob es gut ausgeht.

Werde berichten ...
-- Dieser Beitrag wurde automatisch mit dem folgenden Beitrag zusammengeführt --
So B006 über TWRP BackUp lief sauber durch und das T2 startet gerade. Jetzt wird personalisiert ...
WLan lässt sich nicht auswählen ... ist ausgegraut. Seint also eine "Macke" im BackUp der B006 zu sein.
Springe trotzdem auf die B009

Werde weiter berichten
-- Dieser Beitrag wurde automatisch mit dem folgenden Beitrag zusammengeführt --
Tja .. geht nicht. TWRP zeigt mir die Meldung:

Cannot restore Firmware -- mounted read only.

Wie kann ich die Atribute im TWRP ändern?
-- Dieser Beitrag wurde automatisch mit dem folgenden Beitrag zusammengeführt --
Geht ... habe bis auf BOOT, DATA & System alle Haken beim Restore heraus genommen. Ist das vielleicht der Fehler auch bei der MAC? Bei der B006 restore hatte ich alle Haken (waren 4) drin gelassen und die MAC kam ins trudeln. Hatte bei der B002 nachgesehen was da ein BackUp (nur 3 Partitionen) erhalten hat.

Läuft sauber durch und rebootet gerade.

Also ich werde weiter berichten.
-- Dieser Beitrag wurde automatisch mit dem folgenden Beitrag zusammengeführt --
So Gemeinde ... es ist vollbracht ... die MAC-Adresse ist stabil, bei jeder Einwahl ins WLan und das Tab ist auf dem neusten Stand :biggrin:.
War eine schwere Geburt, aber so scheint es ... hat es sich gelohnt.

Also für alle die die BackUps von TWRP nutzen wollen ... der Schlüssel scheint darin zu liegen, das man in TWRP nur die Partitionen

BOOT
DATA
&
SYSTEM

wieder herstellt.
Und das, aus jedem BackUp aus TWRP heraus!

OK, vielen Dank nochmal an MDXDave, der mir den richtigen Weg gewiesen hat und auf für seine Geduld mit mir.

Werde das Tab jetzt mal richtig einrichten :]. Mittels BackUp aus dem Stock-Programm eine Sache von ein paar Minuten.
So läuft wieder als wäre nichts geschehen :1f44c::1f44d:
 
Zuletzt bearbeitet:
MDXDave

MDXDave

Ehrenmitglied
Ja sollte ich noch erwähnen, man darf die Firmware nicht mit wiederherstellen :)