T2 Pro wechselt städig die MAC-Adresse

  • 31 Antworten
  • Neuester Beitrag
Diskutiere T2 Pro wechselt städig die MAC-Adresse im Root / Custom-ROMs / Modding für Huawei MediaPad T2 10.0 Pro im Bereich Huawei MediaPad T2 10.0 Pro Forum.
hadis

hadis

Stammgast
Moin Gemeinde

Nach meinem kurzen Ausflug zu LineageOS 13 unofficial bin ich wieder auf Stock zurückgekehrt. Vor ein paar Tagen habe ich nun ein Update auf B009 angeboten bekommen. Das wollte ich auch installieren und habe das Update angestoßen. Beim Neustart kam dann TWRP hoch und unterbrach den Startvorgang. Nach nochmaligen Neustart lief aber die Installation durch. Ich hatte aber, so glaubte ich, das Gerät wieder unroot gemacht und auch TWRP deinstalliert. Na und nach dem erneuten Hochfahren des Tablets sah auch alles gut aus ... Versionsinfo B009 steht in den Einstellungen. Allerdings habe ich jetzt ein Problem mit dem ständigen Wechsel der MAC-Adresse bei jeder Einwahl ins WLan. Meine Fritzbox behandelt das Tab jedesmal wie ein Neugerät und sperrt zunächst ersteinmal den Internetzugang. Das ist lästig auf die Dauer.

Das Tab ist mittlerweile wieder Gerutet um die Datei WIFI bearbeiten zu können. Hab ich auch schon gemacht und die Atribute sind auf 444 (rrr) gesetzt, allerdings ist der Spuk noch immer nicht vorbei. Auf dem Tab sind Android 5.1.1 mit SicherheitsPatch 1/18 von Google installiert. Den Ordner /data/nvram gab es nicht. Ich habe ihn erstellt und dort die WIFI & WIFI Coustum Datei dort eingestellt.

Nach dieser Anleitung von AndroidPit bin ich vorgegangen:

Ständig andere MAC Adresse beim Wlan | AndroidPIT

1. handy braucht root
2. hexeditor im playstore runterladen
3. datei data/nvram/APCFG/APRDEB/wifi auf sd-card kopieren
4. datei data/nvram/APCFG/APRDEB/wifi umbenennen (als backup)
5. wifi-datei von cd-card mit hexeditor öffnen
6. von byte 04-09 die jetzt vorhandene mac-adresse eingeben (6 byte) und speichern
7. wifi-datei von sd-card zurück nach data/nvram/APCFG/APRDEB/ kopieren
8. handy neu starten

Auch hier habe ich nach gearbeitet ... mit gleichen Erfolg:

Wechseln der MAC Adresse verhindern [Tutorial]

Leider besteht das Problem weiterhin. Kann jemand sagen ob der Speicherort der WIFI und WIFI Coustum Datei ein anderer ist und wenn wo er ist?

Vielen Dank an alle für die Hilfe
 
Zuletzt bearbeitet:
MDXDave

MDXDave

Ehrenmitglied
Kurze Frage, Wechselt das gab tatsächlich jedes Mal die Mac? Magst du mal ein paar Nummern hier posten? Eventuell ergibt sich ein Muster.
 
hadis

hadis

Stammgast
Hi MDXDave

Also wenn ich die erweiterten Eigenschaften der WLan in den Einstellungen kontrolliere, und dann bei WLan Einstellungen aus den Punkt "Suche immer verfügbar" aktiviere ... bekomme ich jedesmal eine neue MAC zu sehen. Also An/Aus = neue MAC.
-- Dieser Beitrag wurde automatisch mit dem folgenden Beitrag zusammengeführt --
Ein Paar MAC-Adressen

CC:BB:AA:F5:0C:88,
CC:BB:AA:CA:06:4D,
CC:BB:AA:53:81:20,

Das ärgerliche daran ist, das ich gern statische Adressen im WLan für die Clienten nutze um sie auseinander halten zu können. Da aber das T" jedesmal als neues Grät von der FB behandelt wird ... sitze ich erstmal im Standard-Profil fest, wo kein Internet möglich ist.

Die ersten 3 Spalten stimmen mit der Originalen überein, aber danach geht es durcheinander, obwohl die WIFI-Datei nur auf lesen gesetzt ist. Ein Auslesen mittels "ChamelMac" bringt die richtige MAC zu Tage, obwohl eine andere laut FB eingestellt wurde.

Wie oben geschrieben gab es den Ordner nvram und die Unterordner nicht und wurden von mir im /Data erst erstellt. Meine Vermutung ist nun, das ich ... weil ja Android 5.1.1 installiert ist und die TuT's alle älter sind, der angegebene Speicherplatz nicht der richtige ist.
 
Zuletzt bearbeitet:
MDXDave

MDXDave

Ehrenmitglied
Mhm... CC:BB:AA ist kein korrekter Mac-Prefix.

Mit LineageOS trat das Problem nicht auf? Mit der B006 ebenfalls nicht? Du könntest nochmal ein Downgrade auf die B006 durchführen und nach einem Werksreset nochmal das Update durchführen.

Alternativ kannst du versuchen deine WLAN MAC zu spoofen (dafür brauchst du Root-Zugriff) damit du immer dieselbe behälst.
 
hadis

hadis

Stammgast
Hallo MDXDave

LineageOS hate ich nur sehr kurze Zeit drauf, da mich die ständigen Fehlermeldungen doch arg genervt habe . Bei der B006 hatte ich das Problem nicht, es kam erst nach dem unterbrochenen (TWRP kam dazwischen) Update auf B009 zum tragen. Eigentlich hatte ich ja gedacht das TWRP wäre restlos vom Tab ... ja das Denken ... !
Also das Tab ist gerootet, denn sonst käme ich ja nicht zu /Data und was da noch hinter liegt.
Installiert habe ich:

Root-Explorer
Hex-Editor,
Super-SU,
Total-Commander,
ChameleMac ... funktioniert aber nur mit Mediatec und das Tab hat aber einen anderen Chipsatz
Wie muss denn eine correkte MAC-Adresse aussehen? In der WIFI-Datei kann ich ja eine neue erstellen und dann ersetzen.

Wie geht spoofen? Für ein Downgrade habe ich keine B006, leider.

Vielen Dank das Du mir helfen willst :8
 
MDXDave

MDXDave

Ehrenmitglied
Ich würde es zunächst mit dem. Downgrade probieren. Du kannst das TWRP Backup der B006 hier herunterladen: [FDR-A01L] Firmware, Updates, Recovery, Custom-ROM

Danach einmal booten lassen und dann am Besten das originale Recovery flashen. Dann schau mal ob das mit der Mac Adresse immer noch auftritt. Falls nicht kannst du wieder versuchen das B009 Update einspielen.

Eine andere Alternative wäre LineageOS 14 auf Basis von 7.1.2 zu flashen, läuft extrem stabil ohne Fehlermeldungen: LineageOS 14.1 unofficial
 
hadis

hadis

Stammgast
Abend MDXDave

So ... ich habe jetzt LineageOS 14.1 unofficial und die open_gapps-arm64-7.1-full installiert.
Das Problem mit der wechselnden MAC-Adresse ist nicht mehr existent ;-). Allerdings mag ich jetzt doch lieber das Original Image auf dem Pad probieren um zu wissen, ob das Problem auch damit Geschichte ist. Das letzte mal habe ich in der Bootschleife gesessen und bin da nur mit großer Mühe wieder raus gekommen. Auch möchte ich dann das TWRP komplett wieder entfernen, denn ich habe den Verdacht, das TWRP mit der Unterbrechung der Updates von der B006 Stock auf die B009 Stock für die ganze Misere verantwortlich war.
Eine Kleinigkeit vermutlich, aber für mich wichtig ... ich kann keine Ordner erstellen mit dem Nativ-Google Android, in denen ich Programme nach Aspekt ordnen kann. Als langjähriger Huawei Nutzer bin ich an EMUI gewöhnt und finde durchaus Gefallen daran. Mit anderen Worten ... ich möchte zurück zu Stock. Wie stelle ich das an?

Wie bekomme ich TWRP komplett, genauso wie Root vom T2?

Schönen Abend noch und Danke für die Denkanstöße :).
 
Zuletzt bearbeitet:
hadis

hadis

Stammgast
Hallo

Ich habe mir, um auf Stock zurück zu kommen von hier:

StackPath

die B006 geladen. Die habe ich dann auf die SD in DLoad gepackt und mittels TWRP installieren wollen. Leider geht das nicht, denn TWRP meldet mir "unbekannter Zip-Fehler". Was mache ich falsch? Zuvor hatte ich über die Original-Recovery einen Factory Reset angestrengt, auch der geht nicht durch, ich komme immer nach ca. 5% den Fehler "falsches Format".
Jetzt habe ich die gleiche Situation wie hier:

MediaPad T2 Pro hängt

Irgendwie dreht sich das ganze wieder im Kreis. Zumindest habe ich mir die richtige MAC-Adresse aus der LingeaeOS 14.1 notiert, falls nach "Back to Stock" der Spuk mit der wechselnden MAC-Adresse wieder von vorne beginnen sollte.

Das original Recovery von Huawei liegt im Recovery, wurde also nicht durch TWRP ersetzt. Jetzt lade ich mir das BackUp von oben genannter Seite nochmals runter um Fehler im Download ausschließen zu können. In den Bootloader komme ich mittels temporären TWRP ... was schon einmal gut ist. Nur wie muss ich es anstellen, um von hier aus auf Stock zu kommen?

Danke schon mal vorab für Eure Hilfe.
 
Zuletzt bearbeitet:
MDXDave

MDXDave

Ehrenmitglied
Mhm es kann gut sein dass durch das Update auf B009 kein Downgrade auf B006 mehr möglich ist, in dem Fall bräuchtest du ein B009 Backup - was du hoffentlich erstellt hast beim Wechsel auf LineageOS.

Also eigentlich nicht, ich hatte damals problemlos von B006 auf B002 zurückflashen können. :confused2:

Ich kann mein Tablet später mal auf B006 zurückflashen - updaten auf B009 - auf LineageOS und dann wieder auf B006 und kann dir berichten wie ich das gemacht habe und ob es klappt.
 
hadis

hadis

Stammgast
Hallo MDXDave

Nun ich hatte es versäumt mittels TWRP ein BackUp zu machen. Shit! ich habe ja nicht gedacht, das es nötig sein könnte. Es wäre also sehr nett von Dir, wenn Du es machen könntest ... das Rauf und Runter flashen von Deinem Tablet :1f64f:. Ich habe das BackUp nicht erstellt, weil ich annahm den MAC-Fehler auch damit zu zementieren.

Besten Dank im Vorab :1f44d:.

Nachtrag: Der Download ist nicht stabil und schon mehrmals abgebrochen worden. Kann es eventuell daran liegen, das die Inst. zip-Fehler vermeldet? Der Download der B006 von Gestern war auch nicht ohne Unterbrechung erfolgt.
 
Zuletzt bearbeitet:
MDXDave

MDXDave

Ehrenmitglied
Eigentlich ist Android File host sehr stabil. Hast du mal einen alternativen Mirror versucht? Bzw einen anderen Browser/ein anderes Gerät?
 
hadis

hadis

Stammgast
Hi ... ich lade mit dem Schleppi und Mozilla Firefox. Mirror wechseln, kann ich mal testen. Hab noch die Restore von der B002 mit 1,4 GB in Zip-Format ... aber damit der gleiche Fehler wie vor!
Bin auch nicht sicher ob in TWRP über den Punkt "Install" oder "Restore" geflasht wird. Bei "Install" bekomme ich die Zip-Fehler und bei "Restore" findet die APP den ZiP-File nicht. Wo habe ich die Denkblockade?
 
Zuletzt bearbeitet:
MDXDave

MDXDave

Ehrenmitglied
Du musst ein RESTORE durchführen. Das heißt das ZIP-File entpacken und den 2008... Ordner nach TWRP/<Seriennummer> entpacken, wie auch hier beschrieben.
 
hadis

hadis

Stammgast
Ohh ... ja dann kann es ja nicht klappen. Muss ich jatzt das TWRP flashen? hab es ja nur temporär auf dem Pad. Lade jetzt vom Texas Mirror und der läuft stabil :).

Nachtrag: Das Tab wird zwar von HISuite erkannt, aber es wird keine Verbindung hergestellt.
 
Zuletzt bearbeitet:
MDXDave

MDXDave

Ehrenmitglied
Nein, temporäres TWRP sollte reichen. Also am Besten einmal Wipe/Factory Reset und dann B006 Backup flashen (über Restore).

Schmeiß HiSuite runter, brauchst du nicht.
 
Zuletzt bearbeitet:
hadis

hadis

Stammgast
Wie bekomme ich dann aber die Restore B006 in den TWRP Ordner Seriennummer wenn ich doch keine Verbindung vom PC zum Pad habe? Irgendie stelle ich mich wohl gerade besonders blöd an.
-- Dieser Beitrag wurde automatisch mit dem folgenden Beitrag zusammengeführt --
Gut HISuite ist runter. Hab auf der SD einen Ordner Restore mit Unterordner Seriennummer erstellt und darin den Ordner 2008 .... entpackt. In TWRP wird nix gefunden ... also wie gehabt. Sorry das ich auf dem Denkschlauch stehe.
 
MDXDave

MDXDave

Ehrenmitglied
Also der Ordner heißt nicht Seriennummer sondern ist die Seriennummer deines Tablets? Hast du auch External Storage in TWRP ausgewählt?
 
hadis

hadis

Stammgast
in TWRP gibt es bei Wipe keinen Punkt Factoryreset. Nur Dalvic, System, Data, InternalSD, cache, MicroSD und USB-OTG.
-- Dieser Beitrag wurde automatisch mit dem folgenden Beitrag zusammengeführt --
Ja klar externalSD wo die ja auch abgespeichert ist. Auf dem Schleppy sind die "ADB and Fastboot" installiert und daraus wird TWRP temporär gebootet.
 
MDXDave

MDXDave

Ehrenmitglied
Mein Fehler, der Ordner muss nach TWRP/BACKUPS/<Seriennummer>
 
hadis

hadis

Stammgast
So hab versucht über MUI Recovery einen Faktory-Reset auszulösen. Ging bis 10% durch, dann gab es das zu lesen

Data and cache format failes

Irgendwie ist was faul so scheint es.
 
Zuletzt bearbeitet: