Root vorhanden, aber keine Schreibrechte?

  • 51 Antworten
  • Neuester Beitrag
Diskutiere Root vorhanden, aber keine Schreibrechte? im Root / Custom-ROMs / Modding für Huawei MediaPad X1 im Bereich Huawei MediaPad X1 Forum.
RheinPiratBasel

RheinPiratBasel

Stammgast
Einige hier im Forum haben sich in China das Huawei MediaPad X1 geordert welches hier noch nicht erhältlich ist.

Wie bei allen, kamen die Geräte gerootet an weil die Verkäufer die China Apps gelöscht haben.

Zu unserem Problem. Obwohl wir Rootzugriff haben, werden uns schreibrechte verweigert. Beispiel die "Hosts" Datei um einen Adblocker zu installieren...

Mann kann die Datei lesen, kann sie aber weder umbenennen noch editieren :confused2:

Wie ist das möglich? Ich dachte immer root = Vollzugriff? Denn ich hatte schon einige Droiden und bei allen hatte ich vollen Zugriff wenn es gerootet war.


PS: Das ganze betrifft nicht nur die Hosts Datei, sondern auch das installieren des Xposed Frameworks oder das löschen von apks...


Hat da jemand von euch Experten eine idee?
 
P

perpe

Gast
Kannst du auch ein paar Angaben mehr machen? CPU, Android Version...
Kannst du die System Partition mit rw mounten?

Wenn ich mich nicht ganz irre gibt/gab es bei HTC etwas ähnliches, man konnte zwar ohne den Bootloader zu unlocker rooten, aber dann ging root nur eingeschränkt. Evtl. ist es bei euch so was ähnliches.
 
RheinPiratBasel

RheinPiratBasel

Stammgast
HI

Das X1 hat die Huawei eige CPU HiSilicon Kirin 910 und es ist Android 4.2.2 drauf

R/W mount geht ja. (Zum Bsp. kann ich unter /system/media/audio/ui die dort vorhandenen ogg Dateien umbenennen...)
 
P

perpe

Gast
welche Rechte hat die hosts Datei?


edit: und welche Rechte die su binary
 
Zuletzt bearbeitet von einem Moderator:
RheinPiratBasel

RheinPiratBasel

Stammgast
 
P

perpe

Gast
Das ist soweit ok.
Hast du eine Busybox drauf? Wenn ja, dann gibt mal im Terminal mit root Rechten "lsattr" bzw. "busybox lsattr" im Ordner /system/etc ein und schau mal was bei der hosts steht (kannst natürlich auch alle anderen Dateien überprüfen). Wenn die Ausgabe in etwa wie "----i--------e--" ausschaut, dann ist die Datei schreibgeschützt.
Mit "chattr -i hosts" bzw. "busybox chattr -i hosts" kannst du sie wieder schreibbar machen (mit Rootrechten ausführen, system sollte schreibbar gemountet sein)
 
RheinPiratBasel

RheinPiratBasel

Stammgast



gebe ich dann: "chattr -i hosts /system/etc" ein kommt folgende Meldung:




oder gebe ich es falsch ein?
 
P

perpe

Gast
ja, du gibst es falsch ein.
entweder:
Code:
cd /system/etc/
chattr -i hosts
oder
Code:
chattr -i /system/etc/hosts
Da bei dir fast überall das i drin ist kannst du auch
Code:
chattr -R -i /system/etc
eingeben, dann wird der Schreibschutz rekursiv sowohl am Ordner etc als auch in allen Dateien und Unterordnern entfernt. Sollten auch andere Ordner betroffen sein, kannst du natürlich auch "chattr -R -i /system" durchlaufen lassen, entfernt dann halt den Schreibschutz von system und allen darunter liegenden Dateien und Ordnern.
 
RheinPiratBasel

RheinPiratBasel

Stammgast
Ahhh das sieht ja schon ganz anders aus.... ABER hinter jeder auflistung steht: Read-only file system !?
 
P

perpe

Gast
(mit Rootrechten ausführen, system sollte schreibbar gemountet sein)
Hast du das gemacht? Geht mit
Code:
mount -o rw,remount /system
Danach den chattr Befehl.
 
RheinPiratBasel

RheinPiratBasel

Stammgast
UEEEEEEEEEE :thumbsup: :lol: :thumbsup:


VIELEN VIELEN Dank - es hat geklappt xD


Nur noch eine Frage... bleibt der Schreibschutz deaktiviert, oder muss ich das jedes mal wieder machen?
 
P

perpe

Gast
Da ich nicht Hellseher kann, boote einfach mal neu und überprüfe es mit lsattr.
Wenn kein i drin ist, bleibt es erhalten. Müsste eigentlich der Fall sein, ansonsten wirst du es neu eingeben müssen.
 
Zuletzt bearbeitet von einem Moderator:
RheinPiratBasel

RheinPiratBasel

Stammgast
Schade. Nach einem Neustart siehts wieder so aus -------i------A---- :sad:
 
P

perpe

Gast
Bleiben die Veränderungen erhalten? (also z.B. die geänderte hosts Datei)
Gib im Terminal mal auch mount ein und schau mal nach, mit welchen Attributen die system Partition gemountet ist. (am besten direkt nach einem Neustart und ohne dass du zuvor mit rw gemountet hast)
Kannst auch mal in die init Dateien schauen, suche dort nach dem Abschnitt der System mountet. Wenn es da eine Auffälligkeit gibt, dann könntet ihr dieses Verhalten mit einem Custom Boot Image abstellen.
 
Zuletzt bearbeitet von einem Moderator:
RheinPiratBasel

RheinPiratBasel

Stammgast
ja, die veränderte hosts bleibt. Mein X1 ist nun werbefrei.

Auch konnte ich das Xposed Framework installieren.


entweder bin ich doof, aber bis jetzt hab ich keine init gefunden oO

 
P

perpe

Gast
Ne, da sollst du nach den mount Attributen von system suchen. Auf einem Screenshot ist das Mist ;) mach es selber.
Die init Dateien sind in / drin, also z.B. init.rc. Davon sind mehrer enthalten, in ihnen wird irgendwo auch die system Partition gemountet, evtl. ist da was spezielles mit dabei.

Aber es wird dir jetzt nichts bringen danach zu suchen. Solltest du warten bis wer erfahreneres das Gerät hat. Denn wenn dort mit einem speziellen Attribut gemountet wird, dann werdet ihr durch das flashen eines neuen boot.img was ändern können. Ihr habt jetzt nun einen Anhaltspunkt, sollte wer mit etwas Ahnung von boot.img und co. erstellen das Gerät mal haben, dann könnt ihr ihn ja darauf hinweisen ;)

Aktuell könnt ihr sicher auch mit der oberen Lösung leben, schließlich ändert man nicht so oft was an der system Partition ;)
 
RheinPiratBasel

RheinPiratBasel

Stammgast
Danke.

Ich kann uach mit dieser Lösung leben. Hab ein Terminal gefunden bei dem ich Quick Commands festlegen kann. Dann ist es eine Sache von Zwei klicks.


Danke nochmals für die Mühe:thumbup:
 
P

perpe

Gast
Ich hab mal in euer boot.img reingesehen. Dort in init.rc gibt es die Zeile
Code:
exec /sbin/set_immutable 1
direkt unter dem Mountbefehl von system. Diese Zeile müsst ihr entfernen, dann das boot.img wieder packen und flashen.

Aber wie gesagt, lass das wen machen der Ahnung hat und es dann auch testen kann, bevor er euch ein boot.img bereitstellt.
Kannst ja bei euch im Forum auf den Thread hier aufmerksam machen ;)
 
P

perpe

Gast
Flashen sollte kein Problem sein, ihr habt doch fastboot ;)
Aber wie gesagt, warte du da lieber. Es ist zwar nur eine geringe Änderung, aber ein boot.img will trotzdem getestet werden. Sollte daher jemand machen der das Gerät hat und testen kann.

(PS: sie und nicht ihn ;))