Schnelle und saubere BACKUP Lösung

  • 28 Antworten
  • Neuester Beitrag
Diskutiere Schnelle und saubere BACKUP Lösung im Root / Custom-ROMs / Modding für LeEco Le Max 2 im Bereich LeEco Le Max 2 (X820/X821/X822) Forum.
HeinerkannKeiner

HeinerkannKeiner

Stammgast
Backup:

Sollte Dir mal eine ROM nicht gefallen, kommst Du blitzschnell wieder auf die Vorgänger ROM zurück...ohne großartiges flashen wenn Du vorher diese Schritte eingeleitet hast:

Bevor Du eine neue ROM über TWRP installierst, im laufenden OS:
- USB Verbindung in Entwicklereinstellungen freigeben
- Passwörter (Muster, Pin ec.pp.) von Fingerprint und Fingerprint Abdruck löschen (sonst funktioniert das wiedereingespielte Backup nicht!)

anschließend in TWRP (Laut Taste zusammen mit Aus Taste halten):
> Backup über TWRP von der aktuellen ROM erstellen (nur das vorab angehakte übernehmen, nichts zusätzlich im Backup anhaken)
> PC-Phone USB Verbindung herstellen
> den gesamten Ordner TWRP vom dem Phone auf den Computer copy in einen Ordner auf dem PC, den du wieder findest

angenommen Dir gefällt die ROM nicht, die Du aufgespielt hast...:

*im TWRP> Werksreset>Wipe ALLES löschen> Neustart ins Recovery>USB Verbindung PC-Phone> copy den vorher gesicherten Ordner TWRP auf inneren Speicher Phone, mit yes antworten für das Überschreiben des dortigen TWRP Ordner>im TWRP auf Wiederherstellung gehen> Wiederherstellungsordner nach Datum auswählen (wenn du mehrere Backup über TWRP gemacht hast) anklicken und Wiederherstellung abwarten (done) > anschließend Neustart ins System>>>das vorangegangene Build ist genau so wiederhergestellt.

Probiert an allen bisherigen Build mit gleichem Kern. Keine Fehler bei der Wiederherstellung.

Hier auch NOCH einmal zur Erinnerung, was unter einer SAUBEREN Installation zu verstehen ist, bzw. wie man diese ausführt:
Cuoco's 17s ist draußen

Viel Spaß mit Deinem Phone und mehr Sicherheit beim Ausprobieren von neuen Build.
VG
Heiner
 
Zuletzt bearbeitet:
J

jbe007

Neues Mitglied
HeinerkannKeiner schrieb:
...
anschließend in TWRP (Laut Taste zusammen mit Aus Taste halten):
> Backup über TWRP von der aktuellen ROM erstellen
...
Was genau muss man und was muss man denn nicht sichern?
[x] Boot
[_] Cache
[x] Daten
[x] System
[x] Recovery
[?] System-Image
[?] Firmware

fragt Jbe sich und dich
 
HeinerkannKeiner

HeinerkannKeiner

Stammgast
Wenn Du ins TWRP bootest, auf Backup gehst, ist alles Wichtige angehakt. Brauchst nichts zusätzlich anhaken...Funktioniert so wie ich beschrieben habe zig mal bei mir.
Danke für die Nachfrage, nehme den Hinweis zusätzlich noch mit in meine Aufstellung auf.
VG
Heiner
 
Bizepsandi

Bizepsandi

Fortgeschrittenes Mitglied
Toll die Anleitung

Habe damit die couco Gesichert..
Und dann eine cm getestet, wollte dann das Backup wieder zurück spielem und hatte eine Boot Schleife mit dem eui Logo..
Irgendwas ging da wohl schief?
 
HeinerkannKeiner

HeinerkannKeiner

Stammgast
...muss wohl. Ich habe alle ROM getestet und immer wieder meine "Lieblingsrom" (erst die Mokee 6.0.1 jetzt die CM 19S) hiermit zurückgespielt.
Hat immer funktioniert. Ausnahmslos....Schnelle und saubere BACKUP Lösung
VG
Heiner
 
Bizepsandi

Bizepsandi

Fortgeschrittenes Mitglied
Habe das früher zu Galaxy s2 und S3 Zeiten auch immer gemacht, hat immer funktioniert nur leider diesmal nicht..
Naja bleibe nun bei couco rom.,die läuft auf meinem Gerät perfekt
-- Dieser Beitrag wurde automatisch mit dem folgenden Beitrag zusammengeführt --
Ich probiere es noch mal zu sichern Screenshot_2016-10-10-09-50-08.jpg
 
HeinerkannKeiner

HeinerkannKeiner

Stammgast
Vielleicht liegt das am USB Stick ec.pp. ... dürfte nicht...aber?
Ich habe es auf meinen Win10 64 bit Rechner in einem extra Ordner geschoben (den kompletten TWRP Ordner) und kopiere ihn immer komplett wieder auf den inneren Speicher zurüch wobei ich immer komplett überschreiben anhake...
Vielleicht hilft's...
VG
Heiner
 
Bizepsandi

Bizepsandi

Fortgeschrittenes Mitglied
PC sagt immer Fehler, kann nicht kopiert werden..

Muss irgendwie lese, Schreibschutz haben der Ordner..

Habe das nun im recovery mit adb Shell gemacht.
 
HeinerkannKeiner

HeinerkannKeiner

Stammgast
Ich denke, da liegt der Fehler bei Dir im System. Dabei wird irgendetwas nicht übertragen.. Rauskriegen musst Du das allein... :blink:
Ich habe da keine Ansatzpunkte...
VG
Heiner
 
Bizepsandi

Bizepsandi

Fortgeschrittenes Mitglied
Über adb im recovery kann ich es ja auf PC kopieren.. :biggrin:

Letztes mal hatte ich das recovery auf dem Stick gezogen ohne Fehler.
Das zurück spielen ging auch ohne Fehler.

Nur Boot Schleife

Haben viele, das die den twrp Ordner nicht zum PC ziehen können, soll am Android 6 liegen.

PC fehlen die rechte dazu irgendwie..
 
HeinerkannKeiner

HeinerkannKeiner

Stammgast
man(n) bin mal wieder richtig erstaunt, was alles bei mir nicht passiert...muss ja auch nicht. Aber da läuft richtig was anderes, das ich nicht verstehe...mit
Glück hat das nichts zu tun. Meine Schritte, wie ich etwas mache, saubere Installation, flashen, Backup, ec.pp. habe ich hier genau so detailiert niedergeschrieben...trotzdem passieren bei anderen vereinzelnt Fehler.
Das kann ich nur schwer nachvollziehen.
Ich bitte dann wirklich, jeden Schritt genau nach meiner Anleitung nachzuvollziehen.

Eins ist ganz sicher. Bevor ich hier eine Anleitung "reinzimmere", habe ich den Vorgang mindestens 3 Mal vollzogen. Wenn dann 3 mal kein Fehler auftritt, steht es hier.
Ich denke jeder kann sich vorstellen, das ich überhaupt keinen "Bock" darauf habe, zu hören das einer sein geliebtes Phone in einen Ziegel verwandelt hat, weil ich einen Fehler gemacht habe...
VG
Heiner
 
Bizepsandi

Bizepsandi

Fortgeschrittenes Mitglied
Alles gut Heiner..

Niemand wird beschuldigt oder so etwas.
Habe nur geschrieben das es einmal nicht funktioniert hat.

Und ich mit der cuoco nun zufrieden bin, die cm Versionen laufen nicht 100% bzw es gehen nicht alle Sachen, die das Telefon normal kann.

Liegt auch daran das der hersteller den Code nicht freigibt
 
O

OC-Hybrid

Fortgeschrittenes Mitglied
Brauche mal Hilfe. Habe über TWRP ein Backup der Cuoco ROM erstellt. CM13 Rom probiert und für nicht so gut befunden. Backup wieder eingespielt und es bootet alles normal. Nur komme ich nicht mehr über die Musterabfrage hinaus, da er weder Muster noch Fingerprint erkennt. Hätte ich die Sperre beim Backup herausnehmen müssen?
 
Bizepsandi

Bizepsandi

Fortgeschrittenes Mitglied
Ja muss man rausnehmen.. Pin, Fingerabdruck usw
 
HeinerkannKeiner

HeinerkannKeiner

Stammgast
Ja!!!!!! So habe ich es geschrieben. Steht gleich am Anfang. Manchmal verliere ich echt den Glauben an die Menschheit.[emoji88]
Jetzt hilft nur Neueinrichtung! Genau aus diesem Grund ( ist mir auch am Anfang passiert) habe ich das BACKUP genau beschrieben. Mit der Einleitung, das alle PW, Muster ec.pp. VORHER zu entfernen sind.
VG
Heiner
 
O

OC-Hybrid

Fortgeschrittenes Mitglied
Lieber Heiner,
und dann ist es so, habe ich wohl überlesen. Aber immer sachlich. Den Glauben an die Menschheit musst Du nicht verlieren. Das Du hilfst ist schön, aber nicht überheblich sein bitte. Der Ton macht auch die Musik.
 
HeinerkannKeiner

HeinerkannKeiner

Stammgast
Du hast sicherlich Recht. Ich nehme mich zurück. Den vermeidbaren Schaden hast leider Du. Überheblich sollte es sicherlich nicht klingen, da das gegen meine Art ist...und bestimmt in keinem meiner Post vorkommt, die immer als und zur Hilfe ausgelegt sind...eher wie eine generfte Bitte...ist sicher genau so unpassend. Also sry!
 
Zuletzt bearbeitet:
O

OC-Hybrid

Fortgeschrittenes Mitglied
kein Problem, sorry gerne angenommen. Das neue Aufspielen macht mir nichts aus. Habe zig mal bei diversen Handys den Vorgang vollzogen. Habe auch erst nach meinem Backup Einspielen das Forum wieder besucht und wohl zu schnell das ganze überflogen. Daher war es natürlich meine Dummheit. Habe es nicht mehr auf dem Schirm, ob es bei anderen Handys auch so war, wahrscheinlich hatte ich aber keine Sperre aktiviert, so dass die Backups, die immer selbstverständlich waren immer schnell eingespielt waren. Also aus der Routine nicht mehr nachgedacht.
 
HeinerkannKeiner

HeinerkannKeiner

Stammgast
Ich glaube das das eine Kernel Geschichte, hier speziell LeEco ist.
Ich glaube ohne das ich es genau noch wüsste, nie vorher meine PW aus dem OS genommen zu haben...aber genau weiß ich das auch nicht mehr.
Ich war nur genau so erstaunt wie Du , als nach dem ersten Einspielen, ohne vorherige PW Entfernung die Wiederherstellung genau an dieser Stelle ohne vorhandenen Notausgang endet. Leider...
VG
Heiner
 
Zuletzt bearbeitet:
A

ank003

Fortgeschrittenes Mitglied
@HeinerkannKeiner
Mich würde mal interessieren wie Du Deine Apps, Einstellungen, Bilder etc. sicherst wenn Du so oft die Rom wechselst?
MfG