[OS, 4.4.2] KitKat für Cynus T1 (IMO S88, my|phone A898) portiert

  • 231 Antworten
  • Neuster Beitrag
JoWi81

JoWi81

Fortgeschrittenes Mitglied
Threadstarter
Hallo zusammen,

ich möchte mich wieder zurückmelden und dies gleich mit einer Aktualisierung Update_2016-03-09. Ich habe mich wiedermal mit den Speicherproblemen auseinandergesetzt, aber dieses mal diesen an der Wurzel (Boot-Image) gepackt. Dadurch bleiben mir die mittlerweile zahlreichen Anpassungen bzw. Fehlebehebungen an den Ästen (Framework) und Blättern (Apps) erspart :winki:. Hierdurch öffnete sich auch die Tür für die Verschiebung der Apps auf primäre externe SD-Karte.
Desweiteren wurde Build-Property "ro.jowi81.embsdasint=0|1" durch "ro.jowi81.intsdtype=0|1|2" wie folgt ersetzt und erweitert:
  • "0" oder weglassen: Die Einstellung des optimalen internen SD-Kartentypes auf emulierte oder eingebettete SD-Karte erfolgt durch das System ganz automatisch.
    Ist /emmc-Partition größer 1 GB, dann stelle eingebettete SD-Karte ein, sonst emulierte.
  • "1": Stellt die emulierte SD-Karte ein.
  • "2": Stellt die eingebettete SD-Karte ein.

Auch diese Aktualisierung beinhaltet wie folgt hauptsächlich die Fehlebehebungen und Optimierungen der bereits vorhandenen Funktionen:
  • Apps lassen sich auf primäre eingebettete (siehe Screenshot1) bzw. primäre externe (siehe Screenshot2) SD-Karte verschieben und installieren.
  • Build-Property "ro.jowi81.intsdtype=0|1|2" zur manuellen oder automatischen Einstellung eines interne SD-Kartentypes auf emulierte oder eingebettete SD-Karte hinzugefügt. Diese ersetzt Build-Property "ro.jowi81.embsdasint".
  • Einstellungsmöglichkeit eines bevorzugten Installationspfades auf internen Gerätespeicher oder primäre eingebettete (siehe Screenshot3) bzw. primäre externe (siehe Screenshot4) SD-Karte für Apps hinzugefügt.
  • Und einige anderen weniger wichtigen Sachen.

Build-Property-Editor muss ich freizeitbedingt auf andermal verschieben.
Die Vollinstallation möchte ich euch frühestens nach überwiegend positiven Rückmeldungen bereitstellen.

Nick Knatterton schrieb:
data/misc (gibt es bei mir nicht) oder Android/data/misc ?
Nene, ich meine die /data-Partition auf die man nur mit Rootrechten zugreifen kann.

Nick Knatterton schrieb:
Woran kann ich erkennen, dass der Download erfolgreich war?
Anhand der vorhandenen "EPO.DAT" unter "/data/misc ".

Nick Knatterton schrieb:
Z.B. mit ES Explorer wie im Screenshot5.

Obernetter schrieb:
Ich benutzte daheim gern Whatsappweb am PC. Wenn das T1 nun nach zwei Minuten den Bildschirm dunkel schaltet, meldet WA gleich "Telefon nicht verbunden".
Drücke ich die Einschalttaste am T1, ist die Verbindung gleich wieder da.
Die einzige passende Einstellung ist unter erweiterten WLAN Einstellungen, aber da habe ich "Wlan im Ruhezustand abschalten" nicht aktiviert.
Sollte also aktiv bleiben...
Wird dieser Schalter vielleicht falsch ausgewertet?
Probiere mal bitte mit abgeschalteter WLAN-Optimierung unter erweiterte WLAN-Einstellungen.

MfG, JoWi81
 

Anhänge

Zuletzt bearbeitet:
JoWi81

JoWi81

Fortgeschrittenes Mitglied
Threadstarter
Hallo zusammen,

die Aktualisierung Update_2016-04-27 und die langersehnte Vollinstallation Beta_2016-04-27_AROMA bzw. Beta_2016-04-27_Default möchte ich euch nicht vorenthalten. Unteranderem ist jetzt auch eine Prop-Editor-App an Bord (siehe Screenshot1, 2, 3, 4, 5). An dieser Stelle ein großes Dankeschön an Ciubex für über 70% des Quellcodes.

Hier mal wie Folgt alle Änderungen im kurzen Überblick:
  • Offene Stelle in der Tastatur auf der rechten Seite im Landscape-Modus beseitigt.
  • Darstellungsprobleme der Mounts und symbolischer Verknüpfungen der wenigen Apps (z.B. ES Datei Explorer) behoben.
  • Property-Editor-App (com.jowi81.propeditor.apk) hinzugefügt.
  • Sicherung und Wiederherstellung-App (DataTransfer.apk) hinzugefügt.
  • Änderungen aus aktuelleren Version (Build 3_220, Blur 322.0.1, Date 08.01.2015) implementiert.
  • Und einige anderen weniger wichtigen Sachen.

MfG, JoWi81
 

Anhänge

Zuletzt bearbeitet:
C

cyt1

Neues Mitglied
JoWi81, vielen, vielen Dank für deine tolle Arbeit!
 
JoWi81

JoWi81

Fortgeschrittenes Mitglied
Threadstarter
Hallo zusammen,

in der Installationsdatei Beta_2016-04-27_Default wurde im parallellaufenden Thread vom Cynus T2 ein Fehler entdeckt, der zum Abbruch der Installation führte. Diesen habe ich bereits behoben und unter der gleichen Benennung Beta_2016-04-27_Default hochgeladen.
Sorry für die Umstände!
 
Zuletzt bearbeitet:
JoWi81

JoWi81

Fortgeschrittenes Mitglied
Threadstarter
Hallo zusammen,

ich habe eventuell eine Möglichkeit gefunden den Akku-Verbrauch (um vielfaches?) zu senken.
Hierbei habe ich den Verdacht, dass die zurzeit verwendete Library "hwcomposer.mt6577.so" den Bildschirmaufbau immer mittels GPU durchführt.

Eigentlich sollte der Bildschirmaufbau beim normalen Arbeiten im Android OS mittels HW-Overlays erfolgen und erst z.B. in einer Spiele-App automatisch mittels GPU erfolgen. Der Nachteil des Bildschirmaufbaus mittels HW-Overlays ist eine etwas schlechtere Performance bei Bewegungen z.B. beim Scrollen.

Es wäre schön wenn ihr folgenden Fix mit einer anderen Library "hwcomposer.mt6577.so" testet und anschließend über eure Erfahrung berichtet:
Battery-Fix_Test_2016-05-26

Wer anschließend die Performance auf Kosten des höheren Akku-Verbrauchs zurück haben möchte, kann die GPU für jede Art von Bildschirmaufbau über die Einstellungen-App->[Entwickleroptionen*]->[HW-Overlays deaktivieren] aktivieren bzw. erzwingen.
*) Entwickleroptionen sind erst sichtbar wenn man mehrmals hintereinander auf Build-Number in der Einstellungen-App->[Über das Telefon]->[Build-Number] klickt.

MfG, JoWi81
 
Zuletzt bearbeitet:
C

cyt1

Neues Mitglied
Hi JoWi81,

danke für den Fix und deine Arbeit! Wie sind deine Erfahrungen bisher damit, hat es bei dir was gebracht?
 
Nick Knatterton

Nick Knatterton

Ambitioniertes Mitglied
Hallo JoWi81,

ich bin zu meiner Schande bisher nicht dazu gekommen, das letzte Update einzuspielen. Das wird aber sicher gebraucht, um jetzt den Batterie-Fix testen zu wollen, oder? Ich komme für das eine und/oder das andere frühestens am Wochenende dazu.
 
JoWi81

JoWi81

Fortgeschrittenes Mitglied
Threadstarter
Hallo nochmals,

JoWi81 schrieb:
Wer anschließend die Performance auf Kosten des höheren Akku-Verbrauchs zurück haben möchte, kann die GPU für jede Art von Bildschirmaufbau über die Einstellungen-App->[Entwickleroptionen*]->[HW-Overlays deaktivieren] aktivieren bzw. erzwingen...
Hab feststellen müssen, dass wenn man die o.g. Option setzt, diese nach dem Neustart wieder verloren geht. Folgender Fix behebt dieses Problem (ersetzt Battery-Fix_Test_2016-05-26 vollständig):
Battery-Fix_Test_2016-05-31

@cyt1
Meine bisherige Erfahrung war, dass eine Akku-Ladung um ca. 1/3 länger reicht (bei normalen Nutzung wie Nachrichten bzw. E-Mails schreiben usw.)

@Nick Knatterton
Die Aktualisierungen vorher aufzuspielen wäre sinnvoll :winki:
 
D

DxnielKenduch

Neues Mitglied
Hallo zusammen,
Ich habe auch das Mobistel cynus t1 und habe diese Datei auch schon auf die sd karte gepackt
aber beim reboot findet mein Handy diese Datei nicht. Ich bitte um schnellst mögliche Hilfe für die komplette
Instalation. Ich kann auch über Skype oder über Teamspeak reden. Wenn jemand bereit ist mir zu helfen,
soll er mich bitte anschreiben vielen Dank.

Lg,
Daniel
 
Zuletzt bearbeitet von einem Moderator:
Bearbeitet von Verpeilter Neuling - Grund: Private Email entfernt - Gruß Verpeilter Neuling
Verpeilter Neuling

Verpeilter Neuling

Super-Moderator & Mediator
Teammitglied
Hallo Daniel, herzlich willkommen bei Android-Hilfe :). Ich habe aus deinem Beitrag deine private Email-Adresse entfernt. Die solltest du nie öffentlich in Foren posten. Sonst sind Spam und Phishing vorprogrammiert. Ich bin mir sicher, dass dir jeder, der eine Email geschickt hätte, auch hier im Forum helfen kann :)
 
O

Obernetter

Ambitioniertes Mitglied
Hallo,

Datei nicht richtig kopiert? Nach Anleitung funktioniert alles...
Prüfe mal die Datei und das FOrmat..

Gruß
Obernetter
 
D

DxnielKenduch

Neues Mitglied
@Obernetter, ich habe die Datei, also die komplette als rar Datei eingefügt
 
JoWi81

JoWi81

Fortgeschrittenes Mitglied
Threadstarter
DxnielKenduch schrieb:
Hallo zusammen,
Ich habe auch das Mobistel cynus t1 und habe diese Datei auch schon auf die sd karte gepackt
aber beim reboot findet mein Handy diese Datei nicht. Ich bitte um schnellst mögliche Hilfe für die komplette
Instalation. Ich kann auch über Skype oder über Teamspeak reden. Wenn jemand bereit ist mir zu helfen,
soll er mich bitte anschreiben vielen Dank.

Lg,
Daniel
Hallo auch von mir. Von welcher Datei ist hier die Rede? Wenn es die Installationsdatei (.zip) ist: meinst du mit dem Rebooten das Booten in den Recovery-Modus? Wenn ja: hast du ein Custom-Recovery (CWM, TWRP, PhilZ) drauf? Bei einem Stock-Recovery ist 1. die externe SD-Karte (microSD) nicht zugängig, sondern nur die interne SD-Karte (Partition) und 2. die Installationsdatei (.zip) lässt sich nicht installieren. Für die Problemanalyse wären ein paar Infos mehr nicht verkehrt. Eventuell kann dir auch schon die Anleitung "So bekommt T1 Android 4.4.2. mit 1,5GB freien Speicher" vom Nick Knatterton behilflich sein.

MfG, JoWi81
 
genki

genki

Neues Mitglied
Hey JoWi81, hab mich lange nicht gemeldet,
erstmal wollte ich Danke sagen für deine unermüdliche Arbeit. Ich war lange nicht hier, hab gerade den Batteryfix gesehen, evtl. löst der das teils merkwürdige Verhalten meiner Batterieanzeige beim Laden und Neustarten.
Eigentlich aber schreibe ich, weil mich die selbstständige Auswahl des Netzanbieters meines Telefons verunsichert.
Ich habe das jetzt beim Herumreisen im Urlaub mitbekommen: Sobald der Empfang schwach wird, wechselt das Netz und die Karte(n) gehen in den Roamingbetrieb über. Ich habe zwei sim-Karten im Telefon, die sich beide ins o2-de Netz einzuwählen haben. Ich habe entsprechend Anleitung unter Einstellungen/Drahtlos & Netzwerke/Mobilfunknetze/Mobilfunkanbieter schon öfter zwischen "Manuell wählen" und "Automatisch auswählen" hin und her gewechselt, kann das Telefon aber nicht davon abbringen in den Roamingbetrieb überzugehen, wenn der Empfang im o2-Netz schlecht ist.
Kann meine Beobachtung hier jemand nachvollziehen? Oder bin ich der einzige, der in einer Gegend mit teils schlechter Netzabdeckung lebt?

@DxnielKenduch ich hab es auch mit der wirklich guten Schritt für Schritt Anleitung von Nick Knatterton geschafft, mein Telefon zu aktualisieren, da schaffst du das auch.
 
JoWi81

JoWi81

Fortgeschrittenes Mitglied
Threadstarter
Hallo genki,

genki schrieb:
Ich habe das jetzt beim Herumreisen im Urlaub mitbekommen: Sobald der Empfang schwach wird, wechselt das Netz und die Karte(n) gehen in den Roamingbetrieb über. Ich habe zwei sim-Karten im Telefon, die sich beide ins o2-de Netz einzuwählen haben.
Dieses Thema ist nicht ganz unbekannt und nennt sich "National-Roaming" (siehe mein Beitrag).
Wie folgt das Statement von o2:
o2-Team (https://hilfe.o2online.de/docs/DOC-2562) schrieb:
Warum zeigt mein Handy im National Roaming immer "R" im Display an bzw. warum funktioniert das mobile Internet nur, wenn ich Daten-Roaming aktiviere? Wie stelle ich mein Handy ein, wenn ich grenznah wohne und Datenroaming-Kosten vermeiden möchte?
Dies ist abhängig von Ihrem verwendeten Endgerät und tritt nur bei einigen wenigen *Modellen auf. Bei Verwendung innerhalb Deutschlands kann bei diesen Endgeräten Daten-Roaming aktiviert werden, um National Roaming zu nutzen. Bei Verwendung in einer Grenzregion empfehlen wir, Daten-Roaming zu deaktivieren und ergänzend das Netz von o2 per manueller Netzwahl auszuwählen, um Kosten durch Roaming im Ausland zu vermeiden. Allerdings ist dann auch keine Nutzung des National Roamings möglich.

* folgende Handy-Modelle können davon betroffen sein: ...Mobistel Cynus T1...
Hierbei erzählt aber das o2-Team nicht die ganze Wahrheit, denn die Verbindung mit dem manuell ausgewählten Netz bleibt nur bestehen solange das Signal stark genug ist. Sobald das Signal schwächelt, verbindet er sich mit dem nächst stärkstem Roaming-Partner-Netz. Dazu zählen sowohl nationale als auch internationale Partner-Netze.

Die Tage teste ich bereits mit einem Bekannten die Nutzung des nur nationalen Roaming und es wäre schön wenn du dich auch am folgenden Test mit beteiligen könntest:
  • Xposed Installer-App und Xposed GravityBox-Modul herunterladen und installieren.
  • Das Xposed GravityBox-Modul über Xposed Installer-App->[Module]->[GravityBox KK] aktivieren.
  • Das Framework über Xposed Installer-App->[Framework]->[FRAMEWORK: Installieren/Aktualisieren] installieren und anschließend Android OS neustarten.
  • Das Daten-Roaming über Einstellungen-App->[DRAHTLOS & NETZWERKE: SIM-Verwaltung]->[ALLGEMEINE EINSTELLUNGEN: Roaming]->[Daten-Roaming]->[SIM] deaktivieren.
  • Das nationale Daten-Roaming über GravityBox [KK]-App->[Telefoneinstellungen anpassen]-[MOBILE DATEN: Nationales Daten-Roaming] aktivieren.

genki schrieb:
...hab gerade den Batteryfix gesehen, evtl. löst der das teils merkwürdige Verhalten meiner Batterieanzeige beim Laden und Neustarten.
Beim Ausschalten und wieder Einschalten oder beim kompletten Neustart müssen alle Kernel-Elemente neu geladen werden und dies erfordert 1. einen hohen Energiebedarf und 2. führt ggf. zu einer Fehlkalkulation der Akku-Ladung.

Was mir noch aufgefallen ist, dass eine Akkuladung länger reicht wenn man sein Akku vollständig über USB am PC auflädt anstatt über das Netzteil. Der Nachteil ist, dass die Aufladung eventuell doppelt so lange dauert.


MfG, JoWi81
 
Zuletzt bearbeitet:
JoWi81

JoWi81

Fortgeschrittenes Mitglied
Threadstarter
Hallo zusammen,

ich möchte euch den Patch National_Roaming_Support_2016-07-29 für die Unterstützung des nationalen Roaming (z.B. für o2 und E-Plus) vorstellen. Dank des Xposed GravityBox-Modules ist es mir gelungen den für Roaming verantwortlichen Quelltext-Bereich im KitKat JoWi81-Mod zu lokalisieren und dementsprechend zu erweitern. Somit wird Xposed nicht mehr benötigt.

Mit Build-Property [build.prop] "ro.jowi81.natroamingsupport=" hat man die Möglichkeit diese Unterstützung zu steuern:
  • "1": Aktiviert die Unterstützung des nationalen Roaming.
  • "0" oder weglassen: Deaktiviert die Unterstützung des nationalen Roaming.

Nur mal so am Rande: unter Play Store findet ihr meine aktualisierte Prop-Editor-App.


Falls hier jemand zufällig diesen Beitrag liest der nicht KitKat JoWi81-Mod nutzt und dennoch die Unterstützung des nationalen Roaming haben möchte, so habe ich wie folgt eine relativ simple lösung für euch (Root-Rechte erforderlich):
  • Xposed Installer-App und Xposed National Roaming-Modul herunterladen und installieren.
  • Das Xposed National Roaming-Modul über Xposed Installer-App->[Module]->[National Roaming] aktivieren.
  • Das Framework über Xposed Installer-App->[Framework]->[FRAMEWORK: Installieren/Aktualisieren] installieren und anschließend Android OS neustarten.
  • Das Daten-Roaming über Einstellungen-App->[DRAHTLOS & NETZWERKE: SIM-Verwaltung]->[ALLGEMEINE EINSTELLUNGEN: Roaming]->[Daten-Roaming]->[SIM] deaktivieren.

MfG, JoWi81
 
Zuletzt bearbeitet:
genki

genki

Neues Mitglied
Hallo JoWi81,
danke nochmal für den Roaming Fix, hab das installiert und jetzt länger beobachtet. Das funzt ganz prima. Auch zum Batterie Fix kann ich nur positives vermelden, die Batterieladeanzeige scheint mir jetzt logischer bzw. nachvollziehbarer.
Trotzdem hab ich da mal noch ein Problem, dem du dich evtl annehmen/ das du evtl. reproduzieren kannst!? Ich habe die Option Ein- und Ausschalten nach Zeit aktiviert, das tut auch erwartungsgemäß. Ein Problem tritt dann auf, wenn du zusätzlich den Wecker stellst und zwar so, dass er vor der Einschaltzeit losgeht. Dann kannst du deine Pin zur Freischaltung der Sim beliebig oft eingeben die wird einfach nicht angenommen, so zumindest bei mir. Das wird auch nicht als Fehleingabe gewertet und es hilft nur ein Neustart des Telefons.
 
3

3dhubiflieger

Neues Mitglied
Hallo Jowi die Beta_2016-04-27_Default ist bei mir fehlerhaft. Egal wie oft ich sie runterlade. Man kann die Zip nicht im Telefon flashen. (Fehlermeldung, da beschädigte Zip) Und wenn ich versuche diese am Pc zu entpacken kommt ebenfalls ein Fehler.
 
moidept

moidept

Experte
@3dhubiflieger
Der Download und das entpacken der Datei, funktionieren zumindest bei mir ohne Probleme, kannst du testweise einen anderen Webbrowser versuchen. welches Packprogramm nutzt du ?
 
3

3dhubiflieger

Neues Mitglied
Ich hatte firefox benutzt, und dann den IExplorer testweise. Bei beidem das selbe. Ich benutze Izarc.
 
Oben Unten