"root undetected" / "Es ist keine SuperSU Datei installiert"

  • 12 Antworten
  • Neuester Beitrag
Diskutiere "root undetected" / "Es ist keine SuperSU Datei installiert" im Root / Custom-ROMs / Modding für Moto Z im Bereich Motorola Moto Z Forum.
NighteeeeeY

NighteeeeeY

Ambitioniertes Mitglied
Hallöchen

ich habe ein kleines Problem mit meinem neu erworbenen Moto Z.

Kleine Vorgeschichte: hatte vor 2 Monaten bereits beim ersten Saturn Deal eins gekauft, aus Versehen auf 7.0 upgedatet und mich selbst in Arsch gebissen. Bootloader nicht mehr auf 6.x downgradebar (wer hätte das gedacht), ein paar Wochen rumgefrustet und jetzt doch ein neues gekauft.

Gestern dann endlich das Neue bekommen, Bootloader, TurboZ Kernel und Mod Recovery geflasht nach dieser Anleitung.

Jetzt ist das Problem, dass irgendwas mit dem Root nicht stimmt. Der scheint nicht ganz drauf zu bleiben? Hab es mit 2.79 als auch 2.81 SuperSU probiert aber es hakelt.

Ich habe zwar Xposed drauf und es funktioniert auch (das war der eigentliche Grund für den Neukauf), allerdings hatte ich es erst Installiert, dann geflasht (2 stufig) und dann einen Factory Reset gemacht und neu Installiert (ohne neu zu flashen) und zwischenzeitlich mehrere Male SuperSU neu geflasht, dass es irgendwie läuft. Module auch alles kein Problem.

Allerdings hakelt es bei anderen Apps, die Root benötigen. Wie zb. Substratum oder AdAway. Wenn ich SuperSU direkt nach dem neu flashen öffne, ist alles normal. Sobald ich aber eine App öffne, die Root benötigt, hängt sich nicht nur die App auf, auch der Root Zugriff wird nicht gewährt und wenn ich dann SuperSU öffne kommt ein Pop Up dass entweder nur "root undetected" sagt (bei SuperSU 2.81) oder ein Popup kommt mit folgender Meldung bei SU 2.79:

Screenshot_20170616-182928.png

Jetzt habe ich mal fix gegoogelt und offenbar bin ich nicht der einzige der das Problem hat. Gibt es da grade generell ein Problem mit SuperSU? Hat grade jemand ähnliche Erfahrungen oder kann mir grade n Tipp geben, was ich da am besten anstellen kann?

Bin schon mal froh, dass Xposed läuft, wenn auch mehr oder weniger instabil (Module aktivieren und neustarten geht nicht aus dem Installer heraus, muss immer manuell Neustarten), aber Substratum und Adaway und zb auch Greenify wären schon nett, wenn sie ordentlich laufen würden.

Fahre wie gesagt Stock 6.0.1 mit TurboZ Kernel.

Bin dankbar über Hilfe!

LG
 
R

Ryuk

Experte
einfach die aktuelle 2.82 nehmen, dann sollte es funktionieren
Download

btw...die 2.81 war fehlerhaft bei vielen und bei der 2.79 musste man die 2.79sr3 beta nehmen
 
NighteeeeeY

NighteeeeeY

Ambitioniertes Mitglied
Nee leider nicht ._. Hat er zwar richtig installiert, trotzdem kommt das Popup noch. Und der Root Access funktioniert immer noch nicht.

Liegt es vielleicht an dem Turbo Z Kernel? Auf XDA schrieb jemand, dass die verlinkte Methode nur für Nougat geeignet sei.

Was mach ich jetzt am besten, wenn ich nochmal "von Vorne" anfangen will? Reicht irgendein wipe? Muss ich ein Stock Kernel flashen? Oder liegt es an der Mod Recovery, damit die Moto Mods noch funktionieren?

Poah ich habe grade echt keinen Durchblick mehr.

Bitte Hilfe! Vielen Dank!
 
R

Ryuk

Experte
ja, der TurboZ-Kernel ist eigentlich nur für Nougat

flash einfach mal den 6er Stock-Kernel und dann SuperSU...kann aber durchaus sein, dass root nach einer Weile verloren geht und man das Phone dann neustarten muss, damit root wieder geht...war zumindest bei mir so, als ich es unter MM probiert hatte...
anonsten mal mittels Magisk probieren...hab ich aber selbst noch nie versucht

du willst sicher auf MM bleiben zwecks xposed, nehm ich an
 
NighteeeeeY

NighteeeeeY

Ambitioniertes Mitglied
Ja natürlich. Das war der einzige Grund weshalb ich ein 2. Moto Z kaufen musste ^^

Ich finde leider nur nirgendwo einen Stock Marshmallow Kernel. Irgendwo muss es den doch geben?
-- Dieser Beitrag wurde automatisch mit dem folgenden Beitrag zusammengeführt --
So. Habe Magisk geflasht. Und Manager Apk installiert. Wenn ichs öffne, verlangt die App allerdings ebenfalls Root über SuperSU, was ja NICHT FUNKTIONIERT. Ein bisschen beißt sich hier der Hund selbst in den Schwanz.
 
Zuletzt bearbeitet von einem Moderator:
NighteeeeeY

NighteeeeeY

Ambitioniertes Mitglied
Woops. Das war wohl nichts.

Bootloop. Beim Neustart sagte er Encryption failed und wollte einen Factory Reset. Danach Factory Reset Schleife.

Und nu? ^^
-- Dieser Beitrag wurde automatisch mit dem folgenden Beitrag zusammengeführt --
Irgendwelche Caches gewiped, irgendwelche Kernel geflasht, irgendwelche Roms geflasht, plötzlich startet es wieder.

Aaaaalso nochmal alles von vorne. Vielleicht jetzt mit Stock Kernel und SU 2.82...
-- Dieser Beitrag wurde automatisch mit dem folgenden Beitrag zusammengeführt --
Hm! Es ist immer noch der Turbo Z Kernel drauf. Wie bekomme ich jetzt gefahrlos einen anderen/neuen drauf?! Habe ich grade irgendwas falsch gemacht als ich deinen flashen wollte?

Habs mit TWRP gemacht. Aber man macht das wohl besser über Fastboot?
-- Dieser Beitrag wurde automatisch mit dem folgenden Beitrag zusammengeführt --
Hm. Über Fastboot kann ichs nicht flashen, er sagt Image not signed or corrupted.

.......
-- Dieser Beitrag wurde automatisch mit dem folgenden Beitrag zusammengeführt --
Hat den Kernel trotzdem irgendwie geflasht. Nochmal Super SU geflasht - immernoch das gleiche Problem vom Anfang. Root undetected.

GOTT IM HIMMEL.

Woran kann es liegen????? ICH HABE KEINE AHNUNG.
 
NighteeeeeY

NighteeeeeY

Ambitioniertes Mitglied
Jetzt geht übrigens das Wlan nicht mehr. Hab ne Stock Recovery geflasht. Nochmal Stock Kernel. Alles probiert. Nichts gehts mehr. HILFE. :(
 
R

Ryuk

Experte
dachte du weißt was du machst, wenn du u.a. xposed nutzt...aber wenn ich schon lese "irgendwelche caches gewiped und roms und kernel geflasht"...^^
so weiß man ja gar nicht mehr, was drauf ist, was gemacht wurde, etc. ^^
sicher auch alles dirt geflasht ohne danach mal einen factory reset zu machen?
und vorher auch kein backup gemacht, nehm ich mal an?

welchen turboz hast du genommen, v1.0_MM?
TurboZ Kernel For Moto Z - xda-developers DevDB
 
NighteeeeeY

NighteeeeeY

Ambitioniertes Mitglied
Ja also im Prinzip hab ich schon n Plan von dem was ich mache.....grundlegend. ^^ Ist jetzt auch nicht das erste Phone aber das letzte ist schon n bisschen her. Und ich bin mir immer nie so sicher wann ich welche Caches wipen muss und ob mans nur sollte oder muss weils manchmal auch einfach so funktioniert aber ja....alles ein bisschen dirty. Aber doch, Factory Reset habe ich zwischendurch einige gemacht. Hat aber nicht viel geholfen. Und der Kernel und die Recovery bleiben dann ja auch trotzdem noch drauf.

Genau ich hab den Turbo Z for MM genommen.

Der ist aber mittlerweile ja nicht mehr drauf, sondern den, den du gepostet hast. Habe auch alle möglichen Recovery ausprobiert, die "Mod Recovery" aus dem oben verlinkten Thread, als auch die 3.1.0 und 3.0. Hat alles irgendwie nichts gebracht.

Und außer dem einen MM Rom aus dem Moto Z Forum auf XDA, welches ich aber nicht flashen kann, weil eine android-info.txt oder so fehlt (und andere im Thread über Bootloops berichtet haben) finde ich jetzt auch kein anderes MM Stock Rom um irgendwie nochmal "von vorne" anzufangen?

Ich weiß grade nicht was der richtige Weg ist. Kriege ich irgendwie alles nochmal Stock in einem Rutsch hin um nochmal von vorne anzufangen?

Das ist echt von Anfang an verhext gewesen mit diesem **** Moto Z. :(

Ich will doch nur dass der Root ordentlich funktioniert.
 
R

Ryuk

Experte
schau mal hier:
firmware.center

entweder du nimmst die RETEU-EMEA_6.0.1 (daraus hab ich den obigen Kernel) oder die brasilianische RETBR_6.0.1, die hatte ich bei mir geflasht, als ich nochmal angefangen hatte...bin dann aber direkt auf Nougat per OTA...

Anleitung hier:
[Firmware] Moto Z - XT1650-03

und wegen root, probier halt mal phh's superuser...
 
NighteeeeeY

NighteeeeeY

Ambitioniertes Mitglied
Also ich war schon fast soweit auf zu geben. Hab alles nochmal neu gemacht. Cleanes Rom geflasht, aber SuperSU WOLLTE einfach nicht funktionieren. Keine Ahnung woran es gelegen hat.

Nach nochmaligen 3 Factory Resets und jedes mal wieder 190 Apps synchronisieren lassen und heck meck habe ich einfach ganz clean phhs geflasht und siehe da - funktionierte. Einfach so. War erst skeptisch weil ich keine Infos finden konnte ob es aufm Moto Z läuft und er ja dazu schrieb dass es das Device bricken kann.

Aber dabei scheint es sich ja um ein systemless SU zu handeln? Habe bisher keine Einschränkung bis auf AdAway feststellen können. Aber da habe ich irgendwelche Host files gefunden die man flashen konnte und die irgendwelche synthetischen Verbindungen zu /system hergestellt haben. Und seit dem funktioniert auch das.

Xposed, Substratum, Greenify - alles läuft zufriedenstellend.


Vielen vielen Dank für die große Hilfe! Ich habe keine Ahnung warum SuperSU so verbugt ist. Aber jetzt läuft alles wie es soll - hoffentlich. Ob sich der ganze Aufwand auch gelohnt hat, wird sich zeigen, wenn die Qwerty Tastatur von Kickstarter ankommt und problemlos funktioniert ^^ was ich hoffe.

Danke!
 
S

Stuttgarter

Fortgeschrittenes Mitglied
wie hast du denn das WLAN wieder zum Laufen bekommen?