1. Mitglieder surfen ohne Werbung auf Android-Hilfe.de! ✔ Jetzt kostenlos Mitglied in unserer Community werden.
  1. trailrider, 23.06.2018 #1
    trailrider

    trailrider Threadstarter Neuer Benutzer

    Ich dreh noch durch, kann bei meinem X Compact das OEM Unlocking nicht mehr aktivieren. Ist ausgegraut, daher kann ich auch meinen Bootloader nicht unlocken. Zurücksetzen hat nichts gebracht und auch über Companion das System zurück setzen war erfolglos ;-(

    Kann aktuell weder Rooten noch sonst was mache, das Ding ist einfach dicht ...

    Hat jemand ne Idee? z.B. einen Fallback auf Android 6 oder 7? hat vielleicht jemand eine Version die ich mit dem Sony Flasher aufspielen kann? oder sonst einen Tip?

    Kann auch mit Fastboot nix Flashen oder den Bootloader von Hand öffnen: immer FAILED (remote: Command not allowed)

    Aktuell hab ich die 34.4.A.2.70 drauf
     
    Zuletzt bearbeitet: 23.06.2018
  2. trailrider, 23.06.2018 #2
    trailrider

    trailrider Threadstarter Neuer Benutzer

    So, Fehler ist gefunden und behoben, lag daran das ich noch keine Nano-SIM habe und diese Option sich nur ändern lässt wenn eine SIM eigelegt ist ;-)

    Gut aber trotzdem gibts jetzt Probleme, hab das Update auf die 34.4.A.2.85 (DE) drauf gemacht (Stock über XperiFirm / Flashtool) habe dann gleich mal den Bootloader unlock gemacht und diese eigentlich "Einfache" Anleitung genutzt: [stock 8.0][Unlocked bl][34.4.A.2.19; ...32; ...85] Root and Recovery (3 clicks)

    Klappt aber ums Verrecken noch mal nicht, hängt immer beim Sony Logo (Bootschleife) und auch das angebliche "TWRP Update" oder auch das normale 1 Link weiter oben zickt.
    Mal will es ein Password oder dann mal eine Wischgeste aber ich habe keine bzw. meine die ich beim Lockscreen habe nimmt er nicht. Und auch die Speicherkarte und der Interne Speicher haben immer 0 Bytes und lassen sich nicht mounten.

    Ist echt zum verrückt werden, hab diverse TWRP´s versucht, 3.1.1, 3.2.1, 3.2.1-V7 alles was in den Foren zu finden ist aber keines geht wirklich ;-(
     
  3. Android Nutzer 76, 24.06.2018 #3
    Android Nutzer 76

    Android Nutzer 76 Erfahrener Benutzer

    Nimm einfach das Tool Emma von Sony und stell dein Phone wieder her.
    Danach fang mit der Anleitung von vorne an... Irgend etwas muss falsch gelaufen sein.
     
  4. trailrider, 24.06.2018 #4
    trailrider

    trailrider Threadstarter Neuer Benutzer

    Mit Emma ein Repair auf die Version 34.4.A.2.32, das passende Boot.Img installiert und das gleiche Spiel: hängt beim Sony Screen
    Ich dreh noch durch, seit 13 Stunden häng ich schon an dem DRECKS Phone. Kann doch nicht wahr sein, ist ja nun auch nicht das erste Sony
    das ich Roote oder mit Custom Rom´s nutze bzw. vom Datenmüll entferne und mit Xprivacy, AFWall+ absicher bis jetzt hab ich noch NIE solche Probleme
    gehabt. Und wenn ich auf XDA nachlese haben zig Leute dieses Problem mit dem Speicher oder dem Bootloop oder hängenden Sony Logos und irgend wie gibts
    Keinen der ne Lösung dafür gefunden hat *kotz* so jetzt geh ich pennen. PS: Hat nicht jemand einen Link zu nem Oreo mit Root als FTF File?
    auf den TWRP Kram kann ich verzichten auf Root, Xposed und ne Firewall aber nicht ...
     
  5. Andi_K, 24.06.2018 #5
    Andi_K

    Andi_K Moderator Team-Mitglied

    Ich hab mir mal erlaubt den Titel ein bisschen anzupassen. Vorher sah es nämlich so aus, als ob Du um Hilfe bittest weil Dein Gerät dieses Feature "kann", nicht weil es bei Dir nicht funktioniert.

    Schönen Gruß
    Andi
     
  6. trailrider, 24.06.2018 #6
    trailrider

    trailrider Threadstarter Neuer Benutzer

    Das funktioniert jetzt, besser wäre der Titel "suche Oreo 34.4.A.2.85 (DE) mit Root als FTF File"

    denn so langsam dreh ich durch, habe bis jetzt von Version 34.4.A.2.85, 34.4.A.2.70, 34.4.A.2.32. 34.3.A.0.252 (Andorid 7.1.1) und alle dazu passenden TWRP Versionen ab 3.1.0.0 bis zu 3.2.1-v7 und es ist bei JEDER Version und Rom das Gleiche:

    Ich flashe mit Emma oder Flashtool, anschließend kommt die passende TWRP Version drauf. Dann kann ich das Telefon starten und alles läuft.
    Kann das Phone auch 10x starten. Alles TOP! aber so bald ich dann in TWRP gehe und es wieder verlasse bleibt es entweder beim Sony Logo hängen oder
    er zeigt es kurz an und booted danach immer wieder ... Ich kann mir das nicht erklären und hab ehrlich gesagt keine Ahnung mehr was ich noch versuchen kann.
    Habe auch schon unterschiedliche Platform-Tools versionen versucht. Flashen der Roms kein Thema, TWRP aufspielen auch kein Problem aber so bald es genutzt wurde
    beginnt der Bootloop / Boothänger.

    Das schlimmste ist das ich diese TWRP ja nur brauche um mir SuperSU für Rootrechte aufzuspielen. Anders bekomm ich es ja nicht auf das Phone.

    Kann jemand der die aktuelle Oreo Version MIT Root zum Flashen mit Emma oder Flashtool auf shareonline hoch laden?
     
  7. trailrider, 24.06.2018 #7
    trailrider

    trailrider Threadstarter Neuer Benutzer

    3 Stunden später und keinen Schritt weiter, das Problem ist immer noch das TWRP, egal welche Version ich flashe, so bald ich es öffne und ohne jegliche Änderungen einfach verlasse bootet dieses Drecksphone nicht mehr ;-( ich habe jetzt jegliche Versionen die mit Emma noch verfügbar sind versucht und ALLE dazu passenden TRWP Versionen versucht. IMMER das Gleiche, das Phone bootet und alles kann ich einrichten und nutzen. Ich kann es so lange nutzen bis ich auch nur 1x in TWRP Boote und es sofort wieder Verlasse. Ab diesem Zeitpunkt hängt er im Sony Bootlogo oder in einer Bootschleife. Das kann doch nicht wahr sein, Roote alle meine Phones seit es Android gibt und noch NIE hab ich es am Ende nicht doch geschafft. Es ist dermaßen unlogisch, da ist einfach NICHTS was ich falsch machen kann das ich nicht schon zig mal bei allen Phones gemacht habe und popliges Flashen ist ja nun wirklich kein Hexenwerk ...

    Ich heffe jemand von eucht erbarmt sich und kann mir ein Image hochladen, so lange muss ich das drecks Phone halt in die Schublade legen und weiter mein Sony Z1 Nutzen ;-(
     
    Zuletzt von einem Moderator bearbeitet: 11.07.2018
  8. Android Nutzer 76, 24.06.2018 #8
    Android Nutzer 76

    Android Nutzer 76 Erfahrener Benutzer

    Schonmal versucht deine eigene Boot IMG zu erstellen?
    Wird auch erklärt wie das geht... Den die, die er dort anbietet scheinen ja nicht zu funktionieren.
     
  9. trailrider, 24.06.2018 #9
    trailrider

    trailrider Threadstarter Neuer Benutzer

    Ehrlich gesagt noch nicht, da ich ja mit all meinen Fallbacks garnichts an der Boot.img gemacht habe, direkt nach dem ich das Handy mit all den Versionen gebootet habe konnte ich ja jedes mal in´s BS rein gehen und alles einstellen. Android 6, Android 7.1.1 und all die 8er Oreo Versionen. Das Phone fängt erst an mit den Bootproblemen so bald ich 1x in den TWRP Modus gehe. Ich habe alle möglichen TWRP Versionen versucht die ich zu all den Rootanleitungen gefunden habe. So bald ich nur TWRP Verlasse (Reboot System) ist Ende Gelände, das fucking Phone hängt im Sony Bootlogo fest oder es gibt einen Bootloop. Da hab ich noch absolut NIX an der Boot.img oder sonst was geändert. Es langt einfach eine der TWRP Versionen zu starten und beenden. So lange ich diese nicht starte kann ich das Handy 100x starten und beenden. Ich bin echt mit meinem Latein am Ende, zumal ich mit Emma und Flashtool ja wirklich alles Cleanen kann und wirklich alle gelöscht ist. Ich könnte das Teil gerade gegen die Wand schmeißen bin echt kurz davor das Ding zu verkloppen und weiter mein Z1 zu nutzen. Ich bin halt einer der sich lieber die Hände abhacken würde als eine Datenschleuder zu benutzen, kann ehrlich gesagt auch keinen Fehler finden der das verursachen könnte.

    PS: mein Mini-x10 und Xperia Mini hab ich auch mit Customrom und Root noch hier liegen ;-)
     
    Zuletzt von einem Moderator bearbeitet: 24.06.2018
  10. Aaskereija

    Aaskereija Foren-Inventar

    Das liegt daran das ab Android 6 von Haus aus die interne SD verschlüsselt wird. Normalerweilse sollte es reichen wenn du in TWRP auf Wipe > Advanced Wipe > Repair or Change File System (Haken bei Data setzen) > und dann müsste etwas auftauchen von wegen "Verschlüsselung aufheben" oder so ähnlich.

    Kann aber auch sein dass das bei dir woanders verpackt ist, musst einfach ein bisschen suchen
     
Die Seite wird geladen...
Ähnliche Themen Forum Datum
Paranoid Android 7.2.1 für das X Compact Root / Custom-ROMs / Modding für Sony Xperia X Compact 11.08.2017
Du betrachtest das Thema "Kann OEM unlocking auf dem X Compact nicht aktivieren" im Forum "Root / Custom-ROMs / Modding für Sony Xperia X Compact",
  1. Android-Hilfe.de verwendet Cookies um Inhalte zu personalisieren und dir den bestmöglichen Service zu gewährleisten. Wenn du auf der Seite weitersurfst stimmst du der Cookie-Nutzung zu.  Ich stimme zu.