Bootloop

S

slooowrider

Neues Mitglied
Threadstarter
Hallo,

ich habe gestern das Mi 9 entsperrt und TWRP installiert. Soweit hat das ohne Probleme funktioniert.
Nach dem Löschen der Daten und dem Aufspielen von LOS befinde ich mich nun in einem Bootloop von Fastboot.
TWRP startet nicht mehr, auch nicht nach nochmaliger Installation.
Über fastboot devices ist das Gerät auffindbar.
Über MiFlash ist das Mi9 nicht auffindbar und damit auch nicht flashbar.

Hat noch jemand eine Idee? ;(
 
T

thunder43

Stammgast
Mal mit Xiaomitool V2 probiert oder mit der Mi PC Suite 4.0.301.192beta die das Mi 9 unterstützt?
 
S

slooowrider

Neues Mitglied
Threadstarter
Das Xiaomitool V2 nennt 2 Optionen. Bricked (Feature not available) und Mod (USB-Debugging nicht angeschaltet).
Die Mi PC Suite 4.0.301 bringt nach dem Einloggen einen Fehler auf Chinesisch, verstehe ich nicht, kann ich nicht rauskopieren und übersetzen.
Die Mi PC Suite 2.2.0 findet das Mi 9 nicht.

Tolle Show. ;(
 
T

thunder43

Stammgast
Ohne aktivierten USB Debug Modus gehen beide Tools nicht. Hast du den Bootloader überhaupt noch offen?
 
S

slooowrider

Neues Mitglied
Threadstarter
Mit fastboot konnte ich eine Recovery und eine Boot.img flashen. Leider brachte das keinen Erfolg. Ich schätze das System ist zerschossen. Dieses konnte ich aber nicht über fastboot flashen.

Ich weiß nicht mehr weiter und bitte um Hilfe.
 
mcc2005

mcc2005

Stammgast
Probier mal mit dem MiFlash Tool eines der tgz Roms zu flashen (EEA oder Global). Ich hatte solche Probleme am Anfang auch.
 
S

slooowrider

Neues Mitglied
Threadstarter
Wie gesagt findet das MiFlashTool mein Handy nicht, fastboot aber schon.

Wenn ich mich recht erinnere hatte das MiFlashTool das erste Mal das Mi 9 erkannt, Seit ich aber auf Driver geklickt hatte, nicht mehr. Vielleicht gibts da nun ein Treiberproblem.
 
voyi1994

voyi1994

Stammgast
Schon mal versucht, das Flash Tool zu de - und wieder zu installieren? Bei mir hatte das auch
funktioniert, nachdem auf meinem Mi 9 ein rotes Dreieck mit gelben Ausrufezeichen erschien
und einem komischen Text.
 
T

thunder43

Stammgast
Ich denke auch, da fehlt dir im Windows der Treiber. Treibersignatur im Windows 10 vorher deaktiviert? Hast du auch das aktuelle Tool Xiaomi_Flash_20181115.zip benutzt?
 
S

slooowrider

Neues Mitglied
Threadstarter
Treibersignatur deaktiviert.
Das Flash-Tool ist eine portable-Version > keine Installation.
Habe die aktuelle Flash-Tool Version und auch schon ältere probiert.
Die passenden Treiber habe ich direkt von der Xiaomi-Seite runtergeladen und installiert > keine Veränderung.
Sobald ich auf "refresh" drücke, kommt folgender Fehler:
 

Anhänge

T

thunder43

Stammgast
Im internationalen Forum stand mal, dass das Flash Tool unbedingt auf C liegen muss und auf keiner anderen Partition. Hatte auch mal ein Problem damit als ich mein Mix 2 flashen wollte und das hat dann geholfen. Hab´s dann direkt auf C:\MiFlash kopiert und dort gestartet.
 
S

slooowrider

Neues Mitglied
Threadstarter
Danke schon mal für eure ganzen Tipps!

@thunder43: Auf C: liegend bringt leider auch nichts.

Ich habe leider keinen 2. PC oder Laptop, sonst würde ich das von diesem probieren.
 
T

thunder43

Stammgast
Hast du ein aktuelles ADB auf deinem PC installiert (ich denke mal weil du schreibst fastboot devices geht, lautet die Antwort ja)?

Verstehe ich richtig, wenn du mit "fastboot flash recovery twrp.img" das TWRP installierst und dann mit "fastboot boot twrp.img" ins TWRP starten willst kommt wieder Fastboot anstatt TWRP?
 
S

slooowrider

Neues Mitglied
Threadstarter
ADB habe ich drauf, installiert nicht, auch das ist eine portable-Version (r29.0.2).

Genau, TWRP kann ich mit deinem genannten Befehl flashen, starten tut das Mi 9 aber nur noch im fastboot, egal über Befehl oder über Tastenkombination.
 
voyi1994

voyi1994

Stammgast
Dann installiere Miflashtool und ADB Treiber mal nicht als Portable Version, sondern auf deinen
PC. Das TWRP scheint nicht installiert zu sein.
 
S

slooowrider

Neues Mitglied
Threadstarter
Ich habe jetzt lange gesucht bis ich endlich eine MiFlashTool Version gefunden habe, welche ich installieren kann (.msi).
Und siehe da es funktioniert auf Anhieb! Bin gerade dabei eine stable zu flashen und ich hoffe das klappt jetzt. Dann kann ich den 2. Versuch starten LOS zu flashen.
-- Dieser Beitrag wurde automatisch mit dem folgenden Beitrag zusammengeführt --
Hat funktioniert!

Vielen Dank für die Hilfe! Jetzt kann es weitergehen.
Das originale System plus originales Recovery sind wieder drauf.
 
O

One8se7en

Neues Mitglied
Glückwunsch!

Gab es hier übrigens schon einen "richtigen" Brick beim Mi 9?
 
S

slooowrider

Neues Mitglied
Threadstarter
Nachtrag:
LOS draufzubekommen war alles andere als einfach. Ich bin dieser Anleitung gefolgt:
[ROM] LineageOS 16.0

Bis Punkt 5 hat alles reibungslos geklappt. Nach dem Löschen konnte ich ums Verrecken nicht mehr ins TWRP booten. Also exakt wie die letzten Tage. Also musste ich wieder ein Stock-ROM flashen und von Neuem anfangen.
Ich habe den Reboot nach dem Löschen dann ausgespart und versucht direkt mit dem Flashen, also Punkt 6, weiter zu machen. Leider habe ich in keinem Fall die ZIPs aufs Mi 9 rübergebracht.

Das konnte ich dann nur mit ADB Sideload realisieren. Bitte Musik in dem verlinkten Video ignorieren:

Und Voila, es läuft. Bisher ohne Probleme. Theema ist auch schon komplett eingerichtet.

Nur 2 Fragen stellt mir Lineage noch und zwar Trust. Einmal ist LinuxSE deaktiviert und er meckert deswegen. Ich habe rausgefunden, dass das ein Sicherheitsfeature ist, finde aber nirgends etwas dazu wie ich das Feature aktivieren kann. Zweitens meckert er der Vendor wäre veraltet.
Bevor ich jetzt weiter konfiguriere, was sollte ich wegen dem Vendor unternehmen?
 
Thread starter Similar threads Forum Replies Date
Hucky-hiho Root / Custom-ROMs / Modding für Xiaomi Mi9 3
Similar threads
MI9 Bootloop fastboot
Oben Unten