Diskussion Brauche Hilfe beim rooten/Bootloader Unlock/TWRP

  • 100 Antworten
  • Neuester Beitrag
Diskutiere Brauche Hilfe beim rooten/Bootloader Unlock/TWRP im Root / Custom-ROMs / Modding für ZTE Axon 7 im Bereich ZTE Axon 7 Forum.
kevte89

kevte89

Senior-Moderator
Teammitglied
das kann ich dir gar net mal so genau sagen weil ich das noch nie so gemacht habe bzw damit beschäftigt habe.
 
H

hellmichel

Gast
Du musst auf jeden Fall Root entfernen und das Stock Recovery wieder aufspielen. Dann sollte es mit OTA Updates wieder klappen. Den BL auf keinen Fall wieder schließen. Habe bei XDA mehrfach gelesen, dass es dabei sehr häufig zu einem Brick kommt.
 
D

denf

Fortgeschrittenes Mitglied
ist es überhaupt möglich mit stock recovery und stock Rom, Root Rechte zu bekommen?
 
Ball

Ball

Ambitioniertes Mitglied
Hallo allerseits,

ich habe das Vergnügen einer derjenigen zu sein, der gerade günstig an das Axon7 gekommen ist (Mediamarkt-Aktion).

Ich habe auf meinem OnePlus One Lineage OS sehr lieb gewonnen und die Verfügbarkeit von Lineage war auch ein Kaufkriterium beim Axon7.

Nun habe ich schon Android 7.1.1 drauf, was das Entsperren des Bootloaders verkompliziert wie ich dem Forum entnehmen konnte. Ich habe schon gelesen, dass der Umweg zurück auf B10 funktionieren würde, habe aber das Problem, dass ich keine MicroSD-Karte hier habe (und es ist WE :-(). B10 einfach auf den internen Speicher zu kopieren bringt mich leider nicht weiter, da ich von dort im Stock-Recovery nicht installieren kann. Über ADB-Sideload erhalte ich die Fehlermeldung, dass die Datei (ROM mit B10) nicht gelesen werden konnte.

Meine Frage ist also hat jemand einen Tipp für mich wie ich ohne SD Karte zurück zu Android 6 komme oder wie ich den Bootloader unter Nougat entsperre?
Ziel ist wie geschrieben TWRP, Lineage und Root.

Vielen Dank
 
Jugulum

Jugulum

Neues Mitglied
Soweit ich weiß, musst du erst auf Marshmallow downgraden, da man unter Nougat den Bootloader nicht entsperren kann.
 
Ball

Ball

Ambitioniertes Mitglied
Ein Freund hat mir nun eine SD Karte gebracht und ich habe den Weg zurück zu B10 gefunden.

Jetzt hänge ich beim Entsperren des Bootloaders fest. In der dt. Anleitung heißt es:
"15) Geht in euren Geräte-Manager (Win10: Rechtsklick unten links auf das Windows Symbol) und stellt sicher, dass euer Handy als "QUSB_BULK" aufgelistet wird! **
** Wenn ihr Probleme mit dem verbinden eures Axon 7 als QUSB_BULK, downloadet Zadig und ersetzt euren Treiber mit dem WinUSB Treiber. Wenn adb euer Gerät auch nicht als QUSB_BULK erkennen möchte, schließt die adb.exe über den Task Manager."

Die engl. ist an der Stelle etwas genauer:
You should see a Qualcomm HS-USB QDLoader 9008 under Ports - COM & LPT, uninstall it AND TICK DELETE DRIVER SOFTWARE TOO and hold the three buttons of your phone (vol buttons and power) for quite a lot of time, until you see that the device manager list refreshes. If Windows attempts to install the driver cancel it at once, repeat the process if it did install it (it appears as a Qualcomm thing again). After holding the 3 buttons you should see an unidentified device named QUSB_BULK

An der Stelle hänge ich nun fest. Mein PC scheint den Treiber immer wieder von alleine zu installieren ohne, dass ich das unterbinden könnte. Als QUSB_BULK wird es nur kurze Zeit angezeigt.
Darüber hinaus was ist "Zadig"? Wo kann ich das herunterladen?

EDIT: Das Axon installiert sich in kürzester Zeit wieder als "Handset Diagnostic Interface (DFU)"
 
Jugulum

Jugulum

Neues Mitglied
Bei mir hat Widows den Treiber zuerst auch überschrieben. Mit "Zadig" (Zadig - USB driver installation made easy) ging es aber dann.
Als über den Geräte-Manager den "Qualcomm..."-Treiber deinstallieren. Zadig starten und in der Leiste neben dem Edit das Gerät auswählen und dann auf "Install WCID Driver" klicken. Bei mir war danach dann "QUSB_Bulk" ohne Ausrufezeichen ganz unten im Geräte-Manager unter "USB-Geräte".
 
Ball

Ball

Ambitioniertes Mitglied
Und ich komme gerade einen Schritt weiter...

Zunächst mal vielen Dank Jugulum. Ich habe Zadig nun benutzt und das Axon erscheint nun als QUSB_BULK im Gerätemanager.
Leider scheitert nun der Befehl "axon7tool -r gpt boot recovery" an der Fehlermeldung "Device not detected" und "failed to connect"
 
Jugulum

Jugulum

Neues Mitglied
Probier mal die "adb.exe" im Taskmanager zu beenden und prüfe ob das Gerät nach Eingabe des Befehls "adb devices" genannt wird. Ansonsten nochmals ein- und ausstöpseln und Schritt 13 und 14 wiederholen.
 
Zuletzt bearbeitet:
Ball

Ball

Ambitioniertes Mitglied
Das bleibt leider ohne Wirkung. Es wird mir kein Gerät genannt, das erkannt worden sei
 
Jugulum

Jugulum

Neues Mitglied
@Ball Auch nachdem du das Kabel vom Handy gezogen hast und nochmals eingesteckt hast? Bei mir hat das geklappt
 
Ball

Ball

Ambitioniertes Mitglied
Auch das klappt leider nicht.
 
Jugulum

Jugulum

Neues Mitglied
Starte mal das Telefon neu und probier es in der Konsole mit "adb devices" erneut.

Den Schritt hast du gemacht, oder?
10) Geht nun in die Entwickleroptionen und aktiviert die Option "OEM-Entsperrung" und die Option "USB-Debugging"
 
Ball

Ball

Ambitioniertes Mitglied
OEM-Entsperrung und USB Debugging sind jeweils aktiviert.

Wenn ich das Telefon neu starte (dann ist es als Mediengerät verbunden) wird das Device erkannt.

EDIT: Sobald in in EDL-Modus gestartet habe, wird mir kein Device mehr per adb device angezeigt
 
Jugulum

Jugulum

Neues Mitglied
Na wenn das Gerät bei adb devices erkannt wird, kannst du mit Schritt 14 weitermachen. Und vergewissere dich, dass nach "adb reboot edl" das Gerät im Geräte-Manager noch als "QUSB_BULK" aufgelistet ist.
-- Dieser Beitrag wurde automatisch mit dem folgenden Beitrag zusammengeführt --
Was wird denn im Geräte-Manager angezeigt?
 
Ball

Ball

Ambitioniertes Mitglied
Kann ich ja leider nicht. Sobald ich in den EDL Modus gehe scheint die Verbindung zum Gerät verloren zu sein. Dadurch, dass ich den Qualcom-Treiber entferne und das Gerät dann im Gerätemanager als QUSB_BULK habe ich aber nicht wieder eine Verbindung.

Im Gerätemanager taucht das Axon als QUSB_BULK auf
 
Jugulum

Jugulum

Neues Mitglied
Also im EDL-Modus taucht das Gerät mit "QUSB_BULK" auf und bei Eingabe von "axon7tool -r gpt boot recovery" erscheint eine Fehlermeldung?
-- Dieser Beitrag wurde automatisch mit dem folgenden Beitrag zusammengeführt --
Probier mal das:
Wenn das axon7tool, obwohl ihr den Zadig Treiber installiert habt, mit "what(), STD Fehler und whatnot" fehlschlägt:
Geht in den Gerätemananger und deinstalliert QUSB_BULK. Gebt dann "adb reboot edl" ein. Installiert den winUSB Treiber von Zadig und startet euer Handy neu, in dem ihr den Power Button 10 Sekunden lang gedrückt haltet. Gebt erneut "adb reboot edl" ein und dann "axon7tool -r gpt boot recovery".
 
Ball

Ball

Ambitioniertes Mitglied
Jugulum schrieb:
Also im EDL-Modus taucht das Gerät mit "QUSB_BULK" auf und bei Eingabe von "axon7tool -r gpt boot recovery" erscheint eine Fehlermeldung?

Exakt.

Das andere hat leider auch nicht geholfen
 
Ball

Ball

Ambitioniertes Mitglied
Leider auch nicht :crying:

Auf jeden Fall aber vielen Dank für deine Mühen
 
Ähnliche Themen - Brauche Hilfe beim rooten/Bootloader Unlock/TWRP Antworten Datum
7
Ähnliche Themen
ZTE Axon 7 rooten?