Ext Sd unter ICS

  • 20 Antworten
  • Neuester Beitrag
Diskutiere Ext Sd unter ICS im Root / Hacking / Modding für Samsung Galaxy S im Bereich Samsung Galaxy S (I9000) Forum.
ilovemysgs

ilovemysgs

Experte
Moin,

Ist es möglich per adb oder einer Terminal app das mounten von emmc auf sd/external sd zu ändern

Vllt. So :

unmount /emmc
mount/sdcard/external sd

Danke fûr eure antworten

Sent from my GT-I9000 using Tapatalk
 
PJF16

PJF16

Ehrenmitglied
Ich werde heute versuchen, ein CWM flashbares Package zu erstellen. ;)

EDIT: Scheint wohl unter ICS anders zu funktionieren, denn die Einträge existieren in der build.prop gar nicht. ;)
 
Zuletzt bearbeitet:
ilovemysgs

ilovemysgs

Experte
Was von emmc steht im der Init.aries.ac

Sent from my GT-I9000 using Tapatalk
 
n0va

n0va

Erfahrenes Mitglied
Kannst mal das im Terminal eingeben, hält aber nur bis zum Neustart:
mount /mnt/emmc /mnt/sdcard/external_sd
Der Ordner external_sd muss auf der internen Karte vorhanden sein.
 
ilovemysgs

ilovemysgs

Experte
@Nova geht net

Sent from my GT-I9000 using Tapatalk
 
n0va

n0va

Erfahrenes Mitglied
Hab vorhin mal genau das eingegeben und bei mir ist die externe jetzt auch unter /sdcard/external_sd bzw. /mnt/sdcard/external_sd erreichbar..
 
Illusionz

Illusionz

Stammgast
Versuchs nochmal, wenn du "su" vorher eingibst.
 
n0va

n0va

Erfahrenes Mitglied
Daran könnte es liegen, starte bei mir standardmäßig den Emulator mit Rootrechten.
 
ilovemysgs

ilovemysgs

Experte
Alles bring nix
Soll ich mal die der Teufel zip flashen (mountpoint tweak)

Sent from my GT-I9000 using Tapatalk
 
extralife

extralife

Experte
Besser nicht

... using tapatalk
 
ilovemysgs

ilovemysgs

Experte
Ok extralife ;)

Sent from my GT-I9000 using Tapatalk
 
orangerot.

orangerot.

Experte
n0va schrieb:
Kannst mal das im Terminal eingeben, hält aber nur bis zum Neustart:
mount /mnt/emmc /mnt/sdcard/external_sd
Der Ordner external_sd muss auf der internen Karte vorhanden sein.
Ich hab es grad auch probiert..

Terminal emulatr:
su [enter]
dann deine zeilen
exit[enter]

Der emulator spuckt nach der eingabe folgendes aus: Usage: mount [-r] [-w] [-o options] [-t type] device directory. Das gleiche passiert wenn ich es über ADB probiere(ADB shell--> su--> deine zeile-->exit-->exit)

leider kann ich über den Orndern die externe nicht errreichen, die ist immer noch nur unter emmc zu erreichen. Ich verwende build 12(mit perka mod falls das wichtig ist)

Woran liegt es dass es bei dir klappt und bei mir nicht?
 
Zuletzt bearbeitet:
n0va

n0va

Erfahrenes Mitglied
Komisch, per ADB geht's bei mir auch nicht... Wenn ich's aber im Gerät mit dem Better Terminal Emulator Pro eingeb, funktioniert das ohne Probleme... Liegt wohl am Programm.

Edit: Setz mal ein busybox vor den Befehl, dann geht's bei mir auch mit ADB:

busybox mount /mnt/emmc /mnt/sdcard/external_sd
 
orangerot.

orangerot.

Experte
Ich habs jetzt mal mit dem busybox im Termianal Emulator probiert und siehe da es geht :) Aber es gibt ´s keine Option, dass es dauerhaft so bleibt und nicht nach jedem reboot des SGS erneut abgegeändert werden muss?(Ist zwar auch nicht so schlimm, da man es ja nicht all zu oft neustartet, aber es wäre um einiges bequemer :D)

Aber nach der änderung wird das SGS nicht mehr am PC erkannt! Erst durch das installieren der Galaxy Nexus Treiber(statt wie vorher der Nexus Treiber) und einem Neustart des PC´s wird das SGS wieder im ADB und als MTP Gerät erkannt! Ist das immer so oder nur bei mir?
 
Zuletzt bearbeitet:
boarder87

boarder87

Erfahrenes Mitglied
ist da noch jemand dran zu versuchen wie man die externe SD wieder wie in den Stock Firmwares zu mounten?
 
orangerot.

orangerot.

Experte
busybox mount /mnt/emmc /mnt/sdcard/external_sd
So geht es einwandfrei! Du Musst den Befehl halt nur nach jedem Reboot neu ausführen. Einen anderen Weg gibt es glaube ich nicht.
 
G

Gerhard_B

Neues Mitglied
Kann man den Mount-Befehl nicht in einem Script bei jedem booten aufrufen ?

Ich hab schon so einiges versucht, jedoch ist nichts dabei gewesen, was nach dem Booten die /EMMC/ nach /SDCARD/EXTERNAL_SD mountet.


  • Den Mount-Befehl im Terminal eingeben - funktioniert bis zum nächsten Reboot
  • Rom-Toolbox Lite - die Befehle in ein Script eingetragen und dann ausgeführt, funktioniert bis zum nächsten Reboot
  • Directory Bind - funktioniert bis zum nächsten Reboot
  • RemountSD - ohne Wirkung obwohl die Pfade richtig eingetragen waren

Mit dem AOKP - Milestone 6 was ich vorher installiert hatte, konnte ich wenigsten die External_SD einbinden.
Mit dem Helly Bean bekomme ich das aber nicht hin.

Daher wäre ich für ein Sript sowie eine Step by Step Anleitung was ich machen muß sehr dankbar.

Problem gelöst: mit dem Script Manager aus dem Market kann man ein Script beim Booten starten. Mit den richtigen Rechten und Flags versehen wird die Sd-Karte jetzt wieder wie gewohnt unter sdcard/external_sd eingebunden.
 
Zuletzt bearbeitet:
G

grinder777

Ambitioniertes Mitglied
Warum nicht einfach unter

Einstellung-Speicher - MENÜ TASTE - Speicherkonfiguratinon

den internen Speicher deaktivieren?

Gesendet von meinem GT-I9000 mit Tapatalk 2
 
G

Gerhard_B

Neues Mitglied
Weil zum Einen, gibt es da nur die Möglichkeit die Art der PC-Verbindung umzustellen. Zum Anderen möchte ich die externe Karte zusätzlich einbinden und nicht entweder oder. Die Karte ist ja unter EMMC vorhanden aber ohne Freigabe des über geordneten Verzeichnisses durch den Datei-Explorer nicht erreichbar.

Problem gelöst -> siehe vorletzten Post

 
Zuletzt bearbeitet: