[Tool] All-in-One Tool von Condi - Sony Tablet S

  • 149 Antworten
  • Neuster Beitrag
X

xta-c

Neues Mitglied
Danke für die Info. Ist auch installiert, aber mit der Java6 wollte das nicht. Hab nun die 7 installiert und: Ist gerade fertig geworden.
O.K. kann auch sein das im SDK irgendwas hinüber war, was durch die Neuinstallation behoben wurde.
 
T

Toto12

Fortgeschrittenes Mitglied
Hallo

Gibt es denn schon Hoffnung oder erste versuche von Condi das man ICS 4.0.3 rooten kann!!

Habs zwar drauf aber eben ohne Root:sad:

@Obi kannste nicht mal nachfragen ,ob er es überhaupt noch in Aussicht stellt??:unsure:

Gruß und Dank
 
X

xta-c

Neues Mitglied
Kann ich mit dem deutschen Update auch ein custom Rom erstellen nach Condis Anleitung. Dürfte doch egal sein welches Rom ich nehme, es mus doch nur zum Gerät passen.
 
M

mikajo

Erfahrenes Mitglied
Funktioniert das rooten denn jetzt eigentlich auch mit der deutschen 3G-Firmware?

Ich warte jetzt einfach mal ab, was Condis neue Version bringen wird

"in 2-3 days I [Anmerkung: Condi] will release next version, got all the info I need to know for now"
 
Zuletzt bearbeitet:
X

xta-c

Neues Mitglied
Ich hab gerade ein STS bekommen das nach dem Sony nur noch ein beleuchtetes schwarzes Display zeigt. Denke also das ist ein Brick. Da ich nicht dran war kann ich nur das wiedergeben was mir gesagt wurde.

Erstellen eines custom Update mit der deutschen 3G Firmware und dieses aufgespielt. Tablet lief und hatte einen Root. Dann wurde mit dem AIO Tool die "Anti-bootloop protection" nochmals ausgeführt. Warum konne man mir nicht erklären. Danach ging das Tablet nicht mehr.

Laut der Anleitung von condi soll man die 3.2.1r2 firmware aufspielen. Der Link ist aber tot. Hat die zufällig jemand? Oder hat wer eine Idee was man sonst noch machen könnte?

Ach ja, man kommt noch in den recovery mode.
 
V

vlamers

Neues Mitglied
Hi,
Hatte ich auch, nachdem ich wie wild hin und her geflasht hatte. Hatte es mit einigen factory resets wieder zum laufen gebracht.

Hier custom 3.2.1 preroot signed: http://db.tt/hATdJZBg

Gruß
 
X

xta-c

Neues Mitglied
Danke viamers,

was meinst Du mit einigen factory resets? Einfach ein paar mal uber das Recovery Menu einen reset gemacht? Werd ich mal testen.
Das Rom kann ich nicht flashen. Signature verification failed.
 
Zuletzt bearbeitet:
V

vlamers

Neues Mitglied
Ja einfach über dass recovery resettet.
Du musst erst die hack_recovery flashen und dann dass per adb,machen, dass condis tool macht. Da es ja sonst nicht gehen kann.
Entweder im script nachsehen was es tut, oder bei den xdas lesen, ich meine es dort schonmal gelesen zu haben.

Gruß
 
X

xta-c

Neues Mitglied
Das Script hab ich mir angesehen. Damit komme ich nicht klar. ADB Shell kann ich über das AIO Tool auch nicht starten. Geht immer wieder ins Menu zurück. Ansonsten wüsste ich auch nicht was ich noch machen soll. Werd nn noch das neue Update versuchen. Dann geht halt kein Root mehr. Wenn das auch nicht geht wird es wohl in den Müll wandern.
 
V

vlamers

Neues Mitglied
Die adb shell aus dem tool hab ich nicht getestet. Ich nehm die aus der SDK im "DOS Fenster"

Gruß
 
X

xta-c

Neues Mitglied
Hab ich auch versucht. Aber ich finde die richtigen Scrips nicht. Hab mit die Datei im AIO nochmal vorgenommen, aber da wird wirklich einiges geprüft. Blick da nicht wirklich durch. Wenn ich den Befehl wom AIO nochmal ausführe bekomme ich einen Fehler das SU nicht gefunden wurde. Das würde heisen das der Root fehlt. Kann aber auch nicht sagen ob das normal ist.
Ohne Schritt für Schritt Anteitung bin ich erst mal aufgeschmissen.

Die _hack_recovery.zip und das custom_update_signed.zip das zuletzt aufgespielt wurde und ja auch funktioniert hat, habe ich noch.
Das deutsche OTA will er nicht haben, sonst hätte ich das schon getestet. Er will aber unbedingt einen Root.

Wie kann man über adb testen ob der root noch da ist und wie kann ich den signature-check ausschalten?

Bin dankbar für jede Hilfe.
 
V

vlamers

Neues Mitglied
Den signature check musst dir im script suchen oder condi fragen.
Das adb kannst ja im recovery modus verwenden. Nur nicht dass tool, da dass bei einem gebooteten system startet.
Wenn mich nicht alles täuscht werden irgendwelche dateien gepusht. Keine Ahnung welche, werde heut abend die script dateien von condi ansehen.

Durchforste mal den xda thread, da hat condi schonmal geschrieben wie das geht...

Gruß
 
nutsymtom

nutsymtom

Fortgeschrittenes Mitglied
mikajo schrieb:
Ich warte jetzt einfach mal ab, was Condis neue Version bringen wird

"in 2-3 days I [Anmerkung: Condi] will release next version, got all the info I need to know for now"
Da mache ich mit!

Aber wenns den soweit ist - Ich sollte doch mitm AIO meine Bootloop Protection ausschalten und den OTA notifier einschalten können, um somit mein passendes 3g update zu bekommen, da der Link auf XDA tot ist. Oder spricht was dagegen?

gruß nutz
 
M

mikajo

Erfahrenes Mitglied
@nutsymtom: Freut mich, dass es noch jemanden neben mir gibt, der die Geduld aufbringt, etwas abzuwarten :) Jetzt fühle ich mich nicht mehr ganz alleine... ;)

By the way: Version 3.4 ist veröffentlicht.... Da auch hier wieder ein paar fixes vorgenommen wurden, warte ich mal, was die weiteren Versionen so bringen und ob die Lage noch etwas "klarer" wird... insbesondere um mein 3G-Modul sorge ich mich nämlich - lieber, HC mit 3G als ICS ohne 3G!

Deine Frage kann ich dir leider nicht beantworten :(

Grüße, Mikajo
 
X

xta-c

Neues Mitglied
vlamers schrieb:
Den signature check musst dir im script suchen oder condi fragen.
Das adb kannst ja im recovery modus verwenden. Nur nicht dass tool, da dass bei einem gebooteten system startet.
Wenn mich nicht alles täuscht werden irgendwelche dateien gepusht. Keine Ahnung welche, werde heut abend die script dateien von condi ansehen.
So, nach einigem Suchen hab ich rausgefunden woran es liegt. Diebuild.prob ist leer. Hab versucht die neu aufs Pad zu kopieren, aber hatte auch probleme mit busybox. Habs dann so versucht. Ist nicht schön aber sollte ja auch gehen.

adb push files\regions\build.prop /cache/recovery/build.prop

adb shell
/system/bin/tempsu

/system/bin/cp /cache/recovery/build.prop /system/build.prop


Nun komme ich nicht mehr ins adb Shell.

[FONT=&quot][/FONT]- exec '/system/bin/sh' failed: No such file or directory (2) -


Also hat sich nun wohl der Root verabschiedet. Wie kann das sein?
 
V

vlamers

Neues Mitglied
Hmm ich denke mal nicht das dass root war (su).
er kann die shell nicht finden!?
Factory reset schon getestet? kommst noch ins recovery?

Gesendet von meinem A500 mit Tapatalk 2
 
X

xta-c

Neues Mitglied
Ja, schon ein paar Resets durchgeführt. Recovery geht auch noch.

Wenn ich z.B.
adb push old_build.prop cache/recovery/old_build.prop
ausführe bekomme ich

* daemon not running. starting it now *

* daemon started successfully *

2 KB/s (2283 bytes in 1.000s)

Also geht adb. Nur bei adb shell kommt
- exec '/system/bin/sh' failed: No such file or directory (2) -

Hab auch schon versucht das aktuelle update zu flashen. Geht auch nicht.
E: Prohibit update as a result of checking version or base sku
 
V

vlamers

Neues Mitglied
Also bei mir geht dass hack_recovery nicht solange die region nicht auf US gestellt ist. Das temporäre aus dem AIO funktioniert nicht bei mir.
Wenn ich mit region auf DE versuche das hack_recovery zu flashen bekomm ich auch den prohibit error.

Die old_build.prob ist ja die sicherung von deiner originalen build.prob. evtl musst du mit adb nach build.prob pushen und nicht nach old_build.prob...

Dann fehlts ja gar nicht soweit wenn dass recovery noch geht ;)

du musst schauen dass du die originale build.prob und die region per adb anpasst. Aber ich denke da kann dir bloß condi weiter helfen.

Gruß

Gesendet von meinem A500 mit Tapatalk 2
 
X

xta-c

Neues Mitglied
Die region hab ich schon auf US geändert. Die shell hat ja anfangs funktioniert.
Das mit der old.build.prob war nur für den test gerade eben.
Die build.prob muß nach /system/build.prop. Aber ohne su bekomme ich die da nicht hin. Das ist dann also:

adb shell
/system/bin/tempsu
cp /data/local/tmp/old_build.prop /system/build.prop(Und da die busybox auch niiht will hab ichs eben so gemacht. erst die build in den cache:

adb push old_build.prop cache/recovery/old_build.prop
Und dann als su


/system/bin/cat /cache/recovery/old_build.prop > /system/build.prop)

Und genau das geht nicht da die shell nicht funktioniert. Also bin ich im Ar...
 
Oben Unten