Probleme mit Sync der Uhrzeit

  • 55 Antworten
  • Neuester Beitrag
Diskutiere Probleme mit Sync der Uhrzeit im Samsung Galaxy S (I9000) Forum im Bereich Samsung Forum.
Hille

Hille

Erfahrenes Mitglied
schizo schrieb:
Ich habe keine extra-Software installiert, daher denke ich, dass er das Handynetz verwendet.
Sagt mal, lest Ihr eigentlich die Posts, die hier 'rein kommen - oder wiederholt Ihr reflexartig einfach so mal Eure Fragen in der Hoffnung, dass irgendwann auf die identische Frage mal eine Antwort 'rein kommt, die Euch in den Kram passt?

NOCHMALS:
Ist keine App installiert, wird das Zeitsignal aus dem Telefonsignal gesynct. Wann und wie oft das passiert kann man nur raten, gesicherte Aussagen dazu gibt es nicht. Wahrscheinlich aber beim Einschalten wird zumindest versucht, das Zeitsignal zu schnappen. Vielleicht auch beim Wechsel vom Flugmodus in den "Normalbetrieb". Aber das ist geraten.

Voraussetzung dafür ist allerdings, dass der Provider ein entsprechend genaues Signal sendet. Bzw. überhaupt ein Signal sendet, bzw. das Signal nicht grad "kaputt" ist (warum auch immer), der Empfang gut genug ist, das Zeitsignal aus dem Telefonsignal zu extrahieren etc... (1000ende Abweichungsgründe sind möglich). Ich halte Abweichungen bei schlechten Empfang im Bereich von 1-2 Sekunden für durchaus akzeptabel - weil technisch gar nicht anders machbar.

Woran sollte das SGS auch erkennen, ob jetzt das Zeitsignal falsch ist oder die Uhr im Handy schief liegt? Wenn also erfolgreich (also syntaktisch in Ordnung) ein Zeitsignal extrahiert werden kann, so wird das wohl genommen - auch wenn das mal gründlich - aus diversen Gründen - daneben liegen kann! Und das ist gar nicht mal so selten. Und genau diesen Effekt bemerkt Ihr halt.

Wenn man eine App installiert, sind Abweichungen unter einer Sekunde unrealistisch. Weil der Transport des NTP Signals braucht natürlich über das Internet auch seine Zeit. Wenn man einen PING auf einen NTP Server macht (bspw. de.pool.ntp.org) dauert das bei mir über eine normale DSL Leitung rund 65ms. Über eine UMTS Datenverbindung dürfte die Latenz noch um einiges größer sein (geratene 100ms). Für einen daddeligen PING! Also ist die Extraktion des NTP Signals mit einer noch größeren Latenz behaftet. Halbe Sekunde halte ich für realistisch.

Vergleiche mit Standalone Funkuhren ist also ziemlicher Unfug (die DCF77 sendet im Sekundentakt, wird quasi in "Nullzeit" zum Empfänger übertragen und die Verarbeitung in einer Funkuhr ist auch im µsec Bereich - wenn überhaupt).

Wenn ohne eine App die Uhrzeit gründlich daneben liegt, dann vermute ich einfach, dass man aus irgendwelchen Gründen kein genaues Zeitsignal aus dem Telefonsignal extrahieren kann - obwohl es syntaktisch in Ordnung ist. Je nach Provider und je nach Standort kann das schon mal ganz schön unterschiedlich sein. Weil "Zeitsignal" eben nicht die wichtigste Funktion der Sendemasten ist.

Ein Handy ist eben kein portabler DCF77 Empfänger. Im Zweifelsfall muss man sich eben genau dieses besorgen, wenn man Wert darauf legt.

Gruß - Hille.
 
F

#frank

Erfahrenes Mitglied
Hille schrieb:
Sagt mal, lest Ihr eigentlich die Posts, die hier 'rein kommen - oder wiederholt Ihr reflexartig einfach so mal Eure Fragen in der Hoffnung, dass irgendwann auf die identische Frage mal eine Antwort 'rein kommt, die Euch in den Kram passt?
Entschuldige bitte, aber ich wurde explizit danach gefragt, obwohl es eigentlich klar sein sollte.

Deine Schlußfolgerungen empfinde ich aber als nicht logisch, da

1. Der Sync nach Handy-Reboot IMMER korrekt ist
2. Der Sync mit anderen Handys hier am gleichen Mast im O2 Netz einwandfrei funktioniert (u.A. Desire HD)

Ich vermute daher eher ein Problem mit Handy/Firmware, eventuell in Kombination mit O2.
 
frimu

frimu

Neues Mitglied
@ Hille: schöne Zusammenfassung - Respekt.
 
user1313

user1313

Neues Mitglied
Jetzt ist es wieder passiert: Die Uhrzeit hat sich nicht umgestellt (obwohl ich natürlich die Option "durch Netz bereitgestellte Werte verwenden" markiert habe).
Neu ist das Problem bei mir nicht: Wenn ich in eine andere Zeitzone fliege (was öfters vorkommt), stellt es sich durchaus automatisch um - aber bei der Rückkehr ins T-Mobile-Land eben nicht mehr zurück. War beim G1 auch schon so...
 
Zuletzt bearbeitet:
presseonkel

presseonkel

Ehrenmitglied
Moin, ich schiebe es auch mal da rein...:)
 
S

seraph84

Neues Mitglied
Ist eigentlich jemanden schon aufgefallen (oder bin ich der einzige), dass die Zeit zwar immer einwandfrei synced & umstellt... aber immer um ~40sek. vor läuft?
 
presseonkel

presseonkel

Ehrenmitglied
Moin,
bei mir läuft die Zeit analog einer Funkuhr Sekunden genau....:)
 
S

seraph84

Neues Mitglied
Ist mir zuerst beim "Handy-Parking" aufgefallen. Man versucht ja immer zur vollen Viertelstunde die SMS wegzuschicken... & schickte ich die SMS um Punkt z.B 45 weg... lief der Parkschein von 45-15, anstatt von 00-30!

Jetzt überprüfte ich das ganze mit dem Teletext & siehe da --> es sind genau 33 Sekunden :thumbdn:

Selbe "Problem" mit der JPO, JPY & jetzt die offiziele JPY für DBT. Hab natürlich vorher & nacher immer gewiped & die interne SD-Karte formatiert :huh:
 
C

Cameron

Erfahrenes Mitglied
Geschieht die Umstellung auf Sommerzeit überhaupt durch das Netz? Mein SGS war eingeschaltet, aber mein Tab habe ich heute morgen im Flugzeugmodus hochgefahren und es zeigte sofort MESZ an. Wird wohl irgendwo einprogrammiert sein.

Gesendet von meinem GT-P1000 mit der Android-Hilfe.de-App
 
jannis357

jannis357

Ambitioniertes Mitglied
Wie Cameron schon sagte, denke ich auch, das die Zeitumstellung irgendwo einprogrammiert ist, da sich die Uhrzeit bei meinem SGS automatisch umgestellt hat, obwohl ich in den Einstellungen die automtische Einstellung deaktiviert habe.
 
F

#frank

Erfahrenes Mitglied
Um diesen Thread mal wieder auszugraben: Die Zeitprobleme scheinen mit 2.3.3 (JVI) der Vergangenheit anzugehören. Sehr schön!
 
N

nonick

Fortgeschrittenes Mitglied
Kann ich für meins nicht bestätigen, 2.3.3 JVO ,GMT+2, Blau.de, Uhrzeit geht um ca. 7h vor.
 
Zuletzt bearbeitet:
F

#frank

Erfahrenes Mitglied
Ich bin mittlerweile auf 2.3.4 (JVR) und hatte seit Froyo keine Probleme mehr. Wie lange braucht er denn bei dir, bis die 7h erreicht sind - oder springt er direkt um diese Zeit nach vorne?
 
N

nonick

Fortgeschrittenes Mitglied
Mir viel das erst heute morgen auf, gut, dass ich mich nicht vom Handy wecken laß. :)
Hab dann auf manuelle Einstellung umgestellt.
Ich hab inzwischen per CF-ROOT gerootet und jetzt wieder auf Automatisch gestellt,
mal sehen, wann die Zeit wieder falsch ist.

Edit:

Hab grad mal ein bischen rumgespielt.
Umgestellte auf manuell, falsche Uhrzeit eingestellt, umgestellt auf automatisch, Flugmodus an, Flugmodus aus.
Ein paar Minuten gewartet - Keine Änderung der Uhrzeit.
Sieht fast so aus, als würde da nix gesynct.

Wie funktioniert der automatische Sync überhaupt, von wo wird wann die Uhrzeit geholt?
 
Zuletzt bearbeitet:
D

dinerop

Neues Mitglied
nonick schrieb:
Hab grad mal ein bischen rumgespielt.
Umgestellte auf manuell, falsche Uhrzeit eingestellt, umgestellt auf automatisch, Flugmodus an, Flugmodus aus.
Ein paar Minuten gewartet - Keine Änderung der Uhrzeit.
Sieht fast so aus, als würde da nix gesynct.

Wie funktioniert der automatische Sync überhaupt, von wo wird wann die Uhrzeit geholt?
Das selbe bei mir auch, jedoch mit dem SGS2. In 30 Minuten läuft die Atomuhr und die Handyuhr ca 8 Sekunden auseinander. Was schon recht viel ist. Hat jemand eine Ahnung woran das liegen könnte.
Am Costum Rom und/oder Kernel?