SIP mit Fritzbox 2.3.3

  • 15 Antworten
  • Neuester Beitrag
Diskutiere SIP mit Fritzbox 2.3.3 im Sonstige Apps & Widgets im Bereich Android Apps und Spiele.
C

ca3sar

Ambitioniertes Mitglied
Hallo!

Ich habe Probleme beim Einrichten von SIP zu meiner Fritzbox (7270 @ 74.04.88). Mein Gegenüber hört mich tadellos, ich höre ihn aber fast gar nicht. Es ist total zerhexelt und verzerrt was bei mir ankommt.

Ich habe keine Ahnung, was ich noch einstellen könnte... Es ist alles auf Standard, ich habe nur Zugangsdaten eingetragen.

Bye
Ca3sar



# Offtopic
Ich weiß, dass es eine App dafür von AVM gibt ( AVM Service-Portal ) aber diese hängt sich ab und an beim wechsel zwischen Accesspoints auf, was der SIP-Client des Betriebssystems sicher nicht macht. Außerdem ist das App Optisch nicht der Renner und viel schlimmer noch, das Display wird während dem Telefonat nicht mit Hilfe des Näherungssensors abgeschalten, was zu enormen Accuverbrauch führt und dazu, dass man mit der Backe das Gespräch leicht beenden kann.
 
A

ako

Fortgeschrittenes Mitglied
Ich hänge mich da mal dran gleiches Problem bei mir..

Gesendet mit der Android-Hilfe.de-App
 
M

manu

Erfahrenes Mitglied
Habe leider keine Lösung aber das selbe Problem.
Der andere hört mich klar und deutlich.
Aber ich verstehe kaum was. Es scheint, als würden immer paar ms fehlen.
 
BlueMonkey

BlueMonkey

Ambitioniertes Mitglied
Welche Einstellungen habt ihr denn gesetzt? Würde das auch gerne mal ausprobieren. Hab bis jetzt nur die Fritz App getestet, aber da hatte ich immer Aussetzer (mein Gegenüber hat mich gut verstanden)....
 
Katz@Magic

Katz@Magic

Fortgeschrittenes Mitglied
ja bitte postet mal die einstellungen
- ich will das auch ausprobieren
 
C

ca3sar

Ambitioniertes Mitglied
Da gibt es nichts ein zu stellen. An der Fritzbox habe ich ein IP-Telefon angelegt und im Nexus One habe ich die Adresse und die Zugangsdaten der Fritzbox und des IP-Telefons eingetragen. Aus die Maus und es geht nicht.
 
Katz@Magic

Katz@Magic

Fortgeschrittenes Mitglied
Bei mir schreibt er immer:

"Kontoregistrierung aufgrund fehlender WLAN-Verbindung gestoppt."

Bin aber im WLAN - Komisch
 
BlueMonkey

BlueMonkey

Ambitioniertes Mitglied
Im Nexus-S-Forum (Thread VoIP/SIP support ) hat ahcsas eine kleine Anleitung geschrieben, bei der die fritz.box dem Smartphone als SIP-Server dient (geht dann also nur im heimischen WLAN):

ahcsas schrieb:
Ist eigentlich ganz einfach...

zunächst in der Box unter Telefonie -> Telefoniegeräte ein neues Telefon hinzufügen. Als Anschluss LAN/WLAN auswählen und den Assistenten durchklicken. Das Telefon bekommt eine Nummer ab 620 aufsteigend zugewiesen.

Am Nexus S dann unter Einstellungen -> Anrufeinstellungen -> Konten ein neues Konto anlegen. Als Nutzername die 620 (bzw. was halt zugewiesen wurde) eintragen. Passwort was ihr in der FritzBox vergeben habt und als Server fritz.box

Das sollte eigentlich schon reichen. Würde mich freuen wenn ihr mal testen könntet, ob ihr dann auch die Störungen beim Empfang habt.

Mit der FritzApp funktionierts übrigens einwandfrei. Es liegt also nicht an der WLAN-Verbindung.
Hat bei mir sofort funktioniert, aber ich verstehe auf diese Weise mein Gegenüber nicht wirklich gut. Bei meinem Gegenüber scheint die Sprachqualität dagegen zu passen - sprich auch bei mir kommt es zu den von ahcsas angemerkten Empfangsstörungen.
 
Katz@Magic

Katz@Magic

Fortgeschrittenes Mitglied
So habs dann auch hinbekommen...

anstatt "fritz.box" kann man natürlich auch die IP der Box verwenden.

Hab auch die schon angesprochenen Empfangsprobleme.
 
BlueMonkey

BlueMonkey

Ambitioniertes Mitglied
Hab mal versucht die fritz.box über CSipSimple anzusteuern - da gab es aber noch mehr Empfangsprobleme. Daher könnte man davon ausgehen, dass das Problem eher bei der Fritzbox liegt, als bei Gingerbread...

Hab noch auf der Fritzbox rumprobiert. Auch die Option

immer Sprachkodierung mit Festnetzqualität verwenden
FRITZ!Box verwendet grundsätzlich verlustfreie Sprachkodierung wie im Festnetz.
unter "Internettelefonie" hat keine Besserung gebracht.
 
M

maetis

Neues Mitglied
Hallo zusammen,

also mit CSipSimple funktioniert es bei mir sehr gut. Auch die Sprachqualität ist gegenüber der FritzApp deutlich besser. Zudem wird auch das Display während des Telefonats ausgeschaltet.

Ich habe es auch schon mit der in Gingerbread integrierten Sip Funktion versucht, jedoch war das Ergebnis nicht so gut.
Mein Gesprächspartner hat mich wunderbar verstanden, bei mir kam aber nur ganz leise und abgehackt etwas an.
Deshalb ist meine Schlussfolgerung, dass es nicht an der Fritzbox liegt, sondern an Gingerbread. Eine Lösung habe ich aber bisher leider auch nicht gefunden.

Prost
 
C

ca3sar

Ambitioniertes Mitglied
Hallo!

Wie hast du den CSipSimple configuriert, dass es mit deiner Fritzbox zusammenarbeitet? Ich bekomme einfach keine Verbindung :-(
 
M

maetis

Neues Mitglied
ca3sar schrieb:
Hallo!

Wie hast du den CSipSimple configuriert, dass es mit deiner Fritzbox zusammenarbeitet? Ich bekomme einfach keine Verbindung :-(

Moin,
ich benutze die CSipsimple Version 0.02-01 r841. FRITZ!Box Fon WLAN 7270 v2 (UI) mit der Firmware-Version 54.05.04-19798 (Labor).

Zuerst sollte man den "Experten Modus" aktivieren.
Menu-> Einstellungen-> Menu -> Experten Modus

Wichtig ist die Codec Einstellung unter der Rubrik Einstellungen -> Audio ->Bandbreiten-Zuordnung. Weitband hat nie funktioniert auch nicht im eigenen WLAN Netz. Bei der Niederband-Einstellung klappte es dann. Folgende Codecs habe ich aktiviert:
SILK 8 KHz, GSM 8 KHz, speex 8 KHz, PCMU 8 KHz, PCMA 8 KHz. Man kann auch noch mit den anderen mal experimentieren. ( langes Drücken aktiviert den jeweiligen CODEC)

Unter Einstellungen -> Netzwerk bei folgenden Einstellungen ein Häkchen machen:
UDP, Aktiviere Qos, Aktiviere ICE, Verwende WLAN für eingehende Anrufe, Verwende WLAN für ausgehende Anrufe
Den Rest auf Default Einstellung lassen.

Dann natürlich ein Konto einrichten:

Kontoname ist egal.Bei Benutzername habe ich die 620 genommen ( entsprechend in der Fritzbox anlegen), unter SIP Server die IP Adresse der Fritzbox eintragen ( oder: fritz.box ) und zum Schluss das Passwort, welches man ebenfalls in der Fritzbox anlegen muss.
Dann sollte es funktionieren.

Prost
 
C

ca3sar

Ambitioniertes Mitglied
Hm :( ich bekomme das nicht hin. Registrieren klappt zwar aber wenn ich jemanden anrufen möchte, wird mein Display rot mit meinem Verlauf ins schwarze. Dann bricht alles ab und ich bin wieder auf meinem Homescreen. Hast du (oder ein anderer Leser) das schon mal gehabt und gelöst?
 
M

maetis

Neues Mitglied
nee hatte ich noch nicht.
Was für ein ROM hast Du denn auf deinem Handy? Vielleicht liegst daran? Ich habe z.B. Cyanogenmod 7 nightly drauf.
Gruß
 
C

ca3sar

Ambitioniertes Mitglied
Ich habe 2.3.4, so wie Gott äää Google es schuf.