Android 2.2 Apps auf 2.1 instalieren

basti2010

basti2010

Erfahrenes Mitglied
13
Ist es möglich die Apps die für 2.2 sind auch irgendwie auf 2.1 zu installieren?
 
Dank unterschiedlicher Frameworkversion wird das nicht gehen.
 
Da kannst das Manifest editiern und das MinTargetLevel runtersetzten.
Solang das App keine Funktionen nutzt die nur ab 2.2 enthalten sind laufen die sicherlich.

//EDIT Ach glaub du meinst aber eher aus dem Market raus oder?
 
laut Hersteller /Entwikler - nutz es wohl dynamische Karten.

Kann die app sowohl aus dem Market als auch als vorhandene .apk installieren
 
Zuletzt bearbeitet:
basti2010 schrieb:
laut Hersteller /Entwikler - nutz es wohl dynamische Karten.

Kann die app sowohl aus dem Market als auch als vorhandene .apk installieren

Also ist damit dein Problem gelöst?
 
Nein leider nicht ! gibts da denn ne möglichkeit?

Hast du Android 2.1 drauf ?

dann würde ich dir mal den DL link geben für die .apk
 
Ja kannst du machen, und nein ich hab kein 2.1 aber einen emulator.
Was passiert denn wenn du versuchst die apk zu installieren
 
er zeigt: "Beim Parsen des Pakets ist ein fehler aufgetreten"


Was meinst du jetzt mit kannst du machen ?

Das ich es zum laufen bringen kann oder den link posten ?
Link
 
@Basti - klingt verlockend die Apps einer weiter entwickelten Software auf einer "ALTEN" zu implementieren. Allerdings glaube ich eher, dass du bei diesen Versuchen Stammkunde im Forum wirst unter der Rubrik: unerklärliche Fehler - wennst dir viel Ärger ersparen willst - gehst nen Kompromiss ein - entweder eine Mod-Rom mit all diesen Apps - oder ein funktionstüchtiges Handy mit den dazugehörenden, dafür geschriebenen Apps.

Das eine oder das andere mag vielleicht funktionieren - wie bereits hier erwähnt wurde - aber willst dir das wirklich antun?
 
Ich weiß nicht - "Cebit2go" gibst auch als web anwendung - nur das zieht natürlich am AKKU.

Und ne Mod-Rom - keine Ahnung - gibts denn denn schon was Komplettes wo alles geht ? - Glaube momentan gibts da noch nichts was 100 % vollständig ist.

Aber wenn es natürlich eine kleine Möglichkeit gibt - würdwe ich es testen wollen.
 
letzteres wäre ja doch ne Möglichkeit - ja

hier ne kleine Hilfestellung fürs Lesen der verschiedenen ROMS im Forum

:biggrin::biggrin:
 

Anhänge

  • Brille.jpg
    Brille.jpg
    86,1 KB · Aufrufe: 970
So hab mal im Manifest das Framework level runtergesetzt jetzt lässt es sich installieren... Aber natürlich haben die nicht umsonst eine höhere Version gewollt könnte also sein das man ziemlich nervigen fc's bekommt.

Lad dir die apk mal später hoch.
 
Danke - das wär super.

Mit welchen Mitteln hast du das geändert?

Was meinst du mit nervigen FC's

Jetzt nach einem kleinen update des Apps steht sogar bei, auf was das App zugriff hat:

access to...This application has access to the following:


  • Hardware controls:
    take pictures and videos
  • Your location:
    fine (GPS) location,
    coarse (network-based) location
  • Network communication:
    full Internet access
  • Storage:
    modify/delete USB storage contents modify/delete SD card contents

Hide

  • Network communication:
    view Wi-Fi state,
    view network state
 
Zuletzt bearbeitet:
Na hatte ich doch geschrieben apk ganz normal entpacken manifest abändern, und dann packen wieder signieren und installieren.

Mit FC's mein ich abstürze, diese passieren durch zugriffe auf Funktionen die in dieser API noch nicht vorhanden sind.
 
Wäre dir sehr sehr dankbar wenn du mir das hochladen könntest , ich bekomme es nicht hin.
weiß nicht wie ich die manifest ändern kann,einfaches editieren reicht wohl nicht.



Gesendet mit der Android-Hilfe.de-App
 
Ja heute Abend wenn ich dran denke.

Sry heut keine Zeit und lust zu..
aber mach einfach folgendes

apktool decompile apk

sdklevel in der manifest von 8 auf 7

dann apktool build <name vom decompiled apk ordner>

dann ganz normal signieren wie mit einer jar datei.

Das war jetzt wirklich genau das was ich gemacht hab wenn du es nicht hinbekommst frag einen andern :p der es dir macht.
 
Zuletzt bearbeitet:
sdklevel in der manifest ändern - meinst du damit einfach per Notepad ++ öffnen und editieren ?

Sag mir doch mal oder poste/hochladen doch mal bitte nur deine Manifest, villt mache ich oirgendwas falsch.
 
Zuletzt bearbeitet:
Mich würde mal interessieren ob sie ohne probleme auch startet?
 

Ähnliche Themen

O
Antworten
1
Aufrufe
2.840
Anonym6x6
Anonym6x6
T
  • TomTom83
Antworten
1
Aufrufe
968
TomTom83
T
loca-charm
Antworten
11
Aufrufe
3.421
loca-charm
loca-charm
Zurück
Oben Unten