Das M2 Aqua per adb verbinden

  • 19 Antworten
  • Neuester Beitrag
Diskutiere Das M2 Aqua per adb verbinden im Sony Xperia M2 / M2 Aqua Forum im Bereich Weitere Sony Geräte.
franc

franc

Dauergast
Hallo
Der Kollege meiner Freundin hat mir ein M2 Aqua (D2403) gegeben, da soll ich dieses lästige "What's New" und ähnliche Schrottware, also Bloats raus hauen.
Ich finde zwar einen einfachen Weg per adb, nämlich einfach mit:

adb shell
pm block com.sonymobile.advancedwidget.entrance


Aber es scheitert leider daran, dass ich per adb schon gar nicht auf das Ding drauf komme.
Weder finde ich irgendeinen Treiber für dieses Telefon, noch bringen diese Sony Programme "Sony PC Companion" oder das Mac Pendant "Sony Ericsson Bridge for Mac" irgendwas, jedenfalls bleibt ein

adb devices

ohne Ergebnis. Ich habe schon versucht den original Android USB Driver (die inf) anzupassen, also den Geräteschlüssel VID_0FCE&PID_51B8 mit rein zu nehmen, der mir im Gerätemanager angezeigt wird mit gelbem Fragezeichen, bringt nichts.
Ich habe Mac OS 10.10.4 und Windows XP (als VM) EDIT: und Windows 8.1 (64-Bit) s.u.

Wo kann ich einen funktionierenden Treiber für das D2403 finden?

Danke

franc

EDIT: ich habe noch weitere Leutles gefunden, die es auch nicht schaffen, anscheinend ist das mit dem M2 so eine Sache. Rooten scheint auch nicht unbedingt zu gehen.
Das habe ich nämlich auf xda gefragt (ohne Antwort).
Die Hilfe dazu von Sony ist nicht hilfreich.
Unter Windows 8.1 (64-Bit) habe ich es angeschlossen, irgendwelche Treiber werden installiert, aber nicht die ADB-Treiber, siehe Anhänge Gerätemanager etc.
Scheint wirklich nicht gewollt zu sein.
Ich gebe das wieder zurück mit einem "Leider nicht möglich. Empfehlung: Umtauschen oder Verkaufen."
 

Anhänge

Zuletzt bearbeitet:
franc

franc

Dauergast
Leider kann ich die Treibersignatur auf meinem Windows 8.1 nicht deaktivieren, da hab ich mir schon die Zähne dran ausgebissen, allerdings hätte ich virtuell Windows Vista, 7 und XP (physisch auch Vista und XP) aber ich finde ja diese Treiber schon gar nicht. Wo sind die denn?

EDIT: dass diese Z4 ROMs auch für das M2 gehen, steht ja dann dort.
 
Zuletzt bearbeitet:
Aaskereija

Aaskereija

Inventar
Der von dir verlinkte Weg ist aber nur einer von vielen. Schau mal in meine Flashtool Anleitung, dort hab ich auch noch einen Weg beschrieben der bei dir funktionieren könnte.

Treiber kannst du dir z.b. von Sony direkt besorgen: Drivers - Developer World

Ansonsten probier mal das kleine Tool aus Adb Driver - Universal Android USB Driver
 
franc

franc

Dauergast
Aaskereija schrieb:
...Treiber kannst du dir z.b. von Sony direkt besorgen: Drivers - Developer World ...
Auf dieser Seite war ich bereits, aber da steht nichts von M2-Treibern. Sind das die gleichen für irgendein anderes Xperia? Wo steht das dann aber?
 
M

matze6989

Enthusiast
franc schrieb:
Leider kann ich die Treibersignatur auf meinem Windows 8.1 nicht deaktivieren, da hab ich mir schon die Zähne dran ausgebissen, allerdings hätte ich virtuell Windows Vista, 7 und XP (physisch auch Vista und XP) aber ich finde ja diese Treiber schon gar nicht. Wo sind die denn?

EDIT: dass diese Z4 ROMs auch für das M2 gehen, steht ja dann dort.
Man kann immer die treiber Signatur in win 8 deaktivieren. Wenn du das nicht hin bekommst dann brauchst du nicht weiter machen.
Hier ist auch noch was zum rooten.
Xperia M2 Aua 2403 Root, Philz Touch Recover… | Sony Xperia M2 | XDA Forums

Die experience lite 3.0 rom läuft perfekt auf dem aqua. Die habe ich auch drauf.
 
franc

franc

Dauergast
Nein, die Signatur kann ich tatsächlich bei mir nicht deaktivieren, da habe ich schon Tage rumprobiert, geht nicht, siehe Link oben. Müsste wohl W8.1 neu installieren, darauf habe ich aber nur wegen dieser Signaturgeschichte verständlicherweise keine Lust ;)
Ohne das kriege ich natürlich diesen Fehler:
sonytreiber-fehler.jpg
Und im Automatikmodus der Treiberinstallation kriege ich natürlich diesen Fehler:
sonytreiber-autoinstallation-fehler.jpg

Ich probiere es halt über eine W7 VM, das müsste ja gehen.
 
Aaskereija

Aaskereija

Inventar
Bist du sicher dass das deaktivieren nicht funktioniert? Wär ja sehr merkwürdig. Was kommt da für ein Fehler bzw. Meldung?
 
M

matze6989

Enthusiast
Also ganz einfach entweder siehst du zu das du sie deaktivieren kannst oder das wird nichts. Auch nicht wenn du win7 vm nutzen willst.
Dann wirst du dein win8 neu installieren müssen oder deine Freundin muss sich mit ihrem Handy zufrieden geben so wie es ist :D
 
franc

franc

Dauergast
Ja, war Quatsch.
Also auf VM W7 krieg ich es direkt nicht hin, aber über Tricks dann schon.
Mit XP (im Mac) ging das installieren des ADB Treibers problemlos.
Also über die geänderte android_winusb.inf worin zusätzlich der Eintrag steht:

[Google.NTx86]
; SonyEricsson
%SingleAdbInterface% = USB_Install, USB\VID_0FCE&PID_0DDE
%CompositeAdbInterface% = USB_Install, USB\VID_0FCE&PID_0DDE&MI_01
%SingleBootLoaderInterface% = USB_Install, USB\VID_0FCE&PID_0DDE


für 64-Bit braucht man theoretisch diesen Abschnitt:

[Google.NTamd64]
; SonyEricsson
%SingleAdbInterface% = USB_Install, USB\VID_0FCE&PID_0DDE
%CompositeAdbInterface% = USB_Install, USB\VID_0FCE&PID_0DDE&MI_01
%SingleBootLoaderInterface% = USB_Install, USB\VID_0FCE&PID_0DDE


Bei VM W7 (64-Bit) musste ich erst die Treibersignatur deaktivieren:

Bcdedit.exe /set nointegritychecks ON
bcdedit -set loadoptions \"DDISABLE_INTEGRITY_CHECKS"


Dann habe ich in der inf zusätzlich die richtige PID (findet man im Gerätemanager in den Details unter Hardware-IDs) dazu fügen müssen: PID_51B8, also unter den Google.NTamd64 Abschnitt noch dazu:


%SingleAdbInterface% = USB_Install, USB\VID_0FCE&PID_51B8
%CompositeAdbInterface% = USB_Install, USB\VID_0FCE&PID_51B8&MI_01
%SingleBootLoaderInterface% = USB_Install, USB\VID_0FCE&PID_51B8



dann konnte ich die ADB Treiber installieren und komme auch dort jetzt mit adb auf den Sony M2 :)

Danach noch:

bcdedit -deletevalue loadoptions

die Signaturunterdrückung abschließen, weiß aber nicht ob das überhaupt nötig ist.
Jetzt wüsste ich nur noch gerne, welche Apps noch alle Bloatware sind und vor allem wie sie genau heißen.
Die com.sonymobile.advancedwidget.entrance habe ich schon erfolgreich deaktiviert :)
Kennt jemand eine Liste mit den "echten" App-namen?
 
franc

franc

Dauergast
Ich muss noch hinzufügen, dass ich Probleme hatte mit einem zuvor installierten Samsung Treiber Paket.
Das ADB Interface war nämlich zunächst unter Samsung installiert, was aber nicht funktionierte.
Ich habe (das gilt für W7 als auch für XP) also zuerst diese Samsung Sachen deinstalliert, dann erst die Sony ADB Treiber, wichtig.

Ich habe mal die für das M2 Aqua bei mir auf W7-64 funktionierende inf hier angehängt, falls jemand das selbe Problem hat wie ich.

Was mir noch eingefallen ist: mit ADB kann man ja auch den MPE in Betrieb bringen, der braucht ja nur ADB, damit er allerhand aus dem Gerät ziehen kann an Informationen.

Ich will dieses Sony M2 Aqua nämlich nicht so gerne rooten, es genügt nur, die Bloats raus zu hauen, das ist der Auftrag den ich habe.
 

Anhänge

  • android_winusb.zip
    1,8 KB Aufrufe: 109
Zuletzt bearbeitet:
Aaskereija

Aaskereija

Inventar
Das sollte keinen Einfluss haben
 
franc

franc

Dauergast
Hatte es leider doch. Es ging erst als ich die Samsung raus gehauen hatte.
"Sollte" ist eines der wichtigsten Wörter in der IT ;)
EDIT: "sollte" und "irgendwie funktioniert es jetzt " ;) ;)
 
Aaskereija

Aaskereija

Inventar
Richtig, war bei mir komischerweise aber nicht. Aber wenns nun geht, dann passts ja :)
 
franc

franc

Dauergast
Die Liste ist übrigens ja für 5.0 aber auf dem M2 ist noch 4.4.4 (18.3.1.C.1.17) drauf, das ist anscheinend noch nicht ausgerollt, das 5 (LP).

Ich hatte dann den Bootloader nach der Sony Anweisung mit:

fastboot -i 0x0fce oem unlock 0xD912B7835D843309


entsperrt, jetzt hat es anscheinend dabei ein Reset erlebt, interessant. Dachte schon ich habe jetzt einen bösen Bootloop, weil ewig nichts passierte aber dann kam es mit den Grundeinstellungen.
 
Zuletzt bearbeitet:
Aaskereija

Aaskereija

Inventar
Die Liste enthält auch Apps von 4.0.4 Das 5.0 im Titel soll nur als Aktualitätshinweis dienen

Ja, beim Bootloder öffnen wird das Handy zurück gesetzt und alles gelöscht, das ist normal.
 
franc

franc

Dauergast
So jetzt habe ich etwas aufgeräumt. Mit adb und pm block habe ich eingeeist:

com.sonymobile.advancedwidget.entrance
com.sonymobile.advancedwidget.sonyselect
com.sonymobile.sonyselect
com.sonymobile.sonyselect
com.vodafone.vodafone360updates
com.vodafone.android.app.introgreeting
com.vodafone.accesorystore
com.vodafone.cloud
com.vodafone.addressbook
com.vodafone.android.app.rbt
com.vodafone.smhs
de.vodafone.mobiletv
com.vodafone.android.myweb.launcher
com.sonyericsson.album
com.sonyericsson.album.overlay


Man kriegt einfach heraus, was alles installiert ist und vor allem wie die Pakete wirklich heißen mit:
pm list packages -f
Das fand ich auf github. Mit:
pm list packages -f > /storage/sdcard0/installed_packages.txt
Habe ich es in eine Textdatei geschrieben und in meinem Editor dann bequem durchsucht nach Böslingen.

Allerdings fragt mich jetzt das Ding bei jedem Neustart nach dem Land und will dass ich die "wichtigen Informationen" zur Kenntnis nehme.
Das war glaubich aber nach dem Bootloader Freischalten schon so.
Kann man wohl mit leben, so oft schaltet man das ja auch nicht ganz aus.
Ich gebe es jedenfalls jetzt so zurück, rooten tue ich es nur auf ausdrückliche Anweisung, mit einem gerooteten Telefon muss man ja auch umgehen können, für pure Anwender finde ich ist das eher nichts.
 
Zuletzt bearbeitet: