Nach Displaytausch: Display leuchtet beim Booten und geht dann aus.

  • 19 Antworten
  • Neuester Beitrag
Diskutiere Nach Displaytausch: Display leuchtet beim Booten und geht dann aus. im Sony Xperia X Compact Forum im Bereich Sony Forum.
Z

ZimtZicke

Neues Mitglied
Hallo,

mein Display hatte einen Riss. Habe ein neues verbaut. Das neue Display ging an, reagierte aber nicht auf Eingaben. Hab ein zweites gekauft. Das reagiert schon mal auf die Eingaben. Wenn ich aber den Bildschirm über Mustereingabe entsperre und Xperia booten lasse (Logo wird angezeigt) geht die Beleuchtung bzw. das Display immer ca. 1 Sekunde nachdem der Startbildschirm angezeigt wir aus und bleibt dunkel. Das Smartphone ist aber an.
Wenn ich über über das Custom Recovery System TWRP gehe, bleibt der Bildschirm an.

Kann man ausschließen, dass es an der Hardware liegt und es ein Softwareproblem ist? Hatte zuerst Sorge, dass es beim Einbauen ein Kurzschluss o.ä. gab und die Hardware beschädigt wurde. Das Display funktioniert aber offensichtlich kurzzeitig und ich denke dass es an der Software liegt.

Habe mit TWRP einige meiner persönlichen Daten gerettet. Würde das System natürlich wieder richten wollen.
Was kann ich machen?

Model: Sony Xperia X Compact (F5321)
Gerootet
Firmware version: 34.4.A.2.70_R1E
Region: Germany (Generic) [1305-6830]
Android version: 8.0.0
 
Zuletzt bearbeitet:
HerrDoctorPhone

HerrDoctorPhone

Inventar
ZimtZicke schrieb:
TWRP gehe, bleibt der Bildschirm an.....Kann man ausschließen, dass es an der Hardware liegt und es ein Softwareproblem ist?
So siehts augenscheinlich aus...
(Ohne Gewähr)

Versuch über TWRP ein recovery, Cache löschen, sollte normal gehen, ansonsten Software neu Flashen.

VG
 
G

Gabberlein

Experte
Entweder ist das neue Display nicht wirklich das 1:1 oder du musst das Handy ganz platt machen, neue FW drauf ohne TWRP & Custom Rom aber vorher erstmal Versuchen Factory Format vielleicht klappst dann wieder?
 
Z

ZimtZicke

Neues Mitglied
HerrDoctorPhone schrieb:
Versuch über TWRP ein recovery, Cache löschen, sollte normal gehen, ansonsten Software neu Flashen.
1. Recovery hab ich keines.
2. Cache löschen hat nichts gebracht.
3. Neu Flashen: sind dann alle Daten (Apps, Einstellungen, etc.) weg?

Liegt es ggf. am Kernel? Kann man den neu drauf machen?
Beitrag automatisch zusammengefügt:

Gabberlein schrieb:
Entweder ist das neue Display nicht wirklich das 1:1 oder du musst das Handy ganz platt machen, neue FW drauf ohne TWRP & Custom Rom aber vorher erstmal Versuchen Factory Format vielleicht klappst dann wieder?
Das Display ist original.
Was bedeutet FW?
Warum ohne TWRP & Custom Rom?
Das Smartphone ist gerootet, soweit ich weiß geht dann Factory Format nicht mehr. Oder ist Löschen von Cache und Dalvik gemeint? Das habe ich gemacht, ohne Erfolg.
 
Zuletzt bearbeitet:
Z

ZimtZicke

Neues Mitglied
HerrDoctorPhone schrieb:
FW ...das ist FirmWare, Betriebsystem (Wie Window)
Also noch mal die Firmware die ich aktuell drauf habe "Version: 34.4.A.2.70_R1E".
Das würde ich nur als letzten Weg wählen, da ich noch hoffe das System zu retten.
Bring es was den Kernel neu drauf zu machen?
 
Z

ZimtZicke

Neues Mitglied
HerrDoctorPhone schrieb:
Welchen Kernel??
Der hat damit rein gar nichts damit zu tun.
Es geht um die FW, die kannst du im TWRP selber drauf machen dank Recovery.
Falls das nicht geht, musst du eine neue FW mittels Flash drauf machen.
Ok, verstanden.
Wenn ich eine neue FW drauf mache, gibt es irgend einen Weg oder Möglichkeit die Daten und Einstellungen der Apps (E-Mail, Messenger etc.) wieder herzustellen? Fotos habe ich ja schon gerettet über TWRP.
Danke!
 
HerrDoctorPhone

HerrDoctorPhone

Inventar
ZimtZicke schrieb:
ich eine neue FW drauf mache, gibt es irgend einen Weg oder Möglichkeit die Daten und Einstellungen der Apps (E-Mail, Messenger etc.) wieder herzustellen?
Nein.
Sorry.

Viel Glück :1f44d::1f44b:
DOC
 
G

Gabberlein

Experte
Mit glück ja aber nur wenn du die FW als Update einspielst dazu musst du die möglichkeit haben, ist diese nicht gegeben und deine jetztige FW fratze Hilft nur neues Clean Flash damit ist aber alles weg. Das biste aber selber Schuld da du vorher kein Backup gemacht hattest, aber du hast doch das Board eh gewechselt wie kannst du da deine Daten schon drauf haben bei nicht funktionsfähigen Display? Ist mir grad ein Rätsel...
 
Z

ZimtZicke

Neues Mitglied
Danke Gabberlein für deine Vorschläge!

1. Wie kann ich die FW als Update einspielen bzw. wo wird das definiert, dass es als Update laufen soll? Gibt es da bei TWRP oder im Flashtool einen Hacken den man setzen muss?

2. Falls alles weg sein sollte durch das Update oder Clean Flash -> Kann ich es über das Backup von TWRP wieder rückgängig machen (mit der Konsequenz, dass das Display dann wieder nicht funktioniert)?

3. Ich hab nicht das Board gewechselt sondern nur das Display. Das habe ich schon zwei mal gemacht. Dachte nicht, dass da ein Backup notwendig ist.
 
Zuletzt bearbeitet von einem Moderator:
Bearbeitet von reraiseace - Grund: Direkt-/Vollzitat entfernt /VG reraiseace
A

Android Nutzer 76

Stammgast
Warum sollte es ein Softwareproblem sein wenn das Display bei einem Wechsel nicht mehr geht??? Macht Mal überhaupt keinen Sinn... In meinen Augen.. aber egal.
Twrp einfach System und Daten Partition Sichern.... Dann beide Partitionen löschen... Rom auf die System Partition neu einspielen... Wenn's dann funzt, einfach die Daten Backup wieder auf die Daten Partition Flashen... Fertig... Und alle Apps sollten wieder da sein...
 
Z

ZimtZicke

Neues Mitglied
Android Nutzer 76 schrieb:
Warum sollte es ein Softwareproblem sein wenn das Display bei einem Wechsel nicht mehr geht??? Macht Mal überhaupt keinen Sinn... In meinen Augen.. aber egal.
Hallo Android Nutzer 76, danke für deine Zweifel. Die habe/hatte ich auch.
Was mich stutzig mach: das Display funktioniert ja die ersten 15 Sekunden und auch wenn TWRP läuft. Es geht erst nach dem Boot aus. Wenn es die Hardware wäre, dann würde es doch vermutlich gar nicht gehen, oder?

Ich habe auch gelesen, dass manchmal bei unsachgemäßer Arbeit an den Steckern die Sicherung für das Display auf dem Mainboard auslöst. Das kann dann zu Problemen führen. Siehe
. Ich muss leider sagen, dass mir das kaputte Display beim ausbauen weiter zerbröselt ist und ich es dann trotz dem noch einmal an das Mainboard gesteckt habe mit Akku um zu Testen ob es nach dem booten noch an bleibt. Vielleicht gab es da ja ein Problem mit der Sicherung oder ein Problem mit der Software oder Diplay-Treibern (wenn es sowas gibt).

Danke für deine Anleitung wie ich vorgehen soll.
Denkst du, die Option, die Gabberlein vorgeschlagen hat, die FW als Update aufzuspielen ist die schlechtere der beiden Möglichkeiten?
 
G

Gabberlein

Experte
und mit Glück das Display wieder ein Bild zeigen ja sry meinte Display nicht das Board mein Fehler 😁 Bitte prüfe trotzdem nochmal das Flexkabel obs richtig eingesteckt ist und der Bügel fest ist?
 
A

Android Nutzer 76

Stammgast
@ZimtZicke die Firmware als Update einzuspielen wird keine Softwarefehler wirklich beseitigen. Wenn du es testen würdest und es keine Besserung gibt weißt du immernoch nicht woran du bist...
Du wirst es so machen müssen wir ich es oben beschrieben habe, denn nur so kannst du Software Probleme wirklich ausschließen..
Ich gehe sogar noch eins weiter... Falls du es gar nicht hin bekommst, wirst du auch mit dem "Emma" (zwingend) Tool von Sony noch einmal Stock Flashen müssen um wirklich sicher zu sein... Woran du bist.
Beitrag automatisch zusammengefügt:

Die Reperatur natürlich prüfen ob Fehler entstanden sind beim Einbau... Ist klar.
 
Zuletzt bearbeitet:
HerrDoctorPhone

HerrDoctorPhone

Inventar
ZimtZicke schrieb:
Was mich stutzig mach: das Display funktioniert ja die ersten 15 Sekunden und auch wenn TWRP läuft. Es geht erst nach dem Boot aus.
Softwarefehler, logisch.
Denn, Normal geht es bei dir aus oder nicht weiter.
Im TWRP , das ein eigenständiges Programm ist, geht alles einwandfrei.
Konklusion? Software verhauen im Android....
ZimtZicke schrieb:
Ich habe auch gelesen, dass manchmal bei unsachgemäßer Arbeit an den Steckern die Sicherung für das Display auf dem Mainboard auslöst.
Ich würde das im Video nicht nachmachen, das ist nur was für Elektroniker die was davon verstehen, und nichts für Werkstätten die daran herum pfuschen. Finger weg, besser eine Sony Fachwerkstatt aufsuchen.

Wegen Flashen und recovery, da kann ich dir nicht helfen, das ist nicht meine Fachrichtung.

Viel Glück und viele grüße
DOC
 
Zuletzt bearbeitet:
Lenoid

Lenoid

Lexikon
ZimtZicke schrieb:
Wenn ich eine neue FW drauf mache, gibt es irgend einen Weg oder Möglichkeit die Daten und Einstellungen der Apps (E-Mail, Messenger etc.) wieder herzustellen? Fotos habe ich ja schon gerettet über TWRP.
Wenn ich das richtig verstanden habe, fährt das Telefon korrekt hoch, aber nur der Bildschirm fehlt dir irgendwann. Ich würde es mit Fernwartung versuchen. So etwas wie scrcpy:
Genymobile/scrcpy

Da du gerootet hast würde ich die entsprechenden Daten mit TB usw. versuchen auf eine externe SD zu sichern und dann alles komplett platt machen.
 
Z

ZimtZicke

Neues Mitglied
Habe die FW neu geflashed. Das Smartphone bootet wieder, wie auch vorher, die Displaysperre gibt es nicht mehr (mit einer neuen FW müsste diese vermutlich erst aktiviert werden) und dann...passiert genau das gleiche was vorher schon passierte: das Display geht aus 🤬.
Das gibts doch gar nicht! Ich kann es mir nur so erklären, dass es doch was mit der Hardware (entweder Display-Platine oder Motherboard) zu tun hat.
Entweder hol ich mir noch ein Display oder gleich ein gebrauchtes Xperia zum testen....
 
Lenoid

Lenoid

Lexikon
Handelt es sich sich um ein original Display von Sony oder einen Nachbau aus China?
Ich würde es nochmal aus- und wieder einbauen.
 
Z

ZimtZicke

Neues Mitglied
Lenoid schrieb:
Handelt es sich sich um ein original Display von Sony oder einen Nachbau aus China?
Ich würde es nochmal aus- und wieder einbauen.
Angeblich handelt es sich um ein original Display. Ich habe es bestimmt schon 10x aus- und eingebaut und alle Verbindungen überprüft.