[THEME][MOD][DEODEXED] Customize Your Galaxy S3

  • 89 Antworten
  • Neuester Beitrag
Diskutiere [THEME][MOD][DEODEXED] Customize Your Galaxy S3 im Themes für Samsung Galaxy S3 im Bereich Root / Custom-ROMs / Modding für Samsung Galaxy S3.
supergrobi94

supergrobi94

Erfahrenes Mitglied
Okay, konnte das Problem auch reproduzieren, allerdings mit dem Xposed Modul Tinted Statusbar. Da bleiben die Batterie Icons auch immer voll. Mit der Donate Version werden diese aber wieder richtig angezeigt.
 
A

acer09

Erfahrenes Mitglied
Was genau muss ich da machen damit es wieder funktioniert?
 
supergrobi94

supergrobi94

Erfahrenes Mitglied
Probiere mal, diese Datei zu flashen, und dann das Mod erneut zu flashen. Wird die Akku-Anzeige wieder richtig dargestellt?
 
supergrobi94

supergrobi94

Erfahrenes Mitglied
Update 29.12.2013:
- Themes & Mods kompatibel mit Omega v53
Vorsicht: Falls ihr den Xposed Framework zusammen mit einem Theme oder Mod nutzen wollt, kann es eventuell zu Fehler kommen. (Beispiel: Statusbar Theme + XuiMod / Tinted Statusbar = Farben der Texte werden nicht geändert)
 
Zuletzt bearbeitet:
supergrobi94

supergrobi94

Erfahrenes Mitglied
Hinweis 11.01.2014:
- Themes & Mods kompatibel mit Omega v54
 
supergrobi94

supergrobi94

Erfahrenes Mitglied
Update 19.01.2014:
- ThemePack: TW14* hinzugefügt
- Toggles: Neue Themes hinzugefügt (u.a. TW14* Round Design)

*Die TouchWiz2014 Themes stammen vom 4.4.2 KitKat-Update für's S4/Note3.
 
supergrobi94

supergrobi94

Erfahrenes Mitglied
Update 25.01.2014:
- ThemePack: TW14 aktualisiert*
- LockscreenClock / MultiWindows Themes: Note Design hinzugefügt

*Enthält nun auch Elemente vom Tab Pro 10.1 (TouchWiz2014 UI).
 
Zuletzt bearbeitet:
supergrobi94

supergrobi94

Erfahrenes Mitglied
Hinweis 02.02.2014:

Achtung: Zwischen der CWM Version 6.0.4.7 und der Auto-Reboot Funktion (4.3 Themes&Mods) gibt es derzeit Probleme. Nach dem flashen passiert nämlich nichts. Theme oder Mod wird zwar erfolgreich installiert, allerdings müsst ihr das Device manuell neustarten. Mit den Updates am 03.02.2014 wird das Auto-Reboot Feature wieder entfernt.
 
supergrobi94

supergrobi94

Erfahrenes Mitglied
Update 03.02.2014:
- Themes & Mods kompatibel mit Omega v55
- Notification&Statusbar: TW14 Stock hinzugefügt
- ThemePack: TW14 Weiß hinzugefügt
- Optionen&Einblendungen: HoloBlue/KitKat Buttons hinzugefügt
 
SavanTorian

SavanTorian

Ehrenmitglied
Beim Multiwindow Dark-blue Halftransparent klemmt etwas, es hat gut geflasht, sieht auch toll aus, nur musst Du den Rebootvorgang überarbeiten. Ich musste das S3 mit Off-Taste und manuell per Recovery booten. Oder Du tauscht die update-binary aus und aktualisierst sie. :)
 
supergrobi94

supergrobi94

Erfahrenes Mitglied
Danke @SavanTorian,

dass es tatsächlich welche gibt, die die Sachen flashen. Und an dieser Stelle möchte ich mich bei dir für die Unannehmlichkeiten in aller Form entschuldigen.

Also, ich hab's mal eben überprüft, und es hat auch ohne Probs geklappt.

Welche CWM Version nutzt du denn, wenn ich fragen darf? Mit der 6.0.4.7 (PhilZ Touch 6.12.8) klappte es wie beschrieben gut.

Damals, also mit Einführung der 4.3 Themes&Mods gab's ein Feature, welches es ermöglichte, nachdem flashen das device automatisch neuzustarten. Mit der aktuellen 6.0.4.7 ist es allerdings so, dass nachdem flashen einer Datei nichts passierte, es startete nicht automatisch und Optionen das device neuzustarten erschienen auch nicht. Deshalb hab ich mich dafür entschieden, das AutoReboot-Feature wieder bei allen Dateien zu entfernen, sodass der Flash-Vorgang wieder wie bei 4.1.2/4.2.2 abläuft. Nachdem flashen erscheint nur noch die Aufforderung eines reboots.

So sieht das updater-script aus:
HTML:
ui_print("");
ui_print("");
ui_print("================================================================================================");
ui_print("");
ui_print("");
ui_print("                Installing Theme                ");
ui_print("      MultiWindow DarkBlue Semitransparent      ");
ui_print("");
ui_print("");
ui_print("================================================================================================");
ui_print("");
ui_print("");
run_program("/sbin/sleep", "3s");
ui_print("Preparing to theme...");
show_progress(1, 15);
run_program("/sbin/busybox", "mount", "/system");
run_program("/sbin/busybox", "mount", "/data");
run_program("/sbin/busybox", "mount", "/dalvik");
ui_print("Wiping dalvik-cache");
delete_recursive("/data/dalvik-cache");
delete_recursive("/dalvik/dalvik-cache");
package_extract_dir("vrtheme", "/sdcard/vrtheme");
set_perm(0, 0, 0755, "/sdcard/vrtheme/installtheme.sh");
set_perm(0, 0, 0755, "/sdcard/vrtheme/zip");
set_perm(0, 0, 0755, "/sdcard/vrtheme/cleanup.sh");
set_perm(0, 0, 0755, "/sdcard/vrtheme/zipalign");
run_program("/sdcard/vrtheme/installtheme.sh");
ui_print("UI Theming complete");
run_program("/sdcard/vrtheme/cleanup.sh");
package_extract_dir("system", "/system");
package_extract_dir("data", "/data");
ui_print("Additional files copied");
run_program("/sbin/busybox", "umount", "/system"); 
run_program("/sbin/busybox", "umount", "/data"); 
run_program("/sbin/busybox", "umount", "/dalvik"); 
run_program("/sbin/busybox", "umount", "/sdcard"); 

ui_print("");
ui_print("Complete. Enjoy.");
ui_print("");

ui_print("");
ui_print("Please reboot.");
ui_print("");
Sah es beim flashen bei dir auch so aus, vorallem der letzte Abschnitt mit "Please reboot."? Dies ist nämlich die neue Version, samt update-binary, wo eigentlich keine Fehler mehr auftreteten sollte.
 
dkionline

dkionline

Experte
Zum Test mal ein neues zip erstellen. @savan, dalvik/cache geleert?
 
SavanTorian

SavanTorian

Ehrenmitglied
Entschuldigen musst Dich nicht: weil OK und alles ein Lernprozess ;) Am Zip und am Script liegts nicht. Ich würde aber auch eine neuere, aktuellere update-binary einfügen, da Philz mit älteren nicht mehr klar kommt. Wie gesagt, der Mod ist perfekt, nur hing es ein wenig am Reboot, sodass ich es etwas "anschubsen" musste.

Das Ende des Scripts würde ich nach dem

ui_print(" ");
run_program("/sbin/busybox", "umount", "/system");
ui_print(" Reboot & Enjoy!! ");
^^aufbauen, vor allen keine Pausen als Leerzeichen ;)

run_program("/sbin/busybox", "umount", "/data");
run_program("/sbin/busybox", "umount", "/dalvik");
run_program("/sbin/busybox", "umount", "/sdcard");
^^ist prinzipiell gar nicht nötig.

Wenn Du Dalvik- und CacheWipe einbaust, dann bevor Du es wieder unmountest, also als letzten Schritt.
Dann ist die Prozedur sauber, wie ein Kinderpopo ;)

Finally :

[...]
ui_print(" ");
ui_print("Wiping Dalvik");
delete_recursive("/data/dalvik-cache");
delete_recursive("/dalvik/dalvik-cache")
run_program("/sbin/busybox", "umount", "/system");
ui_print(" Reboot & Enjoy!! ");
 
Zuletzt bearbeitet:
supergrobi94

supergrobi94

Erfahrenes Mitglied
Okay,

ich hab nun einen anderen Weg gefunden, welches das flashen noch komfortabler macht. Und zwar so:

HTML:
ui_print("");
ui_print("");
ui_print("================================================================================================");
ui_print("");
ui_print("");
ui_print("                Installing Theme                ");
ui_print("      MultiWindow DarkBlue Semitransparent      ");
ui_print("");
ui_print("");
ui_print("================================================================================================");
ui_print("");
ui_print("");
run_program("/sbin/sleep", "3s");
ui_print("Copying files...");
show_progress(1, 15);
run_program("/sbin/busybox", "mount", "/system");
package_extract_dir("vrtheme", "/sdcard/vrtheme");
set_perm(0, 0, 0755, "/sdcard/vrtheme/installtheme.sh");
set_perm(0, 0, 0755, "/sdcard/vrtheme/zip");
set_perm(0, 0, 0755, "/sdcard/vrtheme/cleanup.sh");
set_perm(0, 0, 0755, "/sdcard/vrtheme/zipalign");
ui_print("Modding files...");
run_program("/sdcard/vrtheme/installtheme.sh");
run_program("/sdcard/vrtheme/cleanup.sh");
run_program("/sbin/busybox", "umount", "/system"); 
run_program("/sbin/busybox", "umount", "/sdcard"); 

ui_print("");
ui_print("Complete. Enjoy.");
ui_print("");

ui_print("");
ui_print("Please reboot now.");
ui_print("");
Das praktische hierbei ist, dass der Flash-Vorgang deutlich schneller abläuft, da das (meist) lange neuladen beim Reboot weg fällt. Dadurch sieht man das Ergebnis nicht nur schneller, sondern spart somit Minuten. Du hättest dann mehr Zeit für das Wesentliche. Ich hoffe, dass du die Idee nicht zu sehr schlecht findest. :unsure:

BTW: Ich hab's auch eben nochmal getestet und funzt einwandfrei. :laugh:
 
SavanTorian

SavanTorian

Ehrenmitglied
Passt, sehr viel besser, als vorher :)
"show progress" und.. run program /"sleep" brauchst nicht.. Überflüssig.. Wozu auch.. Kostet nur Zeit..
 
Zuletzt bearbeitet:
supergrobi94

supergrobi94

Erfahrenes Mitglied
Hinweis 10.02.2014:
- Themes & Mods kompatibel mit Omega v56
 
Naderik

Naderik

Experte
Servus.

Also, da im Opener steht, dass es für 4.3 gedacht ist, habe ich dies einfach bei mir installiert.

Ich habe die 4.3. Stock.

Aber natürlich scheint dass nicht kompatibel zu sein, denn vieles geht danach nicht mehr.

Kann man es wieder rückgängig machen?
Oder habe ich etwas falsch gemacht?

Grüße
 
dkionline

dkionline

Experte
Hi

Funktioniert nur auf deodexed ROMs. Wenn du deine Firmware nochmal flashst sollte alles wieder laufen.

Ciao
 
SavanTorian

SavanTorian

Ehrenmitglied
Wenn uns Supergrobi mitteilt, welche Dateien er gemodded hat, kann man von diesen auch die *odex files, zum Bsp per aromafm löschen. Dann sollte das auch auf odex-Roms gehn... So verhielt sich das auch bei "Raubkatze" Toggle.Mods für 4.1.2 :)



^^ erinnert mich an meine tolle Kindheit :wubwub:
 
supergrobi94

supergrobi94

Erfahrenes Mitglied
Also meistens nur einige Layouts und Bilddateien. Kenne mich mit aromafm nicht aus. Außerdem nutze ich keine odex ROM, sodass ich es nicht testen könnte.
Werde denn Opener nochmal überarbeiten, damit klar wird, dass es nur mit deodexed ROM funktioniert.

Vielen Dank für euer Verständnis & dass ihr supergrobi's stuffs nutzt.