Link2SD - Mount Warnung und Dalvik Cache verknüpfen

Courtesy

Courtesy

Neues Mitglied
Threadstarter
Hallo Community,

WIKO Lenny
Android 4.4.2 KitKat

Kann mir bitte jemand sagen, wie man diese Fehlermeldung weg bekommt? Die Vorschläge "Schnellstart" oder "Mount Script neu erstellen" bringen nichts. Anscheinend startet mein System zu langsam. Wie kann ich das optimieren?

Screenshot_Link2SD Mount Warnung.png
Weitere Fragen an euch zu Link2SD:

Habe gelesen, dass Dalvik Cache verknüpfen dem System viel Platz schafft. Habe das also mal gemacht, in der Hoffnung, diesen Fehler damit beheben zu können. Demnach liegt der Dalvik jetzt wohl auf der SD Karte. Im Nachhinein wohl keine gute Idee: Ist es nicht brandgefährlich, falls die SD Karte aus irgendeinem Grund mal nicht mehr gemounted wird?
Jedenfalls hat diese Aktion die Mount Warnung nicht behoben, im Gegenteil: Jetzt habe ich noch eine zusätzliche Meldung bei jedem Neustart: "Android wird aktualisiert" (Apps werden gestartet, Start wird abgeschlossen). - Schreibt der jetzt permanent den Dalvik neu? Das kann nicht gesund für das Handy sein. Ich finde nirgendwo eine Anleitung, wie man diese Verknüpfung rückgängig macht. Wer weiss Rat?
Ich habe zwar hier im Forum zu diesem Thema gelesen, aber sorry, bei den Fachdiskussionen verstehe ich nur Bahnhof. Wer erklärt es mir im Laienformat? - Danke im voraus!
 
Andy

Andy

Ehrenmitglied
Gibt es denn das Mount Script in /system/etc/init.d/ ?
Kann mich nur noch vage erinnern (ist schon zig Jahre her, wo ich das mal nutzte), aber ich denke du brauchst dann nen Kernel mit init.d Support.
 
Andy

Andy

Ehrenmitglied
Courtesy schrieb:
Wie kann ich mir das ansehen?
Ganz normal mit einem Dateimanager. Und da Link2SD Root benötigt, gehe ich mal davon aus, dass dein Gerät gerootet ist.
Courtesy schrieb:
Schön. Neues Handy oder was bedeutet das?
Nein, erst mal abwarten, was obiges ergibt.

Aber meine ehrliche Meinung: In heutigen Zeiten wo Geräte mit Android 8 + 64GB interner Speicher um die 100 € kosten, würde ich halt persönlich abwägen, ob nicht doch ein Neukauf Sinn macht.
Courtesy schrieb:
Schreibt der jetzt permanent den Dalvik neu?
Ja vermutlich. Da das System ja beim booten noch nicht weiß, dass der Dalvik Cache auf der Speicherkarte liegt.
Alleine performancetechnisch auch ne Krücke, da die Speicherkarte mit Sicherheit nie so schnell ist, wie der interne Speicher.
Courtesy schrieb:
Ich finde nirgendwo eine Anleitung, wie man diese Verknüpfung rückgängig macht.
Vermutlich bei Klick auf "Link to SD card" beim nächsten Fenster den Haken bei "Link dalvik-cache file" entfernen?
 
Courtesy

Courtesy

Neues Mitglied
Threadstarter
Andy schrieb:
Ganz normal mit einem Dateimanager. Und da Link2SD Root benötigt, gehe ich mal davon aus, dass dein Gerät gerootet ist.
Ist es. Aber Dateimanager.... ? <räusper>
Aber meine ehrliche Meinung: In heutigen Zeiten wo Geräte mit Android 8 + 64GB interner Speicher um die 100 € kosten, würde ich halt persönlich abwägen, ob nicht doch ein Neukauf Sinn macht.
Der gleichen Meinung bin ich wohl auch. Betrachte es als "Spielerei mit Lerneffekt", was ich mit dem alten Handy mache. Bevor ich mir ein neues zulege, möchte ich mehr darüber wissen, um es von Anfang an gut einrichten zu können.
Courtesy schrieb:
Schreibt der jetzt permanent den Dalvik neu?
Ja vermutlich. Da das System ja beim booten noch nicht weiß, dass der Dalvik Cache auf der Speicherkarte liegt.
Aua, das ist Phone-Quälerei;-) - In meinem Link2SD (kein Plus, erstmal testen) gibt es links oben das Aktionsmenue und rechts oben kommt man in die Einstellungen. Links habe ich einmal auf "Dalvik Cache verknüpfen" geclickt, in der Annahme, das könne man genauso rückgängig machen wie verlinkte Apps. In den Einstellungen ist der Haken bei "Dalvid Cache verknüpfen wenn nötig" nicht gesetzt.
Alleine performancetechnisch auch ne Krücke, da die Speicherkarte mit Sicherheit nie so schnell ist, wie der interne Speicher.
Dauert ca. 10 Sekunden länger.
Vermutlich bei Klick auf "Link to SD card" beim nächsten Fenster den Haken bei "Link dalvik-cache file" entfernen?
Kann es sein, dass es daran liegt, dass ich kein "plus" habe, dass es bei mir anders aussieht? Oder übersehe ich was?
 
Andy

Andy

Ehrenmitglied
Courtesy schrieb:
Ist es. Aber Dateimanager.... ? <räusper>
Ja einfach einen beliebigen Dateimanager der durch Root auch auf /system lesen kann z.b. Total Commander, Solid Explorer, Root Browser, Root Explorer und wie sie alle heißen.
Courtesy schrieb:
Kann es sein, dass es daran liegt, dass ich kein "plus" habe, dass es bei mir anders aussieht? Oder übersehe ich was?
Kann ich nicht sagen, ich habe mir Screenshots ergoogelt um dir antworten zu können ;).
Zumindest kann ich nicht sehen, dass das nen Plus Feature sein soll.
 
Courtesy

Courtesy

Neues Mitglied
Threadstarter
Okay. system/etc habe ich gefunden, aber darin kein init.d.... - und so sieht mein Link2SD aus.
Unter "Automatisches Verknüpfen" gibt es noch eine Dalvik Einstellung, aber das ist gar nicht aktiv.

Screenshot_TC SystemDirectory.png Screenshot_Link2SD Options.png Screenshot_Link2SD Einstellungen.png
 
Zuletzt bearbeitet:
Courtesy

Courtesy

Neues Mitglied
Threadstarter
ooopss....Habe jetzt in der richtigen directory nachgesehen (/system/etc) - leider kein init.d Ordner oder file zu finden.
Danke für den Link. Ich habe eine Vorstellung davon, was eine Custom ROM ist, aber mich da ranwagen....? <zöger>. Praktisch wäre natürlich, wenn damit die ganze Bloatware weg wäre. Weniger gut: CWM Recovery als Voraussetzung habe ich nicht, denke ich. Und diese vielen Änderungen... vielleicht gefällt mir das Design des neuen Betriebssystems ja gar nicht? Und noch ein Problem käme hinzu: Ein komplettes Backup des Systems vorher mit Titanium Backup wird schwierig. Bei mir meldet der immer, er hätte dafür nicht genug Platz; auf der SD Karte sind aber noch 10 GB locker frei. Kapiere ich auch nicht....

Nach Link2SD screenshots habe ich jetzt auch mal gegoogled. Die sehen in der Tat anders aus als meine. Die Auswahlmöglichkeiten ganz unten sind bei mir gar nicht existent, stattdessen Werbung. Gibt es ohne diese init.d keine Möglichkeit, diese Mount Fehlermeldung weg zu bekommen resp. ohne Link2SD diesen Dalvik Cache neu zu schreiben, wo er hingehört resp. ihn dort hin wieder zu verschieben?
Meinen ausdrücllichen Dank dafür, dass Du Dich so engagierst!
 
Zuletzt bearbeitet:
Oben Unten